What's covered
Learn how to troubleshoot damaged or corrupt InDesign files.
On this page

    An InDesign document could be damaged if an error or other unexpected behavior occurs only while you work in that document. InDesign has an automatic document recovery feature that can prevent damage that system crashes or power outages can cause. However, it can't prevent damage that other system-level problems such as software conflicts, low disk space, or viruses cause. This troubleshooting guide can help you isolate and resolve damage in InDesign documents. It can also help you isolate and resolve system-level problems that appear to be document damage but are related to other causes.


    System-level problems can cause errors and other unexpected behavior. Before assuming that a document is damaged, make sure that your system is relatively free from problems. For example, consider running a disk repair utility, then reopening your document to see if it's fixed, before walking through the document damage troubleshooting tasks below.

    Windows: See Check your hard disk for errors.

    Mac OS: See Resolve startup issues and perform disk maintenance.


    Tip:

    After each troubleshooting task you complete, relaunch InDesign and open your document to see if the problem has been fixed. Open the document this way:

    Choose File > Open, choose your document, then choose Copy. Resave your document as a new name and see if it's fixed.

    1. Back up your document.

    Before you begin troubleshooting, create a backup copy of your damaged document. Some of the following tasks require that you change or delete information in the document. A backup copy of the document lets you easily restore information. If the document is on a network volume or removable media (e.g., a CD or jump drive), move the backup to a local drive.

    2. Install the latest InDesign update.

    • In InDesign, choose Help > Updates.

    -or-

    -or-

    3. Re-create your preference files.

    InDesign stores information about plug-ins, features, and the app itself in its preference files: the InDesign SavedData and InDesign Defaults files. A damaged InDesign preference file can cause unexpected behavior with an InDesign document. You can easily determine if the problem is related to the preference files by re-creating them.

    Alert:

    Re-creating the InDesign preference files restores settings to their defaults, so you lose custom settings associated with the old preference files. To keep these custom settings, rename the old preference files.

    To re-create the InDesign preference files:

    1. Quit InDesign.

    2. Relaunch InDesign and hold down the appropriate keys for your OS:

      • Mac OS X: Control+Option+Command+Shift
      • Windows: Control+Alt+Shift
    3. When prompted to delete InDesign preference files, click Yes. InDesign launches with defaults and regenerated preference files.

      Note:

      If you aren't prompted to delete the preference files, you can delete your preferences manually.

    4. Open the document and see if it's been fixed. If the problem persists, move on to task 4 below.

      Manually delete or rename your preference files

      Alternatively, or additionally, you can:

      • Manually delete your preference files (e.g., if you aren't automatically prompted to delete preferences while launching InDesign, as in the previous procedure)

      -or-

      • Manually rename your preference files (e.g., if you have custom settings associated with the old preference files that you don't want to lose)

      Find your OS in the following table to see where these files are located.

      OS Locations of Preference Files
      Mac OS X

      InDesign Defaults

      Users/[user]/Library/Preferences/Adobe InDesign/Version [version]/[language]/InDesign Defaults

      InDesign SavedData

      Users/[user]/Library/Caches/Adobe InDesign/Version [version]/InDesign SavedData

      Windows XP

      InDesign Defaults

      C:\Documents and Settings\[user]\Application Data\Adobe\InDesign\Version [version]\InDesign Defaults

      Hidden by default. Learn how to show hidden files.

      InDesign SavedData

      C:\Documents and Settings\[user]\Local Settings\Application Data\Adobe\InDesign\Version[version]\Caches\InDesign SavedData

      Windows 7/8

      InDesign Defaults

      C:\Users\[user]\AppData\Adobe\InDesign\Version[version]\[language]\InDesign Defaults

      Hidden by default. Learn how to show hidden files.

      InDesign SavedData

      C:\Users\[user]\AppData\Local\Adobe\InDesign\Version[version]\[language]\Caches\InDesign SavedData

      After you've finished deleting or renaming, restart InDesign to re-create your preference files, and then open your document to see if it's fixed.

      If the problem persists, restore the original preferences by deleting the new files and renaming the old preference files back to their original names.

    4. Save the document in IDML (InDesign CS4 and later) or INX (InDesign CS3 and earlier) format.

    1. Open the file in InDesign.

    2. Choose File > Export.

    3. From the Save As Type menu, choose InDesign Markup (CS4 and later) or InDesign Interchange (CS3 and earlier).

    4. Give the file a name and location, and then click Save.

    5. In InDesign, open the exported IDML or INX file.

      If the problem is gone, continue to use the IDML or INX file as a replacement of your original document. If the problem persists, move on to another step.

    5. Troubleshoot a converted document in its source application.

    If the document was converted from Adobe PageMaker, QuarkXPress, or a previous version of InDesign, try reconverting the document. If the problem recurs, troubleshoot the original document for damage in its source app before you convert it again. A damaged PageMaker or QuarkXPress document likely remains damaged after you convert it.

    For information on troubleshooting a damaged PageMaker publication, see Troubleshoot damaged publications. For information on troubleshooting a damaged QuarkXPress document, visit the Quark website.

    6. Delete character and paragraph styles.

    Styles that you created in InDesign or imported with files created in other apps could be damaged. To find out if this is the case, delete the styles and then resave your document.

    To delete character styles:

    1. In InDesign, open the document and choose Type > Character Styles.

    2. In the Character Styles panel, select all styles except [No character style]. To select multiple styles, press Ctrl (Windows) or Command (Mac OS) while you select styles.

    3. From the Character Styles menu, choose Delete Styles.

    4. Save your document and see if it's fixed. If the problem persists, try deleting paragraph styles.

    To delete paragraph styles:

    1. In InDesign, open the document and choose Type > Paragraph Styles.

    2. In the Paragraph Styles panel, select all styles except [No paragraph style]. To select multiple styles, press Ctrl (Windows) or Command (Mac OS) as you select styles.

    3. From the Paragraph Styles menu, choose Delete Styles.

    4. Save your document and see if it's fixed. If the problem persists, move on to task 7 below.

    7. Check for font damage.

    To determine if the problem is related to a damaged font, replace all fonts used in the document with a standard font, such as Arial or Times New Roman.

    If the problem recurs after you change fonts, it is not font-related. If the problem doesn't recur, the original font or fonts could be damaged or outdated. Try reinstalling the original fonts or obtaining updated versions from the font manufacturer.

    8. Check objects and graphics for damage.

    Try to determine if a specific element on a master page or a document page causes the problem. To isolate elements, first delete empty pages and unnecessary elements, such as those on a pasteboard or hidden layer.

    To delete pages:

    1. In InDesign, open the document and choose Window > Pages.

    2. In the Pages panel, use the Selection tool to select the pages you want to delete. Press Ctrl (Windows) or Command (Mac OS) to select multiple pages, or press the Shift key to select a contiguous range of pages.

      Delete pages
    3. In the Pages panel, click the Delete icon.

    4. Click OK to confirm deletion.

    If the problem recurs after you delete some pages, delete half of the remaining pages and save the document as a new name. Then try to re-create the problem.

    • If the problem recurs, one of the remaining pages could contain a damaged element. Continue to delete pages until you find the page that causes the problem.
    • If the problem doesn't recur, one of the deleted pages could contain a damaged element. Replace the deleted pages until you find the page that causes the problem.

    After you determine the page that causes the problem, remove and replace elements on it, including imported graphics, InDesign-drawn objects, and text frames on the page.

    9. Copy page elements into a new document.

    Copying page elements into a new document leaves structural (internal) damage behind. If the problem recurs after you copy page elements into a new document, delete elements one by one to see if one of the elements is the issue.

    To copy page elements into a new document:

    1. In InDesign, open the original document.

    2. Choose File > New and click OK in the New Document dialog box.

    3. Choose Window > Tile to display both documents.

    4. Click the original document to activate it.

    5. Choose Window > Pages to activate the Pages panel.

    6. Drag a page or spread into the new document window. InDesign copies the page or spread into the new document, adding pages as necessary.

    7. Save the new document to a new name (different from the name of your original document) and try to re-create the problem.

      • If the problem recurs, the damage isn't structural (e.g., on master pages or document pages). Delete elements one by one to see if one of the elements is causing the issue.
      • If the problem doesn't recur, the damage is probably structural. Repeat steps 4 through 7 for each remaining page or spread.

    10. Obtain another copy of the document.

    If you received the document via email, FTP, or removable media (such as a CD), obtain a copy a different way. Or, have the document resent. Damaged media or a faulty email transmission can damage a document. If the document is sent via email, have the sender compress it first (e.g., using WinZip or Smith Micro's StuffIt) to protect the data.


    Remove third-party plug-ins.

    Consider uninstalling third-party plug-ins from InDesign. Plug-ins can sometimes cause file corruption. See Troubleshoot InDesign third-party plug-ins.

    Use a different computer to open the document.

    By changing to a different system environment, you can remove variables that cause the problem.

    Visit the Adobe user-to-user forums.

    You're not alone! Other users may have experienced similar problems with a document and posted a solution. See the InDesign forums.

    Re-create the document.

    If all else fails, re-create the document. Make frequent backup copies, and periodically test the document to ensure that imported elements aren't causing the problem.


     
    Back to top