Overview of selection methods

InDesign provides the following selection methods and tools:

Selection tool 

Allows you to select text and graphics frames, and work with an object using its bounding box. If you click the content grabber (the donut) that appears when you hold the mouse pointer over an image, you can manipulate the image within the frame without switching to the Direct Selection tool.

Content grabber
Content grabber

Direct Selection tool 

Allows you to select the contents of a frame, such as a placed graphic, or work directly with editable objects, such as paths, rectangles, or type that has been converted to a text outline.

Type tool 

Allows you to select text in a text frame, on a path, or in a table.

Select submenu

Allows you to select an object’s container (or frame) and its contents. The Select submenu also lets you select objects based on their position relative to other objects. To view the Select submenu, choose Object > Select. You can also right-click (Windows) or Control-click (Mac OS) an object to display its context menu, and then choose Select.

Select buttons on the Control panel

Lets you the select the content using the Select Content button  or the container using the Select Container button . You can also use the Select Next Object or Select Previous Object to select the next or previous objects in a group or on a spread.

Select All and Deselect All commands

Allow you to select or deselect all objects on the spread and pasteboard, depending on which tool is active and what is already selected. Choose Edit > Select All or Edit >Deselect All.

Note:

Double-click an object to switch between the selecting the frame and the object. Double-click a text frame to place the insertion point and switch to the Type tool.

Select objects

An object is any printable element on a page or on the pasteboard, such as a path or an imported graphic. A frame or path is a shape you draw or a container for text or graphics. A bounding box is a rectangle with eight selection handles that represents an object’s vertical and horizontal dimensions. Before you can modify an object, you must select it using a selection tool.

There are two ways to select an object in InDesign:

Path with bounding box selected
Path with bounding box selected (left), path selected (middle), and path with anchor point selected (right)

  • You can use the Selection tool to select the object’s bounding box for performing general layout tasks, such as positioning and sizing objects. When selecting an image, you can use the Selection tool to select either the frame or the image within the frame.

Edit images with the Selection tool
Using the Selection tool to edit images

A. The content grabber appears when you mouse over an image. B. Click the content grabber to select the contents. C. Click outside the content grabber to select the frame. 
  • You can use the Direct Selection tool to select the contents of a container (such as an imported graphic) or individual points on a path for tasks involving resizing imported graphics, drawing and editing paths, and editing text.

Note:

An imported graphic is always contained within a frame. It’s possible to select the graphic and its frame, the graphic only, or its frame only. The frame and bounding box of an imported graphic can be different sizes. To see how InDesign indicates what’s selected, see Modifying objects using graphics frames.

Bounding box selected (left) rectangular path selected (right)
Bounding box selected (left) compared to rectangular path selected (right)

With rectangular objects, it can be difficult to tell the difference between the object’s bounding box and the path of the object itself. A bounding box always displays eight large hollow anchor points. A rectangular path always displays four small anchor points (which can be hollow or solid).

Select a bounding box

For any object, you can select its bounding box—a rectangle that represents the object’s horizontal and vertical dimensions. (For grouped objects, the bounding box is a dashed rectangle.) The bounding box is also called a container. The bounding box makes it possible to quickly move, duplicate, and scale the object without having to use any other tool. For paths, the bounding box makes it easy to work with an entire object without accidentally altering the anchor points that determine its shape.

Note:

For more precise moving and scaling, and for other modifications such as rotation, use the Control panel or the Transform panel.

  • Using the Selection tool , do one of the following:
    • Click the object. If the object is an unfilled path, click its edge. If the object is an image, click the content grabber to select the bounding box of the image, or click outside the content grabber to select the frame.

    • Drag a dotted selection rectangle or marquee around part or all of the object.

    • With a graphic object or nested content selected, click the Select Container button  on the Control panel.

When you select one or more objects with the Selection tool, you see a bounding box that indicates the size of each object. If you don’t see a bounding box when an object is selected, you may have selected the object using the Direct Selection tool .

If you click a frame and it is not selected, the frame may be a locked item, it may be on a locked layer, or it may be a master page item. See Unable to select objects.

Select a path or points on a path

Paths in InDesign are defined by anchor points, end points, and direction lines. You select anchor points and end points using the Direct Selection tool.

A path with a single point selected (left) and multiple points selected (right)
A path with a single point selected (left) and multiple points selected (right)

  1. Using the Direct Selection tool , click the path to select it.

    Notice how the tool changes when it’s above a path  or a point .

  2. Do any of the following:
    • To select an individual point, click it.

    • To select multiple points on the path, press Shift as you click each point.

    • To select all of a path’s points at once, click the point at the center of the object, or hold down Alt (Windows) or Option (Mac OS) and click the path. If you direct-select any part of the object, the Select All command also selects all the points.

Select text inside a frame

  • To select text by dragging, click on a text frame using the Type tool. An insertion point appears.
  • To create an insertion point in text, double-click a text frame using any selection tool. InDesign switches to the Type tool automatically.

Select an object inside a frame

  • Do any of the following:
    • Click the object using the Direct Selection tool . The Direct Selection tool automatically changes to the Hand tool when placed over a graphic object inside a frame (but not when placed over a non-graphic object, such as a path).

    • If the object inside a frame is an image, click the content grabber to select the image.

    Note:

    If you don’t want the content grabber to appear when you hover over an image, choose View > Extras > Hide Content Grabber.

    • With a frame selected, choose Select > Content from the Object menu or the frame’s context menu.
    • With a frame selected, click the Select Content button  on the Control panel.
       

Select multiple objects

  • To select all the objects in a rectangular area, use the Selection tool  to drag a marquee over the objects you want to select.
  • To select nonadjacent objects, use the Selection tool to select an object and then press Shift as you click additional objects. Clicking selected objects deselects them.
  • To add more objects to a selection, press Shift as you use the Selection tool to drag a marquee over additional objects. Dragging over selected objects deselects them.

Note:

You can use these same techniques with the Direct Selection tool to select objects nested inside groups or frames.

Select or deselect all objects

To deselect all objects on the spread and its pasteboard, choose Edit >Deselect All. Or, with the Selection tool or Direct Selection tool, click at least 3 pixels away from any object.

The Select Allcommand has a different effect depending on the situation:

  • If the Selection tool  is active, all paths and frames on the spread and pasteboard are selected, with their bounding boxes active.

  • If the Direct Selection tool  is active and an object is direct-selected, Select All selects all the anchor points of that object but does not select any other object. If nothing is selected, Select All selects all the path objects on the spread and pasteboard.

  • If the Type tool is active and there is an insertion point in a text frame (indicated by a flashing vertical line), Select All selects all text in that text frame and any text frames threaded to it, but selects no other objects.

  • If an object in a group is selected, Select All selects the rest of the objects in the group but no other objects on the spread.

  1. Select the tool you want to use. If desired, select an object or place the insertion point in a text frame.
  2. Choose Edit > Select All.

    Note:

    The Select All command doesn’t select nested objects, objects that are positioned on locked or hidden layers, master page items that are not overridden on document pages, or objects on other spreads and pasteboards (except for threaded text).

Unable to select objects

Not being able to select an object may be the result of the following issues:

  • The object is covered by another object in a stack. Hold down Ctrl (Windows) or Command (Mac OS), and then click the same place repeatedly until you’ve selected the frame or group you want. See Select nested or overlapping objects.

  • The object is a master page item, as indicated by a dotted border. To select a master page item, either turn to the master page that is applied to the document page, or override the master page item. See Override a master item.

  • The object is locked using the Object > Lock command. Choose Object > Unlock All On Spread. See Lock or unlock objects.

  • The object is on a locked layer. Click the lock icon next to the layer in the Layers panel to unlock the layer. See Lock or unlock layers.

Select nested or overlapping objects

When a frame contains an object, the contained object is said to be nested inside a container, or frame. Three common kinds of nesting are: paths inside frames, frames inside frames, and groups inside groups. Always be aware of exactly which objects or object attributes you need to select, which ones are currently selected, and which selection tools to use to modify selections.

You control selections in nested groups using the Direct Selection and Selection tools, as well as the Select Content and Select Container buttons. You can select text characters using the Type tool at any time, no matter how deeply a text frame is nested.

Select nested, grouped, or overlapping objects

When you nest objects or place objects on top of each other on the same layer, it can be difficult to select a single object or frame. The Object menu and context menu contain selection options to make it easier to select the object you want.

Nested objects
Selecting nested objects

A. Image selected B. Path of the frame containing the image is selected C. Group containing frame selected 

Note:

Opening the Info panel makes it easier to see which object is selected.

  1. Using the Direct Selection tool , click the nested or grouped object.
  2. If you can’t select the object you want, use one of the following techniques:
    • Choose Object > Select, and choose one of the selection options.
    • Position the pointer over the object you want to select and right-click (Windows) or Control-click (Mac OS) to display the context menu. Then choose Select and the desired selection option.

    Note:

    Selecting objects using the context menu commands is not the same as using the Object > Select menu commands. From the context menu, the selections are based on the exact point where you clicked to display the context menu. This means that the next object above or below the mouse click would be selected, rather than the next object in the stacking order.

    • Hold down Ctrl (Windows) or Command (Mac OS), and then click the same place repeatedly until you’ve selected the frame or group you want. (Do not click an anchor point.)

    • To select all objects in a group individually, use the Selection tool to select the group, click the Select Content button  on the Control panel, and then choose Edit > Select All.

  3. To progressively drill down or up through a stack of objects, do one of the following:
    • Right-click (Windows) or Control-click (Mac OS), and then choose an option from the Select context menu.

    • Choose Object > Select > Next Object Below or Next Object Above repeatedly until the object you want is selected. When you reach the beginning or end of the stack, the selection doesn’t change.

    • Hold down Ctrl (Windows) or Command (Mac OS) and click the stack to drill down from the top of the stack. When you reach the end of the stack, the selection starts over at the top of the stack. To drill up from the bottom of the stack, hold down Alt+Ctrl (Windows) or Option+Command (Mac OS) and click the stack using the Selection tool.

    Note:

    The context menu options are sensitive to the location of the pointer.

Select multiple nested objects

  1. Using the Direct Selection tool , click the nested object.
  2. Hold down Shift as you click each additional nested object you want to select.

Selection options

Options on the Select submenu (choose Object > Select or choose Select on the context menu) help you select overlapping, nested, or grouped objects. The availability of some options depends on the type of objects you’re working with. When using the context menu, the object selected depends on the position of the pointer.

First Object Above

Selects the object at the top of the stack.

Next Object Above

Selects the object just above the current object.

Next Object Below

Selects the object just below the current object.

Last Object Below

Selects the object at the bottom of the stack.

Content

Selects the content of the selected graphics frame, or, if a group is selected, selects an object within the group. You can also click the Select Content button in the Control panel.

Container

Selects the frame enclosing the selected object, or, if an object within a group is selected, selects the group that contains it. You can also click the Select Container button in the Control panel.

Previous Object / Next Object

Selects the next or previous object in the group if the selected object is part of a group, or, if an ungrouped object is selected, selects the next or previous object on the spread. Shift-click to skip by five. Ctrl-click (Windows) or Command-click (Mac OS) to select the first or last object in a stack.

Arrange objects in a stack

Overlapping objects are stacked in the order in which they are created or imported. You can use the Arrange submenu to change the stacking order of objects.

The Layers panel also helps determine the stacking order of objects. The order of each layer in the Layers panel determines whether objects in a layer appear in front of or behind objects on other layers. The order of objects within each layer determines the stacking order of those objects within that layer. You can drag the objects within a layer or use the Object > Arrange menu commands to control stacking within each layer. If you haven’t created any layers, your document contains just one stack of objects on the single default layer. Objects on masters exist at the back of each named layer.

Note:

Grouping objects might change their stacking order (in relation to ungrouped objects).

  1. Select the object you want to move forwards or backwards in a stack.
  2. Do any of the following:
    • To move a selected object to the front or back of a stack, choose either Object > Arrange > Bring to Front or Object > Arrange > Send to Back.

    • To move a selected object forward or backward past the next object in a stack, choose either Object > Arrange > Bring Forward or Object > Arrange > Send Backward.

    • In the Layers panel, click the disclosure triangle next to a layer, and then drag objects within the layer to change their stacking order.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy