Animate 파일

Animate에서는 다양한 파일 유형으로 작업할 수 있으며 각 파일별 용도는 다음과 같습니다.

  • FLA 파일은 Animate에서 주로 사용하는 파일로서, 문서의 기본 미디어, 타임라인 및 스크립트 정보를 포함합니다. 미디어 객체는 Animate 문서의 내용을 구성하는 그래픽, 텍스트, 사운드 및 비디오 객체를 가리킵니다. 타임라인은 Animate에서 특정 미디어 객체가 스테이지에 나타나는 시간을 지정합니다. Animate 문서에 ActionScript® 코드를 추가하여 문서의 비헤이비어를 보다 세밀하게 제어하고 사용자의 상호 작용에 응답하도록 할 수 있습니다.

  • 비압축 XFL 파일은 FLA 파일과 비슷합니다. XFL 파일 그리고 같은 폴더 안에 있는 다른 연관된 파일은 비압축 버전의 FLA 파일에 해당할 뿐입니다. 이 형식을 사용하면 사용자 그룹이 Animate 프로젝트의 서로 다른 요소를 동시에 작업하기가 쉬워집니다. 자세한 내용은 비압축 XFL 파일을 사용한 작업을 참조하십시오.

  • 컴파일된 버전의 FLA 파일인 SWF 파일은 웹 페이지에 표시하는 파일입니다. Animate에서 FLA 파일을 제작하면 SWF 파일이 만들어집니다.

    Animate SWF 파일 형식은 다른 응용 프로그램에서도 지원하는 표준으로, 널리 사용됩니다. Animate 파일 형식에 대한 자세한 내용은 www.adobe.com/go/flashplayer_kr를 참조하십시오.

  • AS 파일은 ActionScript 파일이며, 이 파일을 사용하여 ActionScript 코드 전체 또는 코드의 일부를 FLA 파일과 별도로 보관할 수 있습니다. 이렇게 하면 코드 구성에 도움이 되며 여러 작업자가 Animate 내용의 서로 다른 부분을 맡아 작업하는 프로젝트에서도 유용하게 사용할 수 있습니다.

  • SWC 파일에는 재사용이 가능한 Animate 구성 요소가 포함되어 있습니다. 각 SWC 파일에는 컴파일된 동영상 클립, ActionScript 코드 및 구성 요소에 필요한 기타 에셋이 포함되어 있습니다. 참고: SWC 파일은 Animate로 가져올 수 없습니다.
  • ASC 파일은 Adobe Media Server를 실행하는 컴퓨터에서 실행될 ActionScript를 저장하는 데 사용됩니다. 이 파일은 SWF 파일의 ActionScript와 연동하여 작동하는 서버측 논리를 구현하는 기능을 제공합니다. 참조: ASC 파일은 Animate CC에서 지원되지 않습니다.
  • JSFL 파일은 Animate 제작 도구에 새로운 기능을 추가하는 데 사용할 수 있는 JavaScript 파일입니다.
  • APR 파일은 Canvas 제작 템플릿을 해당 제작 프로파일 설정에 따라 번들로 묶어 줍니다. 앞으로 제작 프로파일에 연결된 모든 새 에셋도 번들로 처리되고 공유됩니다. 자세한 내용은 제작 설정을 참조하십시오.

 

 

Animate CC란?

Animate CC란?
Adobe

다음 추가 비디오 및 자습서에서는 Animate/Flash Pro를 사용한 작업을 보여 줍니다. 일부 비디오는 Flash CS3 또는 CS4를 보여 주지만 Flash Pro CS5에도 적용됩니다.

기타 Adobe 응용 프로그램을 사용한 작업

Animate는 광범위한 창의적 작업 과정을 위해 다른 Adobe® 응용 프로그램과 함께 작동되도록 설계되었습니다. 이에 따라 Illustrator® 및 Photoshop® 파일을 Animate로 직접 가져올 수 있으며 비디오를 Animate에서 만든 다음 Adobe® Premiere® Pro 또는 After Effects®에서 편집하거나 두 응용 프로그램 중 하나에서 Animate로 비디오를 가져올 수도 있습니다. SWF 파일을 제작할 때는 Dreamweaver®를 사용하여 웹 페이지에 해당 내용을 포함하고 Dreamweaver 내에서 Animate를 바로 시작하여 내용을 편집할 수 있습니다.

XFL 파일 열기

Animate CC부터는 XFL이 사용자가 만드는 FLA 파일의 내부 형식입니다. Animate에서 파일을 저장하면 기본 형식은 FLA지만 파일의 내부 형식은 XFL입니다.

다른 Adobe® 응용 프로그램(예: After Effects®)에서 XFL 형식으로 파일을 내보낼 수 있습니다. 이러한 파일의 확장명은 FLA가 아니라 XFL입니다. InDesign®에서 내부적으로 XFL인 FLA 형식으로 직접 내보낼 수 있습니다. 따라서 After Effects 또는 InDesign에서 먼저 프로젝트에 대해 작업한 다음 Animate에서 계속 작업할 수 있습니다.

Animate에서 FLA 파일을 열 때와 같은 방식으로 XFL 파일을 열어서 작업할 수 있습니다. Animate에서 XFL 파일을 열면 해당 파일을 FLA 파일로 저장하거나 비압축 XFL 파일로 저장할 수 있습니다.

다음 비디오 자습서에서는 XFL 및 FLA를 통해 InDesign 및 AfterEffects에서 Animate로 내보내는 방법을 보여 줍니다.

Animate에서 XFL 파일을 열려면

  1. InDesign 또는 After Effects와 같은 다른 Adobe® 응용 프로그램에서 작업을 XFL 파일로 내보냅니다.

    응용 프로그램은 원본 파일의 레이어 및 객체를 모두 XFL 파일에 보존합니다.

  2. Animate에서 [파일] > [열기]를 선택하고 XFL 파일을 찾습니다. [열기]를 클릭합니다.

    FLA 파일을 열 때와 같은 방식으로 XFL 파일이 Animate에서 열립니다. 원본 파일의 모든 레이어가 타임라인에 나타나고 원본 객체가 [라이브러리] 패널에 나타납니다.

    그러면 평소와 같이 파일 작업을 수행할 수 있습니다.

  3. 파일을 저장하려면 [파일] > [저장]을 선택합니다.

    Animate에서 [다른 이름으로 저장] 대화 상자에 새 FLA 파일의 이름을 지정해야 합니다.

  4. 이름을 입력하고 FLA 파일을 저장합니다.

비압축 XFL 파일을 사용한 작업

Animate CC부터는 비압축 XFL 형식의 Animate 파일을 사용하여 작업하도록 선택할 수 있습니다. 이 형식을 사용하여 Animate 파일을 구성하는 하위 파일 또는 개별 부분을 확인할 수 있습니다. 이러한 부분은 다음과 같습니다.

  • Animate 파일의 전체를 기술하는 XML 파일

  • 각 라이브러리 심볼을 기술하는 개별 XML 파일

  • 제작 설정, 모바일 설정 및 기타 설정을 포함하는 추가 XML 파일

  • 비트맵 파일 등 Animate 파일에서 사용되는 외부 에셋을 포함하는 폴더

비압축 XFL 형식을 사용할 경우 Animate 파일의 각 부분을 서로 다른 작업자가 개별적으로 사용할 수 있습니다. 또한 소스 제어 시스템을 이용하여 비압축 XFL 파일 내부의 각 하위 파일에 대한 변경 사항을 관리할 수 있습니다. 이러한 기능들을 함께 활용하여 디자이너 및 개발자가 여러 명인 대규모 프로젝트에서 공동 작업을 보다 쉽게 수행할 수 있습니다.

XFL 파일에서 라이브 업데이트 사용

비압축 XFL 문서에 대해 편집 가능한 에셋의 라이브 업데이트 기능을 사용할 경우 문서를 Animate에서 연 상태에서 비압축 XFL 문서의 모든 라이브러리 에셋을 편집할 수 있습니다. 다른 응용 프로그램에서 에셋 편집을 마치면 에셋에 대한 변경 사항이 Animate에 반영됩니다.

다른 응용 프로그램에서 비압축 XFL 문서의 에셋을 편집하려면

  1. 비압축 XFL 형식으로 Animate 문서를 저장합니다.

  2. Photoshop과 같은 적합한 편집기에서, 비압축 XFL 문서의 LIBRARY 폴더에서 편집하려는 에셋을 엽니다.

  3. 에셋을 편집하고 변경 사항을 저장합니다.

  4. Animate로 돌아갑니다.

    에셋의 업데이트 내용은 Animate에 즉시 반영됩니다.

Animate에서 Dreamweaver의 SWF 파일 편집 

Animate와 Dreamweaver가 모두 설치된 경우에는 Dreamweaver 문서에서 SWF 파일을 선택한 다음 Animate를 사용하여 해당 파일을 편집할 수 있습니다. Animate는 SWF 파일을 직접 편집하는 것이 아니라 소스 문서(FLA 파일)를 편집한 다음 해당 SWF 파일을 다시 내보냅니다.

  1. Dreamweaver에서 속성 관리자를 엽니다([창] > [속성]).
  2. Dreamweaver 문서에서 다음 중 한 가지를 수행합니다.
    • SWF 파일 자리 표시자를 클릭하여 선택한 다음 속성 관리자에서 [편집]을 클릭합니다.

    • SWF 파일의 자리 표시자를 마우스 오른쪽 버튼으로 클릭하거나(Windows) Control 키를 누른 채 클릭하고(Macintosh), 컨텍스트 메뉴에서 [편집 : Animate]를 선택합니다.

      이렇게 하면 Dreamweaver는 포커스를 Animate로 전환하고 Animate는 선택된 SWF 파일에 대해 Animate 저작 파일(FLA)을 찾습니다. Animate가 Animate 저작 파일을 찾지 못할 경우 직접 입력하라는 메시지가 표시됩니다.

      참고: FLA 파일 또는 SWF 파일이 잠긴 경우에는 Dreamweaver에서 해당 파일을 확인하십시오.

  3. Animate에서 FLA 파일을 편집합니다. Animate 문서 창을 보면 현재 Dreamweaver에서 파일을 수정하고 있다는 것을 확인할 수 있습니다.

  4. 편집이 끝나면 [완료]를 클릭합니다.

    Animate는 FLA 파일을 업데이트한 다음 이 파일을 SWF 파일로 다시 내보내고 닫은 후에 Dreamweaver 문서로 포커스를 되돌립니다.

    참고:

    SWF 파일을 업데이트하고 Animate를 연 상태로 두려면 Animate에서 [파일] > [Dreamweaver용 업데이트]를 선택합니다.

  5. Dreamweaver 속성 관리자에서 [재생]을 클릭하면 업데이트된 파일을 문서에서 볼 수 있고 F12 키를 누르면 브라우저 창에서 페이지를 미리 볼 수 있습니다.
  1. Animate를 시작합니다.

  2. 기본 Animate 화면에서 [새로 만들기] > [Animate 파일(모바일)]을 선택합니다.

  3. Device Central에서 플레이어 버전과 ActionScript 버전을 선택합니다.
  4. 내용 유형을 선택합니다.
  5. [사용 가능 장치] 목록에서 하나 이상의 대상 장치를 선택하거나 [장치 세트] 목록에서 장치 세트 또는 개별 장치를 선택합니다.
  6. [만들기]를 클릭합니다.
  7. 새 Animate 문서에 내용을 추가합니다.

  8. 문서를 테스트하려면 [컨트롤] > [테스트]를 선택합니다.

새 문서 만들기

Animate에서 새 문서를 작성하거나 이전에 저장한 문서를 열고, 작업 도중 새 윈도우를 열 수 있습니다. 새 문서나 기존 문서의 속성을 설정할 수 있습니다.

원하는 용도와 사용 대상을 선택하면 Animate에서 사전 설정 포맷을 제공합니다. 화면 위쪽의 탭에 있는 캐릭터 애니메이션, 소셜, 게임, 교육, 광고, 웹 고급 등의 선택 항목 중에서 용도를 선택합니다.

각 용도에 적합한 사전 설정을 선택한 후에 만들기를 클릭하면 애니메이션 만들기가 시작됩니다. 왼쪽 창에서 최근에 사용한 에셋을 확인할 수 있습니다. 시작 화면 아래쪽에는 샘플 에셋이 제공됩니다.

Launch-screen

새 문서 만들기

  1. 파일 > 새로 만들기를 선택합니다.

    새 문서
    새 문서
  2. 화면 위쪽의 탭에 있는 캐릭터 애니메이션, 소셜, 게임, 교육, 광고, 웹 고급 등의 선택 항목 중에서 용도를 선택합니다.

  3. 각 용도에 적합한 사전 설정을 선택한 후에 만들기를 클릭합니다.

    문서의 설정을 선택할 수도 있습니다. 자세한 내용은 새 문서 또는 기존 문서의 속성 설정을 참조하십시오.

템플릿을 사용하여 새 문서 만들기

  1. 파일 > 템플릿에서 새로 만들기를 선택합니다.

    [템플릿에서 새로 만들기] 대화 상자
    [템플릿에서 새로 만들기] 대화 상자
  2. [범주] 목록에서 범주를 선택하고 범주 항목 목록에서 문서를 선택한 다음 확인을 클릭합니다. Animate에서 제공하는 기본 템플릿이나 이미 저장한 템플릿 중에서 선택할 수 있습니다.

기존 문서 열기

  1. [파일] > [열기]를 선택합니다.

  2. [열기] 대화 상자에서 파일을 찾거나 [파일 이름] 상자에 파일의 경로를 입력합니다.
  3. [열기]를 클릭합니다.

여러 문서가 열려 있는 경우 특정 문서 보기

여러 개의 문서를 연 경우에는 [문서] 윈도우의 위쪽에 있는 탭을 사용하여 열려 있는 문서를 식별하고 각 문서 간에 쉽게 탐색할 수 있습니다. [문서] 윈도우에서 문서가 최대화되어 있는 경우에만 탭이 표시됩니다.

  1. 보려는 문서의 탭을 클릭합니다.

    기본적으로 탭은 문서가 만들어진 순서대로 표시됩니다. 문서 탭을 드래그하여 순서를 변경할 수 있습니다.

현재 문서에 대한 새 윈도우 열기

  1. [윈도우] > [창 복제]를 선택합니다.

새 문서 또는 기존 문서의 속성 설정

  1. 문서를 열고 [수정] > [문서]를 선택합니다.

    [문서 설정] 대화 상자가 나타납니다.

  2. 스테이지의 [크기]를 설정하려면 다음 중 하나를 수행합니다.
    • 스테이지 크기를 픽셀 단위로 지정하려면 [폭] 및 [높이] 상자에 값을 입력합니다. 최소 크기는 1 x 1 픽셀이며 최대 크기는 2880 x 2880 픽셀입니다.

    • 스테이지 크기를 스테이지의 내용에 사용된 공간에 정확히 맞추려면 [내용에 일치] 옵션을 선택합니다.

    • 스테이지 크기를 사용 가능한 최대 인쇄 영역으로 설정하려면 [프린터에 일치]를 클릭합니다. 이 영역은 [페이지 설정] 대화 상자의 [여백] 영역(Windows) 또는 [인쇄 여백] 대화 상자(Macintosh)에서 선택된 현재 여백을 용지 크기에서 뺀 크기로 결정됩니다.

    • 스테이지 크기를 기본 크기인 550 x 400 픽셀로 설정하려면 [일치: 기본값]을 클릭합니다.

  3. 스테이지에서 3D 객체의 위치와 방향을 조정하여 스테이지 가장자리에 상대적인 모양을 유지하도록 하려면 [3D 투시도 각도를 조정하여 현재 스테이지 투영 유지]를 선택합니다.

    이 옵션은 스테이지 크기를 변경하는 경우에만 사용할 수 있습니다.

  4. (CS5.5만 해당) 스테이지 크기의 변화에 맞춰 스테이지 내용의 크기를 자동으로 조절하려면 [스테이지에 맞게 크기 조절]을 선택합니다.

    이 옵션은 스테이지 크기를 변경하는 경우에만 사용할 수 있습니다. 잠기거나 숨겨진 레이어에서 내용의 크기를 조절할 것인지 여부는 [환경 설정]에서 선택할 수 있습니다. 자세한 내용은 일반 환경 설정 지정을 참조하십시오.

  5. 작업 영역에 표시되는 눈금자의 측정 단위를 지정하려면 [눈금자 단위] 메뉴에서 옵션을 선택합니다. 이 설정으로 [정보] 패널에 사용되는 단위를 결정할 수도 있습니다.
  6. 문서의 배경색을 설정하려면 [배경색] 견본을 클릭하고 팔레트에서 색상을 선택합니다.
  7. [프레임 속도]를 설정하려면 초당 표시할 애니메이션 프레임의 개수를 입력합니다.

    컴퓨터에 표시되는 대부분의 애니메이션, 특히 웹 사이트에서 재생되는 애니메이션의 경우 8fps ~ 15fps(초당 프레임) 정도가 적당합니다. 프레임 속도를 변경하면 새 프레임 속도가 새 문서의 기본값이 됩니다.

  8. (CS5.5만 해당) 지정된 시간 간격마다 문서를 자동으로 저장하려면 [자동 저장] 옵션을 선택하고 저장 간격을 분 단위로 지정합니다.
  9. 다음 중 하나를 수행합니다.
    • 현재 문서에만 새 설정을 적용하려면 [확인]을 클릭합니다.

    • 새 설정을 모든 새 문서에 대한 기본 속성으로 적용하려면 [기본으로 설정]을 클릭합니다.

속성 관리자를 사용하여 문서 속성 변경

  1. 스테이지 외부의 작업 영역을 클릭하여 스테이지에서 모든 객체의 선택을 취소합니다. 문서 속성이 속성 관리자에 나타납니다. 속성 관리자를 열려면 [윈도우] > [속성]을 선택합니다.
  2. (CS5.5만 해당) [제작] 섹션에서 문서에 대해 Flash Player 버전 및 ActionScript 버전을 선택합니다. 추가적인 제작 설정에 액세스하려면 [제작 설정] 버튼을 클릭합니다. 자세한 내용은 제작 설정을 참조하십시오.

  3. [속성] 섹션에서 [FPS](초당 프레임 수)에 대해 초당 재생할 애니메이션 프레임 수를 입력합니다.
  4. 스테이지 크기를 변경하려면 스테이지의 폭 및 높이 값을 입력합니다.
  5. 스테이지의 배경색을 선택하려면 [스테이지] 속성 옆의 색상 견본을 클릭하고 팔레트에서 색상을 선택합니다.
  6. 추가적인 문서 속성을 편집하려면 [크기] 속성 옆의 [편집] 버튼을 클릭합니다. 모든 문서 속성에 대한 자세한 내용은 새 문서 또는 기존 문서에 대한 속성 설정을 참조하십시오.

문서에 XMP 메타데이터 추가

제목, 작성자, 설명, 저작권 등의 XMP(Extensible Metadata Platform) 데이터를 FLA 파일에 포함할 수 있습니다. XMP는 기타 특정 Adobe® 응용 프로그램에서 이해할 수 있는 메타데이터 형식입니다. 메타데이터는 Animate 및 Adobe® Bridge에서 볼 수 있습니다. XMP 메타데이터에 대한 자세한 내용은 Bridge 도움말의 메타데이터 및 키워드를 참조하십시오.

참고: 32비트 Bridge는 Adobe Animate CC에서 지원되지 않습니다.

메타데이터를 포함하면 웹 기반 검색 엔진의 기능이 향상되어 Animate 내용을 보다 효과적으로 검색할 수 있습니다. 검색 메타데이터는 XMP(Extensible Metadata Platform) 사양을 따르며 FLA 파일에 W3C 호환 형식으로 저장됩니다.

파일 메타데이터에는 파일의 내용, 저작권 상태, 원본 및 작업 내역에 대한 정보가 포함됩니다. [파일 정보] 대화 상자에서 현재 파일에 대한 메타데이터를 보고 편집할 수 있습니다.

선택한 파일에 따라 다음과 같은 유형의 메타데이터가 나타날 수 있습니다.

설명

작성자, 제목, 저작권 및 기타 정보를 포함합니다.

IPTC

편집 가능한 메타데이터를 표시합니다. 저작권 정보를 비롯하여 파일에 캡션을 추가할 수 있습니다. IPTC Core는 IPTC(International Press Telecommunications Council)가 2004년 10월에 승인한 사양으로, 새 속성이 추가되고 일부 속성 이름이 변경되었으며 일부 속성이 삭제되었다는 점에서 이전 IPTC(IIM, 레거시)와 다릅니다.

카메라 데이터(Exif)

이미지 촬영 시 사용된 카메라 설정을 비롯하여 디지털 카메라에 할당된 정보를 표시합니다.

비디오 데이터

픽셀 종횡비, 장면 및 샷을 비롯하여 비디오 파일에 대한 메타데이터를 표시합니다.

오디오 데이터

아티스트, 앨범, 트랙 번호 및 장르를 비롯하여 오디오 파일에 대한 메타데이터를 표시합니다.

모바일 SWF

제목, 작성자, 설명 및 저작권을 비롯하여 SWF 파일에 대한 정보를 나열합니다.

작업 내역

Photoshop을 사용하여 이미지에 적용한 변경 내용의 로그를 저장합니다.

주의: 로그가 파일의 메타데이터와 함께 저장되도록 Photoshop에서 [작업 내역 로그] 환경을 설정해야 합니다.

Version Cue

Version Cue 파일 버전 정보를 나열합니다.

DICOM

DICOM(Digital Imaging and Communications in Medicine) 형식으로 저장된 이미지에 대한 정보를 표시합니다.

메타데이터를 추가하려면

  1. [파일] > [파일 정보]를 선택합니다.
  2. 표시되는 [파일 정보] 대화 상자에서 포함할 메타데이터를 입력합니다. 언제든지 FLA 파일에서 메타데이터를 추가하거나 제거할 수 있습니다.

Animate 문서 저장

Animate FLA 문서를 현재 위치에 같은 이름으로 저장하거나 다른 위치에 다른 이름으로 저장할 수 있습니다.

문서에 저장되지 않은 변경 내용이 있으면 문서 제목 막대, 응용 프로그램 제목 막대 및 문서 탭 다음에 별표(*)가 표시됩니다. 문서를 저장하면 별표가 사라집니다.

Animate 문서를 기본 FLA 형식으로 저장

  1. 다음 중 하나를 수행합니다.
    • 현재 버전을 디스크에 덮어쓰려면 [파일] > [저장]을 선택합니다.

    • 문서를 다른 위치에 다른 이름으로 저장하거나 압축하려면 [파일] > [다른 이름으로 저장]을 선택합니다.

  2. [다른 이름으로 저장]을 선택했거나 문서를 처음 저장하는 경우에는 파일 이름과 위치를 입력합니다.
  3. [저장]을 클릭합니다.

비압축 XFL 형식으로 문서 저장

  1. [파일] > [다른 이름으로 저장]을 선택합니다.
  2. [파일 형식] 메뉴에서 [Animate CC 비압축 문서(*xfl)]를 선택합니다.

  3. 파일의 이름과 위치를 선택하고 [저장]을 클릭합니다.

마지막으로 저장된 문서 버전으로 복귀하기

  1. [파일] > [복귀]를 선택합니다.

문서를 템플릿으로 저장

  1. [파일] > [템플릿으로 저장]을 선택합니다.
  2. [템플릿으로 저장] 대화 상자의 [이름] 상자에 템플릿 이름을 입력합니다.
  3. [범주] 팝업 메뉴에서 범주를 선택하거나 이름을 입력하여 새 범주를 만듭니다.
  4. [설명] 상자에 템플릿 설명을 최대 255자까지 입력한 다음 [확인]을 클릭합니다.

    설명은 [새 문서] 대화 상자에서 템플릿을 선택할 때 표시됩니다.

    저장된 템플릿을 삭제하려면 다음 폴더 중 하나로 이동하고 템플릿 FLA 파일이 들어 있는 범주 폴더에서 템플릿 FLA 파일을 삭제하십시오.

    • Windows XP - C:\Documents and Settings\<사용자 이름>\Local Settings\Application Data\Adobe\Flash CS5\ko_KR\Configuration\Templates\

    • Windows Vista 및 7 - C:\Users\<사용자 이름>\AppData\Local\Adobe\Flash CS5\<언어>\Configuration\Templates\

    • Mac OS - <하드 디스크>/Users/<사용자 이름>/Library/Application Support/Adobe/Flash CS5/<언어>/Configuration/Templates/

문서를 Animate CC 문서로 저장

  1. [파일] > [다른 이름으로 저장]을 선택합니다.
  2. 파일 이름과 위치를 입력합니다.
  3. [형식] 팝업 메뉴에서 [Animate CC 문서]를 선택하고 [저장]을 클릭합니다.

    참고:

    Animate CC 형식으로 저장하면 내용이 삭제된다는 경고 메시지가 표시되는 경우 [Animate CC로 저장]을 클릭하여 계속합니다. Animate CC에서만 사용할 수 있는 기능이 문서에 포함되어 있는 경우 이러한 메시지가 표시될 수 있습니다. Animate CC에서 문서를 저장하면 Animate에서 해당 기능을 사용할 수 없습니다.

Animate를 종료할 때 문서 저장

  1. [파일] > [종료](Windows) 또는 [Animate] > [Animate 종료](Macintosh)를 선택합니다.

  2. 저장되지 않은 변경 내용이 있는 문서가 열려 있는 경우 Animate에 변경 내용을 저장할 것인지, 아니면 취소할 것인지를 묻는 메시지가 각 문서별로 표시됩니다.

    • 변경 내용을 저장하고 문서를 닫으려면 [예]를 클릭합니다.

    • 변경 내용을 저장하지 않고 문서를 닫으려면 [아니오]를 클릭합니다.

Animate 문서 인쇄(Flash Professional CC에서 더 이상 사용 안 됨)

문서를 미리 보고 편집하려면 Adobe Animate 문서에서 프레임을 인쇄하거나 뷰어를 통해 Flash Player에서 프레임을 인쇄할 수 있도록 지정합니다.

Animate 문서에서 프레임을 인쇄할 경우 [인쇄] 대화 상자를 사용하여 인쇄할 장면이나 프레임의 범위 및 매수를 지정할 수 있습니다. Windows에서는 [페이지 설정] 대화 상자에서 용지 크기, 방향뿐만 아니라 여백 설정 및 각 페이지에 대한 모든 프레임 인쇄 여부를 포함한 다양한 인쇄 옵션을 지정합니다. Macintosh에서는 이러한 옵션이 [페이지 설정] 및 [인쇄 여백] 대화 상자에 나눠져 있습니다.

[인쇄] 및 [페이지 설정] 대화 상자는 두 운영 체제에서 모두 표준이며 모양은 선택한 프린터 드라이버에 따라 다릅니다.

  1. [파일] > [페이지 설정](Windows) 또는 [파일] > [인쇄 여백](Macintosh)을 선택합니다.
  2. 페이지 여백을 설정합니다. 페이지의 가운데에 프레임을 인쇄하려면 둘 다 [가운데] 옵션을 선택합니다.
  3. [프레임] 메뉴에서 문서의 모든 프레임을 인쇄할 것인지, 아니면 각 장면의 첫 번째 프레임만 인쇄할 것인지를 선택합니다.
  4. [레이아웃] 메뉴에서 다음 옵션 중 하나를 선택합니다.

    실제 크기

    프레임을 전체 크기로 인쇄합니다. 인쇄된 프레임을 줄이거나 늘리려면 [크기 조절]에 값을 입력합니다.

    한 페이지에 맞춤

    각 프레임을 줄이거나 늘려 페이지의 인쇄 영역에 맞춥니다.

    스토리보드

    한 페이지에 여러 축소판을 인쇄합니다. [상자], [격자], [공백] 중에서 선택합니다. [프레임] 상자에 페이지당 축소판 개수를 입력합니다. [프레임 여백] 상자에서 축소판 사이의 간격을 설정하고 프레임 레이블을 축소판으로 인쇄할 [프레임 레이블]을 선택합니다.

  5. 프레임을 인쇄하려면 [파일] > [인쇄]를 선택합니다.

프레임 레이블을 사용하여 인쇄 비활성화

기본 타임라인에 있는 프레임을 인쇄하지 않도록 선택하려면 전체 SWF 파일을 인쇄할 수 없도록 프레임에 !#p 레이블을 지정합니다. 프레임에 !#p 레이블을 지정하면 Flash Player 컨텍스트 메뉴의 [인쇄] 명령이 희미하게 표시됩니다. Flash Player 컨텍스트 메뉴를 제거할 수도 있습니다.

Flash Player에서 인쇄 기능을 비활성화해도 사용자는 브라우저의 [인쇄] 명령을 사용하여 프레임을 인쇄할 수 있습니다. 이 명령은 브라우저 기능이므로 Animate를 사용하여 이 명령을 제어하거나 비활성화할 수 없습니다.

Flash Player 컨텍스트 메뉴에서 인쇄 비활성화

  1. 제작할 Animate 문서(FLA 파일)를 열거나 활성화합니다.

  2. 기본 타임라인에서 첫 번째 키프레임을 선택합니다.
  3. [윈도우] > [속성]을 선택하여 [속성] 관리자를 나타냅니다.
  4. 속성 관리자의 [프레임 레이블]에 !#p를 입력하여 인쇄되지 않는 프레임으로 지정합니다.

    컨텍스트 메뉴에서 [인쇄] 명령을 희미하게 표시하는 !#p 레이블은 하나만 지정해야 합니다.

    참고:

    키프레임 대신 빈 프레임을 선택하고 여기에 #p 레이블을 지정할 수 있습니다.

Flash Player 컨텍스트 메뉴를 제거하여 인쇄 기능 비활성화

  1. 제작할 Animate 문서(FLA 파일)를 열거나 활성화합니다.

  2. [파일] > [제작 설정]을 선택합니다.
  3. [HTML] 탭을 선택하고 [메뉴 표시]의 선택을 취소한 다음 [확인]을 클릭합니다.

프레임 인쇄 시 인쇄 영역 지정

  1. 인쇄 항목으로 설정할 프레임이 들어 있는 Animate 문서(FLA 파일)를 엽니다.

  2. #p 레이블이 지정된 프레임과 같은 레이어에 있는 #p 프레임 레이블을 사용하여 인쇄 항목으로 지정하지 않은 프레임을 선택합니다.

    작업을 구성하려면 #p 레이블이 지정된 프레임 다음에 오는 프레임을 선택합니다.

  3. 원하는 인쇄 영역 크기를 가진 스테이지에 모양을 만듭니다. 프레임의 경계 상자를 사용하려면 인쇄 영역 크기가 적합한 객체가 있는 프레임을 선택합니다.
  4. 경계 상자에 사용할 모양이 들어 있는 프레임을 타임라인에서 선택합니다.
  5. 속성 관리자([윈도우] > [속성])의 [프레임 레이블]에 #b를 입력하여 선택된 모양을 인쇄 영역에 대한 경계 상자로 지정합니다.

    #b 프레임 레이블은 타임라인마다 하나만 사용할 수 있습니다. 이 옵션은 Print 액션을 사용하여 동영상 경계 상자 옵션을 선택하는 것과 같습니다.

인쇄되는 배경색 변경

[문서 속성] 대화 상자에서 설정한 배경색을 인쇄할 수 있습니다. 인쇄할 최하위 타임라인 레이어에 색칠된 객체를 배치하여 인쇄할 프레임의 배경색만 변경합니다.

  1. 스테이지에 있는 채워진 모양을 인쇄될 최하위 타임라인 레이어에 배치합니다.
  2. 모양을 선택한 다음 [수정] > [문서]를 선택합니다. 인쇄 배경색을 선택합니다.

    이렇게 하면 동영상 클립 및 로드된 SWF 파일의 배경색을 포함한 전체 문서의 배경색이 변경됩니다.

  3. 다음 중 하나를 수행합니다.
    • 해당 색상을 문서의 배경으로 인쇄하려면 모양을 배치한 프레임이 인쇄되도록 지정합니다.

    • 인쇄되지 않는 프레임에서 다양한 배경색을 유지하려면 2단계와 3단계를 반복합니다. 그런 다음 인쇄되도록 지정되지 않은 모든 프레임에서 최하위 타임라인 레이어에 모양을 배치합니다.

Flash Player 컨텍스트 메뉴의 [인쇄] 명령을 사용하여 모든 Animate SWF 파일의 프레임을 인쇄할 수 있습니다.

컨텍스트 메뉴의 [인쇄] 명령은 투명도나 색상 효과를 인쇄할 수 없으며 다른 동영상 클립의 프레임도 인쇄할 수 없습니다. 고급 인쇄 기능을 사용하려면 PrintJob 객체 또는 print() 함수를 사용합니다.

  1. 문서를 엽니다.

    이 명령은 인쇄 영역으로 스테이지를 사용하거나 지정된 경계 상자를 사용하여 #p 레이블이 지정된 프레임을 인쇄합니다.

    인쇄할 특정 프레임을 지정하지 않은 경우에는 문서의 기본 타임라인에 있는 모든 프레임이 인쇄됩니다.

  2. [파일] > [제작 미리 보기] > [기본값]을 선택하거나 F12 키를 눌러 브라우저에서 Animate 내용을 봅니다.

  3. 브라우저 윈도우에서 Animate 내용을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하여 Flash Player 컨텍스트 메뉴를 표시합니다.

  4. Flash Player 컨텍스트 메뉴에서 [인쇄]를 선택하여 [인쇄] 대화 상자를 표시합니다.
  5. Windows의 경우 인쇄 범위를 선택하여 인쇄할 프레임을 선택합니다.
  6. Macintosh의 경우 [인쇄] 대화 상자에서 인쇄할 페이지를 선택합니다.
  7. 프린터의 속성에 따라 다른 인쇄 옵션을 선택합니다.
  8. [확인]을 클릭하거나(Windows) [인쇄]를 클릭(Macintosh)합니다.

참고:

컨텍스트 메뉴에서 인쇄할 경우 PrintJob 객체 호출과 상호 작용하지 않습니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책