그래픽 요소끼리 서로 자동으로 정렬되도록 하려면 물리기 기능을 사용합니다. Animate를 사용하면 다음 세 가지 방법으로 스테이지의 객체를 정렬할 수 있습니다.

  • 객체에 물리기 기능은 특정 객체를 다른 객체에, 가장자리를 따라 직접 물립니다.
  • 픽셀에 물리기 기능은 스테이지의 개별 픽셀이나 여러 줄의 픽셀에 직접 객체를 물립니다.
  • 물리기 정렬 기능은 지정된 물리기 허용치, 즉 객체와 다른 객체 간 또는 객체와 스테이지 가장자리 간의 미리 설정된 경계에 객체를 물립니다.
  • 픽셀에 비트맵 물리기 기능은 제작 시 비트맵을 가장 가까운 픽셀에 물려 캔버스에서 더 선명하게 표시되도록 합니다.

참고: 격자 또는 안내선에 물릴 수도 있습니다.

 

객체에 물리기 기능 켜거나 끄기

객체에 물리기 기능을 켜려면 [선택 도구]의 [객체에 물리기] 수정자나 [보기] 메뉴의 [객체에 물리기] 명령을 사용합니다.

[선택 도구]의 [객체에 물리기] 수정자가 켜져 있으면 요소를 마우스로 드래그할 때 포인터 아래에 작은 검정 링이 표시됩니다. 객체가 다른 객체의 물리기 거리 내에 들어가면 작은 링이 더 큰 링으로 바뀝니다.

  1. [보기] > [물리기] > [객체에 물리기]를 선택합니다. 이 명령이 켜져 있으면 명령 옆에 체크 표시가 나타납니다.

    객체를 이동하거나 변경할 때 해당 객체에 있는 선택 도구의 위치가 물리기 링에 대한 참조 포인트가 됩니다. 예를 들어, 채우기 모양의 가운데 부분을 마우스로 드래그하여 이동하는 경우 중심점이 다른 객체에 물립니다. 이 기능은 특히 애니메이션 효과를 위해 모양을 모션 패스에 물릴 때 유용합니다.

    참고:

    물릴 때 객체 위치를 보다 정확하게 조절하려면 모서리 또는 중심점에서 드래그합니다.

픽셀에 비트맵 물리기

비트맵 물리기를 활성화하려면 [보기] 메뉴에서 [픽셀에 비트맵 물리기] 명령을 사용합니다. 그러면 내용 제작 시 비트맵이 정수 위치(소수로 된 값 없음)에 배치됩니다.

  1. [보기] > [물리기] > [픽셀에 비트맵 물리기]를 선택합니다. 

  2. 이 옵션 옆의 확인 표시는 해당 기능이 활성화되었음을 나타냅니다. 확인 표시가 비활성화된 경우, 비트맵을 임의의 위치에 배치할 수 있습니다.

    제작 시 픽셀에 비트맵 물리기

객체에 물리기 허용치 조정

  1. [편집] > [환경 설정](Windows) 또는 [Animate] > [환경 설정](Macintosh)을 선택한 다음 [드로잉]을 클릭합니다.

  2. [드로잉] 설정에서 [선 연결] 설정을 조정합니다.

픽셀에 물리기 사용

픽셀에 물리기 기능을 켜려면 [보기] 메뉴의[픽셀에 물리기] 명령을 사용합니다. [픽셀에 물리기]가 켜진 경우 보기 확대/축소율이 400% 이상으로 설정되면 픽셀 격자가 나타납니다. 픽셀 격자는 Animate 응용 프로그램에 표시되는 개별 픽셀을 나타냅니다. 객체를 만들거나 이동할 때는 픽셀 격자에서만 만들고 이동할 수 있습니다.

예를 들어, 3.5픽셀처럼 폭이 소수인 획을 사용하는 경우와 같이 가장자리가 픽셀 경계 간에 있는 모양을 만드는 경우 [픽셀에 물리기]를 사용하면 모양의 가장자리가 아니라 픽셀 경계에 물립니다.

  • 픽셀에 물리기를 켜거나 끄려면 [보기] > [물리기] > [픽셀에 물리기]를 선택합니다. 확대/축소율이 400% 이상으로 설정되면 픽셀 격자가 표시됩니다. 이 명령이 켜져 있으면 명령 옆에 체크 표시가 나타납니다.

  • 픽셀에 물리기 기능을 일시적으로 켜거나 끄려면 C 키를 누릅니다. C 키를 놓으면 픽셀에 물리기 기능이 [보기] > [물리기] > [픽셀에 물리기] 명령을 사용하여 선택한 상태로 돌아갑니다.

  • 픽셀 격자를 일시적으로 숨기려면 X 키를 누릅니다. X 키를 놓으면 픽셀 격자가 다시 나타납니다.

 

물리기 정렬 편집

[물리기 정렬] 설정을 선택한 경우 객체의 수평 가장자리 또는 수직 가장자리 간의 물리기 허용치와 객체 가장자리와 스테이지 테두리 사이의 물리기 허용치를 설정합니다. 객체의 수평 가운데와 수직 가운데 사이에서 물리기 정렬 기능을 켤 수도 있습니다. 모든 물리기 정렬 설정은 픽셀 단위로 측정됩니다.

  1. [보기] > [물리기] > [물리기 정렬 편집]을 선택합니다.
  2. [물리기 정렬 편집] 대화 상자에서 물릴 대상 객체의 유형을 선택합니다. 기본값 저장을 선택하여 지정된 설정을 .fla 파일에 저장합니다. 활성 문서의 저장된 설정이 새 문서에 전달됩니다.

    물리기 정렬 편집

    [물리기 정렬 편집] 대화 상자에서 물릴 대상 객체의 유형을 선택합니다.
  3. [고급] 버튼을 클릭하고 다음 중 하나를 선택합니다.
    • 객체와 스테이지 테두리 사이의 물리기 허용치를 설정하려면 [동영상 테두리]에 값을 입력합니다.

    • 객체의 수평 또는 수직 가장자리 사이의 물리기 허용치를 설정하려면 [수평], [수직] 또는 둘 모두에 값을 입력합니다.

    • 수평 또는 수직 가운데 정렬 기능을 켜려면 [수평 가운데 정렬], [수직 가운데 정렬] 또는 둘 모두를 선택합니다.

물리기 정렬 켜기

물리기 정렬을 켠 상태에서 지정된 물리기 허용치로 객체를 드래그하면 스테이지에 점선이 나타납니다. 예를 들어, 수평 물리기 허용치가 18픽셀(기본 설정)로 설정되어 있는 경우 객체와 다른 객체 사이의 거리가 정확하게 18픽셀이 되면 드래그하는 객체의 가장자리를 따라 점선이 나타납니다. [수평 가운데 정렬] 기능을 실행하면 꼭지점을 정확하게 정렬할 때 두 객체의 수평 가운데 꼭지점을 따라 점선이 표시됩니다.

  1. [보기] > [물리기] > [물리기 정렬]을 선택합니다. 이 명령이 켜져 있으면 명령 옆에 체크 표시가 나타납니다.

안내선 레이어 만들기

객체를 그릴 때 쉽게 정렬하려면 안내선 레이어를 만든 다음 안내선 레이어에서 만든 객체를 기준으로 다른 레이어의 객체를 정렬합니다. 안내선 레이어는 내보낼 수 없으며 제작된 SWF 파일에 나타나지 않습니다. 모든 레이어를 안내선 레이어로 사용할 수 있습니다. 안내선 레이어 이름의 왼쪽에는 안내 아이콘이 표시됩니다.

  1. 레이어를 선택하고 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)한 다음 컨텍스트 메뉴에서 [안내선]을 선택합니다. 레이어를 일반 레이어로 되돌리려면 [안내선]을 다시 선택합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책