Dreamweaver 체크인/체크아웃 시스템, WebDAV 또는 Subversion를 사용하는 로컬 및 원격 서버의 파일을 체크인 및 체크아웃합니다.

공동으로 작업하는 환경에서 로컬 및 원격 서버의 파일을 체크인 및 체크아웃할 수 있습니다. 혼자 원격 사이트에서 작업하는 경우에는 파일을 체크인하거나 체크아웃할 필요 없이 [내려받기] 및 [올리기] 명령을 사용할 수 있습니다.

참고:

테스트 서버에 [내려받기] 및 [올리기] 기능은 사용할 수 있지만 [체크인/체크아웃] 시스템은 사용할 수 없습니다.

파일을 체크아웃하는 것은 “현재 이 파일로 작업 중입니다. 손대지 마십시오.”라고 선언하는 것과 같습니다. 파일을 체크아웃하면 파일 패널에 해당 파일을 체크아웃한 사람의 이름이 표시되고 해당 파일의 아이콘 옆에는 빨간색 체크 표시(다른 팀 멤버가 파일을 체크아웃한 경우) 또는 녹색 표시(자신이 파일을 체크아웃한 경우)가 나타납니다.

파일을 체크인하면 팀의 다른 멤버가 해당 파일을 체크아웃하고 편집할 수 있게 됩니다. 파일을 편집한 후 체크인하면 사용자의 로컬 버전은 읽기 전용이 되고 파일 패널의 파일 옆에 잠금 기호가 나타나 파일을 변경하는 것을 막습니다.

Dreamweaver는 원격 서버에 있는 체크아웃된 파일은 읽기 전용으로 설정하지 않습니다. Dreamweaver가 아닌 다른 응용 프로그램을 사용하여 파일을 전송할 경우 체크아웃된 파일을 덮어쓸 수도 있습니다. 단, Dreamweaver가 아닌 다른 응용 프로그램에서는 파일 계층 구조에서 체크아웃된 파일 옆에 LCK 파일이 나타나 이런 실수를 방지해 줍니다.

체크인/체크아웃 시스템 설정

체크인/체크아웃 시스템을 사용하려면 먼저 로컬 사이트를 원격 서버에 연결해야 합니다.

  1. [사이트] > [사이트 관리]를 선택합니다.
  2. 사이트를 선택하고 [편집]을 클릭합니다.
  3. [사이트 설정] 대화 상자에서 [서버] 범주를 선택하고 다음 중 하나를 수행합니다.
    • [새 서버 추가] 버튼을 클릭하여 새 서버 추가

    • 기존 서버를 선택하고 [기존 서버 편집] 버튼을 클릭

  4. 필요에 따라 [기본] 옵션을 지정한 다음 [고급] 버튼을 클릭합니다.
  5. 공동으로 작업하는 경우 또는 혼자 작업하지만 여러 컴퓨터에서 작업하는 경우 [파일 체크아웃 활성화]를 선택합니다. 웹 사이트에 대해 파일 체크인/체크아웃을 비활성화하려면 이 옵션을 선택 취소합니다.

    이 옵션은 사용자가 편집하기 위해 파일을 체크아웃했다는 것을 다른 사람에게 알리거나, 파일의 최신 버전이 다른 컴퓨터에 있을 수 있다는 것을 사용자 자신에게 경고하고자 할 때 유용합니다.

    원격 서버를 설정하지 않은 경우 [체크인/체크아웃] 옵션이 표시되지 않습니다.

  6. 파일 패널에서 파일을 더블 클릭하여 열 때 파일을 자동으로 체크아웃하려면 [열 때 파일 체크아웃] 옵션을 선택합니다.

    이 옵션이 선택되어 있어도 [파일] > [열기]를 사용하여 파일을 열면 파일이 체크아웃되지 않습니다.

  7. 다음과 같이 나머지 옵션을 설정합니다.

    체크아웃 이름

    체크아웃 이름은 파일 패널에서 체크아웃한 파일 옆에 나타납니다. 이를 통해 팀의 다른 멤버가 자신이 필요로 하는 파일이 체크아웃된 경우 체크아웃한 사람과 통신할 수 있습니다.

    참고:

    여러 개의 서로 다른 시스템에서 혼자 작업하는 경우, 각 시스템에 서로 다른 체크아웃 이름(예: AmyR-HomeMac 및 AmyR-OfficePC)을 사용하여 체크인을 잊어버렸을 때 최신 버전의 파일이 어디에 있는지 알 수 있도록 합니다.

    이메일 주소

    이메일 주소를 입력한 다음 파일을 체크아웃하면 파일 패널에서 해당 파일 옆에 사용자의 이름이 파란색 밑줄의 링크로 표시됩니다. 팀 멤버가 해당 링크를 클릭하면 기본 이메일 프로그램이 실행되면서 사용자의 이메일 주소를 수신으로 하여 파일 및 사이트 이름이 제목에 입력되어 있는 새 메시지가 열립니다.

원격 폴더에서 파일 체크인 및 체크아웃

[체크인/체크아웃] 시스템을 설정한 뒤에는 문서 창이나 파일 패널을 사용하여 원격 서버의 파일을 체크인 및 체크아웃할 수 있습니다.

파일 패널을 사용하여 파일 체크아웃

  1. 파일 패널([윈도우] > [파일])에서 파일을 선택하여 원격 서버에서 체크아웃합니다.

    참고:

    [테스트 서버] 보기를 제외한 [로컬] 보기 또는 [원격] 보기에서 파일을 선택할 수 있습니다.

    빨간색 체크 표시는 다른 팀 멤버가 파일을 체크아웃했음을 나타내며 잠금 기호는 파일이 읽기 전용(Windows)이거나 잠겨 있음(Macintosh)을 나타냅니다.

  2. 다음 중 하나를 수행하여 파일을 체크아웃합니다.
    • 파일 패널 툴바에 있는 [체크아웃] 버튼을 클릭합니다.

    • 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, 컨텍스트 메뉴에서 [체크아웃]을 선택합니다.

  3. [종속 파일] 대화 상자에서 [예]를 클릭하여 선택한 파일과 함께 종속 파일을 다운로드하거나, [아니요]를 클릭하여 종속 파일을 다운로드하지 않도록 합니다. 기본값은 종속 파일을 다운로드하지 않는 것입니다. [편집] > [환경 설정] > [사이트]에서 이 옵션을 설정할 수 있습니다.

    참고:

    일반적으로 새 파일을 체크아웃할 때는 종속 파일을 다운로드하는 것이 좋지만, 종속 파일의 최신 버전이 이미 로컬 디스크에 있는 경우에는 다시 다운로드할 필요가 없습니다.

    녹색 체크 표시가 로컬 파일의 아이콘 옆에 나타나 사용자가 체크아웃했음을 나타냅니다.

    참고:

    현재 활성화되어 있는 파일을 체크아웃하면 새로 체크아웃한 버전이 현재 열려 있는 버전을 덮어쓰게 됩니다.

파일 패널을 사용하여 파일을 체크인

  1. 파일 패널([윈도우] > [파일])에서 체크아웃한 파일이나 새 파일을 선택합니다.

    참고:

    [테스트 서버] 보기를 제외한 [로컬] 또는 [원격] 보기에서 파일을 선택할 수 있습니다.

  2. 다음 중 하나를 수행하여 파일을 체크인합니다.
    • 파일 패널 툴바에서 [체크인] 버튼을 클릭합니다.

    • 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, 컨텍스트 메뉴에서 [체크인]을 선택합니다.

  3. [예]를 클릭하여 선택한 파일과 함께 종속 파일을 업로드하거나, [아니요]를 클릭하여 종속 파일이 업로드되지 않도록 합니다. 기본값은 종속 파일을 업로드하지 않는 것입니다. [편집] > [환경 설정] > [사이트]에서 이 옵션을 설정할 수 있습니다.

    참고:

    일반적으로 새 파일을 체크인할 때는 종속 파일을 업로드하는 것이 좋지만, 종속 파일의 최신 버전이 이미 원격 서버에 있는 경우에는 다시 업로드할 필요가 없습니다.

    잠금 기호가 로컬 파일의 아이콘 옆에 나타나 파일이 이제 읽기 전용이 되었음을 나타냅니다.

    참고:

    현재 활성화되어 있는 파일을 체크인하면 환경 설정 옵션에 따라 체크인 되기 전에 현재 파일이 자동으로 저장될 수도 있습니다.

문서 창에서 열린 파일 체크인

  1. 체크인하려는 파일이 문서 창에 열려 있는지 확인합니다.

    참고:

    한 번에 하나의 열린 파일만 체크인할 수 있습니다.

  2. 다음 중 하나를 수행합니다.
    • [사이트] > [체크인]을 선택합니다.

    • 문서 창 툴바에서 [파일 관리] 아이콘을 클릭한 다음, 해당 메뉴에서 [체크인]을 선택합니다.

      현재 파일이 파일 패널의 활성 사이트에 속하지 않는 경우 Dreamweaver에서 어떤 로컬 사이트에 속해 있는지 확인합니다. 현재 파일이 파일 패널의 활성 사이트 이외의 사이트에 속한 경우, Dreamweaver는 해당 사이트를 연 다음 체크인 작업을 수행합니다.

    참고:

    현재 활성화되어 있는 파일을 체크인하면 환경 설정 옵션에 따라 체크인 되기 전에 현재 파일이 자동으로 저장될 수도 있습니다.  

파일 체크아웃 실행 취소

파일을 체크아웃한 후 편집하지 않기로 하거나 편집한 내용을 적용하지 않으려는 경우 체크아웃 작업을 취소할 수 있습니다. 그러면 파일이 원래 상태로 돌아갑니다.

파일 체크아웃을 취소하려면 다음 중 한 가지를 수행합니다.

  • 파일을 문서 창에서 연 다음 [사이트] > [체크아웃 취소]를 선택합니다.

  • 파일 패널([윈도우] > [파일])에서 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 채 마우스로 클릭(Macintosh)한 다음, [체크아웃 취소]를 선택합니다.

    이렇게 하면 파일의 로컬 사본이 읽기 전용으로 바뀌고 파일에 대한 변경 내용이 모두 취소됩니다.

WebDAV를 사용하여 파일 체크인 및 체크아웃

Dreamweaver에서는 HTTP 프로토콜에 대한 일련의 확장인 WebDAV(Web-based Distributed Authoring and Versioning)를 사용하는 서버에 연결하여 원격 웹 서버에 있는 파일을 공동으로 편집하고 관리할 수 있습니다. 자세한 내용은 www.webdav.org를 참조하십시오.

  1. 아직 정의하지 않았다면, 프로젝트 파일을 저장할 로컬 폴더를 지정하는 Dreamweaver 사이트를 정의합니다.
  2. [사이트] > [사이트 관리]를 선택한 다음 목록에서 해당 사이트를 더블 클릭합니다.
  3. [사이트 설정] 대화 상자에서 [서버] 범주를 선택하고 다음 중 하나를 수행합니다.
    • [새 서버 추가] 버튼을 클릭하여 새 서버 추가

    • 기존 서버를 선택하고 [기존 서버 편집] 버튼을 클릭

  4. [기본] 화면의 [다음을 사용하여 연결] 팝업 메뉴에서 [WebDAV]를 선택하고 필요한 경우 나머지 [기본] 화면 옵션을 설정합니다.
  5. [고급] 버튼을 클릭합니다.
  6. [파일 체크아웃 활성화] 옵션을 선택하고 다음 정보를 입력합니다.
    • [체크아웃 이름] 상자에 다른 팀 멤버에게 현재 사용자를 확인시켜주는 이름을 입력합니다.

    • [이메일 주소] 상자에 이메일 주소를 입력합니다.

      이름과 이메일 주소는 WebDAV 서버에서 소유권을 확인할 때 사용하며 파일 패널에 표시되어 연락처로 사용됩니다.

  7. [저장]을 클릭합니다.

    Dreamweaver에서 WebDAV 액세스를 위한 사이트를 구성합니다. 임의의 사이트 파일에 대해 체크인 또는 체크아웃 명령을 사용하면 WebDAV를 사용하여 해당 파일이 전송됩니다.

    참고:

    PHP 태그나 SSI와 같은 동적 내용이 있는 파일을 체크아웃하면 HTTP GET 명령이 해당 파일을 렌더링하기 때문에 WebDAV에서는 이러한 파일을 제대로 체크아웃할 수 없습니다.

SVN(Subversion)을 사용하여 파일 내려받기 및 체크인

참고:

Subversion(SVN) 지원은 Dreamweaver CC 2017 버전부터 지원되지 않습니다.

Dreamweaver는 사용자가 원격 웹 서버에 있는 파일을 공동으로 편집 및 관리할 수 있는 버전 제어 시스템인 SVN(Subversion)을 사용하는 서버에 연결할 수 있습니다. Dreamweaver가 전체 SVN 클라이언트는 아니지만 사용자가 최신 파일 버전을 내려받고, 변경하고 파일을 적용할 수 있도록 합니다.

참고:

Dreamweaver CS5는 Subversion 1.6.6 클라이언트 라이브러리를 사용하고 Dreamweaver CS5.5는 1.6.9 클라이언트 라이브러리를 사용합니다. 최신 버전의 Subversion 클라이언트 라이브러리는 이전 버전과 호환되지 않습니다. TortoiseSVN과 같은 타사 클라이언트 응용 프로그램을 최신 버전의 Subversion에서 작업할 수 있도록 업데이트하는 경우 업데이트된 Subversion 응용 프로그램은 로컬 Subversion 메타 데이터를 업데이트하고 Dreamweaver는 더 이상 Subversion과 통신할 수 없게 됩니다. 이 문제는 이러한 업데이트가 이전 버전과 호환되므로 Subversion 서버 업데이트에 영향을 받지 않습니다. Subversion 1.7 이상과 작동하는 타사 클라이언트 응용 프로그램으로 업그레이드하는 경우 Subversion을 다시 Dreamweaver와 함께 사용할 수 있도록 해 주는 업데이트가 있는지 Adobe에 확인해야 합니다. 이 문제에 대한 자세한 내용은 www.adobe.com/go/dw_svn_en을 참조하십시오.

SVN 버전 제어 파일을 작업할 때 타사의 파일 비교 도구를 사용하는 것이 좋습니다. 파일의 차이점을 비교하면 다른 사용자의 파일 변경 사항을 정확히 알 수 있습니다. 파일 비교 도구에 대한 자세한 내용을 보려면 Google 검색 등 웹 검색 엔진을 사용하여 “파일 비교” 또는 “diff” 도구를 검색하십시오. Dreamweaver에서는 대부분의 타사 도구를 사용할 수 있습니다.

SVN 및 Dreamweaver를 사용하는 작업에 대한 비디오 개요를 보려면 www.adobe.com/go/lrvid4049_dw를 참조하십시오.

SVN 연결 설정

Dreamweaver에 SVN(Subversion)을 버전 제어 시스템으로 사용하려면 SVN 서버에 대한 연결을 설정해야 합니다. SVN 서버에 대한 연결은 [사이트 정의] 대화 상자의 [버전 제어] 범주에서 설정합니다.

SVN 서버는 여러 사용자가 파일을 내려받고 적용할 수 있는 파일 저장소로, Dreamweaver에 일반적으로 사용하는 원격 서버와는 다릅니다. SVN을 사용하면 원격 서버는 웹 페이지의 “라이브” 서버로 남아 있고, SVN 서버는 버전 제어를 유지 관리할 파일의 저장소 역할을 합니다. 일반적인 작업 과정은 SVN 서버에서 파일을 내려받고 SVN 서버에 파일을 적용하여 Dreamweaver에서 원격 서버에 게시하는 것입니다. 원격 서버 설정과 SVN 설정은 완전히 별개의 과정입니다.

SVN 설정을 시작하려면 SVN 서버 및 SVN 저장소에 대한 액세스 권한이 있어야 합니다. SVN에 대한 자세한 내용은 Subversion 웹 사이트(/http://subversion.apache.org/)를 참조하십시오.

SVN 연결을 설정하려면 다음 단계를 수행합니다.

  1. [사이트] > [사이트 관리]를 선택하고 버전 제어를 설정할 사이트를 선택한 다음 [편집] 버튼을 클릭합니다.

    참고:

    Dreamweaver 사이트의 로컬 및 원격 폴더를 아직 설정하지 않은 경우에는 로컬 사이트만이라도 설정한 후 다음 절차를 진행해야 합니다. 이 단계에서는 원격 사이트가 필요 없으나 파일을 웹에 게시하려면 결국 원격 사이트를 설정해야 합니다. 자세한 내용은 Dreamweaver 사이트 작업을 참조하십시오.

  2. [사이트 설정] 대화 상자에서 [버전 제어] 범주를 선택합니다.

  3. [액세스] 팝업 메뉴에서 [Subversion]을 선택합니다.

  4. 액세스 옵션을 다음과 같이 설정합니다.

    • [프로토콜] 팝업 메뉴에서 프로토콜을 선택합니다. 사용 가능한 프로토콜은 HTTP, HTTPS, SVN 및 SVN+SSH입니다.

    참고:

    SVN+SSH 프로토콜을 사용하려면 특수한 구성이 필요합니다. 자세한 내용은 www.adobe.com/go/learn_dw_svn_ssh_en를 참조하십시오.

    • [서버 주소] 텍스트 상자에 SVN 서버의 주소를 입력합니다. 서버 주소는 일반적으로 servername.domain.com 형식입니다.

    • [저장소 경로] 텍스트 상자에 SVN 서버의 저장소 경로를 입력합니다. 경로는 일반적으로 /svn/your_root_directory와 같은 형태입니다. SVN 저장소의 루트 폴더 이름 지정은 서버 관리자의 역할입니다.

    • (선택 사항) 기본 서버 포트 이외의 서버 포트를 사용하려면 [기본값 아님]을 선택하고 텍스트 상자에 포트 번호를 입력합니다.

    • SVN 서버 사용자 이름과 암호를 입력합니다.

  5. [테스트]를 클릭하여 연결을 테스트하거나 [확인]을 클릭하여 대화 상자를 닫습니다. 그런 다음 [완료]를 클릭하여 [사이트 관리] 대화 상자를 닫습니다.

서버에 연결이 설정되면 파일 패널에서 SVN 저장소를 볼 수 있습니다. SVN 저장소를 보려면 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼 을 클릭합니다.

최신 버전의 파일 내려받기

SVN 저장소에서 최신 버전의 파일을 내려받으면 Dreamweaver가 파일 내용을 해당 로컬 사본의 내용과 병합합니다. 즉, 파일을 마지막으로 적용한 후 다른 사용자가 파일을 업데이트한 경우 해당 업데이트 내용이 컴퓨터에 있는 로컬 버전 파일에 병합됩니다. 로컬 하드 드라이브에 해당 파일이 없는 경우 Dreamweaver는 파일을 내려받기만 합니다.

참고:

저장소에서 파일을 처음 가져오는 경우 비어 있는 로컬 디렉터리 또는 저장소에 있는 파일과 이름이 같은 파일이 포함되어 있지 않는 로컬 디렉터리에서 작업해야 합니다. Dreamweaver에서 처음 작업할 때 로컬 드라이브에 원격 저장소에 있는 파일과 동일한 이름의 파일이 포함되어 있으면 저장소 파일을 로컬 드라이브에 마운트하지 않습니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 다음 중 하나를 수행합니다.

    • [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다. 원하는 파일 또는 폴더를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)하고 [버전 제어] > [최신 버전 내려받기]를 선택합니다.

    • 파일 패널의 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼을 클릭하여 SVN 저장소 파일을 표시합니다. 원하는 파일 또는 폴더를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [최신 버전 내려받기]를 선택합니다.

참고:

파일을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 [체크아웃]을 선택하거나 파일을 선택하고 [체크아웃] 버튼을 클릭하여 최신 버전을 가져올 수도 있습니다. 그러나 SVN은 체크아웃 작업 과정을 지원하지 않기 때문에 이 액션으로 인해 실제로 파일이 체크아웃되지는 않습니다.

파일 적용

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 다음 중 하나를 수행합니다.

    • [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다. 그런 다음 적용할 파일을 선택하고 [체크인] 버튼을 클릭합니다.

    • 파일 패널의 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼을 클릭하여 SVN 저장소 파일을 표시합니다. 적용할 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [체크인]을 선택합니다.

  3. [적용] 대화 상자에서 액션을 확인하고 필요에 따라 변경한 다음 [확인]을 클릭합니다.

    액션을 변경할 파일을 선택하고 [적용] 대화 상자 아래쪽에 있는 해당 버튼을 클릭하여 액션을 변경할 수 있습니다. 선택할 수 있는 액션으로는 적용과 무시의 두 가지가 있습니다.

참고:

파일 패널의 파일에 녹색 체크 표시가 있으면 변경된 파일로서 저장소에 아직 적용되지 않았음을 나타냅니다.

저장소의 파일 또는 폴더 상태 업데이트

단일 파일 또는 폴더의 SVN 상태를 업데이트할 수 있습니다. 이 업데이트가 전체 표시를 새로 고치지는 않습니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 파일 패널의 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼을 클릭하여 SVN 저장소 파일을 표시합니다.

  3. 저장소에서 원하는 폴더 또는 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [업데이트 상태]를 선택합니다.

로컬 파일 또는 폴더의 상태 업데이트

단일 파일 또는 폴더의 SVN 상태를 업데이트할 수 있습니다. 이 업데이트가 전체 표시를 새로 고치지는 않습니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다.

  3. 파일 패널에서 원하는 폴더 또는 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [업데이트 상태]를 선택합니다.

파일 개정 버전 보기

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 다음 중 하나를 수행합니다.

    • [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다. 개정 버전을 볼 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)하고 [버전 제어] > [개정 버전 표시]를 선택합니다.

    • 파일 패널의 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼을 클릭하여 SVN 저장소 파일을 표시합니다. 개정 버전을 볼 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [개정 버전 표시]를 선택합니다.

  3. [개정 버전 내역] 대화 상자에서 원하는 개정 버전을 하나 이상 선택하고 다음 중 한 가지를 수행합니다.

    • 선택한 개정 버전을 해당 파일의 로컬 버전과 비교하려면 [로컬과 비교]를 클릭합니다.

    참고:

    파일을 비교하려면 타사 파일 비교 도구를 설치해야 합니다. 파일 비교 도구에 대한 자세한 내용을 보려면 Google 검색 등 웹 검색 엔진을 사용하여 “파일 비교” 또는 “diff” 도구를 검색하십시오. Dreamweaver에서는 대부분의 타사 도구를 사용할 수 있습니다.

    • 선택한 두 개정 버전을 비교하려면 [비교]를 클릭합니다. 두 개정 버전을 동시에 선택하려면 Ctrl 키를 누르고 클릭합니다.

    • 선택한 개정 버전을 보려면 [보기]를 클릭합니다. 이 액션을 통해 같은 파일의 현재 로컬 사본을 덮어쓰지는 않습니다. 다른 파일을 저장하는 것과 마찬가지 방식으로 선택한 개정 버전을 하드 드라이브에 저장할 수 있습니다.

    • 선택한 개정 버전을 저장소에서 최신 개정 버전으로 만들려면 [승격]을 클릭합니다.

파일 잠금 및 잠금 해제

SVN 저장소의 파일을 잠가 다른 사용자가 파일 사용 여부를 알 수 있게 할 수도 있습니다. 다른 사용자가 아직은 로컬로 파일을 편집할 수 있지만 잠금을 해제할 때까지 파일을 적용할 수는 없습니다. 저장소에서 파일을 잠그면 해당 파일에 열린 자물쇠 아이콘이 표시됩니다. 다른 사용자에게는 완전히 잠긴 자물쇠 아이콘이 표시됩니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 다음 중 하나를 수행합니다.

    • 파일 패널의 [보기] 팝업 메뉴에서 [저장소 보기]를 선택하거나 확장된 파일 패널에서 [저장소 파일] 버튼을 클릭하여 SVN 저장소 파일을 표시합니다. 원하는 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [잠금] 또는 [잠금 해제]를 선택합니다.

    • [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다. 원하는 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [잠금] 또는 [잠금 해제]를 선택합니다.

저장소에 새 파일 추가

파일 패널의 파일에 파란색 플러스(+) 기호가 있으면 SVN 저장소에 없는 파일임을 나타냅니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. 파일 패널에서 저장소에 추가할 파일을 선택하고 [체크인] 버튼을 클릭합니다.

  3. [적용] 대화 상자에서 [적용]에 대한 파일이 선택되어 있는지 확인한 다음 [확인]을 클릭합니다.

파일 이동, 복사, 삭제 또는 복귀

  • 파일을 이동하려면 파일을 로컬 사이트의 대상 폴더로 드래그합니다.

    파일을 이동할 때 Dreamweaver에는 [작업 내역과 함께 추가] 기호와 함께 새 위치의 파일이 표시되고 [삭제] 기호와 함께 이전 위치의 파일이 표시됩니다. 해당 파일을 적용하면 이전 위치의 파일은 사라집니다.

  • 파일을 복사하려면 파일을 선택하여 복사하고([편집] > [복사]) 새 위치에 파일을 붙여넣습니다([편집] > [붙여넣기]).

    파일을 복사하여 붙여넣을 때 Dreamweaver에는 [작업 내역과 함께 추가] 기호와 함께 새 위치의 파일이 표시됩니다.

  • 파일을 삭제하려면 파일을 선택하고 [삭제]를 누릅니다.

    파일의 로컬 버전만 삭제할지 또는 로컬 버전과 SVN 서버 버전을 모두 삭제할지 여부를 선택할 수 있는 옵션이 표시됩니다. 로컬 버전만 삭제하도록 선택하는 경우 SVN 서버의 파일은 영항을 받지 않습니다. SVN 서버 버전도 삭제하도록 선택하는 경우 [삭제] 기호와 함께 로컬 버전이 표시되고 삭제가 이루어지도록 파일을 적용해야 합니다.

  • 복사한 파일 또는 이동한 파일을 원래 위치로 되돌리려면 파일을 마우스 오른쪽 버튼으로 클릭하고 [버전 제어] >[복귀]를 선택합니다.

충돌 파일 해결

서버에서 사용자 파일이 다른 파일과 충돌하면 파일을 편집한 다음 해결된 상태로 만들 수 있습니다. 예를 들어 다른 사용자의 수정 사항과 충돌하는 파일을 체크인하려고 하면 SVN에서 파일 적용을 못하게 합니다. 저장소에서 파일의 최신 버전을 가져와 수동으로 작업 복사본에 수정 사항을 적용한 다음 파일을 해결된 상태로 표시하면 파일을 적용할 수 있습니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다.

  3. 해결할 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음 [버전 제어] > [해결됨으로 표시]를 선택합니다.

오프라인으로 이동

오프라인으로 이동하여 다른 파일 전송 작업 중에 저장소 액세스를 방지할 수 있습니다. 최신 버전 내려받기 및 적용 같은 연결이 필요한 작업을 호출하면 즉시 SVN 저장소로 다시 연결됩니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다.

  3. 파일 패널에서 원하는 파일 또는 폴더를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음 [버전 제어] > [오프라인으로 이동]을 선택합니다.

로컬 SVN 사이트 정리

이 명령을 사용하면 파일의 잠금을 제거하여 완료하지 못한 작업을 다시 시작할 수 있습니다. “작업 복사본 잠김” 오류가 발생하면 이 명령을 사용하여 이전 잠금을 제거해야 합니다.

  1. SVN 연결이 제대로 설정되었는지 확인합니다.

  2. [보기] 팝업 메뉴에서 [로컬 보기]를 선택하여 파일 패널에 SVN 파일의 로컬 버전을 표시합니다. 확장된 파일 패널에서 작업하는 경우 로컬 보기가 자동으로 표시됩니다.

  3. 정리할 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음 [버전 제어] > [정리]를 선택합니다.

Subversion 제어 사이트에서 파일 및 폴더 이동 정보

Subversion 제어 사이트에서 파일 또는 폴더의 로컬 버전을 이동하는 경우 SVN 저장소에 동기화하는 다른 사용자에게 문제를 야기할 수 있습니다. 예를 들어 파일을 로컬에서 이동하고 몇 시간 동안 저장소에 적용하지 않는 경우 다른 사용자가 해당 파일의 이전 위치에서 파일의 최신 버전을 내려받을 수 있습니다. 그러므로 파일을 로컬에서 이동한 다음에는 항상 SVN 서버에 파일을 다시 적용해야 합니다.

파일 및 폴더는 수동으로 삭제할 때까지 SVN 서버에 남아 있습니다. 따라서 파일을 다른 로컬 폴더로 이동하고 적용하더라도 파일의 이전 버전은 서버의 이전 위치에 그대로 있습니다. 이동한 파일 및 폴더의 이전 사본을 삭제하여 혼동을 방지하는 것이 좋습니다.

로컬에서 파일을 이동하고 SVN 서버에 다시 적용하면 파일 버전 작업 내역이 사라집니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책