Admin Console에서 설정 >ID > (디렉터리 이름)> 인증으로 이동합니다.
Adobe Admin Console을 사용하여 ID 공급자(IdP)에 대한 SSO를 설정했는데 최종 사용자가 Adobe 앱 및 서비스에 로그인할 수 없는 경우 SAML 인증서가 만료되었을 수 있습니다.
문제
다음과 같은 문제가 발생합니다.
- 최종 사용자가 로그아웃되어 Adobe Creative Cloud 웹, 모바일 또는 데스크탑 앱에 로그인할 수 없습니다.
- 최종 사용자가 로그인을 시도하면 다음과 같은 오류 메시지가 표시됩니다.
- SAML 인증 확인에 실패했습니다.
- SAML 응답의 디지털 서명이 ID 공급자의 인증서로 확인되지 않았습니다.
- 관리자가 사용자 또는 제품 프로필을 추가/제거/관리할 수 없습니다.
- 관리자가 곧 만료 예정인 SAML 인증서를 갱신하고자 합니다.
원인
SAML 교환에서 관련된 두 엔티티는 다음과 같습니다.
- ID 공급자(IdP)
IdP 인증서는 고객이 자체 IdP(ADFS, OKTA, Shiboleth) 내에서 소유하고 관리되며 Admin Console에 업로드됩니다. - 서비스 공급자(SP) 역할을 하는 Adobe
Adobe 엔티티는 Admin Console에서 관리되며 고객의 IdP에 업로드됩니다.
두 엔티티 모두 트러스트를 구축하는 데 사용되는 각각의 인증서를 가지고 있습니다.
Adobe Admin Console을 사용하여 ID 공급자(IdP)에 대한 SSO를 설정했는데 최종 사용자가 Adobe 앱 및 서비스에 로그인할 수 없다면 SAML 인증서가 만료되었을 수 있습니다.
Admin Console 알림
Adobe는 Adobe에서 생성한 인증서가 만료되도록 설정되거나 만료되면 디렉터리별 상태 업데이트와 함께 Admin Console의 배너 알림을 통해 알려 드립니다. SAML 인증서의 상태를 보려면 설정 > ID 설정으로 이동하여 디렉터리 탭의 상태 열을 검토하십시오.
해결 방법
SAML 설정
인증서가 만료되었거나 곧 만료되는 경우 Admin Console을 통해 페더레이션 설정을 직접 업데이트할 수 있습니다. SAML 인증서는 SAML 설정과 함께 업데이트됩니다.
IdP가 인증서의 유효성을 확인하지 않는 경우 조치가 필요하지 않습니다.
시스템 관리자는 다음 단계에 따라 Admin Console에서 자체 서명된 인증서를 직접 업데이트하고 관리할 수 있습니다.
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편집 및 다음을 차례로 클릭합니다.
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사용 가능한 인증서와 상태를 봅니다. 인증서를 새로 생성하거나 새 인증서 서명 요청을 생성할 수 있습니다.
참고:자체 서명된 인증서는 보다 편리하며 보안 모범 사례를 따릅니다. 조직에 자체 서명 인증서를 통해 충족될 수 없는 특정 요구 사항이 있는 경우가 아니라면 자체 서명 인증서를 선택하는 것이 좋습니다.
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새 인증서 생성을 클릭합니다.
활성 SAML 구성을 위해 선택한 페더레이션 디렉터리 내에 새 SAML 인증서가 생성됩니다.
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새 서명 요청을 만듭니다.
인증서 서명 요청 만들기를 클릭합니다.
표시되는 대화 상자에 인증 기관(CA)에서 제공한 다음 정보의 세부 사항을 입력합니다.- 인증 기관의 세부 정보를 입력합니다.
- 새 서명 요청을 생성하기로 선택한 경우 해당 요청이 SAML 인증서에 적용되도록 CA(인증 기관)의 프로세스를 완료해야 합니다.
- 작업으로 이동하여 완료를 클릭합니다.
- 인증 기관의 인증서 파일을 업로드하고 완료 및 완료를 차례로 클릭합니다
인증서가 정상적으로 생성되면 기본값으로 설정, 활성화, 비활성화, 메타데이터 다운로드, 인증서 다운로드 및 삭제를 포함한 추가 작업을 수행할 수 있습니다.
IdP가 여러 인증서를 지원하는 경우 로그인 중단 없이 다음 단계를 따르십시오.
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이전 인증서 외에 새 인증서를 IdP에 업로드합니다.
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Adobe Admin Console에서 새 인증서를 기본으로 설정합니다.
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로그인을 테스트합니다.
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IdP 구성에서 이전 인증서를 제거합니다.
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이전 인증서를 비활성화/삭제합니다.
삭제하면 복구할 수 없으므로 비활성화하는 것이 좋습니다.
IdP가 여러 인증서를 지원하지 않는 경우 갱신을 수행하기 위한 가동 중단 간격을 선택해야 합니다.
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새 인증서를 IdP에 업로드합니다.
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Adobe Admin Console에서 새 인증서를 기본으로 설정합니다.
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로그인을 테스트합니다.
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이전 인증서를 비활성화합니다.
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문제가 없다면 이전 인증서를 삭제하십시오.
인증서를 삭제하면 복구할 수 없으므로 이전 인증서를 삭제하기 전에 신중하게 고려해 볼 것이 권장됩니다.
감사 로그
인증서 생성 및 관리와 관련하여 수행된 작업은 감사 로그에서 확인할 수 있습니다.
감사 로그를 보려면 Admin Console에서 인사이트 > 로그 > 감사 로그로 이동합니다.