Aprenda cómo realizar transformaciones XSL en el lado del servidor en Dreamweaver. Cree páginas XSLT y convierta páginas HTML en XSLT.

Nota:

la interfaz de usuario se ha simplificado en Dreamweaver CC y versiones posteriores. Como resultado, es posible que no encuentre algunas de las opciones que se describen en este artículo en Dreamweaver CC y versiones posteriores. Para obtener más información, consulte este artículo.

Flujo de trabajo para la realización de transformaciones XSL en el lado del servidor

Puede llevar a cabo transformaciones XSL en el lado del servidor. Infórmese sobre las transformaciones XSL del lado del servidor y del lado del cliente y sobre la utilización de XML y XSL con páginas Web antes de crear páginas que muestren datos XML.

Nota:

El servidor debe estar configurado correctamente para realizar transformaciones en el lado del servidor. Para más información, póngase en contacto con el administrador del servidor.

El flujo de trabajo general para realizar transformaciones XSL del lado del servidor es el siguiente (cada uno de los pasos se describe en otros temas):

1. Configure un sitio de Dreamweaver.

2. Seleccione una tecnología de servidor y configure el servidor de aplicación.

3. Pruebe el servidor de aplicaciones.

Por ejemplo, cree una página que requiera procesamiento y verifique que el servidor de aplicaciones procesa la página correctamente.

4. Cree un fragmento o página XSLT o convierta una página HTML en una página XSLT.

  • En el sitio de Dreamweaver, cree un fragmento de XSLT o una página completa XSLT.

  • Convierta una página HTML existente en una página completa XSLT.

5. Adjunte una fuente de datos XML a la página.

6. Visualice los datos XML vinculándolos al fragmento de XSLT o a la página XSLT completa.

7. Si procede, añada un objeto XSLT Repetir región a la tabla, o bien una fila de tabla que contenta los marcadores de posición de datos XML.

8. Inserte referencias.

  • Para insertar una referencia en el fragmento de XSLT de la página dinámica, utilice el comportamiento de servidor Transformación XSL.

  • Para insertar una referencia a la página completa XSLT de la página dinámica, elimine todo el código HTML de una página dinámica y, a continuación, utilice el comportamiento de servidor Transformación XSL.

9. Publique la página y el fragmento.

Publique tanto la página dinámica como el fragmento de XSLT (o la página completa XSLT) en el servidor de aplicaciones. Si utiliza un archivo XML local, deberá publicarlo también.

10. Visualice la página dinámica en un navegador.

Al hacerlo, el servidor de aplicaciones transforma los datos XML, los inserta en la página dinámica y la muestra en el navegador.

Creación de una página XSLT

Puede crear páginas XSLT que permitan mostrar datos XML en páginas Web. Es posible crear una página XSLT completa (una página XSLT con una etiqueta <body> y una etiqueta <head>), o bien crear un fragmento de XSLT. Al crear un fragmento de XSLT, se crea un archivo independiente que no contiene etiquetas body ni head: se trata de una porción sencilla de código que, más adelante, se insertará en una página dinámica.

Nota:

Si utiliza una página XSLT existente como base, deberá adjuntar una fuente de datos XML.

  1. Seleccione Archivo > Nuevo.
  2. En la categoría Página en blanco del cuadro de diálogo Nuevo documento, seleccione una de las opciones siguientes de la columna Tipo de página:
    • Seleccione XSLT (página completa) para crear una página XSLT completa.

    • Seleccione XSLT (fragmento) para crear un fragmento de XSLT.

  3. Haga clic en Crear y siga uno de estos procedimientos en el cuadro de diálogo Buscar origen XML:
    • Seleccione Adjuntar un archivo local en mi equipo o en la red de área local, haga clic en el botón Examinar, busque un archivo XML en su equipo y, por último, haga clic en Aceptar.
    • Seleccione Adjuntar un archivo remoto en Internet, escriba el URL de un archivo XML de Internet (por ejemplo, uno proveniente de un agregador RSS) y haga clic en Aceptar.

    Nota:

    Si hace clic en el botón Cancelar, se generará una página XSLT nueva sin fuente de datos XML adjunta.

    El panel Vinculaciones muestra el esquema de la fuente de datos XML

    Panel Vinculaciones
    Panel Vinculaciones

    En la tabla siguiente se incluyen explicaciones de los distintos elementos del esquema que pueden aparecer:

    Elemento

    Representa

    Detalles

    <>

    Elemento XML no repetido requerido

    Un elemento que aparece exactamente una vez dentro de su nodo padre

    <>+

    Elemento XML repetido

    Un elemento que aparece una o más veces dentro de su nodo padre

    <>+

    Elemento XML opcional

    Un elemento que no aparece ninguna vez o más veces dentro de su nodo padre

    Nodo de elemento en negrita

    Elemento de contexto actual

    Normalmente, el elemento repetido cuando el punto de inserción se encuentra dentro de una región repetida

    @

    Atributo XML

     

     

  4. Guarde la nueva página (Archivo > Guardar) con la extensión .xsl o .xslt (.xsl es la extensión predeterminada).

Conversión de páginas HTML en páginas XSLT

También es posible convertir páginas HTML existentes en páginas XSLT. Por ejemplo, si ha predefinido una página estática a la que quiere añadir datos XML, puede convertirla en una página XSLT en vez de crear una página XSLT y rediseñarla desde cero.

  1. Abra la página HTML que desea convertir.
  2. Seleccione Archivo > Convertir > XSLT 1.0.

    Se abre una copia de la página en la ventana de documento. La nueva página es una hoja de estilos XSL y se guarda con la extensión .xsl.

Cómo adjuntar fuentes de datos XML

Si utiliza una página XSLT existente como base, o si no desea adjuntar una fuente de datos XML al crear una nueva página XSLT con Dreamweaver, deberá adjuntar una fuente de datos XML a través del panel Vinculaciones.

  1. En el panel Vinculaciones (Ventana > Vinculaciones), haga clic en el vínculo XML.
    Haga clic en un archivo XML del panel Vinculaciones.
    Haga clic en un archivo XML del panel Vinculaciones.

    Nota:

    También puede hacer clic en el vínculo Origen situado en la esquina superior derecha del panel Vinculaciones para añadir una fuente de datos XML.

  2. Siga uno de estos procedimientos:
    • Seleccione Adjuntar un archivo local en mi equipo o en la red de área local, haga clic en el botón Examinar, busque un archivo XML en su equipo y, por último, haga clic en Aceptar.

    • Seleccione Adjuntar un archivo remoto en Internet y escriba el URL de un archivo XML de Internet (por ejemplo, uno procedente de un agregador RSS).

  3. Haga clic en Aceptar para cerrar el cuadro de diálogo Buscar origen XML.

    El panel Vinculaciones muestra el esquema de la fuente de datos XML.

Visualización de datos XML en páginas XSLT

Una vez creada la página XSLT y tras adjuntar una fuente de datos XML, puede vincular los datos a la página. Para ello, puede añadir un marcador de posición de datos XML a la página y luego utilizar el Creador de expresiones XPath o el inspector de propiedades para aplicar formato a los datos seleccionados que se mostrarán en la página.

  1. Abra una página XSLT con una fuente de datos XML adjunta.
  2. (Opcional) Seleccione Insertar > Tabla para añadir una tabla a la página. Las tablas ayudan a organizar los datos XML.

    Nota:

    En la mayoría de los casos, deberá utilizar el objeto XSLT Repetir región para mostrar elementos XML repetidos en una página. En este caso, puede resultar conveniente crear una tabla de una sola fila con una o varias columnas, o bien una tabla de dos filas si desea incluir un encabezado de tabla.

  3. En el panel Vinculaciones, seleccione un elemento XML y arrástrelo hasta el lugar de la página en el que desea insertar los datos.
    Selección de un elemento XML del panel Vinculaciones
    Selección de un elemento XML del panel Vinculaciones

    Aparece en la página un marcador de posición de los datos XML. Este marcador de posición se muestra resaltado y encerrado entre llaves. Utiliza la sintaxis XPath (Lenguaje de rutas XML) para describir la estructura jerárquica del esquema XML. Por ejemplo, si arrastra el elemento hijo title a la página y dicho elemento tiene rss, channel e item como elementos padre, la sintaxis del marcador de posición del contenido dinámico será {rss/channel/item/title}.

    Haga doble clic en el marcador de posición de datos XML de la página para abrir el Creador de expresiones XPath. El Creador de expresiones XPath permite dar formato a los datos seleccionados o seleccionar otros elementos del esquema XML.

  4. (Opcional) Para aplicar estilos a los datos XML, seleccione un marcador de posición de datos XML y aplíquele los estilos como haría con cualquier otro fragmento de contenido. Utilice para ellos el inspector de propiedades o el panel Estilos CSS. Como alternativa, puede utilizar hojas de estilo de tiempo de diseño para aplicar estilos a los fragmentos de XSLT. Cada uno de estos métodos tiene sus ventajas y limitaciones.
  5. Obtenga una vista previa de su trabajo en un navegador (Archivo > Vista previa en el navegador).

    Nota:

    Al obtener una vista previa de su trabajo mediante la opción Vista previa en el navegador, Dreamweaver lleva a cabo una transformación XSL interna sin utilizar ningún servidor de aplicaciones.

Visualización de elementos XML repetidos

El objeto XSLT Repetir región permite mostrar elementos repetidos de una fuente de datos XML en una página. Por ejemplo, si muestra títulos y descripciones de artículos de un servidor de noticias, y éste contiene entre diez y veinte artículos, cada título y descripción del archivo XML probablemente sería un elemento hijo de un elemento repetido.

Cualquier región de la vista de Diseño que contenga un marcador de posición de los datos XML puede convertirse en una región repetida. Sin embargo, las regiones más comunes son tablas, filas de tablas o una serie de filas de tablas.

  1. En la vista de Diseño, seleccione una región que contenga uno o varios marcadores de posición de los datos XML.

    La selección puede ser una tabla, una fila de una tabla o incluso un párrafo de texto.

    Vista de diseño
    Vista de diseño

    Nota:

    Para seleccionar de forma precisa una región de la página, puede utilizar el selector de etiquetas que se encuentra en la parte inferior de la ventana de documento. Por ejemplo, si la región es una tabla, haga clic dentro de la tabla de la página y, a continuación, haga clic en la etiqueta table del selector de etiquetas.

  2. Siga uno de estos procedimientos:
    • Seleccione Insertar > Objetos XSLT > Región repetida.

    • En la categoría XSLT del panel Insertar, haga clic en el botón Repetir región.

  3. En el Creador de expresiones XPath, seleccione el elemento repetido (señalado con un pequeño signo más).
    Creador de expressiones XPATH
    Creador de expressiones XPATH

  4. Haga clic en Aceptar.

    En la ventana de documento, aparecerá un contorno delgado delimitado con tabulaciones de color gris alrededor de la región repetida. Al obtener una vista previa de su trabajo en un navegador (Archivo > Vista previa en el navegador), el contorno gris desaparece y la selección se amplía para mostrar los elementos repetidos especificados del archivo XML.

    Cuando añada el objeto XSLT Repetir región a la página, se truncará el marcador de posición de datos XML en la ventana de documento. Esto se debe a que Dreamweaver trunca la sintaxis XPath del marcador de posición de datos XML para que esté relacionado con la ruta de acceso del elemento repetido.

Configuración de las propiedades de Repetir región (XSL)

En el inspector de propiedades, puede seleccionar un nodo XML distinto para crear la región repetida.

  1. En el cuadro de selección, introduzca un nuevo nodo, presione el icono de rayo y seleccione el nodo en el árbol del esquema XML que aparece.

Edición de un objeto XSLT Repetir región

Después de añadir un objeto XSLT Repetir región a una región, puede editarlo mediante el inspector de propiedades.

  1. Seleccione el objeto haciendo clic en la ficha gris que rodea a la región repetida.
  2. En el inspector de propiedades (Ventana > Propiedades), haga clic en el icono dinámico situado junto al cuadro de texto Seleccionar.
  3. En el Creador de expresiones XPATH, realice los cambios y haga clic en Aceptar.

Inserción de fragmentos de XSLT en páginas dinámicas

Una vez creado un fragmento de XSLT, puede insertarlo en una página Web dinámica mediante el comportamiento de servidor Transformación XSL. Al añadir el comportamiento del servidor a la página y verla en un navegador, un servidor de aplicaciones lleva a cabo una transformación que muestra los datos XML desde el fragmento de XSLT seleccionado. Dreamweaver admite transformaciones XSL para páginas de ColdFusion, ASP o PHP.

Nota:

Si quiere insertar el contenido de una página completa XSLT en una página dinámica, el procedimiento es exactamente el mismo. Antes de utilizar el comportamiento de servidor Transformación XSL para insertar la página completa XSLT, elimine todo el código HTML de la página dinámica.

  1. Abra una página de ColdFusion, ASP o PHP existente.
  2. En la vista de Diseño, sitúe el punto de inserción donde desee insertar el fragmento de XSLT.

    Nota:

    Al insertar fragmentos de XSLT, siempre debe hacer clic en el botón Mostrar vistas de código y diseño después de situar el punto de inserción en la página para poder garantizar que el punto de inserción se encuentra en la ubicación correcta. Si no es así, tal vez deba hacer clic en cualquier otro lugar de la vista de Código para situar el punto de inserción en la ubicación que desee.

  3. En el panel Comportamientos del servidor (Ventana > Comportamientos del servidor), haga clic en el botón del signo más (+) y seleccione Transformación XSLT.
    Panel Comportamientos de servidor
    Panel Comportamientos de servidor

  4. En el cuadro de diálogo Transformación XSLT, haga clic en el botón Examinar y busque un fragmento de XSLT o una página completa XSLT.

    Dreamweaver completa el siguiente campo de texto con la ruta de archivo o el URL del archivo XML adjunto al fragmento especificado. Para modificarlo, haga clic en el botón Examinar y busque otro archivo.

  5. (Opcional) Haga clic en el botón del signo más (+) para añadir un parámetro XSLT.
  6. Haga clic en Aceptar para insertar una referencia al fragmento de XSLT en la página. Este fragmento no se puede editar. Puede hacer doble clic en el fragmento para abrir el archivo de origen y poder editarlo.

    Asimismo, se crea una carpeta llamada includes/MM_XSLTransform/ en la carpeta raíz del sitio, que contiene un archivo de biblioteca de tiempo de ejecución. El servidor de aplicaciones utiliza las funciones definidas en el archivo para realizar la transformación.

  7. Cargue la página dinámica en su servidor (Sitio > Colocar) y haga clic en Sí para incluir archivos dependientes. Tanto el archivo que contiene el fragmento de XSLT como el archivo XML que contiene los datos y el archivo de biblioteca de tiempo de ejecución generado deben estar en el servidor para que la página se muestre correctamente. (Si ha seleccionado un archivo XML remoto como fuente de datos, dicho archivo deberá residir en alguna otra ubicación de Internet).

Eliminación de fragmentos de XSLT de páginas dinámicas

Para quitar un fragmento de XSLT de una página, puede eliminar el comportamiento de servidor Transformación XSL utilizado para insertar el fragmento. Al eliminar el comportamiento del servidor, solo se elimina el fragmento de XSLT; no se eliminan otros archivos asociados, como los archivos XML, XSLT o los archivos de biblioteca de tiempo de ejecución.

  1. En el panel Comportamientos del servidor (Ventana > Comportamientos del servidor), seleccione el comportamiento de servidor Transformación XSL que desee eliminar.
  2. Haga clic en el botón del signo menos (-).

    Nota:

    Debe eliminar siempre los comportamientos del servidor de esta forma. La eliminación manual del código generado únicamente quita el comportamiento del servidor de forma parcial, incluso si el comportamiento del servidor desaparece del panel Comportamientos del servidor.

Edición de comportamientos de servidor Transformación XSL

Una vez añadido el fragmento de XSLT a una página Web dinámica, puede editar el comportamiento de servidor Transformación XSL siempre que lo desee.

  1. En el panel Comportamientos del servidor (Ventana > Comportamientos del servidor), haga doble clic en el comportamiento de servidor Transformación XSL que desee editar.
  2. Realice los cambios que desee y haga clic en Aceptar.

Puede crear un vínculo dinámico en su página XSLT que se vincule a un URL específico cuando el usuario haga clic en una palabra o grupo de palabras determinado desde sus datos XML. Para obtener instrucciones completas, consulte la fe de erratas de Dreamweaver en www.adobe.com/go/dw_documentation_es.

Aplicación de estilos a fragmentos de XSLT

Al crear una página completa XSLT (es decir, una página XSLT que contiene etiquetas <body> y <head>), puede visualizar los datos XML en la página y, después, aplicarles formato como haría con cualquier otro fragmento de contenido mediante el inspector de propiedades o el panel Estilos CSS. Sin embargo, al crear un fragmento de XSLT para su inserción en una página dinámica (por ejemplo, un fragmento para insertar en una página ASP, PHP o Cold Fusion), la representación de los estilos en el fragmento y en la página dinámica se complica bastante. Aunque trabaje con un fragmento de XSLT fuera de la página dinámica, es importante recordar que el fragmento sirve para su utilización dentro de la página y que el resultado del fragmento reside en última instancia en las etiquetas <body> de la página dinámica. Teniendo en cuenta este flujo de trabajo, es importante asegurarse de no incluir elementos <head> (como definiciones de estilos o vínculos a hojas de estilos externas) en los fragmentos de XSLT. Si lo hace, el servidor de aplicaciones insertará estos elementos en la sección <body> de la página dinámica, lo que provocará un marcado no válido.

Por ejemplo, puede que desee crear un fragmento de XSLT para insertarlo en una página dinámica y aplicarle formato con la misma hoja de estilos externa que la página dinámica. Si adjunta la misma hoja de estilos al fragmento, la página HTML resultante contendrá un vínculo duplicado a la hoja de estilos (uno en la sección <head> de la página dinámica y otro en la sección <body> de la página, donde aparece el contenido del fragmento de XSLT). En vez de utilizar este método, debería utilizar hojas de estilo de tiempo de diseño para hacer referencia a la hoja de estilos externa.

Al dar formato al contenido de los fragmentos de XSLT, utilice el siguiente flujo de trabajo:

  • En primer lugar, adjunte una hoja de estilos externa a la página dinámica. (Esta es la práctica recomendada para aplicar estilos al contenido de cualquier página Web).

  • A continuación, adjunte la misma hoja de estilos externa al fragmento de XSLT como una hoja de estilos de tiempo de diseño. Tal como indica su propio nombre, las hojas de estilos de tiempo de diseño solo funcionan en la Vista de diseño de Dreamweaver.

    Una vez finalizados los dos pasos anteriores, puede crear nuevos estilos en el fragmento de XSLT con la misma hoja de estilos que adjuntó a la página dinámica. El código HTML resultante será más claro (ya que la referencia a la hoja de estilos solo es válida mientras se trabaja en Dreamweaver) y el fragmento seguirá mostrando los estilos adecuados en la Vista de diseño. Además, todos los estilos se aplicarán tanto al fragmento como a la página dinámica cuando la visualice en la vista de Diseño, o cuando obtenga una vista previa de la página dinámica en un navegador.

Nota:

Si obtiene una vista previa del fragmento de XSLT en un navegador, éste no mostrará los estilos. Deberá obtener la vista previa de la página dinámica en el navegador para poder visualizar el fragmento de XSLT en el contexto de la página dinámica.

Utilización de los parámetros en las transformaciones XSL

Puede definir parámetros para su transformación XSL al añadir el comportamiento de servidor Transformación XSL a una página Web. Los parámetros controlan el modo en que se procesan y se muestran los datos XML. Por ejemplo, puede resultar conveniente utilizar un parámetro para identificar y mostrar un artículo concreto de un servidor de noticias. Cuando la página se carga en el navegador, solo se muestra el artículo especificado con el parámetro.

Adición de un parámetro XSLT a una transformación XSL

  1. Abra el cuadro de diálogo Transformación XSL. Puede hacerlo de dos modos: haciendo doble clic en un comportamiento de servidor Transformación XSL del panel Comportamientos del servidor (Ventana > Comportamientos del servidor), o bien añadiendo un comportamiento de servidor Transformación XSL nuevo.
  2. En el cuadro de diálogo Transformación XSL, haga clic en el botón del signo más (+) situado junto a Parámetros XSLT.
    Cuadro de diálogo Transformación XSL
    Cuadro de diálogo Transformación XSL

  3. En el cuadro de diálogo Añadir parámetros, introduzca el nombre del parámetro en el cuadro Nombre. El nombre solo puede contener caracteres alfanuméricos. No puede contener espacios.
  4. Siga uno de estos procedimientos:
    • Si desea utilizar un valor estático, introdúzcalo en el cuadro de Valor.

    • Si lo que quiere es utilizar un valor dinámico, haga clic en el icono dinámico situado junto al cuadro Valor, rellene los datos necesarios del cuadro de diálogo Datos dinámicos y, por último, haga clic en Aceptar. Para más información, haga clic en el botón Ayuda del cuadro de diálogo Datos dinámicos.

  5. En el cuadro Valor predeterminado, introduzca el valor que quiere que utilice el parámetro si la página no recibe ningún valor de tiempo de ejecución y haga clic en Aceptar.

Edición de un parámetro XSLT

  1. Abra el cuadro de diálogo Transformación XSL. Puede hacerlo de dos modos: haciendo doble clic en un comportamiento de servidor Transformación XSL del panel Comportamientos del servidor (Ventana > Comportamientos del servidor), o bien añadiendo un comportamiento de servidor Transformación XSL nuevo.
  2. Seleccione un parámetro en la lista de parámetros XSLT.
  3. Haga clic en el botón Editar.
  4. Realice los cambios que desee y haga clic en Aceptar.

Eliminación de un parámetro XSLT

  1. Abra el cuadro de diálogo Transformación XSL. Puede hacerlo de dos modos: haciendo doble clic en un comportamiento de servidor Transformación XSL del panel Comportamientos del servidor (Ventana > Comportamientos del servidor), o bien añadiendo un comportamiento de servidor Transformación XSL nuevo.
  2. Seleccione un parámetro en la lista de parámetros XSLT.
  3. Haga clic en el botón del signo menos (-).

Creación y edición de regiones condicionales XSLT

Puede crear regiones condicionales simples o múltiples en una página XSLT. Puede seleccionar un elemento en la vista de Diseño y aplicar una región condicional a la selección, o bien puede insertar una región condicional en el punto de inserción del documento.

Por ejemplo, si quiere mostrar la expresión “No disponible” junto al precio de un elemento cuando éste ya no esté disponible, puede escribir el texto “No disponible” en la página, seleccionarlo y, después, aplicar una región condicional al texto seleccionado. Dreamweaver rodea la selección con etiquetas <xsl:if> y solo muestra la palabra “No disponible” en la página cuando los datos cumplen las condiciones de la expresión condicional.

Aplicación de una región condicional XSLT

Puede escribir una expresión condicional simple para insertarla en la página XSLT. Si el contenido está seleccionado al abrir el cuadro de diálogo Región condicional, el contenido se ajustará en un bloque <xsl:if>. Si no hay contenido seleccionado, el bloque <xsl:if> se añadirá en el punto de inserción de la página. Es recomendable utilizar el cuadro de diálogo para familiarizarse con su uso y, más adelante, personalizar la expresión en la vista de Código.

El elemento <xsl:if> es similar a la declaración if de otros lenguajes de programación. Este elemento sirve para probar una condición y decidir después qué hacer en función del resultado. El elemento <xsl:if> permite probar una expresión para un valor simple true o false.

  1. Seleccione Insertar > Objetos XSLT > Región condicional o haga clic en el icono Región condicional en la categoría XLST del panel Insertar.
  2. En el cuadro de diálogo Región condicional, escriba la expresión condicional que quiere utilizar para la región.

    En el siguiente ejemplo, comprobaremos si el valor del atributo @available del nodo de contexto es true.

    Cuadro de diálogo Región condicional
    Cuadro de diálogo Región condicional

  3. Haga clic en Aceptar.

    El código siguiente se inserta en la página XSLT:

    <xsl:if test="@available=&apos;true&apos;"> 
        Content goes here 
    </xsl:if>

    Nota:

    Debe rodear los valores de cadena, como los valores true, entre comillas. Dreamweaver codifica las comillas por el usuario (&apos;) para que se introduzcan como XHTML válido.

    Además de los nodos de prueba para los valores, puede utilizar cualquiera de las funciones compatibles de XSLT en cualquier declaración condicional. La condición se prueba para el nodo actual del archivo XML. En el siguiente ejemplo, queremos probar el último nodo del conjunto de resultados:

    Prueba del último nodo en el conjunto de resultados
    Prueba del último nodo en el conjunto de resultados

    Para más información y ejemplos de expresiones condicionales, consulte la sección <xsl:if> del panel Referencia (Ayuda > Referencia).

Aplicación de múltiples regiones condicionales XSLT

Puede escribir una expresión condicional simple para insertarla en la página XSLT. Si el contenido está seleccionado al abrir el cuadro de diálogo Región condicional, el contenido se ajustará en un bloque <xsl:choose>. Si no selecciona ningún contenido, el bloque <xsl:choose> se añadirá en el punto de inserción de la página. Es recomendable utilizar el cuadro de diálogo para familiarizarse con su uso y, más adelante, personalizar la expresión en la vista de Código.

El elemento <xsl:choose> es similar a la declaración case de otros lenguajes de programación. Este elemento sirve para probar una condición y decidir después qué hacer en función del resultado. El elemento <xsl:choose> permite probar condiciones múltiples.

  1. Seleccione Insertar > Objetos XSLT > Región condicional múltiple o haga clic en el icono Región condicional múltiple en la categoría XLST del panel Insertar.
  2. En el cuadro de diálogo Región condicional múltiple, escriba la primera condición.

    En el siguiente ejemplo, probaremos si el subelemento price del nodo actual es menor que cinco.

    Cuadro de diálogo Región condicional múltiple
    Cuadro de diálogo Región condicional múltiple

  3. Haga clic en Aceptar.

    En el ejemplo, se inserta el código siguiente en la página XSLT:

    <xsl:choose> 
        <xsl:when test="price&lt;5"> 
            Content goes here 
        </xsl:when> 
        <xsl:otherwise> 
            Content goes here 
        </xsl:otherwise> 
    </xsl:choose>
  4. Para insertar otra condición, coloque el punto de inserción en la vista de Código entre los pares de etiquetas <xsl:when> o justo antes de la etiqueta <xsl:otherwise> y, a continuación, inserte una región condicional (Insertar > Objetos XSLT > Región condicional).

    Después de especificar la condición y hacer clic en Aceptar, se inserta otra etiqueta <xsl:when> en el bloque <xsl:choose>.

    Para más información y ejemplos de expresiones condicionales, consulte las secciones <xsl:choose> del panel Referencia (Ayuda > Referencia).

Configuración de las propiedades de región condicional (If)

El inspector de propiedades de definición de región condicional sirve para modificar la condición utilizada en una región condicional de la página XSL. La región condicional prueba la condición y decidir qué hacer después en función del resultado.

  1. En el cuadro de prueba, introduzca una nueva condición y presiona la tecla Intro.

Configuración de las propiedades condicionales (When)

El inspector de propiedades de definición de región condicional sirve para modificar la condición utilizada en una región condicional múltiple de la página XSL. La región condicional múltiple prueba la condición y decidir qué hacer después en función del resultado.

  1. En el cuadro de prueba, introduzca una nueva condición y presione la tecla Intro.

Inserción de comentarios XSL

Puede añadir etiquetas de comentarios XSL en un documento o ajustar una selección en las etiquetas de comentarios XSL.

Adición de etiquetas de comentarios XSL a un documento

  1. Siga uno de estos procedimientos:
    • En la vista de Diseño, seleccione Insertar > Objetos XSLT > Comentario XSL, redacte el contenido del comentario (o deje el cuadro en blanco) y haga clic en Aceptar.

    • En la vista de Código, seleccione Insertar > Objetos XSLT > Comentario XSL.

    Nota:

    También puede hacer clic en el icono Comentario XSL de la categoría XSLT del panel Insertar.

Ajuste de una selección en etiquetas de comentarios XSL

  1. Cambie a la vista de Código (Ver > Código).
  2. Seleccione el código que quiere comentar.
  3. En la barra de herramientas Programación, haga clic en el botón Aplicar comentario y seleccione Aplicar comentario <xsl:comment></xsl:comment>.

Uso del Creador de expresiones XPath con el fin de añadir expresiones para datos XML

XPath (Lenguaje de rutas XML) es una sintaxis no XML para especificar porciones de un documento XML. Se suele utilizar sobre todo como lenguaje de consultas para datos XML, del mismo modo que el lenguaje SQL se utiliza para realizar consultas en bases de datos. Para obtener más información sobre XPath, consulte la especificación del lenguaje XPath en el sitio web de W3C www.w3.org/TR/xpath (en inglés).

El Creador de expresiones XPath es una función de Dreamweaver que le permite crear expresiones XPath simples para identificar nodos de datos concretos y regiones repetidas. La ventaja de este método reside en que, en vez de arrastrar los valores desde el árbol del esquema XML, puede dar formato al valor que se visualiza. El contenido actual se identifica en función de la posición del punto de inserción en el archivo XSL cuando está abierto el cuadro de diálogo Creador de expresiones XPath. El contexto actual se muestra en negrita en el árbol del esquema XML. A medida que se realizan selecciones en este cuadro de diálogo, se generan declaraciones XPath correctas relativas al contexto actual. Con esto se simplifica el proceso de creación de expresiones XPath correctas para ingenieros y usuarios avanzados.

Nota:

Esta función está diseñada para ayudarle a crear expresiones XPath simples que identifiquen un nodo concreto o regiones repetidas. No da la posibilidad de editar las expresiones manualmente. Si necesita crear expresiones más complejas, utilice el cuadro de diálogo Creador de expresiones XPath para empezar y, después, personalice las expresiones en la vista de Código o en el inspector de propiedades.

Creación de una expresión XPath para identificar un nodo concreto

  1. Haga doble clic en el marcador de posición de datos XML de la página para abrir el Creador de expresiones XPath.
  2. En el cuadro de diálogo Creador de expresiones XPATH (Texto dinámico), seleccione cualquier nodo del árbol del esquema XML.

    Se escribe la expresión XPath correcta en el cuadro Expresión para identificar al nodo.

    Nota:

    Si selecciona un nodo distinto en el árbol del esquema XML, la expresión cambia para reflejar la selección.

    En el siguiente ejemplo, se mostrará el subelemento price del nodo item:

    Cuadro de diálogo Creador de expresiones XPATH (Texto dinámico)
    Cuadro de diálogo Creador de expresiones XPATH (Texto dinámico)

    La selección insertaría el siguiente código en la página XSLT:

    <xsl:value-of select="price"/>
  3. (Opcional) Seleccione una opción de formato en el menú emergente Formato.

    Dar formato a una selección resulta útil cuando el valor del nodo devuelve un número. Dreamweaver proporciona una lista predefinida de las funciones de formato. Si desea obtener una lista completa de las funciones y ejemplos de formato disponibles, consulte el panel Referencia.

    En el siguiente ejemplo, daremos formato al subelemento price como una divisa con dos posiciones decimales:

    Formato del subelemento price como una divisa con dos posiciones decimales
    Formato del subelemento price como una divisa con dos posiciones decimales

    Estas opciones insertarían el siguiente código en la página XSLT<xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>

    <xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>
  4. Haga clic en Aceptar.
  5. Para visualizar el valor de cada nodo del archivo XML, aplique una región repetida al elemento que contiene el texto dinámico (por ejemplo, la fila de una tabla HTML o un párrafo).

    Para más información y ejemplos de selección de nodos que devuelven un valor, consulte la sección <xsl:value-of/> del panel Referencia.

Selección de un nodo para repetir

Puede seleccionar un nodo sobre el que repetir y, opcionalmente, para filtrar los resultados. En el cuadro de diálogo Creador de expresiones XPath, el contenido seleccionado se ajustará dentro de un bloque <xsl:for-each>. Si no ha seleccionado ningún contenido, el bloque <xsl:for-each> se introducirá en el punto de inserción del cursor.

  1. Haga doble clic en el marcador de posición de datos XML de la página para abrir el Creador de expresiones XPath.
  2. En el cuadro de diálogo Creador de expresiones XPATH (Repetir región), seleccione el elemento que desea repetir en el árbol del esquema XML.

    Se escribe la expresión XPath correcta en el cuadro Expresión para identificar al nodo.

    Nota:

    Los elementos repetidos se identifican con un símbolo de signo más (+) en el árbol del esquema XML.

    En el siguiente ejemplo, repetiremos en cada nodo item dentro del archivo XML.

    Cuadro de diálogo Creador de expresiones Xpath (Repetir región)
    Cuadro de diálogo Creador de expresiones Xpath (Repetir región)

    Al hacer clic en Aceptar, el siguiente código se inserta en la página XSLT:

    <xsl:for-each select="provider/store/items/item"> 
     Content goes here 
    </xsl:for-each>

    En algunos casos, tal vez quiera trabajar con un subconjunto de los nodos repetidos; por ejemplo, puede que solo le interesen los elementos que tengan atributos un valor específico. En este caso, deberá crear un filtro.

Filtro de los datos que desea repetir

Utilice un filtro para identificar los nodos repetidos que tienen valores de atributo concretos.

  1. En el árbol del esquema XML, seleccione un nodo para repetir.
  2. Haga clic en el botón de expansión de creación del filtro.
  3. Haga clic en el botón de signo más (+) para crear un filtro vacío.
  4. Introduzca los criterios del filtro en los siguientes campos:

    Filtrar por

    Especifica el nodo repetido que contiene los datos con los que desea filtrar. El menú emergente proporciona una lista de nodos ascendentes relacionados con el nodo seleccionado en el árbol del esquema XML.

    Dónde

    Especifica el atributo o el subelemento del nodo Filtrar por que se utilizará para limitar los resultados. Puede seleccionar un atributo o un subelemento en el menú emergente, o bien introducir su propia expresión XPath en este campo para identificar los hijos que se encuentran en la estructura profunda del árbol del esquema.

    Operador

    Especifica el operador de comparación que se utiliza en la expresión del filtro.

    Valor

    Especifica el valor que se debe comprobar en el nodo Filtrar por. Introduzca el valor. Si los parámetros dinámicos están definidos en la página XSLT, puede seleccionar uno de ellos en el menú emergente.

  5. Si quiere especificar otro filtro, vuelva a hacer clic en el botón del signo más (+).

    Al introducir valores o realizar selecciones en los menús emergentes, cambia la expresión XPath en el cuadro Expresión.

    En el siguiente ejemplo, queremos restringir el conjunto de resultados a los nodos item en los que el valor del atributo @available sea true.

    Restricción del conjunto de resultados a los nodos item en los que el valor del atributo @available sea true
    Restricción del conjunto de resultados a los nodos item en los que el valor del atributo @available sea true

    Al hacer clic en OK, se inserta el siguiente código en la página XSLT:<xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]"> Content goes here </xsl:for-each>

    <xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]"> 
          Content goes here 
    </xsl:for-each>

    Nota:

    Debe rodear los valores de cadena como valores true entre comillas. Dreamweaver codifica las comillas por el usuario (&apos;) para que se introduzcan como XHTML válido.

    Es posible crear filtros más complejos que permitan especificar nodos padre como parte de los criterios de filtro. En el siguiente ejemplo, queremos restringir el conjunto de resultados a los nodos item en los que el atributo @id de store sea igual a 1 y el nodo price de item sea mayor que 5.

    Restrinja el conjunto de resultados a los nodos item en los que el atributo @id de store sea igual a 1 y el nodo price de item sea mayor que 5.
    Restrinja el conjunto de resultados a los nodos item en los que el atributo @id de store sea igual a 1 y el nodo price de item sea mayor que 5.

    Al hacer clic en OK, se inserta el siguiente código en la página XSLT:<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> Content goes here </xsl:for-each>

    Para más información y ejemplos de regiones repetidas, consulte la sección <xsl:for-each> del panel Referencia.

    <xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> 
        Content goes here 
    </xsl:for-each>

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea