Learn how you can format your content in many ways to enhance its readability and presentation.

Once you've created topics in Adobe RoboHelp, you are set to add text, images, tables, videos, links, and more. Format inline text, characters, paragraphs, and tables, and display them your way. You can also add symbols, HTML elements, expanding text, drop-down text, and more. You can format your content using the formatting options in the standard toolbar and the General tab in the Properties panel. To quickly preview your changes, click Preview  in the Standard toolbar (upper-right corner of the screen).

Apply formatting

To format your content, use the formatting options available in the:

Standard toolbar

The standard toolbar contains the following options:

Icon  Formatting option Description
Bulleted List Styles

Use this option to format content as an unordered list. For more information, see Work with lists.
Numbered List Styles Use this option to format steps, activities, and tasks as an ordered list. For more information, see Work with lists.
Multilevel List Styles Use this option to format content as an unordered or ordered list of multiple levels. For more information, see Work with lists.
Insert Table Add tables to organize data and showcase content in a simplified format. You can organize text and multimedia in a table, highlight them using different colors, and do more. For more information, see Work with tables.
Insert Image Add images in various formats, such as PNG, JPEG, WEBP, and SVG, and enrich your content. You can add images from your project and local files, and web links. For more information, see Work with images and multimedia.
Insert Multimedia Add videos, including Adobe Captivate videos, from your computer, YouTube, and Vimeo. For more information, see Add videos.
Insert Link You can add hyperlinks to internal content (from other topics in your project) and to external content (from local files, emails, and web pages). For more information, see Create and manage links.
Insert Bookmark You can select content and insert it as a bookmark by clicking Insert Bookmarks. You can use these bookmarks to create intra-topic links.
Insert Variables/Snippet/Fields Add variables, snippets, and fields in your topic to single-source content and quickly update different types of outputs. For more information, see Create and use variables and Single-source with snippets.
Insert HTML Elements Add HTML elements, such as Horizontal Line, iframe, and Text Box to control the appearance and layout of content.
Insert Special Character Add various characters to your text. Choose from various fractional numbers, shapes, and icons. For more information, see Work with special characters.
Create Expanding Text Use this option to add extra text adjacent to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the additional text. For more information, see Work with expanding text.
Create Drop-down Text Use this option to add drop-down text to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the drop-down text. For more information, see Work with drop-down text.
Insert Mini TOC Placeholder Use this option to insert a Mini TOC placeholder in your topic or master page. For more information, see Insert a Mini TOC.
Insert See Also Placeholder

Use this option to insert a See Also placeholder in your master page or topic. For more information, see Insert the See Also placeholder in a master page or a topic.
Insert Related Topics Placeholder Use this option to insert a Related Topics placeholder in your master page or topic. For more information, see Insert the Related Topics placeholder.

General tab in Properties panel

Use the General tab in the Properties panel to format content. You can edit font type and style, character spacing, indent, color, and more. You can also add borders and customize backgrounds.

To format content:

  1. In the Author toolbar, select Contents. The Contents panel opens.

  2. In the Contents panel, double-click a topic to open it. You can view the Properties panel on the right side of the screen.

    Pastaba:

    If you are unable to view the Properties panel, select View > Properties Panel.

    In the Properties panel, the General tab is selected by default. 

  3. In your topic, click or select an element to view its type in the Type field. For example, selecting a topic title displays h1 (Heading 1) as the type and a paragraph displays p as the type.

    For a selected element displayed in the Type field:

    • You can edit the formatting, and then apply the same formatting to all elements of the same nature across your project, and update the style sheet. To do so, click the Update Style icon next to the Type field. 
      For example, the default font (according to the style sheet) of a topic title is Arial 20 points. You changed the font to Adobe Clean 24 points. To apply Adobe Clean 24 points font to all topic titles in your project, and update the style sheet, click Update Style.
    • You can clear the current formatting by selecting the text and clicking  next to the Type field or choosing Edit > Clear Formatting.
      For example, the default font of a topic title (according to the style sheet), was Arial 20 points. You changed the font to Adobe Clean 24 points but did not update the style sheet. To restore the default font to Arial 20 points (according to the style sheet), select the text and click .
  4. To format text, click the Font drop-down section. This panel has the following options:

    • Font Family Use the drop-down list to select your desired font type.
    • Font Style Use the drop-down list to select your desired font style such as italic, oblique, and more.
    • Font Size Enter your desired font size or use the increment and decrement buttons to automatically change the current size by .5 units. From the units drop-down list, you can choose the unit as pixel, percentage, and more. 
    • Color Click  to choose your preferred font color. You can also enter the color code in this field. Black is the default text color.
    • Text Transform Use the options in the drop-down list to easily capitalize, change upper or lowercases, and more.
    • Inline formatting options Select the content and click the icons to apply inline formatting such as strikethrough, underline, bold, italics, superscript, and subscript.
    • Character Spacing Enter your desired character spacing or use the increment and decrement buttons to automatically increment the current spacing by .5 units. From the units drop-down list, you can choose the unit as pixel, percentage, and more.
  5. To change the alignment of content, click the Alignment drop-down section. This panel has the following options:

    • Alignment options Align your content left, center, right, or justify.
    • Line Height Use the drop-down list to choose a line height.
    • Decrease/Increase Indent Use the respective buttons to change the distance between margin and content.
  6. To add and edit borders to your content, click the Border drop-down section. This panel has the following options:

    • Border Style Use the drop-down list to select your preferred border style. You can find options such as dotted, dashed, double, and more.
    • Color Click  to select the preferred border color or specify RGB codes.
    • Width Enter the numerical value for the width of your border and choose the unit from the Unit drop-down list.

    Use the following icons to apply the border to specific content edges:

     Applies border to all four edges.

     Applies border only to the top edge.

     Applies border only to the right edge.

     Applies border only to the bottom edge.

     Applies border only to the left edge.

  7. To format the layout of your content, click the Layout drop-down section. This panel has the following options:

    • Height Specify the height of the content. You can also use the Increment and Decrement buttons to increase and decrease the height. Select the unit from the Unit drop-down list.
    • Width Specify the width of the content. You can also use the Increment and Decrement buttons to increase and decrease the width. Select the unit from the Unit drop-down list.
    • Margin 
      • Select the unit of the margin from the Unit drop-down list. 
      • You can also specify values for the top, bottom, left, and right margins, and use the Increment and Decrement buttons to increase and decrease each of the four margin values. 
      • To link all four margin values so that updating the value of one margin syncs all margin values, click 
      • To keep four different margin values so that updating the value of one margin does not sync all margin values, click .
    • Padding 
      • Select the unit of the padding from the Unit drop-down list. 
      • You can also specify top, bottom, left, and right padding values, and use the Increment and Decrement buttons to increase and decrease each of the four padding values. 
      • To link all four padding values so that updating the value of one padding syncs all padding values, click 
      • To keep four different padding values so that updating the value of one padding does not sync all padding values, click 
    • Float Used for positioning and layout on web pages. Select a float value from the drop-down list:
      • inherit Indicates that the element inherits the float value of its parent
      • none Indicates that the element does not float (is displayed where it occurs in the text)
      • left and right Indicate the direction of the container to which the content floats
    • Clear Specifies which elements can float beside the cleared element and on which side. Select a clear value from the drop-down list:
      • inherit Indicates that the element inherits the clear value of its parent
      • both Indicates that no floating elements are allowed on either left or right side
      • none Indicates that floating elements are allowed on both the left and right sides
      • left and right Indicate that no floating elements are allowed on the left or the right side
  8. To format your content background, click the Background drop-down section. This panel has the following options:

    • Shading Click  to choose your preferred background color. You can also enter the color code in this field. Black is the default background color.
    • Image Insert a background image by browsing through your computer.
    • Width Specify the width of the background image.
    • Maintain aspect ratio icon Click to maintain the aspect ratio of the background image. If you change one component (width/height) of the image, the other component (height/width) is automatically changed according to aspect ratio.
    • Height Specify the height of the background image.
    • Reset to default icon Click to reset to the original height and width of the background image.
  9. To copy the formatting of selected content, choose Edit > Copy Formatting. Then, select the content to which you want to apply the copied formatting.

  10. To remove the formatting of selected content, choose Edit > Clear Formatting. The selected content displays the default formatting.

  11. To save the changes, click the Save All icon  in the standard toolbar.

Work with lists

You can create bulleted or numbered lists to present your content in a neat and easy-to-read manner. You can then adjust the indent, add color, add a paragraph within a list, and more. You can even match the bullet color to its text color.

To create a list:

  1. Select the desired text and do one of the following:

    • To create a bulleted list, click Bulleted List Styles  in the standard toolbar and choose a style from the drop-down list. 
    • To create a numbered list, click Numbered List Styles  in the standard toolbar and choose a style from the drop-down list.
    • To create a numbered or bulleted list containing multiple levels, do the following:
      1. Click Multilevel List Styles  in the standard toolbar and choose a style from the drop-down list.
      2. To create a sublevel list, select the text and press Tab. Or, from the Properties panel > General tab > Alignment drop-down section, click the Increase Indent icon.
  2. To remove list formatting, click , or  in the standard toolbar, and select the None style.

Work with tables

In RoboHelp, you can insert tables to organize and present content in a structured manner. You can also edit colors, indent, customize borders, and more for tables.

To insert a table:

  1. In an open topic, place the cursor at the desired location and click Insert Table  in the standard toolbar.

  2. To select the required number of rows and columns, drag your cursor over the drop-down table grid. The selected rows and columns are highlighted in blue. Click to insert the selected rows and columns in your topic.

Right-click options for table

Right-clicking inside a table cell will display a pop-up menu with the actions you can perform:

Convert to header

Each cell in a header row works as the heading of its column. Similarly, you can also use the header column to label the corresponding rows. To convert an existing row or column into the header, do the following:

  • Select a row or column that you want to use as header row or column.
  • Right-click and choose Convert to Header.

Remove header

  • Select the header cells of a row or column.
  • Right-click and choose Remove Header.

Add or delete rows and columns

You can easily insert and delete additional rows and columns into an existing table. Click where you want to add or remove a row or column in your table and then right-click.

  • To add rows, click Row Before or Row After and to add columns, click Column Before or Column After.
  • To add cells, click Cell Before or Cell After.
  • Click Delete, and then click the option your need on the menu.

Merge cells

To create more complex tables, with merged cells, use the Merge command from the Table menu.

  • To merge cells, place the cursor in a cell and select multiple cells by holding arrow key along with shift key. Alternatively, select the cells using mouse. It will highlight the cells to merge.

  • Right-click and choose Merge > Cells.

Split cells

You can split one cell in a table into two or more smaller cells horizontally or vertically. To split cells in a table:

  • Place the cursor in the cell you want to split.
  • Right-click and choose SplitCells Horizontally or Cells Vertically, depending on how you want to split the cell.

AutoFit to resize a table or column

To automatically adjust your table or columns to fit the size of the content, use the AutoFit command from the Table menu.

  • Select AutoFit to Contents to resize the cells to fit their content.
  • Click AutoFit Window to stretch the table across the page to fit the topic. 
  • Click Fixed Column Width to set the width of the columns manually.

Select tables cells, rows, and columns

There are times you may want to select a single cell, an entire row or column, or an entire table.

Select row To select a row in a table, right-click and from the context menu, choose Select > Row.

Select column To select a column in a table, right-click and from the context menu, choose Select > Column.

Select cell To select an individual cell, right-click and from the context menu, choose Select > Cell.

Select table To select an entire table, right-click and from the context menu, choose Select > Table.

General tab in the Properties panel

You can resize tables to specify, increase, or decrease the width and height of the table, or row height and change the width of the columns.

  1. Right-click the table and choose Select > Table to open the formatting properties of the table. You can view the Properties panel on the right side of the screen.

    In the Properties panel, the General tab is selected by default. 

  2. The following options are available to format the table:

    Table width The width attribute specifies the width of a table. To resize the width of the entire table, specify the Table Width in any unit of measurement of the entire table.

    Column width To change the width to a specific measurement, select the Column number that you want to resize. On the table settings in the Properties panel, click in the Column Width box, and then specify the width in any unit of measurement you want.

    Row height To set the row height to a specific measurement, select the Row number that you want to resize. On the table settings in the Properties panel, click the Row Height box, and then specify the height in any unit of measurement you want.

    Table caption Table Caption can be used to provide a title to a table. It is optional to use the table caption, and it can be added above or bottom of the table. Use the following icons to select the positioning of the caption:

    Displays the caption above the table.

    Displays the caption below the table.

     Removes the caption from the table.

Work with special characters

You can insert special characters into your content by using the Insert Special Character Dialog. The Insert Special Character Dialog allows you to search for and insert special characters from a large set of characters, organized in various categories.

  1. In an open topic, place the cursor at the desired location and click Insert Special Character  in the standard toolbar. Alternatively, you can use CTRL+4 to insert special characters.

  2. Select a category from the following options in the dropdown list:

    • Arrows
    • Currency Symbols
    • Extended ASCII
    • Miscellaneous
    • Number Forms
    • Punctuation
    • Special Characters
  3. Hover your mouse on the character to see its full readable name. Choose the character you want to insert or search for a specific character by typing name in the Find Box, and double-click on it. The symbol will be added at the cursor's point. Alternatively, click Insert.

  4. Click Close to close the Insert Special Character dialog.

Work with expanding text

In a content-heavy topic, you can use expanding text to add extra text adjacent to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the additional text.

  1. In an open topic, select the text you want to expand, and then click Create Expanding Text  in the standard toolbar.

    The selected text becomes the title of the expanding text. A placeholder for the content appears.

  2. In the placeholder, specify the content of the expanding text.

  3. Manage expanding texts in the following ways:

    • Toggle the display of the boundary of all expanding text placeholders in your topic: Choose View > Show > Expanding/Drop-down Text Boundary.
    • Toggle the display of a specific expanding text placeholder: Right-click the text header and click Show Expanding Text or Hide Expanding Text
    • Remove an expanding text: Right-click the text header and click Remove Expanding Text
    • Collapse or expand an expanding text: Double-click the text header.
    • Collapse or expand all expanding texts in your topic: Right-click any expanding text header and click Collapse All Text or Expand All Text.
    • Set separate text for the title of an expanding text in collapsed state: Click the expanding text. In the Properties panel > General tab > Text when collapsed field, type the new title. As expanding texts are collapsed by default, in your output, the new title is displayed in the collapsed state. On expanding the text, the original text on which the expanding text was created is displayed.
    • Add twisty images.
  4. Click the Save All icon  at the left side of the standard toolbar.

In a content-heavy topic, you can add drop-down text to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the drop-down text.

  1. In an open topic, select the text you want to drop down, and then click Create Drop-down Text  in the standard toolbar.

    The selected text becomes the title of the drop-down text. A placeholder for the content appears below the selected text.

  2. In the placeholder, specify the content of the drop-down text.

  3. Manage drop-down texts in the following ways:

    • Toggle the display of the boundary of all drop-down text placeholders in your topic: Choose View > Show > Expanding/Drop-down Text Boundary.
    • Toggle the display of a specific drop-down text placeholder: Right-click the text header and click Show Drop-down Text or Hide Drop-down Text
    • Remove a drop-down text: Right-click the text header and click Remove Drop-down Text
    • Collapse or expand an drop-down text: Double-click the text header.
    • Collapse or expand all drop-down texts in your topic: Right-click any drop-down text header and click Collapse All Text or Expand All Text.
    • Set separate text for the title of a drop-down text in collapsed state: Click the drop-down text. In the Properties panel > General tab > Text when collapsed field, type the new title. As drop-down texts are collapsed by default, in your output, the new title is displayed in the collapsed state. On expanding the text, the original text on which the drop-down text was created is displayed.
    • Add twisty images.
  4. Click the Save All icon  at the left side of the standard toolbar.

Add or edit twisty images

You can add twisty images–an image each for expanded and collapsed states–to expanding and drop-down texts, and topic TOCs. In preview and in your output, the respective images appear in expanded and collapsed states.

To add twisty images:

  1. In an open topic, click an expanding or drop-down text, or the word Caption in a topic TOC.

  2. In the Properties panel > Styles tab, select Hyperlink Styles from the drop-down list.

  3. From the list of hyperlink styles displayed, click a style to apply it to the selected item. If the applied style has the twisty feature set, the twisty images are displayed in the preview and output.

  4. Do one of the following:

    • Click  against the applied style to edit it.
      In the Styles panel of the style sheet editor, in Hyperlink Styles, the applied style opens for editing.
    • From the Contents panel, expand assets > css. From the list of style sheets displayed, double-click one or click  against it. Then, expand the Hyperlink Styles and click the applied style.
  5. In the Properties panel of the style sheet editor, expand Twisties.

  6. Against the Image when expanded and Image when collapsed fields, click  to select and insert the required images.

  7. Click  to place images at the start of text (default) or  to place images at the end of text. 

  8. Click the Save All icon  at the left side of the standard toolbar.

    Pastaba:

    After you set twisty images for a particular hyperlink style, you can apply the same twisty images to different items by just applying the same hyperlink style from the Styles panel. 

Use the Color Picker dialog box

The Color Picker dialog provides multiple ways of choosing a color as per the following: 

  • The Color Picker displays a grid of predefined color swatches. You can see the names by hovering your mouse over any of the swatches. The list of these swatches can be modified in the Project settings.
  • You can either pick from a set of predefined colors (swatches) or create your own using an RGB value.
  • The Color Picker displays the color along with the associated hexadecimal (HEX) color value. You can also type a hexadecimal number  (e.g., #0000FF) directly in the given blank space.
  • You can set the opacity of color with an alpha channel. The alpha parameter is a number between 0 (fully transparent) and 100 (fully opaque).
  • You can also pick the color from anywhere on your screen. Click on the eye-dropper icon  and hover over pixels on your screen to choose a specific color. When you click, the selected color is automatically updated into the color picker dialog. You can click 'Mouse Right-click' or 'Escape' key to close the screen color dropper if you don't want to pick a color. The color dropper also works on a multi-monitor setup in case you want to choose color across multiple monitors.
  • The first swatch visible in the list of predefined swatches represent None  (no fill). To remove any selected color, you can click on "None."
The color picker dialog box
The color picker dialog box

A. Screen Color Picker B. Hexadecimal (HEX) color value C. RGB values D. Alpha component E. Predefined swatches F. No fill