حلول للمشكلات الشائعة بشأن عرض ملفات PDF من موقع ويب.

الأعراض 

أعراض شائعة عند عدم إمكانية عرض PDF على الويب:

  • صفحة فارغة في مستعرض الويب
  • رمز X أحمر
  • مؤشر رابط تالف مثل مربع أحمر أو مثلث أزرق أو دائرة زرقاء
  • الخطأ: "لا يمكن استخدام Adobe Acrobat/Reader قيد التشغيل لعرض ملفات PDF في مستعرض ويب. Adobe Acrobat/Reader الإصدار 8 أو 9 مطلوب.. يُرجى الإغلاق وإعادة المحاولة".

لحل بعض أكثر مشاكل عرض PDF شيوعًا، اتبع التعليمات التالية بالترتيب: قم بتحديث Reader أو Acrobat، قم بإصلاح مشاكل PDF، تحقق من إعدادات المستعرض، قم بإصلاح أو إعادة تثبيت Reader أو Acrobat.

تحديث Reader أو Acrobat

فشركة Adobe تصدر تحديثات أمنية مجانية كل ربع سنة. تأكد من تحديث إصدار Reader أو Acrobat إلى أحدث إصدار. وتشمل التحديثات عادة إصلاحات للمشكلات الشائعة. قم بتنزيل آخر تحديث مجاني.

  1. افتح Reader أو Acrobat.

  2. اختر Help (تعليمات) > Check for Updates (التحقق من وجود تحديثات). 

    Acrobat 9 وأقدم: في حاله توفر تحديث جديد، يتم تثبيته تلقائيًا.

    Acrobat X و XI: انقر فوق تحديث ثم انقر فوق تثبيت.

    Acrobat DC: تابع إلى الخطوة التالية.

    التحقق من وجود تحديثات
  3. عند ظهور مربع حوار Updater (برنامج التحديث)، انقر فوق تنزيل.

    تحديث Acrobat
  4. بعد اكتمال التنزيل، انقر فوق رمز تثبيت Acrobat. في نافذة Acrobat Updater، انقر فوق تثبيت.

    التحديث جاهز
  5. بعد اكتمال التثبيت، أعد تشغيل الكمبيوتر واختبار PDF لمعرفة ما إذا كان يمكنك عرضه.

حلول PDF

قم بتحديث الصفحة أو إعادة تحميلها

عادة ما يؤدي تحديث الصفحة في المستعرض إلى السماح بتحميل PDF بالكامل.

  • اضغط مع الاستمرار على مفتاح Shift واضغط على الزر   تحديث أو   إعادة تحميل في المستعرض.

جرب عرض ملف PDF آخر

جرب عرض ملف PDF آخر. على سبيل المثال، جرب هل سيتم عرض النموذج العينة هذا في المستعرض. إذا تمكن Acrobat أو Reader من فتح النموذج العينة، فقد يكون ملف PDF الآخر تالفًا أو قد تكون هناك مشكلة في خادم الويب. تواصل مع الشخص أو الشركة التي تدير موقع الويب إن أمكن.

حاول عرض ملف PDF على محرك الأقراص الثابتة لديك

حدد ما إذا كان بإمكان مستعرض الويب فتح ملف PDF من محرك الأقراص المحلي بدلاً من الويب. لهذا الاختبار، تحتاج إلى ملف PDF محفوظ على جهاز الكمبيوتر.

  1. قم بأحد الإجراءات التالية في مستعرض الويب:

    • Mac OS: اختر ملف > فتح (أو فتح ملف).
    • Windows: اضغط على Control+O.
  2. انقر فوق استعراض.

  3. (Windows فقط) من القائمة أنواع الملفات، اختر كل الملفات.

    اختر كل الملفات
  4. ابحث عن ملف PDF على جهاز الكمبيوتر وحدده، ثم انقر فوق فتح.

    إذا تم فتح ملف PDF، فقد تكون هناك مشكلة في موقع الويب الذي تعرضه. تواصل مع الشخص أو الشركة التي تدير موقع الويب.

حلول المستعرض وإعدادات المستعرض

استخدام مستعرض ويب مختلف

قد تؤدي ظروف معينة على الكمبيوتر، مثل إعدادات الأمان أو ملفات تعريف ارتباط المستعرض إلى منع عرض ملف PDF. عادة ما يكون أسرع حل هو محاولة فتح الصفحة باستخدام مستعرض مختلف. قم بتجربة استخدام أي من المستعرضات التالية التي لم تحاول استخدامها بالفعل:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

للاطلاع على قائمة بالمستعرضات المتوافقة مع Reader و Acrobat، راجع مستعرضات الويب المتوافقة.

انتقل إلى طريقة عرض التوافق (Internet Explorer)

يتم عرض بعض مواقع الويب بشكل أفضل في طريقة عرض التوافق في Internet Explorer. تعرض طريقة عرض التوافق الصفحة كما لو كانت في إصدار أقدم من المستعرض.

للتعليمات عن كيفية التبديل إلى طريقة العرض هذه، راجع إصلاح مشاكل عرض الموقع في طريقة عرض التوافق.

أعد تشغيل الكمبيوتر وحاول فتح PDF مرة أخرى

أعد تشغيل الكمبيوتر، ثم افتح صفحة الويب مرة أخرى. تؤدي إعادة تشغيل الكمبيوتر إلى مسح الذاكرة وذاكرة التخزين المؤقت. ببساطة، تؤدي إعادة تشغيل الكمبيوتر من حين لآخر إلى حل مشاكل العرض.

قم بحذف ملفات الإنترنت المؤقت (Internet Explorer و Firefox و Chrome)

امسح ذاكرة التخزين المؤقت للمستعرض (أحيانًا تسمى ملفات الإنترنت المؤقتة) لضمان عرض إصدار جديد من الصفحة.

انتبه عند تحديد الخيارات. امسح التخزين المؤقت للمستعرض فقط. إذا قمت بمسح كل ملفات الإنترنت المؤقتة، فقد تمسح ملفات تعريف الارتباط التي تحتوي على معلومات تسجيل الدخول والتفضيلات. معظم المستعرضات تتيح لك اختيار نوع المحتوى الذي تريد حذفه.

مسح المحفوظات
يتيح لك مربع الحوار مسح كل التاريخ في Firefox حذف التخزين المؤقت للمستعرض فقط.

للتعليمات بشأن مسح التخزين المؤقت للمستعرض، راجع هذه المقالات:

Firefox: حذف تاريخ التصفح والبحث والتنزيل

Chrome: حذف التخزين المؤقت والتاريخ وبيانات المستعرض الأخرى

Internet Explorer 8 إلى 11: عرض تاريخ المستعرض وحذفه

Internet Explorer 7حذف تاريخ صفحات الويب

إعادة تعيين التفضيل عرض PDF في المستعرض (Acrobat/Reader X أو أقدم)

جرب إعادة تعيين تفضيل العرض في المستعرض لإصلاح مشكلة العرض.

  1. في Reader أو Acrobat، انقر بزر الماوس الأيمن فوق تفضيلات عرض الصفحة.

    تفضيلات عرض الصفحة
  2. من القائمة على اليسار، حدد إنترنت.

    حدد تفضيلات الإنترنت
  3. قم بإلغاء تحديد عرض PDF في المستعرض، ثم انقر فوق موافق.

    قم بإلغاء تحديد عرض PDF في المستعرض
  4. حاول فتح ملف PDF مرة أخرى من موقع الويب.

عرض PDF في إصدار 32 بت من Internet Explorer أو Safari (Windows Vista فقط)

ينطبق هذا الإجراء فقط على مستخدمي Explorer 9 أو إصدار أقدم على نظام التشغيل Windows Vista.

تطبيقات Acrobat و Reader هي تطبيقات 32 بت على Windows.إذا جربت فتح ملف PDF في إصدار 64 بت من Internet Explorer، فسيتم فتح ملف PDF في تطبيق Acrobat أو Reader وليس في Internet Explorer.

ملاحظة:

يتم دعم Internet Explorer 9 فقط في Reader 10.1 أو Acrobat 10.1 والإصدارات الأحدث.

للتأكد من استخدام الأصدار 32 بت من Internet Explorer، اتبع الخطوات التالية:

  1. في Internet Explorer، اختر تعليمات > حول Internet Explorer. (في بعض إصدارات Internet Explorer، حدد علامة الاستفهام في الجانب الأيمن العلوي لتحديد حول Internet Explorer).

    حول Internet Explorer 9

    إذا رأيت "إصدار 64 بت" بجانب الإصدار، فانتقل إلى الخطوة 2.

    Internet Explorer 64 بت
  2. للتبديل إلى الإصدار 32 بت من Internet Explorer، قم بإنهاء الإصدار 64 بت من Internet Explorer أولاً. انقر نقرًا مزدوجًا فوق رمز البرنامج لإصدار 32 بت:

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    Internet Explorer 32 بت

حلول Reader و Acrobat

إصلاح Reader أو Acrobat

قد يكون هناك تلف في Reader أو Acrobat. عملية إصلاح التثبيت هي حماية سريعة تعتمد على استكشاف الأخطاء وإصلاحها.

الإصلاح من داخل Reader أو Acrobat

اختر Help (تعليمات) > Repair Installation (إصلاح التثبيت).

التعليمات، إصلاح التثبيت

الإصلاح باستخدام لوحة التحكم (Windows)

يمكنك أيضًا إصلاح تثبيت Acrobat أو Reader باستخدام لوحة تحكم Windows.

  1. أغلق Reader أو Acrobat.

  2. انقر فوق بدء > لوحة التحكم.

    ابدأ لوحة التحكم
  3. نفّذ أحد الإجراءات التالية في لوحة التحكم تبعًا لإصدار Windows:

    • (Windows 8/7/Vista) انقر فوق Programs (البرامج)، ثم فوق Programs and Features (البرامج والميزات).
    • (Windows XP) انقر نقرًا مزدوجًا فوق Add or Remove Programs (إضافة أو إزالة برامج).
  4. في قائمة البرامج، حدد Adobe Reader أو Adobe Acrobat.

  5. انقر فوق Change (تغيير) واتبع تعليمات إصلاح التطبيق.

    انقر فوق Change to repair (تغيير للإصلاح)
  6. عند انتهاء العملية، انقر فوق Finish (إنهاء).

حلول متقدمة

إذا لم تؤدِ الحلول في الأقسام السابقة إلى حل مشكلة عرض ملفات PDF، فيمكنك تجربة الخطوات المتقدمة التالية.

تمكين وظيفة Adobe PDF الإضافية في المستعرض (Internet Explorer 8 والإصدارات الأحدث)

تأكد من تمكين وظيفة Adobe PDF الإضافية في المستعرض.

  1. افتح Internet Explorer واختر أدوات > إدارة الوظائف الإضافية.

  2. من Add-on Types، حدد Toolbars And Extensions.

  3. في القائمة إظهار، اختر كل الوظائف الإضافية.

    كل الوظائف الإضافية
  4. في قائمة الوظائف الإضافية، حدد Adobe PDF Reader.

    ملاحظة:

    في حال عدم رؤية المكون الإضافي لـ Adobe PDF Reader، جرب الخيارات الأخرى الواردة في القائمة. مثلاً، في بعض الأنظمة، يظهر المكون الإضافي عندما تختار Run Without Permission.

  5. انقر فوق الزر تمكين.

    ملاحظة:

    إذا كان الزر يعرض "تعطيل"، فتكون الوظيفة الإضافية ممكنة بالفعل. يبدل هذا الزر بين "تمكين" و"تعطيل"، حسب حالة الوظيفة الإضافية المحددة.

    تمكين يضبط الوظيفة الإضافية Adobe PDF Reader لفتح مستندات PDF في المستعرض.

    تعطيل يوقف تشغيل الوظيفة الإضافية بحيث لا يفتح مستندات PDF في المستعرض.

    تمكين Acrobat Reader

تمكين وظيفة Adobe PDF الإضافية في المستعرض (Firefox)

تأكد من تمكين وظيفة Adobe PDF الإضافية (nppdf32.dll) في المستعرض.

  1. في شريط عنوان Firefox، اكتب about:plugins

  2. مرر إلى القسم باسم Adobe Acrobat.

    ممكن في مستعرض Firefox
  3. تأكد من أن اسم الملف "nppdf32.dll" و "Adobe Acrobat Plug-In for Netscape."
    إذا كان هذا الإدخال غير متاح، فقم بتثبيت أحدث إصدار من Reader أو Acrobat.

قم بتشغيل Acrobat أو Reader في حساب مسؤول محلي جديد

قم بإنشاء حساب مستخدم له نفس صلاحيات الحساب الذي تستخدمه عند حدوث المشكلة. أو قم بإنشاء حساب مسؤول محلي. إذا لم تحدث المشكلة عند الدخول إلى الحساب الجديد، فقد يكون حساب المستخدم الأصلي تالفًا.

للمعلومات عن إعداد حساب مستخدم، راجع المصادر التالية أو اتصل بمسؤول الشبكة:

Windows XP: لإضافة مستخدم جديد إلى الكمبيوتر

Windows Vista/7/8: إنشاء حساب مستخدم

Mac OS X: إعداد مستخدمين على Mac

تنظيم ملفات PDF الكبيرة

إذا كان حجم ملف PDF 4 ميجابايت أو أكبر، فاطلب من مقدم ملف PDF تحسينه. للمعلومات عن تحسين ملفات PDF، راجع تحسين ملفات PDF.

التحقق من مسار السجل لـ Acrobat أو Reader (Windows)

إخلاء المسؤولية: يحتوي السجل على معلومات للنظام ضرورية للكمبيوتر والتطبيقات بشدة. قبل تعديل السجل، تأكد من عمل نسخة احتياطية له. لا تقدم Adobe دعمًا للمشاكل الناتجة عن تعديل السجل بشكل غير مناسب. توصى Adobe بشدة بامتلاك خبرة في تحرير ملفات النظام قبل تعديل السجل. للمزيد من المعلومات عن السجل، راجع وثائق Windows أو تواصل مع Microsoft.

  1. انتقل إلى بدء > تشغيل.

  2. قم بكتابة regedit وانقر فوق موافق.

  3. استعرض إلى المفتاح HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. تأكد من أن القيمة (الافتراضية) معينة للمسار المثبت فيه Acrobat أو Reader.

    • المسار الافتراضي لـ Reader هو "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe".
    • المسار الافتراضي لـ Acrobat هو "C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe".

    ملاحظة:

    إذا لم يتم تثبيت Acrobat أو Reader في المسار الافتراضي، فتأكد من أن قيمة المفتاح (الافتراضية) تشير إلى الموقع الفعلي.

لمشاهدة عرض فيديو للإجراء، راجع التحقق من مسار السجل الصحيح.

إذا كان عنصر السجل أعلاه غير موجود في النظام، فقم بما يلي:

  1. انتقل إلى بدء > تشغيل.

  2. قم بكتابة regedit وانقر فوق موافق.

  3. النسخ الاحتياطي لملف السجل الحالي:

    • في مربع حوار محرر السجل، اختر ملف > تصدير.
    • اكتب اسمًا للملف واختر موقعًا.
    • لنطاق التصدير، اختر الكل.
    • انقر فوق Save.
  4. انتقل إلى تحرير > جديد > مفتاح، وقم بإنشاء المفتاح المفقود HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. انتقل إلى تحرير > جديد > قيمة سلسلة وقم بتسمية المفتاح (افتراضي).

  6. حدد (افتراضي)، ثم انتقل إلى تحرير > تعديل. اكتب المسار الافتراضي (موضح أعلاه) في "Value data" (بيانات القيمة) للمنتج.

  7. أعد تشغيل الكمبيوتر.

إصلاح مفتاح السجل HKCR\AcroExch.Document (Windows)

من المحتمل أن يكون هذا المفتاح تالفًا، أو يشير إلى وجود إصدار قديم من Acrobat أو Reader أو يشير إلى برنامج عرض PDF من جهة خارجية.

إخلاء المسؤولية: يحتوي السجل على معلومات للنظام ضرورية للكمبيوتر والتطبيقات بشدة. قبل تعديل السجل، تأكد من عمل نسخة احتياطية له. لا تقدم Adobe دعمًا للمشاكل الناتجة عن تعديل السجل بشكل غير مناسب. توصى Adobe بشدة بامتلاك خبرة في تحرير ملفات النظام قبل تعديل السجل. للمزيد من المعلومات عن السجل، راجع وثائق Windows أو تواصل مع Microsoft.

  1. اختر بدء > تشغيل، اكتب regedit في حقل النص "مفتوح" في مربع الحوار تشغيل، ثم انقر فوق موافق.

  2. النسخ الاحتياطي لملف السجل الحالي:

    • في مربع حوار محرر السجل، اختر ملف > تصدير.
    • اكتب اسمًا للملف واختر موقعًا.
    • لنطاق التصدير، اختر الكل.
    • انقر فوق Save.
  3. انتقل إلى HKEY_CLASSES_ROOT\AcroExch.Document.

  4. انقر بزر الماوس الأيمن فوق AcroExch.Document واختر حذف؛ تأكد من أن لديك المفتاح الصحيح وانقر فوق نعم في أي مطالبة.

  5. انقر بزر الماوس الأيمن فوق AcroExch.Document.7 واختر حذف؛ تأكد من أن لديك المفتاح الصحيح وانقر فوق نعم في أي مطالبة.

  6. يعرض هذا الفيديو هذه الخطوات.

     

قم بتغيير عنوان نوع المحتوى على خادم الويب (مسؤولو الويب)

إذا كنت مسؤول الويب أو لديك صلاحيات إدارية على موقع ويب، فقم بتكوين خادم الويب لإرسال عناوين نوع محتوى "application/pdf" لملفات PDF. للتعليمات، راجع المستندات المرفقة مع خادم الويب أو راجع مقال الدم من Microsoft هذا.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت