For the latest InDesign tutorials, visit InDesign video tutorials page.

Design and layout

Multiple page sizes

You can define different page sizes for pages within a single document. This feature is especially useful when you want to manage related designs in one file. For example, you can include business card, postcard, letterhead, and envelope pages in the same document.

To create multiple page sizes, use the Page tool to select a page, and then change the settings in the Control panel. See Use multiple page sizes.

New Layers panel

The new InDesign Layers panel is now more similar to the Illustrator Layers panel. Each layer has a disclosure triangle that can be expanded to reveal the objects and their stacking order on that given layer for the active spread.

By default, new page items are given generic names such as <rectangle> and <path>. You can give any page item a custom name by click-pause-clicking the item name in the Layers panel.

You can change the stacking order of objects by dragging items in the list. The Layers panel also lets you show or hide and lock or unlock individual page items.

See Layers.

Custom page sizes

Instead of editing a text file to create custom page sizes, you can use the Custom Page Size dialog box to make custom page sizes available when you create documents. See Create custom page sizes.

Simplified transformations

InDesign includes several new selection and transformation features that simplify manipulating objects.

Content grabber

The content grabber appears as a circle when you hover over an image using the Selection tool. Use the content grabber to select and move the content of a frame with the Selection tool still selected. This behavior effectively replaces that of the Position tool, which is removed from InDesign CS5. If you rotate the content with the frame, a horizontal line appears in the center of the content grabber. This line mirrors the rotation angle of the content.

The content grabber draws over each frame that is part of a group. Use the Selection tool to reposition content within a frame that is part of the group.

If you don’t want the content grabber to appear when you hover over an image, choose View > Extras > Hide Content Grabber.

See Select objects.

Double-click behavior

Double-clicking graphics with the Selection tool no longer switches to the Direct Selection tool. Instead, double-clicking a graphic frame now selects the content in the frame. If the content is selected, double-clicking the content selects the content’s frame. (When the content is selected, you can also click the edge of its containing frame to select the frame.)

In a group, double-clicking an item in the group selects the item you double-clicked. To reselect the group, double-click the edge of the selected item or group. In all cases, the Selection tool remains the active tool. This approach gives you a quick and consistent way to select graphic frames and groups.

Frame edge highlighting

InDesign now temporarily draws the frame edges as you use the Selection tool to hover over items on a page. This method makes it easier to find the item you want before you select it. The color of the frame edge drawn matches the color of the layer the object is on. Groups are drawn with a dashed line. This feedback is especially helpful when working in Preview Mode or with Hide Frame Edges selected.

Path and point highlighting

When you hover over a page item with the Direct Selection tool, InDesign displays the path and display the path points. This feedback makes it easier to view the path point you want to manipulate. You no longer have to select the object with the Direct Selection tool and then select the path point. You can simply drag the point you want.

Rotate

As in Illustrator, you don’t have to switch to the Rotate tool to rotate a selected page item. With the Selection tool, you can simply position the pointer just outside a corner handle, and drag to rotate the item. When you stop dragging, the Selection tool remains the active tool. See Rotate an object using the Selection tool.

Transform multiple selected items

You no longer have to group multiple items before you can resize, scale, or rotate them with the Selection tool. Simply select the items you want to transform, and you see a transformation bounding box around the selected items. Dragging a handle resizes the selected elements; holding down Shift resizes them proportionally. Holding down Ctrl (Windows) or Command (Mac OS) scales them. Holding down Ctrl+Shift (Windows) or Command+Shift (Mac OS) scales them proportionally. Including Alt (Windows) or Option (Mac OS) performs the transformations from the center of the selected objects. See Transform objects.

Live Screen Drawing

In InDesign CS5, you see the content draw as you drag it. In previous InDesign versions, you pause before dragging to see the content draw. You can change the Live Screen Drawing setting in Interface preferences to use the previous behavior. See Change Interface preferences.

Favor the selected object

If you select one of several overlapping page items and begin dragging, the selected object remains selected. To select a different item, simply click a portion of that different item that is not overlapping or intersecting the currently selected item.

Live Distribute

When transforming multiple selected objects, InDesign CS5 lets you proportionally resize the space between the selected items instead of resizing the actual items. See Distribute objects using Live Distribute.

Reordering of the Transformation Tools

The Rotate, Scale, and Shear tools appear under the Free Transform tool in the Tools panel. You can rotate, resize, and scale objects without having to switch from the Selection tool.

Gap tool

The Gap tool provides a quick way to adjust the size of a gap between two or more items. The Gap tool is a one-step way to adjust your layout by directly manipulating the whitespace. See Align objects using the Gap tool.

Paragraphs that span or split columns

In InDesign CS5, you can make a paragraph span multiple columns without creating separate text frames. You can also split a paragraph into multiple columns within the same text frame. See Create paragraphs that span or split columns.

Keep with previous

The Keep Options dialog box now has a Keep With Previous option that keeps the first line of the current paragraph with the last line of the previous paragraph. See Control paragraph breaks using Keep Options.

Balanced columns

The Balance Columns setting in the Text Frame Options dialog box lets you automatically balance text across columns in a multiple column text frame. See Add columns to a text frame.

Vertical justification in non-rectangular frames

In previous versions of InDesign, applying a non-rectangular text frame causes vertical justification settings to be ignored. In InDesign CS5, you can apply both vertical justification and corner effects and other irregular-shaped frames. See Align or justify text vertically within a text frame.

Live corner effects

Click the yellow square that appears near the upper right corner of a selected frame to apply corner effects to rectangular frames. In addition, you can now apply a different corner effect and a different corner radius to each corner. See Use Live Corners.

Swatches in Control panel

You can apply swatches to objects directly in the Control panel. Select an object and choose the swatch from the Fill or Stroke menu in the Control panel. You can also drag the current color swatch displayed in the Control panel and apply it to other objects. See Apply color.

Grid place enhancements

When placing multiple files, simply start dragging, and then use the arrow keys to change the number of columns and rows of the placed images. While dragging, hold down Ctrl (Windows) or Command (Mac OS) and press arrow keys to change the gutter space. See Place multiple graphics and Create contact sheets.

Auto-Fit

Select the Auto-Fit option so that the image is resized automatically whenever you resize the frame. See Using Auto Fit.

Drawing multiple frames in a grid

When using frame creation tools such as the Rectangle or Type tool, you can press arrow keys to create equally spaced frames. See Draw multiple objects as a grid.

Duplicating objects into a grid

You can create a grid of objects while dragging a copy of a selected object. See Duplicate objects into a grid.

Live captions from metadata

In InDesign CS5, you can generate captions based on image metadata using a number of methods.

  • You can generate captions while you place images by turning on the Create Static Captions checkbox in the Place dialog box.

  • You can generate captions from placed images. First, use the Caption Setup dialog box to identify which metadata is included in the image. Then choose an option from the Object > Captions menu to generate either a live or static caption.

  • You can add a text variable to a text frame that display the metadata of the image that touches or is grouped with the text frame.

See Captions.

Mini Bridge

Mini Bridge is a subset of Adobe Bridge that is available as a panel within InDesign. Mini Bridge lets you navigate your file system and preview files as visual thumbnails without having to leave InDesign. You can drag-and-drop files from Mini Bridge to InDesign as an alternative way to place files into a document. Doing so loads the dragged images into the place cursor, just like dragging from Bridge. You can also drag selected items into Mini Bridge to create snippets.

Improved Adobe Bridge integration

InDesign CS5 and Adobe Bridge CS5 are more integrated in two ways.

Page Thumbnails

A new File Handling preference option lets you generate page thumbnails for more than the first page of InDesign files. The default number of pages to generate thumbnails for is set to 2, but you can change it to 1, 2, 5, 10, or All. You can now see previews of the pages within an INDD file in the Preview pane of Bridge. Choosing more thumbnail pages may cause your InDesign document to take longer to save. See Include previews in saved documents.

View Links in an InDesign File while in Bridge

You can view the links inside an InDesign document while in Adobe Bridge, without having to open the document in InDesign. For example, suppose that you don’t remember the location of an image, but you remember placing it in an InDesign document. In Adobe Bridge, navigate to the InDesign file, and then display thumbnails of all the placed files contained within the selected InDesign file.

Cross media design

Interactive documents and presentations

FLV and MP3 import

You can import video files in Flash Video format (.FLV and .F4V), H.264-encoded files (such as MP4), and SWF files. You can import audio files in MP3 format. Legacy media file types like QuickTime (.MOV), .AVI, and .WMV are still supported. However, use FLV, F4V, MP4, and MP3 formats to take full advantage of the rich media support offered in the most recent versions of Acrobat, Adobe Reader, and Adobe Flash Player.

Use Adobe Media Encoder to convert older media file types to .FLV. See Relink legacy media files.

Media panel

The Media panel lets you preview SWF, FLV, F4V, MP4, and MP3 files directly in InDesign. For FLV, F4V, and MP4 files, you can choose any frame in the video as the placeholder poster image. You can choose which video playback controls you want the viewer of your interactive document to have. The Media panel lets you create navigation points, which are time-code markers that you can target with button actions. See Add movies and sound files to documents.

Motion presets

The Animation panel lets you assign a motion preset to any page item as a way to quickly create an animation. These motion presets are the same motion presets found in Adobe Flash CS5 Professional. Furthermore, InDesign can import any custom motion preset created in Flash, enabling InDesign and Flash users to collaborate to create animation effects. See Animate a document with motion presets.

Animation panel

Use the Animation panel to create or edit animation effects. You can edit supported animation attributes such as Position, Scale, Rotate, and Opacity. Save any custom animation created in InDesign as a custom motion preset that can be shared with others.

Use the Animation panel to specify when an animated object is played, such as when the page is loaded or clicked. See Animation.

Timing panel

Use the Timing panel to change the order of when animated objects play. See Use the Timing panel to change the animation order.

Object States panel

Use the Object States panel to create multiple versions of an object. For example, you can create a single page object with 20 different states, and each state contains a different photo. Anyone who opens the PDF or SWF file can click forward and back buttons to browse the photo gallery. See Create a multi-state object slide show.

Preview panel

In InDesign, you can preview interactivity and animation of the current selection, the current spread, or the entire document using the Preview panel. You can also test interactive elements in a web browser. See Preview interactive documents.

Pixels as unit of measurement

You can now specify Pixels for your unit of measure in Preferences > Units & Increments. You can override the current unit of measure by adding “px” to your values in edit fields in the Control panel, dialog boxes, and other panels. When using pixels, objects and X/Y coordinates snap to whole pixel values, and the line weights listed in the Stroke panel also change to pixels. See Change rulers and measurement units.

Convert URLs to hyperlinks

Use the Convert URLs To Hyperlinks command to search the current selection, story, or document for URL strings and convert them to hyperlinks. You can also assign a character style to the found URLs. See Convert URLs to hyperlinks.

Improved export to Flash Player

SWF file export can now include animation, video, audio, and remote rollovers. In addition, several new options let you control the final SWF file output. See Create interactive SWF (Flash) files for the web.

Improved export to Flash Professional

InDesign CS5 exports to FLA format rather than XFL format for editing the file in Flash Professional. FLA export options support rich media content and offer more ways to handle text. See Create FLA files for the web.

Improved export to Interactive PDF

InDesign CS5 includes separate commands for exporting print and interactive PDF files.

InDesign CS5 exports all rich media content to the Rich Media Annotation Layer when exporting to Interactive PDF, resulting in more reliable playback in Adobe Reader. For best results, video files must be in FLV or F4V format and audio files must be in MP3 format.

A few new options are available when exporting to interactive PDF, including initial view options, presentation settings, and page transitions. See Create interactive documents for PDF.

Improved XHTML export

Exporting to XHTML is a way to extract your content out of an InDesign document and hand it over to a web developer who can repurpose it using a web application such as Dreamweaver. InDesign CS5 enhancements include the ability to match the attributes of InDesign text formatting, preserve local formatting, and control the order of content. InDesign Tables are now assigned unique IDs, allowing them to be referenced as Spry data sets in Dreamweaver. See Export content to Dreamweaver (CS5).

Improved JPEG export

The Export JPEG dialog box includes several new options, including the ability to specify the color space, use document bleed settings, and simulate overprinting. See Export to JPEG format.

Collaboration

Integrated comment and review

CS Review is an online service that provides a simple way to share designs on the web so others can provide feedback. Use the CS Review panel in InDesign to upload snapshots of the current document to an Acrobat.com workspace, where others can add comments. See Reviewing InDesign documents.

Track text changes

When the Track Text Changes feature is turned on, changes made to the text are tracked on a per user basis. You can view changes in Story Editor (but not in Layout view). Text changes that are supported include deleting text, moving text, and inserting text. Use the Track Changes panel to accept and reject changes in the document. See Tracking and reviewing changes.

Document installed fonts

Any fonts in a Document Fonts folder that’s in the same location as an InDesign document are available when the document is opened. Fonts installed by one document are not available to other documents. The Package command can generate a Document Fonts folder when you want to share your document or move it to a different computer. See Document installed fonts.

Presentation Mode

InDesign CS5 has a new screen mode called Presentation Mode. In Presentation Mode, the application menu and all panels are hidden. Keystrokes and clicks let you move forward or backward through the document one spread at a time. See Use Presentation Mode.

Color labels for page thumbnails

You can now assign colored labels to the page thumbnails in the Pages panel. See Create color labels for page thumbnails.

Usability and productivity

Background tasks

When you save large documents or export them to PDF or IDML files, you can continue working on your document. You can also queue up multiple PDF exports in the background. Use the Background Tasks panel (Window > Utilities > Background Tasks) to view the progress of the export processes. See Background Tasks panel.

Spring-loaded tools shortcut

You can temporarily switch from the current tool to any other tool by holding down the appropriate letter key. As you hold down the key, your current tool changes the new tool, and when you release it, you return to the previous tool. For example, press the U key to use the Gap tool, and then release it to return to the Selection tool. See Select tools temporarily.

Tool Hints panel

The Tool Hints panel (Window > Utilities > Tool Hints) lists all the hidden modifier key behaviors available for the currently selected tool. See View tool hints.

Community Help

Adobe Community Help offers access to complete Adobe product documentation as well as to community-created learning content and other learning content on Adobe.com. Adobe Community Help includes an AIR-based viewer that displays the latest online Help or defaults to a local version of Help when a web connection is unavailable.

Community Help also includes expert-moderated comments and user ratings on Adobe documentation, knowledge base articles, tutorials, and other content.

Specify starting page number

When you create a document in InDesign CS5, you can make the first page start on a specified page number. If you specify an even number with facing pages turned on, the document begins with a two-page spread. You can also change the starting page number in the Document Setup dialog box after you’ve created a document. See Create new documents.

Edit Original for multiple selected items

You can choose the Edit Original command to open multiple images in their respective editing applications. See Edit original artwork.

New options for locking objects

To lock and unlock objects, you can now choose Object > Lock or Object > Unlock All On Spread. Clicking the lock icon also unlocks a locked object.

The new Prevent Selection Of Locked Objects option in General preferences lets you determine whether you can select locked objects.

Relink file extensions

Relink files based on file extension. For example, you can replace a set of JPEG files with TIFF files. See Relink files with different file extensions.

Hide objects

You can now choose Object > Hide to hide objects on the page. Hidden objects are not printed or exported, and they cannot be selected. Choose Object > Show All On Spread to view all hidden objects.

Sticky Preview check boxes

InDesign now remembers whether the Preview checkbox is selected in a dialog box after you exit and restart.

Place cursor when dragging from Adobe Bridge

In previous versions, dragging an image from Adobe Bridge or the desktop inserted the image on to the page, creating a frame the size of the image. In InDesign CS5, this action loads the place cursor, letting you drag a proportionally sized frame for your image.

Open book files in Explorer or Finder

A command appears on the books panel menu that lets you view a document in an Explorer or Finder window.

Miscellaneous enhancements

Round CMYK values to whole numbers

The Colors panel round the values for the CMYK sliders to the nearest whole value.

Delete all guides

A new Delete All Guides On Spread command appears in the View > Grids & Guides menu.

Zoom from dialog boxes

You can now use the keyboard shortcuts to zoom in and out of your document when you have a modal dialog box open. Press Ctrl+- or Ctrl+= (Windows) or Command+- or Command +=.

New default font

The default font is changed from Times (Mac) and Times New Roman (Windows) to the cross-platform OpenType version of Minion Pro Regular.

Collapse multiple links to same source

In InDesign, links to images placed multiple times in a document are collapsed into a single row in the Links panel. You can now turn off this collapsing behavior with a new option in the Panel Options dialog box.

Remember Story Editor window location

When you close and reopen a Story Editor window, InDesign reopens the window to its previous width, height, and location on the screen.

Fold marks

If you select Crop Marks while printing spreads, fold marks are printed as solid lines.

Menu commands changed or moved

The following menu commands have new names or new locations.

Tip: Choose Window > Workspace > [New in CS5] to highlight menu commands of new and enhanced features.

InDesign CS4 command

InDesign CS5 new location

File > Export For Digital Editions

File > Export For > EPUB

File > Export For Dreamweaver

File > Export for > Dreamweaver

Object > Lock Position

Object > Lock

Object > Unlock Position

Object > Unlock All On Spread

Object > Interactive > Movie Options / Sound Options

Media panel

Object > Paths > Convert Point > Line End / Corner / Smooth / Smooth Symmetrical

Object > Convert Point > Plain / Corner / Smooth / Symmetrical

View > Show/Hide Hyperlinks, Show/Hide Text Threads, Show/Hide Frame Edges, Show/Hide Assigned Frames, and Show/Hide Notes

View > Extras > Show/Hide Hyperlinks, Show/Hide Text Threads, Show/Hide Frame Edges, Show/Hide Assigned Frames, and Show/Hide Notes

Window > Assignments

Window > Editorial > Assignments

Window > Attributes

Window > Output > Attributes

Window > Automation > Data Merge / Script Label / Scripts

Window > Utilities > Data Merge / Script Label / Scripts

Window > Color

Window > Color > Color

Window > Gradient

Window > Color > Gradient

Window > Object Styles

Window > Styles > Objects Styles

Window > Swatches

Window > Color > Swatches

Window > Tags

Window > Utilities > Tags

Window > Type & Tables > Notes

Window > Editorial > Notes

Window > Type & Tables > Cell Styles / Character Styles / Paragraph Styles > Table Styles

Window > Styles > Cell Styles / Character Styles / Paragraph Styles > Table Styles

Help/InDesign > Configure Plug-ins

Help/InDesign > Manage Extensions

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy