User Guide Cancel

Generate image assets from layers

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Photoshop and Adobe Stock
    5. Use the Capture in-app extension in Photoshop
    6. Creative Cloud Libraries
    7. Creative Cloud Libraries in Photoshop
    8. Use the Touch Bar with Photoshop
    9. Grid and guides
    10. Creating actions
    11. Undo and history
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web beta
    1. Common questions | Photoshop on the web beta 
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web beta
    4. Keyboard shortcuts | Photoshop on the web beta
    5. Supported file types | Photoshop on the web beta
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
    9. Share files and comment in-app
  7. Workspace
    1. Workspace basics
    2. Learn faster with the Photoshop Discover Panel
    3. Create documents
    4. Use the Touch Bar with Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Default keyboard shortcuts
    13. Touch capabilities and customizable workspaces
    14. Place Photoshop images in other applications
    15. Preferences
    16. Default keyboard shortcuts
    17. Rulers
    18. Show or hide non-printing Extras
    19. Specify columns for an image
    20. Undo and history
    21. Panels and menus
    22. Place files
    23. Position elements with snapping
    24. Position with the Ruler tool
    25. Presets
    26. Customize keyboard shortcuts
    27. Grid and guides
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
  17. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
    14. Text Engine error using Type tool in Photoshop | Windows 8
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors
  24. Content authenticity
    1. Learn about content credentials
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  25. 3D and technical imaging
    1. Photoshop 3D | Common questions around discontinued 3D features
    2. Creative Cloud 3D Animation (Preview)
    3. Print 3D objects
    4. 3D painting
    5. 3D panel enhancements | Photoshop
    6. Essential 3D concepts and tools
    7. 3D rendering and saving
    8. Create 3D objects and animations
    9. Image stacks
    10. 3D workflow
    11. Measurement
    12. DICOM files
    13. Photoshop and MATLAB
    14. Count objects in an image
    15. Combine and convert 3D objects
    16. 3D texture editing
    17. Adjust HDR exposure and toning
    18. 3D panel settings

You can generate JPEG, PNG, GIF, or SVG image assets from the contents of a layer or layer group in a PSD file. Assets are automatically generated when you append a supported image format extension to a layer name or a layer group name. Optionally, you can also specify quality and size parameters for the generated image assets.

Generating image assets from a PSD file is particularly useful for multidevice web design.

How to create and export web graphics see How to export files in various formats from Photoshop.

Generate image assets from layers or layer groups

To understand the image asset generator better, consider a simple PSD file (download from this link) with the following layer hierarchy:

Photoshop generate image assets
Example PSD file and its layer hierarchy

The layer hierarchy for this file has two layer groups—Rounded_rectangles and Ellipses. Each of these layer groups contains five layers.

Follow these steps to generate image assets from this PSD file:

  1. With the PSD file open, select File > Generate > Image Assets.
  2. Append appropriate file format extensions (.jpg, .png.gif, or .svg) to the names of the layers or layer groups from which you want to generate image assets. For example, rename the layer groups, Rounded_rectangles and Ellipses, as Rounded_rectangles.jpg and Ellipses.png; and the layer, Ellipse_4 as Ellipse_4.gif.
Note:

The special characters : and * are not supported in layer names.

Photoshop generates the image assets and saves them in a subfolder alongside the source PSD file. If the source PSD file is not saved yet, Photoshop saves the generated assets in a new folder on your Desktop.

Photoshop Image asset names
Image asset names are generated from layer names/layer group names

Note:

Image asset generation is enabled for the current document. Once enabled, the feature remains available whenever the document is opened next. In order to disable image asset generation for the current document, deselect File > Generate > Image Assets.

Generate assets for cloud documents

If you are working with a Cloud Document, then assets will be saved within the "Photoshop Cloud Associates" directory:

  • Windows: C:\Users\yourname\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/yourname/Documents/Adobe/Photoshop Cloud Associates

Generate multiple assets from a layer or layer group

To generate multiple assets from a layer/layer group, separate the asset names with commas. For example, the following layer name generates three assets:

Ellipse_4.jpg, Ellipse_4b.png, Ellipse_4c.png

Save assets to a subfolder

You can choose to save image assets generated from particular layers/layer groups in a subfolder directly under the document's asset folder. Include the subfolder name in the layer/layer group name; for example:

[subfolder]/Ellipse_4.jpg 

A web design use case

Generating image assets from a PSD file is particularly useful for multidevice web design. Consider the following web design and its layer structure:

A web design and its layer hierarchy

Let's extract the icon on top and the top row of the Global Hotspots image grid as image assets:

  • Append image format extensions to the appropriate layer names.
Photoshop Rename the appropriate layers/layer groups

Photoshop Rename the appropriate layers/layer groups

Rename the appropriate layers/layer groups

Note:

A single image asset is generated from the contents of a layer/layer group. For example, the AdventureCo Logo layer group in the screenshot above contains a shape layer and a live text layer. These layers are flattened when an image asset is generated from the layer group.

Photoshop generates the assets and saves them in the same location as the source PSD file.

Photoshop Generated image assets
Generated image assets

Specify quality and size parameters

JPEG assets are generated at 90% quality by default. PNG assets are generated as 32-bit images by default. GIF assets are generated with basic alpha transparency.

While renaming layers or layer groups in preparation for asset generation, you can customize quality and size.

Parameters for JPEG assets

  • Add the desired output quality as a suffix to the asset name: .jpg(1-10) or .jpg(1-100%). For example:
    • Ellipse_4.jpg5
    • Ellipse_4.jpg50%
  • Add the desired output image size (relative or in supported formats: px, in, cm, and mm) as a prefix to the asset name. Photoshop scales the image accordingly. For example:
    • 200% Ellipse_4.jpg
    • 300 x 200 Rounded_rectangle_3.jpg
    • 10in x 200mm Rounded_rectangle_3.jpg

Note: Remember to add a space character between the prefix and the asset name. If you're specifying the size in pixels, you can omit the unit. For example, 300 x 200.

Note:

As illustrated, you can mix different units and pixels while specifying the desired output image size. For example, 4in x 100 Rounded_rectangle_3.jpg is a valid layer name for asset generation.

Parameters for PNG assets

  • Add the desired output quality as a suffix to the asset name: 8, 24, or 32. For example:
    • Ellipse_4.png24
  • Add the desired output image size (relative or in supported formats: px, in, cm, and mm) as a prefix to the asset name. Photoshop scales the image accordingly. For example:
    • 42% Ellipse_4.png
    • 300mm x 20cm Rounded_rectangle_3.png
    • 10in x 50cm Rounded_rectangle_3.png

Note: Remember to add a space character between the prefix and the asset name. If you're specifying the size in pixels, you can omit the unit. For example, 300 x 200.

Note:

As illustrated, you can mix different units and pixels while specifying the desired output image size. For example, 4in x 100 Rounded_rectangle_3.png is a valid layer name for asset generation.

Parameters for GIF assets

  • Add the desired output image size (relative or in supported formats: px, in, cm, and mm) as a prefix to the asset name. For example:
    • 42% Ellipse_4.gif
    • 300mm x 20cm Rounded_rectangle_3.gif
    • 20in x 50cm Rounded_rectangle_3.gif

Note: Remember to add a space character between the prefix and the asset name. If you're specifying the size in pixels, you can omit the unit. For example, 300 x 200.

Note:

As illustrated, you can mix different units and pixels while specifying the desired output image size. For example, 4in x 100 Rounded_rectangle_3.gif is a valid layer name for asset generation.

Quality parameters are not available for GIF assets.

Construct complex layer names

You can specify multiple asset names with parameters while naming a layer for asset generation. For example:

120% Delicious.jpg, 42% Delicious.png24, 100x100 Delicious_2.jpg90%, 250% Delicious.gif

Photoshop generates the following assets from this layer:

  • Delicious.jpg (an 8-quality JPG image scaled 120%)
  • Delicious.png (a 24-bit PNG image scaled 42%)
  • Delicious_2.jpg (a 90%-quality JPG image that has an absolute size of 100x100 px)
  • Delicious.gif (a GIF image scaled 250%)

Absolute scaling examples

Good examples of absolute scaling

  • 100x80 foo.png (simple absolute scaling)
  • 80 x 100px foo.png (spaces between lengths)
  • 4in x100 foo.png (mix of units and no units)
  • 90mm x120cm foo.png (mix of different units)
  • 100x? foo.png (wild card)
  • ?x60in foo.png (wild card at beginning)

Bad examples of absolute scaling

  • 100x100foo.png (no space before file name)
  • 80x100 60% foo.png (mix of absolute and relative scaling)
  • 50% 80x100 foo.png (mix of absolute and relative scaling)
  • 20in cm x50cm foo.png (multiple units)
  • 30nm x20 nano.png (invalid unit)

Formatting and separating multiple files

Good examples

  • Layer 1.png (Space in file name is allowed -- results in a single file called "Layer 1.png")
  • Layer 1.png,Layer 2.jpg (Comma as separator)
  • Layer 1.png, Layer 2.jpg (Comma followed by space(s) as separator)
  • Layer 1.png+Layer 2.jpg (Plus as separator)
  • Layer 1.png + Layer 2.jpg (Plus followed by space(s) as separator)

Putting it all together

100% Delicious, 42% Layer 1.png24 + 100x100 Layer.jpg-90% , 250% Quux/Foo Bar Baz.gif results in three files (the "100% Delicious" string is ignored, because it's not a filename):

  • Layer 1.png, at 42% scale, as a 24-bit png
  • Layer.jpg, as an absolute size of 100x100 pixels, as a 90% quality jpg
  • Foo Bar Baz.gif in subfolder Quux, at 250% scale, as a gif.

Specify default settings for assets

You can specify document-wide default settings for the generated assets. Follow these steps:

  1. Create an empty layer in the document.
  2. Begin the name of the layer with the keyword default. Now, enter the settings that you want to apply to all image assets generated from the document. For example:

default hi-res/

Generates all image assets in a subfolder named hi-res. For example, [asset_folder]/hi-res/Delicious.jpg.

default hi-res/@2x

Generates all image assets in a subfolder named hi-res. Additionally, suffixes the asset names with @2x. For example, [asset_folder]/hi-res/Delicious@2x.jpg.

default 50% lo-res/

Saves image assets scaled down by 50% in the subfolder lo-res under the document's asset folder 

default hi-res/@2x + 50% lo-res/

Generates two image assets from a layer:

  • In the hi-res subfolder, an image asset whose name is suffixed with @2x
  • In the lo-res subfolder, an image asset scaled down by 50%
Note:

Default scaling factors are overridden by scaling factors specified for individual layers.

Disable image asset generation for all documents

You can disable image asset generation globally for all Photoshop documents by modifying your Preferences.

  1. Choose Edit > Preferences > Plug-Ins.
  2. Deselect Enable Generator.
  3. Click OK.
Note:

The File > Generate menu command is unavailable when you disable image asset generation from Preferences. The feature can be enabled again only in the Preferences dialog box.

FAQ

Asset names must be unique at a document level.

JPG assets are generated at 90% quality by default. PNG assets are generated as 32-bit images by default. GIF assets are generated with basic alpha transparency.

Yes. Transparency and other effects applied to a layer are reflected in the assets generated from that layer. However, such effects may be flattened in the generated assets.

Assets are clipped to the document boundaries. If an image does not fall within the document boundaries, Generator does not create the associated image assets.

In addition to the comma (,), you can use the plus (+) symbol as a separator between image asset names. For example:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

is the same as:

42% Rounded_rectangle_1.png24, 100x100 Rounded_rectangle_1.jpg90%

More like this

Adobe logo

Sign in to your account