Assorted animation tools

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

Motion paths

When you animate spatial properties—including Position, Anchor Point, and effect control point properties—the motion is shown as a motion path. A motion path appears as a sequence of dots, where each dot marks the position of the layer at each frame. A box in the path marks the position of a keyframe.

Motion paths are simply an alternative visual, spatial way of viewing and working with spatial properties and their keyframes, in addition to the ways that you work with properties in the Timeline panel. You can modify a motion path by changing an existing keyframe or adding a keyframe. You can modify the shape of a motion path by changing the spatial interpolation methods for its keyframes. (See About spatial and temporal keyframe interpolation.)

The density of dots between the boxes in a motion path indicates the relative speed of the layer or effect control point. Dots close together indicate a lower speed; dots farther apart indicate a greater speed.

Note:

Right-click (Windows) or Command-click (Mac OS) a keyframe to open its context menu.

Using the Pen tool or Selection tool to edit keyframes for a spatial property in the Composition or Layer panel is like modifying a Bezier path for a mask or for a shape on a shape layer. (See About paths.)

A motion path is less complex and generally easier to modify when you use fewer keyframes to describe the path. You can use the Smoother to remove extraneous keyframes from a motion path.

Show motion path controls

Position motion paths appear in the Composition panel. Anchor Point and effect control point motion paths appear in the Layer panel.

  • To show motion path controls in the Composition panel, choose View > View Options, and select Effect Controls, Keyframes, Motion Paths, and Motion Handles. To see a Position motion path in the Composition panel, the Position property must be selected.
  • To show motion path controls in the Layer panel, choose the property or effect from the View menu at the bottom of the Layer panel.
  • To specify how many keyframes to show for a motion path, choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS), and select an option in the Motion Path section.
  • To specify the size of Bezier direction handles for motion paths, choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS), and edit the Path Point Size value.

Move motion path keyframes

  1. In the Timeline panel, select the layer for which to modify the motion path.
  2. If you cannot see the keyframe that you want to modify in the Composition panel or Layer panel, move the current-time indicator to the keyframe.

  3. In the Composition panel or Layer panel, use the Selection tool for dragging a keyframe or its handles.

    Note:

    The current-time indicator doesn't need to be on a keyframe before you drag it.

    Move one position keyframe by dragging a keyframe in the Composition panel
    Move one position keyframe by dragging a keyframe in the Composition panel

    You can move multiple keyframes at one time by selecting them in the Timeline panel before you drag them in the Composition panel or Layer panel. To move the entire motion path, select all keyframes by clicking the property name in the Timeline panel before dragging a keyframe in the Composition panel.

    Dragging all keyframes on a motion path by one keyframe
    Dragging all keyframes on a motion path by one keyframe

Add a keyframe to a motion path using the Pen tool

  1. Display the motion path that you want to modify in the Composition panel or Layer panel.
  2. Select the Pen tool or Add Vertex tool from the Tools panel.
  3. In the Composition panel, place the Pen tool over the motion path where you want to add the new keyframe and click to add the keyframe.

    A new keyframe appears at the frame you clicked, on the motion path and in the Timeline panel. To move the keyframe, use the Selection tool.

    Note:

    Though the results are different, the techniques for manipulating motion-path curves with the Pen tool work in much the same way as the techniques used to create and modify other Bezier paths, such as mask and shape paths.

Sketch a motion path with Motion Sketch

You can draw a path for the motion of a selected layer using Motion Sketch, which records the position of the layer and the speed at which you draw. As you draw, a Position keyframe is generated at each frame.

Motion Sketch does not affect keyframes that you have set for other properties. For example, if you set Rotation keyframes for an image of a ball, you can use Motion Sketch to generate Position keyframes, so that the ball appears to roll along the path you created.

John Dickinson provides a demonstration of Motion Sketch in a video tutorial on his Motionworks website.

  1. In the Composition or Timeline panel, select the layer for which you want to sketch a motion path.
  2. In the Timeline panel, set the work-area markers to the duration in which you want to sketch motion.
  3. If you want to hear the audio in your composition as you sketch, make sure that the Mute Audio button is not selected in the Preview panel.
  4. Choose Window > Motion Sketch.
  5. Select the appropriate Motion Sketch options:

    Show Wireframe

    Displays a wireframe view of the layer as you sketch the motion path.

    Show Background

    Displays the static contents of the frame at which you started sketching in the Composition panel while you sketch. This option is useful if you want to sketch motion relative to other images in your composition.

    Smoothing

    Eliminates unnecessary keyframes from the motion path. This setting has the same result as using the Tolerance setting with the Smoother. Higher values produce smoother curves, but too high a value may not preserve the shape of the curve that you draw.

    Note:

    You can smooth a motion path after it has been created by using the smooth expression or the Smoother.

    Capture Speed At

    The ratio of the speed of the recorded motion to the speed of playback. If Capture Speed At is 100%, the motion is played back at the speed at which it was recorded. If Capture Speed At is greater than 100%, the motion plays back slower than it was recorded.

  6. Click Start Capture and then drag in the Composition panel to create the motion path. Stop capturing by releasing the mouse button.

    Note:

    After Effects automatically ends capturing when the capture time reaches the end of the work area (which, by default, is the composition duration).

Create a motion path from a mask, shape, or paint path

You can create a motion path from any of several types of paths:

  • A Mask Path property

  • A shape Path property on a shape layer

  • A Path property for a paint stroke

  • A path copied from Illustrator or Photoshop

You can paste any of these paths into the Position or Anchor Point property for a layer, or into the position property of an effect control point. The pasted keyframes are set to rove in time, except for the first and last ones, to create a constant velocity along the path.

By default, the duration of the pasted motion path is 2 seconds. You can adjust the duration by dragging the first or last keyframe in the Timeline panel.

  1. Copy a path to the clipboard:
    • Select a Path property in the Timeline panel, and choose Edit > Copy.

    • Select a path in Illustrator or Photoshop, and choose Edit > Copy.

  2. In the Timeline panel, select the property into which to paste the path.
  3. Place the current-time indicator at the time for the first keyframe of the motion path.
  4. Choose Edit > Paste.

Andrew Devis shows how to use paths from Illustrator as motion paths in After Effects in this video on the Creative COW website.

Motion blur

When you view one frame of motion-picture film or video containing a moving object, the image is often blurred, because a frame represents a sample of time (in film, a frame is 1/24 of a second long). In that time, a moving object occupies more than one position as it travels across the frame, so it doesn’t appear as a sharp, still object. The faster the object moves, the more it is blurred. The camera shutter angle and shutter phase also affect the appearance of the blur, determining how long the shutter stays open and when the shutter opens relative to the beginning of the frame.

In contrast, in a single frame of a computer-generated animation, you may not be able to tell which objects are moving because all moving objects may appear as sharp and clear as nonmoving objects. Without motion blur, layer animation produces a strobe-like effect of distinct steps instead of an appearance of continuous change. Adding motion blur to layers that you animate in After Effects makes motion appear smoother and more natural.

You enable motion blur for each layer individually, and you also determine whether the motion blur is rendered for previews and final output. Use the Enable Motion Blur composition switch at the top of the Timeline panel to enable or disable motion blur rendering for previews. Modify the render settings in the Render Queue panel to enable or disable motion blur rendering for final output. If the Switches Affect Nested Comps preference in the General preferences category is enabled, then nested compositions obey the setting for the compositions in which they’re contained. (See About precomposing and nesting.)

Motion blur slows rendering, so you may want to disable the composition switch while working, and only enable it to see the finished result.

To enable motion blur for a layer, do one of the following:

  • Click the Motion Blur layer switch for the layer in the Timeline panel.
  • Select the layer and choose Layer > Switches > Motion Blur.

The number of samples that After Effects uses to calculate motion blur adapts for each layer, depending on the motion of that layer. This adaptivity provides high-quality motion blur without unnecessarily sampling the motion of a slow-moving layer as frequently as the motion of a fast-moving layer. High sampling rates decrease rendering performance.

When motion blur is enabled for a composition and the Timeline panel is zoomed in so that you can see individual frames, a light gray region around the current-time indicator indicates the shutter phase and shutter angle. The width of the column shows the shutter angle, and the offset of the column shows the shutter phase. This visual indication shows how individual frames are sampled to calculate motion blur within this composition.

You can use motion blur when you animate a layer—for example, moving a layer of text across the screen. You cannot add motion blur to motion that exists within a layer by means of the Motion Blur layer switch and Enable Motion Blur composition switch.

If you want to smooth live-action video to which you assigned a frame rate much lower or higher than the original, use frame blending, not motion blur.

To create a fake motion blur, see Apply motion blur.

Motion blur settings in the Advanced tab of Composition Settings

Samples Per Frame

The minimum number of samples. This minimum is the number of samples used for frames for which After Effects is not able to determine an adaptive sampling rate based on layer motion. This sample rate is used for 3D layers and shape layers.

Adaptive Sample Limit

The maximum number of samples.

Shutter Angle

The shutter angle is measured in degrees, simulating the exposure allowed by a rotating shutter. The shutter angle uses the footage frame rate to determine the simulated exposure, which affects the amount of motion blur. For example, entering 90° (25% of 360°) for 24-fps footage creates an effective exposure of 1/96 of a second (25% of 1/24 of a second). Entering 1° applies almost no motion blur, and entering 720° applies a large amount of blur.

Shutter Phase

The shutter phase is also measured in degrees. It defines an offset that determines when the shutter opens relative to the beginning of a frame. Adjusting this value can help if an object with motion blur applied appears to lag behind the position of the object without motion blur applied.

Note:

A Shutter Phase value that is -1/2 of the Shutter Angle value is best for a layer that is composited on top of another using motion tracking data. (For example, Shutter Phase = -90, Shutter Angle = 180.) This setting combination causes a blur that is centered on the original object.

Apply motion blur to a mask

Motion blur creates a blur based on the movement of a mask in the composition. You can apply motion blur to individual masks. Within each composition, the Enable Motion Blur composition switch must be selected for any layer or any mask within a layer to exhibit motion blur.

  1. Select one or more masks.
  2. Choose Layer > Masks > Motion Blur, and choose one of the following options:

    Same As Layer

    The mask has motion blur only if the Motion Blur switch is selected for the layer.

    On

    The mask will have motion blur regardless of the setting of the Motion Blur switch for the layer.

    Off

    The mask will not have motion blur.

Additional resources about motion blur

When you shoot a fast-moving object, there is motion blurring when the object is rendered. Also, if you shoot moving objects with a high shutter speed, the objects appear to jump between frames leading to strobed motion.

The Pixel Motion Blur effect in After Effects CC tracks the movement of pixels between frames. The effect analyzes a clip to determine what parts are in motion, creates a set of motion vectors, and then uses that information to add motion blur within the frame.

If the object moves too fast, increase the value of Shutter Samples to create more in-between frames. Increase the value of Vector Detail to minimize the possibility of errors when pixel groups are analyzed between frames. 

Chris and Trish Meyer have provided a video tutorial for Pixel Motion Blur effect in the ProVideo Coalition website.

Todd Kopriva has blogged about this effect in the After Effects official blog.

For more information about other time effects in After Effects, see Time effects.

Mark Christiansen explains some of the concepts surrounding motion blur, shutter speed, and shutter angle on the ProVideo Coalition website.

Andrew Kramer provides a video tutorial on his Video Copilot website in which he demonstrates the advantages of using 32-bpc color with motion blur. (See Color depth and high dynamic range color.)

Smooth motion and velocity by removing extra keyframes

Smooth motion paths, value curves, and velocity curves to eliminate bumpiness or excess keyframes using the Smoother, which adds keyframes or removes unnecessary keyframes.

Note:

You can also use the smooth expression method for this purpose, without removing keyframes. (See Property attributes and methods (expression reference).)

Although you can smooth a curve for any property, the Smoother is most useful when applied to curves automatically generated by Motion Sketch, where you may have excess keyframes. Applying the Smoother to keyframes that have been set manually may result in unexpected changes to the curve.  

Note:

To avoid the need to use the Smoother on a path generated by Motion Sketch, set the Smoothing option in the Motion Sketch panel before sketching the motion path.

When you apply the Smoother to properties that change spatially (such as Position), you can smooth only the spatial curve (the curve defined by the motion). When you apply the Smoother to properties that change only in time (such as Opacity), you can smooth only the value and velocity curves (the curve defined by the value or the velocity).

In addition to adding keyframes or eliminating unnecessary keyframes, the Smoother also applies Bezier interpolation at each keyframe when smoothing the temporal curve. (See Keyframe interpolation methods.)

  1. In the Timeline panel, either select all the keyframes for a property to smooth the entire curve, or select at least three keyframes to smooth only a portion of a curve.
  2. Choose Window > Smoother. In the Apply To menu, the Smoother automatically selects Spatial Path or Temporal Graph, depending on the type of property for which you selected keyframes in step 1.
  3. Set a value for Tolerance. The units of Tolerance match the units of the property you are smoothing. New keyframe values vary no more than the specified value from the original curve. Higher values produce smoother curves, but too high a value may not preserve the original shape of the curve.

  4. Click Apply and preview the results.
  5. If necessary, choose Edit > Undo Smoother to reset the keyframes, adjust the value for Tolerance, and then reapply the Smoother.

Add randomness to a property with the Wiggler

You can add randomness to any property as it varies over time by using the Wiggler.

Note:

You can also use the wiggle expression method for this purpose. Usually, it is easier to use the expression than to use the Wiggler. (See Property attributes and methods (expression reference).)

Depending on the property and the options you specify, the Wiggler adds a certain number of deviations to a property by adding keyframes and randomizing interpolations coming into or out of existing keyframes. You need at least two keyframes to use the Wiggler.

Using the Wiggler, you can more closely simulate natural movement within specified limits. For example, add randomness to an animated butterfly to produce fluttering. Simulate the flicker of an old projector by adding it to brightness or opacity.

  1. Select a range of keyframes for the property.
  2. Choose Window > Wiggler.
  3. For Apply To, select the type of curve you want the Wiggler to change. If you selected keyframes for a property that varies spatially, you can select Spatial Path to add deviations to the motion, or Temporal Graph to add deviations to the velocity. If you selected keyframes for a property that does not vary spatially, you can select only Temporal Graph.
  4. Select a Noise Type option to specify the type of deviation due to randomly distributed pixel values (noise):

    Smooth Noise

    Produces deviations that occur more gradually, without sudden changes.

    Jagged Noise

    Produces sudden changes.

  5. Select the dimensions of the property you want to affect:

    X, Y, or Z

    Adds deviations to only one dimension of the selected property. Choose the dimension from the menu.

    All Independently

    Independently adds a different set of deviations to each dimension.

    All The Same

    Adds the same set of deviations to all dimensions.

  6. Set Frequency to specify how many deviations (keyframes) per second After Effects adds to the selected keyframes. A low value produces only occasional deviations, while a high value produces more erratic results. A value less than 1 creates keyframes at intervals of less than one per second. For example, a value of 0.5 creates one keyframe every 2 seconds.
  7. Set Magnitude to specify the maximum size of the deviations. After Effects sets the specified magnitude to the units of the selected property, so a value for one property may produce different results in another property.

  8. Click Apply and preview the results.
  9. If necessary, choose Edit > Undo Wiggler to reset the keyframes, adjust the values for Frequency and Magnitude, and then reapply the Wiggler.

Convert audio to keyframes

The Convert Audio To Keyframes keyframe assistant analyzes audio amplitude within the work area and creates keyframes for audio amplitude.

  1. With the composition active in the Composition panel or Timeline panel, choose Animation > Keyframe Assistant > Convert Audio To Keyframes.

This keyframe assistant creates an Audio Amplitude layer representing all audio sources in the composition, with three Expression Controls effects with Slider properties that contain the keyframes: Left Channel, Right Channel, and Both Channels.

To use the keyframes created by this keyframe assistant, link the changes in audio amplitude to other layer properties. For example, use an expression to link the audio keyframes to the Scale property of a layer to make the layer grow and shrink as the amplitude increases and decreases.

Online resources for converting audio to keyframes

Aharon Rabinowitz provides a video tutorial on the Creative COW website that shows how to link the audio amplitude keyframes to other properties—in this case the properties of the Wave Warp effect, to synchronize animation with sound.

Nathan Gambles provides an expression on the Video Copilot website that ducks (reduces the volume of) audio on one layer when the volume of audio on another layer increases. This technique is useful, for example, for automatically decreasing the volume of a soundtrack when dialog occurs. This expression for the Stereo Mixer effect depends on the Convert Audio To Keyframes keyframe assistant having been applied to the other audio layer.

Lloyd Alvarez provides a script on his After Effects Scripts website that adds markers, splits a layer, or adds a text layer with incrementing numbers based on audio intensity.

Andrew Devis provides a pair of video tutorials on the Creative COW website that show in detail how to use the linear expression method along with the Convert Audio To Keyframes command.

Adobe logo

Sign in to your account