Acerca de los filtros

Descripción general de los filtros

Los filtros de (efectos gráficos) permiten añadir enriquecedores efectos visuales para texto, botones y clips de película. Una característica exclusiva de Animate es que permite animar los filtros que aplique utilizando interpolaciones de movimiento.

Los modos de mezcla de Animate permiten crear imágenes compuestas. Composición es el proceso de variar la transparencia o la interacción de colores de dos o más objetos solapados. Además, los modos de mezcla ofrecen una nueva dimensión de control de la opacidad de objetos e imágenes. Así, puede utilizar los modos de mezcla de Animate para crear resaltados o sombras que dejan entrever detalles de la imagen subyacente, o para colorear una imagen desaturada.

Filtros animados

Es posible animar los filtros en la línea de tiempo. Los objetos incluidos en diferentes fotogramas clave unidos entre sí por una interpolación tienen los parámetros de los correspondientes filtros interpolados en los fotogramas intermedios. Si un determinado filtro no cuenta con un filtro coincidente (del mismo tipo) en el extremo opuesto de la interpolación, éste se añade automáticamente para garantizar que el efecto se encuentre al final de la secuencia de animación.

Para evitar problemas de funcionamiento de las interpolaciones de movimiento si falta un filtro al final de la interpolación, o si los filtros se han aplicado en un orden distinto en cada extremo, Animate hace lo siguiente:

  • Si se aplica una interpolación de movimiento a un clip de película al que ya se han aplicado filtros, al insertar un fotograma clave en el extremo opuesto de la interpolación, el clip adopta automáticamente en el último fotograma de la interpolación los mismos filtros en el mismo orden de apilamiento que los existentes al comienzo de la misma.

  • Si se sitúan dos clips de película en dos fotogramas diferentes con distintos filtros aplicados a cada uno de ellos y se aplica entonces una interpolación de movimiento entre los fotogramas, Animate procesa en primer lugar el clip de película que contiene mayor número de filtros. A continuación, Animate compara los filtros aplicados al primer clip de película con los aplicados al segundo. Si no se encuentran filtros coincidentes en el segundo clip de película, Animate genera un filtro ficticio sin parámetros y con el color de los filtros existentes.

  • Si existe una interpolación de movimiento entre dos fotogramas clave y se añade un filtro al objeto de un fotograma clave, Animate añade automáticamente un filtro ficticio al clip de película cuando éste llega al fotograma clave situado en el otro extremo de la interpolación.

  • Si existe una interpolación de movimiento entre dos fotogramas clave y se elimina un filtro de un objeto de un fotograma clave, Animate elimina automáticamente el filtro correspondiente del clip de película cuando éste llega al fotograma clave situado en el otro extremo de la interpolación.

  • Si no hay una coherencia en la definición de los parámetros de filtro en uno y otro extremo de una interpolación de movimiento, Animate aplica a los fotogramas interpolados la configuración de filtro del fotograma inicial. Se crea una incoherencia en la configuración cuando los siguientes parámetros del extremo inicial y el extremo final de una interpolación son distintos: extractor, sombra interior, iluminado interior, y tipo de iluminado degradado y tipo de bisel degradado.

    Por ejemplo, si crea una interpolación de movimiento utilizando el filtro de sombra y aplica una sombra con extractor al primer fotograma de la interpolación y una sombra interior al último, Animate corrige esta incoherencia. En este caso concreto, Animate aplica la configuración de filtro aplicada al primer fotograma de la interpolación: una sombra con extractor.

Los filtros y el rendimiento de Flash Player

El tipo, cantidad y calidad de los filtros aplicados a los objetos influye en el rendimiento de la reproducción de los archivos SWF. Cuantos más filtros aplique a un objeto, mayor número de cálculos tendrá que realizar Adobe® Flash® Player para mostrar correctamente los efectos visuales creados. Por esta razón, Adobe® aconseja aplicar únicamente un número limitado de filtros a un determinado objeto.

Cada filtro incluye controles que le permiten ajustar su intensidad y calidad. Un ajuste en valores bajos mejora el rendimiento en los equipos más lentos. Si crea contenidos para su reproducción en una variada gama de equipos o no tiene seguridad de que su audiencia cuente con equipos de cierta potencia, conviene que establezca un nivel de calidad bajo para maximizar el rendimiento en la reproducción.

Información sobre los filtros de Pixel Bender

Adobe Pixel Bender™ es un lenguaje de programación desarrollado por Adobe que permite al usuario crear filtros personalizados, efectos y modos de mezcla para su uso en Animate y After Effects. Pixel Bender es independiente del hardware y está diseñado para ejecutarse de forma eficaz en una serie de arquitecturas de GPU y CPU de forma automática.

Los desarrolladores de Pixel Bender crean filtros escribiendo código de Pixel Bender y guardando este código en un archivo de texto con la extensión pbj. Una vez escrito, un filtro de Pixel Bender se puede utilizar en cualquier documento de Animate. Utilice ActionScript® 3.0 para cargar el filtro y emplee sus controles.

Para obtener más información sobre el trabajo con Pixel Bender en ActionScript, consulte la Guía del desarrollador de ActionScript 3.0.

Lee Brimelow ha publicado varios ejemplos útiles de Pixel Bender en su blog, en http://theflashblog.com/?cat=44 (en inglés).

El siguiente tutorial de vídeo muestra el uso de filtros de Pixel Bender en Animate:

Trabajo con filtros

Función mejorada en Animate CC

Cada filtro que se aplica a un objeto se añade a la lista de filtros aplicados a dicho objeto en el inspector de propiedades. Se pueden aplicar varios filtros a un mismo objeto, así como eliminar los que se hayan aplicado previamente. Es posible aplicar filtros solamente a objetos de texto, de botones, de componentes, de clips de película y a clips compilados.

También puede crear una biblioteca de configuración de filtros que le permita aplicar fácilmente un filtro o un conjunto de filtros a un objeto. Animate almacena la configuración predefinida del filtro que se crea en la sección Filtros del inspector de propiedades en el menú Filtros > Configuración predefinida.

Con Flash Professional CS6 y versiones anteriores, la aplicación de filtros estaba limitada a los símbolos de clip de película y de botón únicamente. Con Animate CC, ahora es posible aplicar además filtros a clips compilados y a componentes de clip de película. Esto permite añadir efectos a los componentes directamente, con sólo hacer clic (o doble clic) y lograr que las aplicaciones tengan mucho mejor aspecto. Con Flash CS6, para añadir filtros u otros efectos a componentes, uno debe “envolverlo” dentro de un símbolo de clip de película. Esto es:

  1. Crear o añadir un componente en el escenario.
  2. Hacer clic con el botón derecho en el componente y seleccionar Convertir en símbolo.
Con  CS6 (y versiones anteriores), era posible añadir filtros y otros efectos después de envolver el componente dentro de un símbolo. Sin embargo, esta acción se presentaba como la solución a un problema, no como una práctica recomendada.
 
Con Animate CC, podría añadir varios filtros a los componentes directamente usando las opciones Filtros, Efectos de color y Configuración de visualización disponibles en el panel Propiedades. Para comprender perfectamente esta mejora clave, considere el siguiente ejemplo:
 
Añadir un filtro de bisel a un componente de botón
 
  1. Cree o añada un botón en el escenario desde el panel Componentes y seleccione después el botón.
  2. En el panel Propiedades, haga clic en la lista desplegable de botones de la sección Filtros y elija Bisel. Se visualizarán las propiedades y los valores del filtro Bisel.
  3. Modifique o defina los valores adecuados para cualquier propiedad que desee. Por ejemplo , Desenfoque X, Desenfoque Y, Intensidad, Sombra, etc. Verá cómo los efectos se aplican en el botón seleccionado todos al mismo tiempo.
El menú Añadir filtro del inspector de propiedades

Aplicación o eliminación de un filtro

  1. Seleccione un objeto de texto, de botón o de clip de película para aplicarle o eliminarle un filtro.
  2. En la sección Filtros del panel Propiedades, realice uno de los siguientes pasos:

    • Para añadir un filtro, haga clic en el botón y seleccione un filtro. Experimente con la configuración hasta obtener el resultado que desea.

    • Para eliminar un filtro, selecciónelo en la lista de filtros aplicados y haga clic en el botón Eliminar filtro . Puede eliminar o cambiar el nombre de cualquier valor predefinido.

Cómo copiar y pegar un filtro

  1. Seleccione el objeto cuyo filtro desea copiar y haga clic en el panel Filtros.
  2. Seleccione el filtro que quiera copiar y haga clic en el botón . En la lista desplegable, haga clic en Copiar filtro seleccionado. Para copiar todos los filtros, elija Copiar todos los filtros.

  3. Seleccione el objeto al que quiera aplicar el filtro y haga clic en el botón. En la lista desplegable, haga clic en Pegar filtros.

Aplicación de un filtro preestablecido a un objeto

  1. Seleccione el objeto al que va a aplicar un filtro preestablecido y seleccione la ficha Filtro.
  2. Haga clic en el botón para abrir la lista desplegable.

  3. Seleccione el filtro predefinido que va a aplicar en la lista que aparece en la parte inferior de la lista desplegable.

Nota:

Cuando se aplica un filtro preestablecido a un objeto, Animate sustituye todos los filtros que éste pudiera tener aplicados por los filtros que utiliza la configuración predeterminada.

Activación y desactivación de un filtro aplicado a un objeto

  1. De forma predeterminada, todos los filtros permanecen activados. Haga clic en el icono situado junto al nombre del filtro para desactivarlo en la lista de filtros. Haga clic en el botón X situado junto al nombre del filtro para activarlo.

    Nota:

    también puede hacer clic con la tecla Alt (Windows) u Opción (Macintosh) pulsada para alternar el estado de activación o desactivación de los demás filtros de la lista. Si hace clic con la tecla Alt presionada sobre el icono , el filtro seleccionado quedará activado y todos los demás desactivados.

Activación y desactivación de todos los filtros aplicados a un objeto

  1. Haga clic en el botón y seleccione Activar todos o Desactivar todos en la lista desplegable.

    Nota:

    para activar o desactivar todos los filtros de la lista, haga clic con la tecla Ctrl pulsada en el icono de activación o desactivación de la lista Filtros.

Creación de bibliotecas de filtros preestablecidos

Guarde las configuraciones de filtros como bibliotecas de preestablecidos que más tarde podrá aplicar fácilmente a clips de película y objetos de texto. También podrá compartir sus configuraciones de filtros con otros usuarios con sólo facilitarles el archivo de configuración. Se trata de un archivo XML que se guarda en la carpeta de configuración de Animate en la siguiente ubicación:

 

  • Windows 7 y 8: C:\Users\nombreusuario\AppData\Local\Adobe\Flash CC\idioma\Configuration
  • (Sólo Flash Professional CS6 o versiones anteriores) Windows XP: C:\Documents and Settings\nombreusuario\Local Settings\Application Data\Adobe\Flash CS6\idioma\Configuration\Filters\filtername.xml
  • (Sólo Flash Professional CS6 o versiones anteriores) Windows Vista: C:\Users\nombreusuario\Local Settings\Application Data\Adobe\Flash CS6\idioma\Configuration\Filters\filtername.xml
  • Macintosh: Macintosh HD/Users/nombreusuario/Librería/Application Support/Adobe/Flash CC/idioma/Configuration/Filters/filtername.xml

Creación de una biblioteca de filtros con configuraciones preestablecidas

  1. Aplique el filtro o los filtros a cualquier objeto seleccionado.

  2. Haga clic en el botón para añadir un filtro nuevo.

  3. Seleccione el filtro y haga clic en el botón ; después, elija Guardar como filtro predefinido...

  4. Introduzca un nombre para la configuración de filtro en el cuadro de diálogo Guardar preestablecido como y haga clic en Aceptar.

Cambio de nombre de un filtro preestablecido

  1. Haga clic en el botón y añada un filtro nuevo.

  2. Seleccione el filtro y haga clic en el botón . Haga clic en Editar predefinidos.

  3. Haga doble clic en el filtro preestablecido cuyo nombre desea cambiar.

  4. Escriba el nombre nuevo y haga clic en Aceptar.

Eliminación de un filtro preestablecido

  1. Haga clic en el botón y añada un filtro nuevo.

  2. Seleccione el filtro y haga clic en el botón .

  3. Haga clic en Editar predefinidos.

  4. En el cuadro de diálogo Editar predefinidos, seleccione el valor predefinido que quiera quitar y haga clic en Eliminar.

Aplicación de filtros

Aplicación de sombras

El filtro Sombra simula el aspecto de un objeto que proyecta su sombra sobre una superficie.

Texto con el filtro Sombra aplicado

Para obtener un ejemplo de sombra con una interpolación clásica, consulte la página de ejemplos de Animate en www.adobe.com/go/learn_fl_samples_es. Descargue y descomprima el archivo zip de ejemplos y vaya al directorio Graphics\AnimatedDropShadow.

  1. Seleccione el objeto al que desea aplicar una sombra.
  2. En la sección Filtros del inspector de propiedades, haga clic en el botón y seleccione Sombra.

  3. Edite la configuración del filtro:
    • Para definir la anchura y la altura de la sombra, establezca los valores Desenfocar X e Y.
    • Para definir la opacidad de la sombra, establezca el valor Intensidad. Cuanto mayor sea el valor numérico, tanto más opaca será la sombra.
    • Elija el nivel de calidad de la sombra. Un nivel de calidad Alta equivale aproximadamente a un desenfoque de Gauss. Una calidad baja maximiza el rendimiento de reproducción.
    • Para establecer el ángulo de la sombra, introduzca un valor.
    • Para definir la distancia de la sombra del objeto, establezca el valor Distancia.
    • Seleccione la casilla de verificación Extractor para extraer (u ocultar) el objeto origen y mostrar únicamente la sombra en la imagen extraída.
    • Para aplicar la sombra en los límites del objeto, seleccione Sombra interior.
    • Para ocultar el objeto y mostrar solamente su sombra, seleccione Ocultar objeto. Esta opción facilita la creación de sombras de mayor realismo.
    • Para abrir el selector de color y establecer el color de la sombra, haga clic en el control de color.

Creación de sombras sesgadas

El sesgo del filtro Sombra permite crear sombras de apariencia más real

  1. Seleccione el filtro con la sombra que desee sesgar.
  2. Duplique (seleccione Edición > Duplicar) el objeto original.
  3. Seleccione el objeto duplicado y sésguelo utilizando la herramienta Transformación libre (Modificar > Transformar > Rotar y sesgar).
  4. Aplique el filtro Sombra al objeto de texto o clip de película duplicado. (Ya se habrá aplicado si el objeto duplicado tenía previamente una sombra.)
  5. En el panel Filtros, seleccione Ocultar objeto para ocultar el objeto duplicado y dejar visible su sombra.
  6. Seleccione Modificar > Organizar > Hacia atrás para colocar el objeto duplicado y su forma detrás del objeto original.
  7. Ajuste la configuración del filtro Sombra y el ángulo de la sombra sesgada hasta que adopte la apariencia deseada.

Aplicación de un desenfoque

El filtro Desenfocar suaviza los bordes y los detalles de los objetos. Aplicando este filtro a un objeto puede conseguir que parezca estar detrás de otros objetos o estar en movimiento.

Texto con el filtro Desenfocar aplicado

  1. Seleccione un objeto para aplicarle un desenfoque y seleccione Filtros.
  2. Haga clic en el botón y seleccione Desenfocar.

  3. Edite la configuración del filtro en la ficha Filtro:
    • Para definir la anchura y la altura de la sombra, establezca los valores Desenfocar X e Y.
    • Seleccione el nivel de calidad del desenfoque. Un nivel de calidad Alta equivale aproximadamente a un desenfoque de Gauss. Una calidad baja maximiza el rendimiento de reproducción.

Aplicación de iluminado

El filtro Iluminado permite aplicar un color a los bordes de un objeto.

Texto con el filtro Iluminado aplicado

  1. Seleccione un objeto para aplicarle un iluminado y seleccione Filtros.
  2. Haga clic en el botón y seleccione Iluminado.

  3. Edite la configuración del filtro en la ficha Filtro:
    • Para definir la anchura y la altura de la sombra, establezca los valores Desenfocar X e Y.
    • Para abrir el selector de color y establecer el color del iluminado, haga clic en el control de color.
    • Para definir la opacidad de la sombra, establezca el valor Intensidad.
    • Seleccione la casilla de verificación Extractor para extraer (u ocultar visualmente) el objeto origen y mostrar únicamente el iluminado en la imagen extraída.
    Utilización del filtro Iluminado con la opción Extractor

    • Para aplicar el iluminado en los límites del objeto, seleccione Iluminado interior.
    • Seleccione el nivel de calidad del iluminado. Un nivel de calidad Alta equivale aproximadamente a un desenfoque de Gauss. Una calidad baja maximiza el rendimiento de reproducción.

Aplicación de un bisel

El bisel aplica al objeto un efecto de resaltado que le hace aparecer curvado por encima de la superficie del fondo.

Texto con un bisel aplicado

  1. Seleccione un objeto para aplicarle un bisel y seleccione Filtros.
  2. Haga clic en el botón y seleccione Bisel.

  3. Edite la configuración del filtro en la ficha Filtro:
    • Para definir el tipo de bisel, seleccione un bisel en el menú Tipo.
    • Para definir la anchura y la altura del bisel, establezca los valores Desenfocar X e Y.
    • Seleccione los colores de sombra y resaltado para el bisel en la paleta emergente de colores.
    • Para establecer la opacidad del bisel sin que se vea afectada la anchura, establezca el valor Intensidad.
    • Para cambiar el ángulo de la sombra que proyecta un borde biselado, establezca el valor Ángulo
    • Para definir la anchura del bisel, introduzca un valor en el campo Distancia.
    • Para extraer (u ocultar visualmente) el objeto origen y mostrar únicamente el bisel en la imagen extraída, seleccione Extractor.

Aplicación de iluminado degradado

El iluminado degradado produce un efecto de iluminación en un color degradado de un lado al otro de la superficie del iluminado. Este efecto requiere un color con un valor Alfa igual a 0 en el principio del degradado. Este color no se puede mover de su posición, pero sí se puede cambiar.

Texto con iluminado degradado aplicado

  1. Seleccione un objeto en el que aplicar el iluminado degradado.
  2. En la sección Filtros del inspector de propiedades, haga clic en el botón y seleccione Iluminado degradado.

  3. Edite la configuración del filtro en la ficha Filtro:
    • Seleccione el tipo de iluminado que se aplica al objeto en el menú emergente Tipo.
    • Para definir la anchura y la altura de la sombra, establezca los valores Desenfocar X e Y.
    • Para definir la opacidad del bisel sin que se vea afectada la anchura, establezca el valor Intensidad.
    • Para cambiar el ángulo de la sombra que proyecta un borde biselado, establezca el valor Ángulo.
    • Para definir la distancia de la sombra del objeto, establezca el valor Distancia.
    • Para extraer (u ocultar visualmente) el objeto origen y mostrar únicamente el iluminado degradado en la imagen extraída, seleccione Extractor.
    • Especifique el color de degradado que desea aplicar al iluminado. Los degradados contienen dos o más colores que se desvanecen o se mezclan entre sí. El color seleccionado al comienzo del degradado se denomina color alfa.
    • Para cambiar un color del degradado, seleccione uno de los punteros de color situados bajo la barra de definición del degradado y haga clic en el espacio de color que aparece justo debajo de la barra de degradado para mostrar el Selector de colores. De este modo de ajusta el nivel y la posición del color correspondiente dentro del degradado.
    • Para añadir un puntero al degradado, haga clic en la barra de definición del degradado o debajo de ésta. Para crear un degradado con hasta 15 transiciones de color, añada 15 punteros. Para volver a colocar un puntero en el degradado, arrastre el puntero por la barra de definición del degradado. Arrastre el puntero hacia abajo y fuera de la barra de definición del degradado para eliminarlo.
    • Seleccione el nivel de calidad del iluminado degradado. Un nivel de calidad Alta equivale aproximadamente a un desenfoque de Gauss. Una calidad baja maximiza el rendimiento de reproducción.

Aplicación de un bisel degradado

El bisel degradado confiere al objeto un efecto de resaltado que le hace aparecer elevado por encima del fondo, con un color degradado de un lado al otro de la superficie del bisel. Este efecto requiere un color con un valor Alfa igual a 0 en el centro del degradado.

  1. Seleccione un objeto en el que aplicar el bisel degradado.

  2. En la sección Filtros del inspector de propiedades, haga clic en el botón y seleccione Bisel degradado.

  3. Edite la configuración del filtro en la ficha Filtro:

    • En el menú emergente Tipo, seleccione el tipo de bisel que desea aplicar.

    • Para definir la anchura y la altura del bisel, establezca los valores Desenfocar X e Y.

    • Para modificar la suavidad del bisel sin afectar su anchura, introduzca un valor para Intensidad.

    • Para establecer el ángulo de la fuente de luz, introduzca un valor para Ángulo.

    • Para extraer (u ocultar visualmente) el objeto origen y mostrar únicamente el bisel degradado en la imagen extraída, seleccione Extractor.

    • Especifique el color de degradado que desea aplicar al bisel. Los degradados contienen dos o más colores que se desvanecen o se mezclan entre sí. El puntero central controla el color alfa del degradado. Puede cambiar el color de este puntero, pero no su posición en el degradado.

      Para cambiar un color del degradado, seleccione uno de los punteros de color situados bajo la barra de definición del degradado y haga clic en el espacio de color que aparece justo debajo de la barra de degradado para mostrar el Selector de colores. De este modo se ajusta el nivel y la posición del color correspondiente dentro del degradado.

      Para añadir un puntero al degradado, haga clic en la barra de definición del degradado o debajo de ésta. Para crear un degradado con hasta 15 transiciones de color, añada 15 punteros. Para volver a colocar un puntero en el degradado, arrastre el puntero por la barra de definición del degradado. Arrastre el puntero hacia abajo y fuera de la barra de definición del degradado para eliminarlo.

Aplicación del filtro Ajustar color

El filtro Ajustar color permite controlar con precisión los atributos de color del objeto seleccionado, incluyendo contraste, brillo, saturación y tono.

  1. Seleccione un objeto para el que ajustar el color.
  2. En la sección Filtros del inspector de propiedades, haga clic en el botón y seleccione Ajustar color.

  3. Introduzca valores para los atributos de color. Estos atributos y sus correspondientes valores son los siguientes:

    Contraste

    Ajusta los resaltados, sombras y medios tonos de una imagen.

    Brillo

    Ajusta el brillo de una imagen.

    Saturación

    Ajusta la intensidad de un color.

    Tono

    Ajusta el tono de un color.

  4. Para restablecer todos los ajustes de 0 y devolver el objeto a su estado original, haga clic en Restablecer filtro.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea