Group, lock, duplicate and copy objects in Adobe XD.

Group objects

You can combine several objects into a group so that the objects are treated as a single unit. You can then move or transform a group of objects without affecting their attributes or relative positions. For example, you can group the objects in a logo design so that you can move and scale the logo as one unit. You can ungroup the group to get back the editing control on individual components again.

You can also edit fill and stroke properties for all objects within a group at a group level.

Groups can also be nested. They can be grouped within other objects or groups to form larger groups.

  1. Select the objects to be grouped or the group to be ungrouped.

  2. On Mac, choose either Object > Group or Object > Ungroup from the main menu, or select Group or Ungroup from the context menu.

    On Windows, select the objects to be grouped or ungrouped, right-click, and select Group or Ungroup from the context menu.

You can also group objects using the Layers panel. For more information on layers, see Work with layers.

Select objects in a group

Normally, you can select an object by simply clicking on it. When the object is part of a group, the whole group is selected when you click the object. To select an object in a group, double-click or Cmd + click / Ctrl + Click the object in the group.

Group objects
Group objects

Lock and unlock objects

Locking objects prevents you from selecting and editing them.

  • On Mac, select the object and click Object > Lock. Or, right-click the object and select Lock from the context menu.
  • On Windows, right-click the object and select Lock from the context menu.

When you lock an object, a lock icon appears when you select it.

To unlock objects, select them and click the lock icon, or click Object > Unlock.

Opmerking:

You can also use the lock/unlock options in the Layers panel.

Lock objects
Lock objects

Duplicate objects

Select one or more objects. Option‑drag (Mac) or Alt-drag (Windows) the selection (but not a handle on the bounding box). On Mac, you can also click Edit > Duplicate to duplicate an object.

Copy and paste objects

You can select an object or group of objects, copy them (Ctrl + C or Cmd + C), and paste them (Ctrl + V or Cmd + V) onto multiple artboards. When you paste them, XD intelligently places them in the same X and Y location where the original object was located. This feature is especially useful while copying headers or footers across multiple artboards.

Opmerking:

If the artboard is selected but is not within the viewport, then XD does not paste on that artboard.

You can also copy an object's style, and paste that style onto other objects or text elements in your project. Copy the object, right-click (on Windows) or Ctrl-click (on Mac) another object, and select Paste Appearance. The object formatting alone is copied and pasted.

Flip objects

You can use the flip option to flip objects or elements for faster and more precise design process on the design canvas. Artwork flip accounts for the current rotation of the object when applied. You can use the flip option to toggle between vertical and horizontal flip and view the flipped objects flipped on all surfaces such as preview, mobile, and web.

Exceptions when working with flip:

  • Flip is not supported on artboard, repeat grid, and symbols.
  • Location of the flipped object does not change.
  • Flip takes the center point of the object or group and flips across the axis.
  • Flip does not impact shadows.
  • Shadows will not be affected by flip. 
  • If an object is rotated, the object flips across the visual axis, not the original object's axis
  • If multiple objects are selected, objects will flip as a group.
  • Objects that are locked will not flip if selected or multi-selected but flips if it is inside a group that the you flip.

Apply artwork flip

  1. Select the element to be flipped in the artboard.

     

  2. Use any of the following options to flip the selected elements:

    • From the command menu, select Object > Transform > Flip > Horizontal or Vertical. 
    • Select Vertical or Horizontal flip options from the Property Inspector.
    Flip objects
    Flip objects

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid