Captions workflow in Premiere Pro | Adobe

The July 2021 release of Premiere Pro (v. 15.4) introduced Speech to Text, which adds automatic video transcription for the Captions workflow. This document explains how to work with captions in Premiere Pro. See Speech to Text to learn how to create transcripts.

 If you are using Premiere Pro versions 14.9 or earlier, see the Captions documentation for these releases.

Speech to Text and the Captions workflow in Premiere Pro

Captions and subtitles add value to videos, making them more accessible for more people – and helping to drive viewer engagement.

Premiere Pro provides a comprehensive toolset that lets you create edit, stylize, and export captions and subtitles in all supported formats.

Start by creating a transcript of your video. Edit the transcript in the Text panel and then use Create captions to add your captions to the Premiere Pro timeline. There you can adjust them like any other media using the editing tools. Edit the text in the Text panel or right on-screen in the Program Monitor. Stylize captions using the design tools in the Essential Graphics panel.

When your video is ready, you can export the captions as stylized, burned-in subtitles, a .srt sidecar text file, or embedded in a QuickTime or MXF file.

Where do Captions fit in the workflow?

Usually it’s best to add captions when your edit is finished, or close to finished. You can fine-tune and edit along with a caption track.

However, if you delete caption segments, you will need to recreate them manually if you need to restore a part of a clip to your final edit.

The Captions workspace

To access the Captions workspace: Select Window > Workspaces > Captions from the main menu.

The Captions workspace
The Captions workspace

The Captions workspace consists of (A) the Text panel where you can edit caption text. You can see the captions displayed on (B) the Program Monitor, and you can edit the appearance of the captions in (C) the Essential Graphics panel. Captions have their own (D) caption track on the timeline where you can edit them.

Add captions to your sequence

Use a third-party service

If you already have a workflow that uses a third-party transcription service, you can bring in that file. 

  1. Import the SRT file into your Premiere Pro project just like any piece of media.
  2. Drag the SRT from the Project panel into your sequence and drop it anywhere in the sequence.

Premiere Pro creates a new caption track, and the captions are placed on the track.

Manually transcribe captions

If you have short sequences, you can choose to manually transcribe sequences.

  1. Open the Captions workspace (Window > Workspaces > Captions).  This opens the Text panel (where you create and edit caption text) and the Essential Graphics panel (where you stylize your text).  In the Text panel, click Create new caption track (macOS: Opt + Cmd + A | Win: Ctrl + Alt + A).

  2. In the New Caption Track dialog that opens, you can choose your caption track format and style.

    Creating a captions track
    Creating a captions track

    The default format option is Subtitle that allows you to create nice looking stylized subtitles that get burned into the video image, or can be exported as a sidecar.

     Optional: If you have created and saved any text styles previously, you can choose a style from the Style drop-down list.

    Click OK to create the track.

    Premiere Pro adds a new caption track to your current sequence.

    You can change your track format later if you want.

  3. Place the playhead at the beginning of your first piece of dialog.

     Use the waveforms in the audio to help align the text caption to the audio.

  4. Click the + icon in the Text panel to add a blank caption. Or use these keyboard shortcuts (macOS: Opt + Cmd + C | Win: Ctrl +Alt + C).

  5. Double-click New Caption in the Text panel or the Program Monitor to start editing the caption. Then type in the caption text.

  6. Trim the end of the caption in the timeline to align with the end of the spoken dialog. Continue adding captions in the same way to the rest of the audio in the sequence. 

 Check out the keyboard shortcuts at the bottom of this page to find out how you can make manually transcribing captions a breeze.

Working with captions in the timeline

Captions have their own track on the timeline where you can edit them like any other video track. Additionally, you can modify the display of the caption track.

Toggle the eye icon to turn the caption track on or off.

Click the CC icon to see options to hide or show all caption tracks, or to show just the active caption track.

Set label colors with captions.

To set label colors for all the caption items in a Captions track, select the track in the Project panel, then select Edit > Label and choose a label color.

To set a label color for an item(s) in the Captions track, select the track(s) in the timeline, then select Edit > Label and choose a label color.

 

Trim video tracks along with their linked caption tracks simultaneously.

Just select the caption track and its linked audio or video track and move it to trim both tracks at the same time. 

To turn off linking, click the Linked Selection tool in the Timeline panel.

Caution:

Unlike video or audio clips, if you remove a Captions item during an edit, it is deleted from the Captions track. You will need to recreate it manually if you restore that clip or clip section.

Stylize captions

You can stylize your captions using the various styling options (such as font, size, and location) in the Essential Graphics panel.

  1. In the Captions workspace (Window > Workspaces > Captions), select a caption on the captions track.

  2. Change font. 

    Use the Text options in the Essential Graphics panel to change the font, text alignment and tracking for your caption.

    • Font: Set font, font style and font size.

    • Paragraph Alignment: For horizontal alignment use Left align text, Center align text, Right align text and Justify. For Vertical alignment, use  Top align text, Center text vertically and Bottom align text. This defines how a caption grows when adding additional lines. 

    • Tracking: Loosen or tighten the space between characters.

    Change font properties
    Change font properties

    • Leading: Loosen or tighten the vertical space between lines.

    • Faux Styles: Bold, Italic, All Caps, Small Caps, Superscript, Subscript, Underline.

  3. Change text position.

    Align and transform text
    Align and transform text

    Use the Align and Transform options to align your text and change its position.

    • Position captions with zones: You can choose from different zones to position your caption in different areas on screen.

    • Fine tune position: Through Set Horizontal and Set Vertical Position you can add an offset to your zone setting.
       Vertical and horizontal text alignment are automatically set according to the zone position as well. 

    • Change the text box size: If you want to shrink or expand the text box size you can do this through Set Horizontal Scale and Set Vertical Scale. This will affect text wrapping and paragraph align settings. You can also change the text. box size using the text box controls on the Program Monitor.
  4. Change text appearance.

    Options to change text appearance
    Options to change text appearance

    Change the appearance of your text by playing around with the fill and stroke, background, and shadow.

    • Fill: Change the color of your captions.

    • Stroke: Add single or multiple strokes. The Graphics Properties menu under the wrench menu gives you more control over stroke styling.

    • Background: Add a background box. You can choose the color, add additional padding and change the opacity.

    • Shadow: You can add a shadow and fine tune with controls such as opacity, angle, distance and more.

Create styles for your captions

Create Track Styles for consistent styling across the entire captions track. A style saves all the settings made in the Essential Graphics panels, including font, alignment, color and more. Setting a Track Style to one caption applies it to all captions on the track. You can have different styles for different tracks.

To create a style:

  1. Edit the style of the caption text.

  2. Creating a style
    Creating a style

    Save it as a new style.

    In the Track Style section of the Essential Graphic panel, select Create Style.

    In the New Text Style dialog box that opens, give your style a name. Click OK.

    Premiere Pro saves your changes as a new text style and it is available for you to apply from the Track Style drop down list.

  3. Use the Push and Pull options when you want to make changes to a style.

    Push style to all captions on track
    Push style to all captions on track

    If you need to make changes to the style, this is easy.  First adjust the settings to your new desired look.

    Then push this style to all captions on track by clicking the Push to Track or Style icon.

    You can then choose to push to:

    • All captions on track: Only updates the captions on this track.
    • Style in project: Updates all uses of this style in project. This affects every use of the style in your project, even in other sequences.
  4. Use Sync from Style when you have made changes and want to revert those changes back to the saved style.

    Sync from Style
    Sync from Style

Export captions

After you finish creating and editing your captions, you can export the sequence containing the captions through Premiere Pro or Adobe Media Encoder using the Export Settings dialog box.

You can export your sequence with captions using one of the following options: 

  • Burned in,
  • Sidecar file, or 
  • Embedded (only supported for captions tracks set to a closed caption standard)
  1. Click File > Export.

  2. Open the Captions tab in the export settings and choose any of the export options.

    • None: Does not include captions of any type; only your video and audio is exported.
    • Create Sidecar File: Supported formats are SCC, MCC, XML, STL, SRT, and DFXMP.
       There are limitations regarding the type of sidecar you can create from each caption track type.
      • Subtitles -> SRT, STL
      • OP47 / EBU Subtitles / Teletext -> .xml, .stl, .srt
      • CEA608-> .scc, .mcc, .stl, .srt
      • CEA708 -> .scc, .mcc, .srt
    • Embedded: The option to export as Embedded is available only for pro codecs like MXF OP1a, DNX, and ProRes and requires that the caption track format be set to one of the broadcast standards like CEA-608.
       QuickTime embedded export currently only supports embedding CEA-608. MXF Op1a Formats can embed CEA-608, CEA-708, and Australian OP-47 (if 25fps). You will also need those track types in your sequence in order to embed. For example, if you have an SRT in sequence, that cannot be embedded. You must have a compatible format such as 608, 708 or Aus OP-47.
    • Burn Captions into Video
    Export captions
    Export captions

  3. Click Export.

Supported file formats

Closed captioning

Sidecar files

  • SCC
  • MCC
  • XML
  • STL
  • SRT
  • DFXMP

XML files

  • W3C TTML (also known as DFXP)
  • SMPTE-TT
  • EBU-TT
Note:

For XML files, besides viewing the captions in the Captions panel, the captions are also viewable from a text editor.

Premiere Pro supports embedding into and decoding from the following file formats:  

  • MOV
  • DNxHD MXF Op1a
  • MXF Op1a

Keyboard shortcuts

Command

macOS

Windows

Create new captions track

Opt + Cmd + A

Ctrl + Alt + A

Add a new caption segment at the playhead

Opt + Cmd + C

Ctrl + Alt + C

Go to previous caption segment in the timeline

Opt + Cmd + Up

Ctrl + Alt + Up

Go to next caption segment in the timeline

Opt + Cmd + Down

Ctrl + Alt + Down

Try it out!

Download this sample project and try experimenting with our new captions workflow!

Adobe logo

Sign in to your account