Błąd: nieprawidłowy parametr podczas usuwania stron z pliku PDF

Podczas próby usunięcia strony z pliku PDF wyświetlany jest komunikat o błędzie „Nieprawidłowy parametr”. Ten sam komunikat o błędzie może pojawić się także wtedy, gdy próbujesz wstawić lub dodać stronę do pliku PDF.

Błąd „Nieprawidłowy parametr” występuje, gdy program Acrobat znajdzie problem z ukrytą strukturą znaczników w pliku PDF. Wypróbuj poniższe rozwiązanie.

Rozwiązanie 1: Połącz plik PDF z innym plikiem PDF

  1. Uruchom program Pcrobat, a następnie wybierz opcje Plik > Utwórz > Połącz pliki w pojedynczy plik PDF. 

  2. Kliknij menu Dodawanie plików i wybierz opcję Dodaj pliki.

  3. Przejdź do pliku PDF, dla którego wyświetlany jest błąd „Nieprawidłowy parametr”, a następnie kliknij przycisk Otwórz.

  4. Kliknij menu Dodawanie plików i wybierz opcję Dodaj pliki.

  5. Przejdź do innego pliku PDF, najlepiej jednostronicowego, pustego, a następnie kliknij przycisk Otwórz.

  6. Kliknij przycisk Połącz lub Połącz pliki. Wybrane pliki zostaną połączone w pojedynczy plik PDF (Binder1.pdf), który zostanie otwarty w programie Acrobat.

  7. Zapisz plik. Zaznacz wszystkie strony dodane do pliku PDF za pomocą operacji łączenia plików (strony drugiego pliku PDF wybranego podczas łączenia plików). Usuń zaznaczone strony:

    • W programie Acrobat DC/2017 wybierz opcje Widok > Narzędzia > Organizuj strony > Otwórz. Wybierz pliki do usunięcia, a następnie kliknij ikonę Usuń lub naciśnij klawisz Delete.
    • W programie Acrobat XI wybierz opcje Widok > Narzędzia > Strony.Wybierz strony do usunięcia, a następnie kliknij ikonę Usuń w prawym panelu lub naciśnij klawisz Delete.
  8. Zapisz plik ponownie. Aby sprawdzić, czy błąd nadal występuje, spróbuj usunąć stronę z pliku PDF.

Rozwiązanie 2: Wyeksportuj plik PDF jako plik PostScript, następnie przekonwertuj go na format PDF za pomocą programu Distiller

Rozwiązanie to sprawdza się w przypadku pliku PDF bez elementów interaktywnych, takich jak multimedia lub pola formularzy.

Nie próbuj tego rozwiązania, gdy plik PDF zawiera elementy interaktywne, ponieważ mogą one działać nieprawidłowo po wyeksportowaniu pliku PDF do formatu PostScript, a następnie przekonwertowaniu go z powrotem na plik PDF.

  1. Otwórz plik PDF w programie Adobe.

  2. Wybierz opcje Plik > Eksportuj > PostScript.

  3. W oknie dialogowym Zapisz jako PDF wpisz inną nazwę pliku, a następnie kliknij przycisk Zapisz.

  4. W folderze, gdzie został zapisany plik PostScript, kliknij plik prawym przyciskiem myszy i wybierz polecenie Otwórz za pomocą programu Adobe Acrobat Distiller.

    Acrobat Distiller przekonwertuje plik PostScript na plik PDF. Plik PDF jest zapisywany w tym samym folderze.

  5. Aby sprawdzić, czy błąd nadal występuje, otwórz plik PDF w programie Acrobat i spróbuj usunąć, wstawić lub dodać stronę.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online