Debugger JavaScript w programie Acrobat

Debugger JavaScript w programie Acrobat umożliwia szczegółowe przeglądanie kodu, ustawianie punktów przerwania i sprawdzanie zmiennych za pomocą okna dialogowego debuggera.

Aby włączyć obsługę debuggera JavaScript, wybierz opcję Edycja > Preferencje > JavaScript, a następnie włącz debugowanie skryptu JavaScript przy ponownym uruchomieniu programu Acrobat.

Aby uruchomić debugger, wybierz opcję Narzędzia > JavaScript > Debugger.

Zarządzanie skryptami JavaScript dokumentów

Za pomocą okna dialogowego skryptu JavaScript dokumentu można edytować lub usuwać skrypty w bieżącym dokumencie.

Aby otworzyć to okno, wybierz polecenie Narzędzia > JavaScript > Skrypt JavaScript dokumentu.

Edytor JavaScript

Edytor JavaScript umożliwia tworzenie i edytowanie skryptów.

Aby otworzyć edytor, wybierz polecenie Narzędzia > JavaScript > Wszystkie skrypty JavaScript.

Operacje na dokumencie i skrypty JavaScript

Można przypisywać konkretny kod JavaScript do określonej operacji na dokumencie. Uruchomienie operacji powoduje wykonanie skryptu.

Aby otworzyć okno dialogowe Operacje na dokumencie, wybierz opcję Narzędzia > JavaScript > Operacje na dokumencie.

Wybierz operację i kliknij przycisk Edytuj, aby dodać skrypt do operacji.

Dostosowywanie plików PDF za pomocą skryptów JavaScript

Jest to jeden z najprostszych i najbardziej wydajnych sposobów dostosowywania plików PDF za pomocą skryptów JavaScript. W oparciu o język JavaScript w wersji 1.5 według ISO-16262 (dawniej znany jako ECMAScript) skrypt JavaScript w programie Adobe Acrobat implementuje obiekty, metody i właściwości, które pozwalają na modyfikowanie plików PDF, tworzenie plików PDF w oparciu o bazy danych, modyfikowanie wyglądu plików PDF i wiele więcej. Można przypisać kod JavaScript programu Acrobat do konkretnego dokumentu PDF, strony, pola lub przycisku wewnątrz tego dokumentu; pola lub przycisku w pliku PDF, a nawet do działań użytkowników.

Skrypt JavaScript wspomaga pracę formularzy XML. Skrypt JavaScript umożliwia automatyczną obsługę formularzy, komunikację z siecią i bazami danych, wstawianie komentarzy i obsługę funkcji interfejsu użytkownika. Pliki PDF utworzone za pomocą aplikacji Acrobat i Adobe LiveCycle umożliwiają przesyłanie danych, które mają być wyodrębnione w niestandardowych schematach jako XML. Aplikacjenapisanew języku Java i innych językach łatwo integrują program Acrobat z usługami sieciowymi korzystającymi z protokołu SOAP (Simple Object Access Protocol).

Więcej informacji można znaleźć w artykule Tworzenie aplikacji programu Acrobat przy użyciu języka JavaScript.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online