Создание экземпляров

После символа его экземпляры могут быть созданы в любом месте документа, в том числе внутри других символов. При изменении символа Animate (ранее Flash Professional CC) обновляет все его экземпляры.

Имена экземпляров задаются в инспекторе свойств. По имени экземпляра производится обращение к нему из сценариев ActionScript. Чтобы управлять экземплярами с помощью ActionScript®, каждый из них должен иметь уникальное имя в пределах данной временной шкалы. 

Инспектор свойств позволяет задать цветовые эффекты, назначить действия, настроить графический режим отображения на экране и изменить поведение новых экземпляров. Экземпляр наследует поведение символа, если не указано иное. Любые внесенные изменения влияют только на экземпляр, но не отражаются на символе.

Создание экземпляра символа

  1. Выберите слой на временной шкале. Animate может помещать экземпляры только в ключевые кадры и всегда на активный слой. Если выбран не ключевой кадр, то Animate добавит экземпляр в первый ключевой кадр слева от текущего.

    Примечание.

    Ключевым кадром называется кадр, в котором определено изменение анимации. Дополнительные сведения см. в разделе «Добавление кадров во временную шкалу».

  2. Выберите меню «Окно» > «Библиотека».

  3. Перетащите символ из библиотеки в рабочую область.

  4. Если создан экземпляр графического символа, то выберите меню «Вставка» > «Временная шкала» > «Кадр», чтобы ввести число кадров, которые будут содержать графический символ.

Назначение имени экземпляру

  1. Выделите экземпляр в рабочей области.

  2. Выберите меню «Окно» > «Свойства» и введите имя в поле «Имя экземпляра».

Редактирование свойств экземпляра

Каждый экземпляр символа имеет собственные свойства, существующие отдельно от символа. Для него можно изменить оттенок цвета, прозрачность и яркость, переопределить поведение (например, заменить графику на фрагмент ролика), а также указать, каким образом воспроизводится анимация внутри графического экземпляра. Экземпляр можно также наклонять, вращать и масштабировать, это никак не отражается на символе.

Кроме того, экземпляру фрагмента ролика или кнопки может быть дано имя, что позволит использовать сценарии ActionScript, чтобы изменять его свойства. Дополнительные сведения см. в разделе Объекты и классы в руководстве Изучение ActionScript 3.0. Редактирование свойств экземпляра производится в инспекторе свойств (меню «Окно» > «Свойства»).

Свойства экземпляра сохраняются вместе с ним. После редактирования символа или привязки экземпляра к другому символу все измененные свойства экземпляра по-прежнему применяются к экземпляру.

Настройка видимости экземпляра

Чтобы сделать невидимым экземпляр символа в рабочей области, отключите свойство «Видимый». При использовании свойства «Видимый» визуализация символа выполняется быстрее, чем при использовании свойства альфа-канала со значением 0.

При использовании свойства «Видимый» необходимо выбрать проигрыватель Flash Player 10.2 или более поздней версии. Оно поддерживается только для экземпляров фрагментов роликов, кнопок и компонентов.

  1. Выделите экземпляр в рабочей области.

  2. В разделе «Отображение» панели «Свойства» снимите флажок рядом со свойством «Видимый».

Изменение цвета и прозрачности экземпляра

Каждый экземпляр символа может иметь свой собственный цветовой эффект. Инспектор свойств позволяет задать параметры цвета и прозрачности экземпляров. Настройки в инспекторе свойств влияют также на растровые изображения, размещенные в символах.

При изменении цвета и прозрачности экземпляра в определенном кадре Animate вносит изменения немедленно по мере отображения данного кадра. Для постепенных изменений цвета применяется анимация движения. При tween-анимации цвета в начальном и конечном ключевых кадрах экземпляра вводятся различные параметры эффекта, а затем задаются промежуточные настройки, позволяющие постепенно смещать цвета.

sy_tint_tween
sy_alpha_tween
Tween-анимация цвета постепенно изменяет цвет и прозрачность экземпляра.

Примечание.

Если применить цветовой эффект к символу фрагмента ролика, состоящего из множества кадров, то Animate применяет эффект к каждому из кадров.

  1. Выделите экземпляр в рабочей области и выберите меню «Окно» > «Свойства».
  2. В инспекторе свойств выберите один из следующих вариантов в меню «Стиль» раздела «Цветовой эффект».

    Яркость

    Регулирует, насколько светлым или темным является изображение по шкале от черного (–100%) до белого (100%). Чтобы настроить яркость, щелкните треугольник и перетащите ползунок либо введите значение в поле.

    Тон

    Окрашивает экземпляр одним цветовым тоном. Чтобы задать значение тона в процентах от прозрачного (0%) до полностью насыщенного (100%), воспользуйтесь ползунком «Тон» в инспекторе свойств. Для настройки тона щелкните треугольник и перетащите ползунок либо введите значение в поле. Чтобы выбрать цвет, введите значения красного, зеленого и синего в соответствующих полях либо щелкните элемент управления цветом и выберите цвет из палитры цветов.

    Альфа-канал

    Регулирует прозрачность экземпляра, от прозрачного (0%) до полностью насыщенного (100%). Чтобы настроить значение «Альфа», щелкните треугольник и перетащите ползунок или введите значение в поле.

    Дополнительно

    Отдельно настраивает значения красного, зеленого и синего цветов, а также прозрачности экземпляра. Наиболее полезен при создании и анимации тонких цветовых эффектов в растровых изображениях. Элементы управления слева позволяют уменьшить значения цвета или прозрачности, указав их величины в процентах. Элементы управления справа позволяют уменьшить или увеличить значения цвета или прозрачности на постоянную величину.

    Текущие значения красного, зеленого, синего и альфа-канала умножаются на процентные величины, а затем складываются с постоянными значениями в правом столбце, образуя в результате новые цветовые значения. Например, если текущее значение красного равно 100, то перемещение левого ползунка в положение 50%, а правого ползунка в положение 100% дает новое значение красного цвета 150 ([100 x .5] + 100 = 150).

    Примечание. Дополнительные настройки в меню панели рассчитываются по формуле (a * y+ b)= x, где a — процентные показатели, заданные в левом наборе полей, y — цвет исходного растрового изображения, b — значение, заданное в правом наборе полей, а x — результирующий эффект (от 0 до 255 для RGB и от 0 до 100 для альфа-прозрачности).

    Цвет экземпляра можно изменить и с использованием объекта ColorTransform ActionScript. Дополнительные сведения об объекте Color см. в разделе «ColorTransform» руководства Справочник ActionScript® 2.0 для Adobe® Flash® Professional CS5 или Справочник ActionScript® 3.0 для Adobe® Flash® Professional CS5.

Замена одного экземпляра другим

Чтобы отобразить различные экземпляры в рабочей области и сохранить цветовые эффекты, действия кнопок и все остальные свойства исходного экземпляра, назначьте экземпляру другой символ.

Предположим, было начато создание комикса, персонажем которого была крыса, а затем решено было заменить ее на кошку. После замены символа крысы символом кошки обновленный символ во всех кадрах появится примерно в тех же местах.

Назначение экземпляру другого символа

  1. Выделите экземпляр в рабочей области и выберите меню «Окно» > «Свойства».

  2. В инспекторе свойств нажмите кнопку «Заменить».

  3. Выберите символ для замены того символа, который в настоящий момент назначен экземпляру. Чтобы создать дубликат выделенного символа, нажмите кнопку «Дублировать символ», а затем кнопку «ОК».

    Дублирование позволяет создать новый символ на основе существующего и до минимума снижает необходимость копирования при подготовке нескольких символов, имеющих небольшие различия.

Замена всех экземпляров символа

  1. Перетащите из одной панели «Библиотека» на панель «Библиотека» редактируемого FLA-файла символ с тем же именем, что и у заменяемого, а затем нажмите кнопку «Заменить». Если в библиотеке есть папки, то новый символ необходимо перетаскивать в ту же папку, где находится заменяемый символ.

Изменение типа экземпляра

Чтобы переопределить поведение экземпляра в приложении Animate, смените его тип. Например, если в графическом экземпляре содержится анимация, которая должна независимо воспроизводиться в основной временной шкале, переопределите графический экземпляр как экземпляр фрагмента ролика.

  1. Выделите экземпляр в рабочей области и выберите меню «Окно» > «Свойства».
  2. В инспекторе свойств выберите в меню пункт «Графика», «Кнопка» или «Фрагмент ролика».

Задание цикла для графического экземпляра

Чтобы в приложении Animate определить способ воспроизведения последовательностей анимации внутри графического экземпляра, задайте параметры в инспекторе свойств.

Анимированный графический символ привязан к временной шкале документа, в которой он находится. В отличие от него символ фрагмента ролика имеет собственную независимую временную шкалу. Анимированные графические символы отображают анимацию в режиме редактирования документа, так как пользуются той же временной шкалой, что и основной документ. Символ фрагмента ролика отображается в рабочей области как статический объект и его анимация в среде редактирования Animate не видна.

  1. Выделите графический экземпляр в рабочей области и выберите меню «Окно» > «Свойства».
  2. Выберите вариант анимации в меню «Параметры» раздела «Циклы» в инспекторе свойств.

    Цикл

    Зацикливает все последовательности анимации в текущем экземпляре на число кадров, занимаемое экземпляром.

    Воспроизвести один раз

    Воспроизводит последовательность анимации от указанного кадра до конца анимации, после чего воспроизведение останавливается.

    Один кадр

    Отображает один кадр последовательности анимации. Указывает кадр для отображения.

  3. Чтобы первый кадр графического символа отображался при зацикливании, введите номер кадра в текстовое поле «Первый». Параметр «Один кадр» также использует задаваемый здесь номер.

Выбор кадров

Функция выбора кадра помогает выполнить визуальный предпросмотр и выбрать первый кадр для графического символа. В предыдущих выпусках был доступен только предварительный просмотр кадров без доступа к символу в режиме Редактирование. Эта функция упрощает использование таких рабочих процессов анимации, как синхронизация речи.

Примечание.

Панель «Выбор кадров» работает только с графическими символами, она отключается для символов типа «Фрагмент ролика» или «Кнопка». Прежде чем работать с этой функцией, обязательно преобразуйте ресурсы в символы.

  1. Выберите Графический символ > Панель «Свойства» > Цикл > Использовать панель «Выбор кадров » для отображения панели «Выбор кадров» или выберите Окно > Выбор кадров

    Frame Picker_ PI
    Выбор кадров

  2. На панели «Выбор кадров» выберите вид «Список» или «Миниатюры» для предварительного просмотра всех кадров выбранного графического символа. Также можно просматривать номера и метки кадров. 

    Список: отображает кадры в виде вертикального списка. 

    Миниатюра: отображает кадры в виде таблицы, которая подстраивается при изменении размера панели. 

    Создать ключевой кадр: этот параметр позволяет автоматически создавать ключевой кадр при выборе позы на панели «Выбор кадров». 

    Цикл: отображаются различные параметры цикла для графики, включая «Цикл», «Воспроизвести один раз» и «Один кадр». 

    Стрелка ползунка: корректирует размер области предварительного просмотра

    Левая кнопка ползунка: помещает больше кадров в области просмотра

    Правая кнопка ползунка: уменьшает количество кадров в области просмотра

    Раскрывающийся список «Фильтр параметров кадра»: показывает различные параметры фильтра кадров

    list
    Просмотр в виде списка

    thumnail
    Вид «Миниатюры»


  3. Используйте кнопки Ползунок или Масштаб для регулировки размера окна предпросмотра или миниатюры. Для одновременного просмотра большего числа миниатюр перетащите ползунок в крайний левый угол панели. Если перетащить ползунок до правого угла, миниатюры будут более крупные.

  4. Щелкните любой кадр, чтобы сделать его первым для выбранного символа.

Создать ключевой кадр

На панели «Выбор кадров» есть флажок «Создать ключевой кадр», который позволяет автоматически создавать ключевые кадры при выборе кадра на панели «Выбор кадров». На панели «Выбор кадров» также можно настроить параметр цикла для графических символов.

Чтобы вызывать панель «Выбор кадров», выберите Графический символ > Панель «Свойства» > Цикл > Использовать панель «Выбор кадров» для отображения панели «Выбор кадров» или выберите Окно > Выбор кадров.

CreateKeyframe

Параметры фильтрации для кадров

Animate предоставляет параметры фильтрации для кадров, перечисленных на панели. Могут быть выбраны следующие варианты: 

  • Все кадры — показывает все кадры.
  • Ключевые кадры — показывает только выбранные вами ключевые кадры.
  • Метки — показывает только кадры с метками.
filterOptions

Автоматическая синхронизация речи

Автоматическая синхронизация речи позволяет проще и быстрее помещать подходящие формы рта на временную шкалу с учетом выбранного аудиослоя. Вы можете выполнить эту задачу с помощью существующего списка поз рта, которые рисуются внутри графического символа. Когда автоматическая синхронизация речи применяется к графическому символу, после анализа выбранного аудиослоя автоматически создаются ключевые кадры в разных позициях в соответствии с аудиовиземами. По завершении можно вносить дальнейшие необходимые корректировки, используя обычные рабочие процессы и панель «Выбор кадров».

Визема — это типовое изображение лица, которое можно использовать для обозначения звука. 

Создание синхронизации речи

Выполните перечисленные ниже действия, чтобы приступить к созданию синхронизации речи.:

  1. Создайте графический символ (поза рта).

    Внутри графического символа можно нарисовать все позы рта или виземы.

  2. На главной временной шкале импортируйте аудио в новый слой.

    Примечание.

    Автоматическая синхронизация губ лучше всего работает с параметром «Синхронизация звука», имеющим значение Поток.

    Пример символа с аудиослоем.
    Пример символа с аудиослоем.
  3. Выберите рот (графический символ). В инспекторе свойств нажмите кнопку Cинхронизация речи.

    «Синхронизация речи» в инспекторе свойств
    «Синхронизация речи» в инспекторе свойств

    Откроется диалоговое окно «Создание синхронизации речи». По умолчанию отображается 12 базовых типов визем (см. снимок экрана ниже). 

    Создание синхронизации речи.
    Создание синхронизации речи.
  4. Щелкните любую визему, чтобы изменить сопоставленную позу рта. Появится всплывающее окно со всеми позами в графическом символе. Выберите подходящий кадр и задайте его для текущей виземы.

    Изменение позы рта для каждой виземы
    Изменение позы рта для каждой виземы
  5. Выберите аудиослой, для которого требуется синхронизация речи. Нажмите кнопку Синхронизировать.

    Снимок экрана временной шкалы после применения синхронизации речи.
    Снимок экрана временной шкалы после применения синхронизации речи.

    Примечание.

    Автоматическая синхронизация речи применяется к диапазону кадров, где есть выбранный графический символ. Вы можете также сначала выбрать несколько ключевых кадров, чтобы применить синхронизацию речи к выбранному диапазону кадров.

  6. Нажмите Ctrl+Enter, чтобы запустить файл и предварительно просмотреть вывод.

    Можно просмотреть анимированный файл с автоматически созданными движениями рта, синхронизированными с аудиофайлом.

Разбивка экземпляра символа

Чтобы разорвать связь между экземпляром и символом, превратив экземпляр в набор несгруппированных фигур и линий, нужно произвести разбивку экземпляра. Эта функция полезна в тех случаях, когда необходимо существенно переработать экземпляр, не затрагивая при этом другие экземпляры. 

Изменения исходного символа экземпляра не влияют на экземпляр после его разбиения.

  1. Выделите экземпляр в рабочей области.
  2. Выберите «Модификация» > «Разделить». Эта операция разбивает экземпляр на составляющие графические элементы.
  3. Для изменения этих элементов пользуйтесь инструментами рисования и раскраски.

Получение информации об экземплярах в рабочей области

В инспекторе свойств и панели «Информация» отображаются следующие данные об экземплярах, выделенных в рабочей области.

  • Инспектор свойств позволяет просмотреть поведения и параметры экземпляра: параметры цветовых эффектов, расположение и размер (для экземпляров всех типов), режим повтора и первый кадр, который содержит изображения (для графики), имя экземпляра (если оно задано) и режим отслеживания (для кнопок), имя экземпляра (если назначено) для фрагментов ролика. В качестве местоположения инспектор свойств приводит координаты x и y точки регистрации символа.

  • Панель «Информация» позволяет просмотреть размер и расположение экземпляра, местоположение его точки регистрации, значения красного (R), зеленого (G), синего (B) цветов и альфа-канала (A) (если экземпляр имеет сплошную заливку), а также позицию указателя. В разделе «Положение и размер» Инспектора свойств отображаются координаты x и y точки регистрации или точки трансформации символа. Используйте переключатель для просмотра координат точки регистрации или точки трансформации.

  • В обзоре ролика доступно для просмотра содержимое текущего документа, в том числе экземпляры и символы.

    На панели «Действия» можно просмотреть любые действия, назначенные для кнопки или фрагмента ролика.

Получение информации об экземпляре

  1. Выделите экземпляр в рабочей области.

  2. Отобразите инспектор свойств (меню «Окно» > «Свойства») или необходимую панель.

    • Чтобы отобразить панель «Информация», выберите меню «Окно» > «Информация».

    • Чтобы отобразить панель «Обзор ролика», выберите меню «Окно» > «Обзор ролика».

    • Чтобы отобразить панель «Действия», выберите меню «Окно» > «Действия».

Просмотр определения выделенного символа на панели «Обзор ролика»

  1. Нажмите кнопки «Показать фрагменты ролика, кнопки и графику» в верхней части панели «Обзор ролика».

  2. Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), и выберите «Показать экземпляры символа» и «Перейти к определению символа» либо выберите эти параметры из меню в верхнем правом углу панели «Обзор ролика».

Переход к монтажному кадру, содержащему экземпляры выделенного символа

  1. Отобразите определения символов.

  2. Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), и выберите пункт «Показать элементы ролика» и «Перейти к определению символа» либо выберите эти параметры из меню в верхнем правом углу панели «Обзор ролика».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет