Примечание.

В Photoshop CS6 функциональные возможности, связанные с MATLAB, были доступны в Photoshop Extended. Все возможности прежнего выпуска Photoshop Extended теперь доступны в Photoshop CC. Photoshop CC не имеет специальной версии Extended.

О совместном использовании Photoshop и MATLAB

MATLAB является интерактивной средой для разработки алгоритмов, рендеринга и анализа данных, а также для численных расчетов с помощью высокоуровневого специализированного языка технических расчетов. С помощью Photoshop можно просматривать в Photoshop результаты обработки изображений с помощью MATLAB, а также объединять команды MATLAB с возможностями Photoshop по редактированию изображений.

После установления связи между Photoshop и MATLAB в командной строке MATLAB можно будет вводить команды, которые будут выполняться в Photoshop. В Photoshop можно также выполнять алгоритмы MATLAB и просматривать результаты их применения к изображениям.

Примечание.

Для обмена данными между Photoshop и MATLAB используется интерфейс Photoshop JavaScript и библиотечный интерфейс MATLAB.

Настройка MATLAB и Photoshop

Установите на компьютер Photoshop и MATLAB. После установки Photoshop и MATLAB необходимо проверить интеграцию MATLAB.

Для 64-разрядных систем установите соответствующий компилятор

Чтобы использовать интерфейс Photoshop в 64-разрядной системе, должен быть установлен компилятор языка C.

  • В Windows установите Microsoft Developer Studio.

  • В Mac OS установите XCode.

Дополнительные сведения см. в файле «MATLAB Photoshop Read Me» в папке приложения Photoshop.

Примечание.

В ОС Windows используйте 64-разрядную версию Photoshop с 64-разрядной MATLAB или 32-разрядную версию Photoshop с 32-разрядной MATLAB.

Проверка интеграции MATLAB

  1. Запустите Photoshop, а затем MATLAB.

  2. Из окна программы MATLAB добавьте путь Photoshop/MATLAB, включая вложенные папки.
  3. При появлении диалогового окна MATLAB откройте папку MATLAB, найдите и откройте папку Tests, затем введите команду testall.
  4. Программы Photoshop и MATLAB выполнят ряд проверок для гарантии интеграции между собой, после чего отобразится итоговый отчет.

Настройка доступа к Photoshop из MATLAB (необязательно)

Для обеспечения прямого доступа из MATLAB к командам Photoshop можно задать путь к Photoshop.

  1. В программе MATLAB выберите пункт меню «Файл» > «Задать путь».
  2. Нажмите кнопку «Добавить папку» и выберите папку MATLAB, в которую установлена программа Photoshop.

  3. Нажмите кнопку «Сохранить», затем кнопку «Закрыть».
  4. В меню программы MATLAB выберите «Файл» > «Установки».
  5. В диалоговом окне «Установки» щелкните «Основное дерево» (вверху слева).
  6. Нажмите кнопку «Обновить кэш пути к палитре инструментов».
  7. Нажмите кнопку «Применить», затем кнопку «ОК».

Установление или разрыв соединения с Photoshop из MATLAB

  1. В программе MATLAB выполните одно из следующих действий.
    • Чтобы запустить Photoshop или установить с ним соединение, введите команду pslaunch, затем нажмите клавишу «Ввод» (Windows) или «Return» (Mac OS).

    • Чтобы отключиться от Photoshop и закрыть его, введите команду psquit, затем нажмите клавишу «Ввод» (Windows) или Return (Mac OS).

Использование справочной системы MATLAB

Справочная система MATLAB содержит примеры рабочих процессов MATLAB и Photoshop.

  1. Выберите пункт меню «Справка» > «Полное семейство продуктов».

    Отобразится палитра инструментов Photoshop с элементами вложенных меню, содержащих примеры для начала работы. Если палитра инструментов Photoshop не отображается, попробуйте выполнить следующие действия.

  2. Нажмите кнопку «Пуск».
  3. Выберите «Инструменты рабочего стола» > «Просмотр исходных файлов».
  4. Последовательно нажмите кнопку «Обновить», кнопку «Закрыть», а затем повторно выберите меню «Справка».

Команды MATLAB

Ввод команд в командной строке MATLAB позволяет устанавливать и разрывать соединение с программой Photoshop, а также генерировать видимые пикселы в документах Photoshop.

Для получения сведений о полном списке команд MATLAB Photoshop просмотрите файл psfunctionscat.html, находящийся в папке «MATLAB» каталога, в который установлен Photoshop. Чтобы получить полное описание необходимой команды, включая синтаксис, аргументы и примеры применения команды, введите команду help (имя команды) в командной строке MATLAB.

Примечание.

Все команды MATLAB поддерживают японскую азбуку. Версия MATLAB для Windows поддерживает интерфейс пользователя на японском языке в японских версиях операционной системы Windows XP. MATLAB для Mac OS поддерживает американский английский только в системах Mac OS с интерфейсом на японском языке. За дополнительными сведениями обратитесь в компанию MathWorks Inc.

Создание документа в MATLAB

  1. В MATLAB введите команду psnewdoc.
  2. Для определения атрибутов нового документа выполните одно из следующих действий.
    • Для создания нового документа, используя значения по умолчанию, введите psnewdoc(). Дополнительные сведения о значениях по умолчанию см. далее.

    • Для создания нового документа с определенной шириной и высотой введите psnewdoc(W,H). Значения «W» и «H» используют текущие единицы измерения, установленные для параметра «Единицы измерения и линейки» в диалоговом окне «Установки». Остальные атрибуты документа устанавливаются в значения по умолчанию.

    Примечание.

    Введите «undefined» для пропуска входных аргументов. Размер нового документа по умолчанию равен 504 x 360 пикселей.  

    • Для создания нового документа с конкретными атрибутами введите psnewdoc(W,H,R,N,M,F,A,B,P). Дополнительные сведения об атрибутах нового документа см. далее.

    Здесь приведен пример кода для создания нового документа и определения всех его атрибутов в программе MATLAB.

    psnewdoc(10, 10, 72, 'hi', 'cmyk', 'transparent', 2.5, 16, 'U.S. Web Coated (SWOP) v2')

Атрибуты нового документа и их значения по умолчанию

При вводе команды psnewdoc(W,H,R,N,M,F,A,B,P) создается новый документ со значениями для следующих атрибутов.

W

Задает ширину документа, используя текущие установки единиц измерения для параметра «Единицы измерения и линейки» диалогового окна «Установки». По умолчанию ширина равна 504 пиксела.

H

Задает высоту документа, используя текущие установки единиц измерения для параметра «Единицы измерения и линейки» диалогового окна «Установки». По умолчанию высота равна 360 пикселов.

R

Задает разрешение изображения. Значение по умолчанию равно 72 пикс/дюйм.

N

Задает название документа. Название документа по умолчанию имеет вид «Untitled‑X», где X — номер нового документа.

М

Задает цветовой режим: RGB, CMYK, Lab, битовый формат или градации серого. По умолчанию используется режим RGB.

F

Задает содержимое фона нового документа: белый, фоновый цвет или прозрачный. По умолчанию используется белый фон.

A

Задает пиксельное форматное соотношение. Значение по умолчанию равно 1,0 (квадрат).

B

Задает битовую глубину цвета: 1, 8, 16 или 32. По умолчанию используется значение 8.

P

Задает цветовой профиль. По умолчанию используется рабочее цветовое пространство для заданного цветового режима. Рабочие пространства задаются в диалоговом окне «Настройка цветов» программы Photoshop.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет