Görüntüleri ve grafikleri dışa aktarma

PNG dizisi

Bir görüntü dosyası serisini, Kütüphane'deki veya Sahne Alanı'ndaki tek bir film klibi, düğme ya da grafik sembolünden dışa aktarabilirsiniz. Animate CC (eski Flash Professional CC), dışa aktarma işlemi sırasında sembol içindeki her bir kare için ayrı bir görüntü dosyası oluşturur. Sahne Alanı'ndan dışa aktarırsanız, sembol örneğine uyguladığınız tüm dönüştürmeler (örneğin, ölçekleme) görüntü çıktısında korunur.

Bir PNG dizisini dışa aktarmak için:

  1. Kütüphane'de veya Sahne Alanı'nda tek bir film klibi, düğme veya grafik sembolü belirleyin.

  2. Seçtiğiniz öğeyi sağ tıklatın ve PNG Sırasını Dışa Aktar'ı seçin.

    select-png-sequence
  3. Farklı Kaydet iletişim kutusunda, çıktı için bir konum seçin ve Tamam'ı tıklatın.

     

  4. PNG Sırasını Dışa Aktar iletişim kutusunda istediğiniz seçenekleri belirleyin. 

    export-pngsequence

    Genişlik - Görüntü çıktısının genişliğidir. Bu değeri değiştirerek çıktıyı ölçeklendirebilirsiniz. Varsayılan, sembol içeriğinin genişliğidir.

    Yükseklik - Görüntü çıktısının yüksekliğidir. Bu değeri değiştirerek çıktıyı ölçeklendirebilirsiniz. Varsayılan, sembol içeriğinin yüksekliğidir.

    Çözünürlük - Görüntü çıktısının çözünürlüğüdür. Varsayılan 72 dpi'dir.

    Renkler - Görüntü çıktısının bit derinliğidir. 8, 24 veya 32 bit olarak belirleyebilirsiniz. Varsayılan, saydamlığı destekleyen 32 bit değeridir. Saydamlığı desteklemeyen 24 bit veya 8 bit değerini seçerseniz, Arka Plan ayarı Sahne Alanı olarak değişir. Aşağıya bakın.

    Arka Plan - Görüntü çıktısı için arka plan rengi olarak kullanılacak renktir. Bu ayar yalnızca Renkler seçeneği 8 veya 24 bit olarak ayarlandığında kullanılabilir. Renkler seçeneği 32 bit olarak ayarlandığında görüntü arka planı her zaman saydam olur. Renkler seçeneği 8 bit veya 24 bit olarak ayarlandığında Arka Plan seçeneği varsayılan olarak Sahne Alanı rengi olur. 8 bit veya 24 bit görüntülerle ayarı Opak olarak değiştirebilir ve sonra renk seçiciden bir arka plan rengi seçebilirsiniz. Alternatif olarak, saydamlık oluşturmak üzere arka plan için bir alfa değeri seçin.

    Düzgünleştir - Görüntü çıktısının kenarlarına düzgünleştirme uygulama özelliğini açar veya kapatır. Saydam bir arka plan kullanmıyorsanız ve bir arka plan rengine yerleştirilen görüntüler, Sahne Alanı'nın geçerli renginden farklıysa bu seçeneği kapatın.

  5. PNG sırasını dışa aktarmak için Dışa Aktar seçeneğini tıklatın.

Animasyonlu GIF'i dışa aktarma

Aşağıdaki adımları uygulayarak Animate'te animasyonlu GIF dosyalarını dışa aktarabilirsiniz: 

  1. Dosya > Dışa Aktar > Animasyonlu GIF'i Dışa Aktar seçeneklerini belirleyin

    Bir iletişim kutusu görünür. 

    export-animated-gif
  2. İletişim kutusunda istediğiniz seçenekleri belirleyin ve animasyonunuzu animasyonlu GIF dosyası olarak dışa aktarmak için Bitti'yi tıklatın. 

    animated-gif-dialog

    Ayrıca, Dosya > Dışa Aktar > Görüntüyü Dışa Aktar seçeneklerini belirleyerek hareketsiz GIF görüntü dosyasını da dışa aktarabilirsiniz.

Görüntüleri ve grafikleri CC kitaplığına dışa aktarma

Görüntülerinizi veya grafiklerinizi CC kitaplığına dışa aktarmak için Pencere > CC kitaplığı seçeneklerini belirleyin

CC Libraries penceresi görünür. 

add-to-cc-library

CC Libraries penceresinin sol alt köşesindeki + simgesini tıklatın ve görüntüleri veya grafik dosyalarını seçerek Ekle'yi tıklatın.

FXG grafik değişim biçimi (Animate CC'de kaldırılmıştır)

FXG dosyaları hakkında

FXG biçimi, Animate/Flash Platformu için bir grafik değişim dosya biçimidir. FXG, Flex çerçevesi tarafından kullanılan XML-tabanlı programlama dili olan MXML'in bir alt kümesine dayalıdır. FXG formatı, tasarımcıların ve geliştiricilerin aslına uygunluğu yüksek olan grafik içeriği değişimi yapmalarına izin vererek daha verimli bir şekilde iş birliği yapmalarına yardımcı olur. Tasarımcılar Adobe tasarım araçlarını kullanarak grafik oluşturabilir ve bunları FXG formatı şeklinde dışa aktarabilir. Daha sonra FXG dosyasını zengin bir İnternet deneyimi yaşamak ve uygulamaları geliştirmek için Adobe Flash Builder ve Adobe Flash Catalyst gibi araçlarda kullanabilirsiniz.

Bir FXG dosyası oluştururken, vektörel grafikler doğrudan dosyanın içinde saklanır. FXG'de karşılık gelen etiketleri olmayan öğeler, o anda FXG dosyasında başvurulan bitmap grafikleri olarak dışa aktarılır. Bunlar bitmap'leri, bazı filtreleri, bazı karışım modlarını, degradeleri, maskeleri ve 3B'yi içerir. Bu efektlerden bazıları FXG olarak dışa aktarılabilir, ancak FXG dosyasını açan uygulama tarafından içe aktarılamaz.

FXG dışa aktarmayı kullanarak vektör veya bitmap görüntülerini içeren bir dosyayı dışa aktardığınızda, FXG dosyasıyla beraber ayrı bir klasör oluşturulur. Bu klasör <filename.assets> adına sahiptir ve FXG dosyasıyla ilişkilendirilmiş bitmap görüntülerini içerir.

FXG dosya biçimi ile ilgili daha fazla bilgi için bkz. FXG 2.0 Belirtimi.

FXG dışa aktarma sınırlamaları

Animate, FXG'ye dışa aktarma için sahne alanındaki nesneleri tek veya çoklu seçme imkanı verir. FXG biçimine dışa aktarılırken nesne ve katman adları korunur.

Aşağıdaki öğeler FXG dosyasına kaydedilirken sınırlanır:

  • Ölçek-9 ızgaraları: dışa aktarılır ancak yalnızca Adobe Illustrator tarafından okunabilir.

  • Ses ve video: dışa aktarılmaz.

  • Bileşenler: dışa aktarılmaz.

  • Ara doldurma ve çoklu kareli animasyonlar: dışa aktarılmaz ancak seçili bir kare statik nesne olarak dışa aktarılır.

  • Gömülü fontlar: dışa aktarılmaz.

  • Düğme sembolleri: Animate, düğmelerin yalnızca Yukarı durumlarını dışa aktarır.

  • 3B özellikleri: dışa aktarılmaz.

  • Ters Kinematik (TK) özellikleri: dışa aktarılmaz.

  • Metin nitelikleri: bazı nitelikler dışa aktarılmayabilir.

Animate içeriğini FXG biçiminde dışa aktarma

Animate'te içeriği FXG biçiminde aktarmanın iki yolu bulunur:

  • Nesneleri Sahne Alanı'ndan FXG olarak dışa aktarmak için, nesneleri seçin ve Dışa Aktar > Seçimi Dışa Aktar'ı seçin. Ardından Dosya Türü menüsünden FXG biçimini seçin.

  • Tüm Sahne Alanı'nı FXG olarak kaydetmek için, Dışa Aktar > Görüntüyü Dışa Aktar'ı, ardından da Dosya Türü menüsünden Adobe FXG'yi seçin.

JPEG Dizisi ve JPEG Görüntüsü

Bu seçenekler, JPEG Yayınlama Ayarları seçenekleriyle eşleşir. Ancak, Ekrana Eşleştir seçeneği, ekranınızda görüntülendikçe, dışa aktarılan görüntüyü Animate içeriğinin boyutuyla eşleştirir. Filme Eşleştir, JPEG görüntüsünü Animate içeriğiyle eşleştirir ve orijinal görüntünün en boy oranını korur.

PNG Sırası ve PNG Görüntüsü

PNG dışa aktarma ayarları seçenekleri, şu istisnalar dışında PNG Yayınlama Ayarları seçeneklerine (sizin de uygulayabileceğiniz) benzer:

Boyutlar

Dışa aktarılan bitmap görüntüsünün boyutunu Genişlik ve Yükseklik alanlarına girdiğiniz piksel sayısına göre ayarlar.

Çözünürlük

Dpi biriminde bir çözünürlük girin. Ekran çözünürlüğünü kullanmak ve orijinal görüntünüzün en boy oranını korumak için Ekrana Eşleştir'i seçin.

Renkler

PNG Yayınlama Ayarları sekmesindeki Bit Derinliği seçeneğinin aynısıdır. Görüntüyü oluştururken kullanılacak piksel başına bit sayısını ayarlar. 256 renklik bir görüntü için 8 bit'i seçin; binlerce renk için 24‑bpc'yi seçin; saydamlık içeren binlerce renk (32 bpc) için 24‑bpc, Alfa ile seçeneğini belirleyin. Bit derinliği ne kadar yüksekse, dosya o kadar büyük olur.

Dahil Et

Minimum görüntü alanını dışa aktarmayı seçin veya tam belge boyutunu belirtin.

Not:

Dışa aktarılan GIF boyutları, maksimum 4000 piksel ile sınırlıdır. Boyutlardaki bu sınırlama, CS6'dan sonraki sürümleri için geçerlidir.

Not:

Düz Renkleri Taklit Et seçeneği, 256 Renk seçeneği belirlenmediyse çalışmaz. Bu, seçili GIF renk şemasının 256 renk olmaması durumunda GIF görüntüsünün taklit edilmeyeceği anlamına gelir.

(Animate CC'de kaldırılmıştır) Bitmap (BMP) görüntüsü

Başka uygulamalarda kullanmak için bitmap görüntüleri oluşturun. Dışa Aktar Bitmap iletişim kutusu şu seçenekleri içerir:

Boyutlar

Dışa aktarılan bitmap görüntüsünün boyutunu piksel biriminde ayarlar. Belirttiğiniz boyut her zaman orijinal görüntünüzle aynı en boy oranına sahiptir.

Çözünürlük

Dışa aktarılan bitmap görüntüsünün çözünürlüğünü nokta/inç (dpi) biriminde ayarlar ve çiziminizin boyutuna bağlı olarak genişlik ve yüksekliği otomatik olarak hesaplar. Monitörünüzle eşleştirmek üzere çözünürlüğü ayarlamak için Ekrana Eşleştir'i seçin.

Renk Derinliği

Görüntünün bit derinliğini belirtir. Bazı Windows uygulamaları, bitmap görüntüleri için daha yeni olan 32 bit/kanal (bpc) derinliğini desteklemez. 32 bpc biçimini kullanmada sorun yaşarsanız, 24 bpc biçimini kullanın.

Düzgünleştir

Dışa aktarılan bitmap'e kenar yumuşatma uygular. Kenar yumuşatma daha yüksek kalitede bir bitmap görüntüsü üretir ancak renkli bir arka plan üzerine yerleştirilmiş bir görüntünün etrafında gri piksellerden meydana gelen bir hale oluşturabilir. Bir hale görünürse kenar yumuşatma seçimini kaldırın.

Animate belgesi (SWF)

Animate içeriğini Dreamweaver gibi başka bir uygulamanın içine yerleştirmek üzere belgenin tümünü bir SWF dosyası olarak dışa aktarın. Animate, FLA dosyasına yönelik Yayınlama Ayarları'ndaki geçerli ayarları kullanarak SWF dosyasını dışa aktarır.

Adobe Media Encoder ile HD videoları dışa aktarma

Animate CC; araları, sembolleri ve grafikleri çeşitli biçimlerde Yüksek Tanımlı videolara dışa aktarmanıza olanak sağlar. Animate ile dışa aktarılan HD videolar, İletişim özelliği etkin uygulamalarla, görüntülü konferans, akışa alma ve paylaşma için kullanılabilir.

Varsayılan olarak Animate, yalnızca QuickTime Movie (.MOV) dosyalarına dışa aktarabilir. Animate, MOV dosyaları dışa aktarılırken QuickTime kütüphanelerinden yararlandığından, dışa aktarma işlevi en son QuickTime Player sürümünü kurmanızı gerektirir.

Animate şimdi Adobe Media Encoder ile entegre edildiğinden, HD video dışa aktarma iş akışı yeniden modellenmiştir. MOV dosyalarını diğer çeşitli biçimlere dönüştürmenize olanak sağlar. Bu nedenle, Adobe Media Encoder yalnızca Animate içeriği ile ilgili olan dışa aktarma biçimlerini sunacak şekilde optimize edilmiştir. Adobe Media Encoder'ı kullanarak videoları Kodlama ve Dışa Aktarma hakkında daha fazla bilgi için bkz. Video ve sesi kodlama ve dışa aktarma.

Not:

Creative Cloud masaüstü uygulamasından Animate CC'yi yüklediğinizde Adobe Media Encoder otomatik olarak yüklenir.

Önceki ve en yeni video dışa aktarma iş akışları arasındaki farklar

Yeni iş akışı, CS6 ve önceki sürümlerin video dışa aktarma iş akışından farklıdır.

Ana farklılık noktaları şunlardır:

  • Adobe Media Encoder ile entegrasyon: Animate CC, Adobe Media Encoder 7.0 ile entegre edilmiştir; önceki sürümler AME'ye bağlı değildi.
  • Dışa aktarma biçimleri: Animate CC yalnızca QuickTime filmlerini dışa aktarabilir.
  • HD videolar: Animate CC, HD videolar dışa aktarmanıza olanak tanır.

Ayrıca CS6 iş akışı şu sorunları da içeriyordu:

  • QuickTime'ı kullanan MOV dışa aktarma iş akışı hata yapmaya açıktı ve çok fazla bellek kullanıyordu.
  • AVI dışa aktarma işlevi film kliplerini desteklemiyordu.

Animate CC ile kare kaybı sorunu da dahil olmak üzere yukarıda belirtilen sorunlar düzeltilmiştir. Adobe Media Encoder iş akışı sayesinde Animate CC ile sorunsuz bir şekilde MOV dosyalarına dışa aktarabilirsiniz. Yeni AME tabanlı iş akışıyla, Animate içeriğini MOV dosyalarına dışa aktarabilir ve daha sonra MOV dosyalarını istediğiniz çıktı biçimine dönüştürmek için AME'yi kullanabilirsiniz.

Dışa aktarma 2 No'lu Karede başlar

Zaman Çizelgesi yapısına bağlı olarak, dışa aktarılan video şu senaryolardan birinin sonucu olabilir:

  1. Kök zaman çizelgesinde birden fazla kare varsa dışa aktarma 2 no'lu kareden başlar.
  2. Kök zaman çizelgesinde yalnızca bir kare varsa dışa aktarma 1 no'lu kareyi içerir.
  3. Kök zaman çizelgesinde birden fazla kare varsa ve 1 no'lu kareye ActionScript veya ses eklendiyse çağrılmaz.

HD video dışa aktarma

Dışa aktarmayı başlatmadan önce aşağıdakileri yapın:

  • QuickTime'ı yükleyin
  • Kare hızını, 60 fps'ye eşit veya bu değerden küçük bir değere ayarlayın. Daha fazla bilgi için bkz. Animasyon Temelleri.
  1. Bir FLA oluşturun ya da mevcut bir FLA dosyasını açın.

  2. Dosya > Dışa Aktar > Videoyu Dışa Aktar seçeneğine gidin.

    export-video
    Video dışa aktarma iletişim kutusu

  3. Videoyu Dışa Aktar iletişim kutusunda Görüntü Oluşturma Genişliği ve Görüntü Oluşturma YüksekliğiSahne Alanı boyutu için ayarlanan genişlik ve yükseklik değerlerini varsayar.

  4. Video Dışa Aktar iletişim kutusunda istediğiniz seçenekleri belirleyin:

    • Görüntü Oluşturma Boyutu Y ve G: HD video veya normal dışa aktarım yapmak istemenize bağlı olarak, dışa aktarmak istediğiniz çözünürlüğe göre görüntü oluşturma boyutunu yapılandırın. Sırayla Sahne Alanı'nın Genişlik ve Yükseklik değerine eşit olan değerleri ayarlayın. Görüntü Oluşturma Genişliği ve Görüntü Oluşturma Yüksekliği değerlerini değiştirmek istiyorsanız, Sahne Alanı boyutunu uygun şekilde değiştirin. Animate, en boy oranını Sahne Alanı boyutlarına göre korur.
    • Sahne Alanı Rengini Yoksay (alfa kanalı oluştur): Sahne alanı rengini kullanarak bir alfa kanalı oluşturur. Alfa kanalı, saydam bir parça olarak kodlanır. Arka plan rengini veya sahneyi değiştirmek için diğer içeriğin üst kısmını dışa aktarılan QuickTime filmiyle kaplamanıza olanak sağlar.
    • Adobe Media Encoder'da Video Dönüştür: Dışa aktarılan MOV dosyasını, AME kullanarak farklı bir biçime dönüştürmek istiyorsanız bu seçeneği belirleyin. Seçildiyse, Animate videoyu dışa aktarmayı tamamladıktan sonra AME başlatılır.
    • Dışa Aktarılan Video Yolu: Videoyu dışa aktarmak istediğiniz yolu girin veya yola göz atın.
    • Dışa Aktarmayı Durdur: Animate'in dışa aktarmayı ne zaman sonlandıracağını belirtin.
      • Son Kareye Gelindiğinde: Son karede sonlandırmak istiyorsanız bu seçeneği belirleyin.
    Son kareye gelindiğinde dışa aktarmayı durdur
    Son kareye gelindiğinde dışa aktarmayı durdur
    • Dışa Aktarmayı Durdur: Animate'in dışa aktarmayı ne zaman sonlandıracağını belirtin.
      • Şu Kadar Süre Sonra: Bu seçeneği belirleyin ve dışa aktarmayı sonlandırmadan önce geçmesini istediğiniz süreyi belirtin. Bu seçenek, video bölümlerini ayrı ayrı dışa aktarmanıza olanak sağlar.
    1 dakika 15 saniye sonra dışa aktarmayı durdur
    1 dakika 15 saniye sonra dışa aktarmayı durdur
    3 saniye sonra dışa aktarmayı durdur
    3 saniye sonra dışa aktarmayı durdur

  5. Dışa Aktar'ı tıklatın. Adobe Media Encoder'da videoyu dönüştür seçeneğini belirlediyseniz, AME başlatılır ve dışa aktarılan MOV dosyası yeni bir kuyrukta kullanılabilir olur. AME kullanarak videoları kodlama ve dönüştürme hakkında daha fazla bilgi edinmek için bkz. Video ve Sesi Kodlama ve Dışa Aktarma.


Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi