Tablo, satır ve sütun hücrelerinden oluşur. Hücre, metin, bağlantılı çerçeveler veya diğer tablolar ekleyebileceğiniz metin çerçevesine benzer. Adobe InDesign CS5 uygulamasında tablolar oluşturun veya diğer uygulamalardan dışa aktarın.

Not:

Adobe InCopy uygulamasında tablolar oluşturmak, düzenlemek ve biçimlendirmek için Mizanpaj görünümünde olduğunuzdan emin olun.

Tablolar oluşturma

Tablo, satır ve sütun hücrelerinden oluşur. Hücre, metin, satır içi grafikler veya diğer tablolar ekleyebileceğiniz metin çerçevesine benzer. İlk baştan veya mevcut metinden dönüştürerek tablolar oluşturabilirsiniz. Tablo içine tablo da gömebilirsiniz.

Tablo oluşturduğunuzda yeni tablo, kapsayıcı metin çerçevesinin genişliğini doldurur. Ekleme noktası satırın başlangıcında olduğunda, tablo aynı satıra eklenir veya ekleme noktası satırın ortasında olduğunda sonraki satıra eklenir.

Tablolar, satır içi grafiklerin yaptığı gibi çevreleyen metinle akarlar. Örneğin, tablonun üzerindeki metinin punto boyutu değişirse veya metin eklenmiş veya çıkarılmışsa, tablo, akıtılan çerçeveler boyunca ilerler. Bununla birlikte, tablo yol üzerindeki metin çerçevesinde görüntülenmez.

Yatay tabloları oluşturduğunuz şekilde dikey tablolar oluşturabilirsiniz. Tablonun yazma yönü tabloyu oluşturmak için kullanılan metin çerçevesine bağlıdır ve metin çerçevesinin yazma yönü değiştirildiğinde tablonun yazma yönü de değişir. Bu davranış çerçeve ızgarası içinde tablo oluşturduğunuzda da aynı kalır. Ancak tablonun içindeki hücreler için yazma yönü, tablonun yazma yönünden bağımsız olarak değiştirilebilir.

Not:

Tablo oluşturmadan önce metin çerçevesinin yazma yönünü doğrulayın.

Michael Murphy, tablo oluşturma ve biçimlendirme hakkında Mind Your Table Manners (Tablolardaki Davranışınıza Dikkat Edin) başlıklı bir makale sunuyor.

InfiniteSkills.com'dan Jeff Witchell Tablo oluşturma temelleri konulu bir video gösterimi sunuyor.

Sıfırdan tablo oluşturma

Oluşturduğunuz tablo, metin çerçevesinin genişliğini doldurulur.

  1. Yazım aracını  kullanarak tablonun görüntülenmesini istediğiniz yere ekleme noktasını yerleştirin.
  2. Tablo > Tablo Ekle'yi seçin.
  3. Satır ve sütun sayılarını belirtin.
  4. Gövde satırındaki yatay hücrelerin ve sütundaki dikey hücrelerin sayısını belirtin.
  5. Tablo içerikleriniz bir veya daha fazla sütun ya da çerçevede devam edecekse, yinelenmesini istediğiniz bilgilerin olacağı üstbilgi veya altbilgi satırlarının sayısını belirtir.
  6. (İsteğe bağlı) Tablo stilini belirtin.
  7. Tamam'ı tıklatın.

Tablonun satır yüksekliği, belirtilen tablo stili tarafından belirlenir. Örneğin, tablo stili tablonun farklı bölümlerini biçimlendirmek için hücre stillerini kullanabilir. Bu hücre stillerinden herhangi biri paragraf stilleri içeriyorsa paragraf stillerinin başlangıç değeri, bu alanın satır yüksekliğini belirler. Paragraf stili kullanılmamışsa, belgenin varsayılan bilgisi satır yüksekliğini belirler. (Bilgi, başlangıç değerini temel alır. Bu bağlamda bilgi, seçili metinde vurgulamanın yaklaşık yüksekliğidir.)

Mevcut metinden tablo oluşturma

Metni tabloya dönüştürmeden önce metni doğru ayarladığınızdan emin olun.

  1. Metni dönüştürmek üzere hazırlamak için sekmeler, virgüller, satır başları veya sütunları ayırmak üzere farklı karakter ekleyin. Sekmeler, virgüller, satır başları veya satırları ayırmak üzere farklı karakter ekleyin. (Birçok örnekte, metin düzenlenmek zorunda kalmadan tabloya dönüştürülebilir.)
  2. Yazım aracını  kullanarak tabloya dönüştürmek istediğiniz metni seçin.
  3. Tablo > Metni Tabloya Dönüştür'ü seçin.
  4. Sütun Ayırıcı ve Satır Ayırıcı için yeni satır ve sütunların nerede başlaması gerektiğini belirtin. Sütun Ayırıcı ve Satır Ayırıcı alanında Sekme, Virgül veya Paragraf'ı seçin veya noktalı virgül (;) gibi bir karakter yazın. (Yazdığınız karakter, metinden tablo oluşturduğunuz bir sonraki sefer menüde görüntülenir.)
  5. Aynı ayırıcıyı sütun ve satırlar için belirlediyseniz, tablonun içermesini istediğiniz sütun sayısını belirtin.
  6. (İsteğe bağlı) Tabloyu biçimlendirmek için bir tablo stili belirtin.
  7. Tamam'ı tıklatın.

Satırın tablodaki sütun sayısından daha az öğe sayısına sahipse, boş hücreler satırları doldurur.

Tablo içine tablo gömme

  1. Aşağıdakilerden birini yapın:
    • Gömmek istediğiniz hücreleri veya tabloyu seçin ardından Düzenle > Kopyala veya Yapıştır'ı belirleyin. Tablonun görüntülenmesini istediğiniz yere ekleme noktasını yerleştirin ardından Düzenle > Yapıştır'ı seçin.

    • Bir hücrenin içini tıklatın, Tablo > Tablo Ekle'yi seçin, satır ve sütunların sayısını belirtin ve Tamam'ı tıklatın.

  2. Hücre iç metnini gerektiği gibi ayarlayın. (Bkz. Tablo içindeki metni biçimlendirme.)

Hücre içinde tablo oluşturuyorsanız, hücre sınırlarından taşan tablonun herhangi bir bölümünü seçmek için fareyi kullanamazsınız. Bunun yerine, sütun veya satırı genişletin veya ekleme noktasını tablonun ilk bölümüne yerleştirin ve ekleme noktasını taşımak ve metni seçmek için klavye kısayollarını kullanın.

Diğer uygulamalardan tabloları içe aktarma

Tablolar içeren Microsoft Word belgesini veya Microsoft Excel çalışma sayfası içe aktarmak için Yerleştir komutunu kullandığınızda, içe aktarılan veriler düzenlenebilir tablodur. Biçimlendirmeyi denetlemek için İçe Alma Seçenekleri iletişim kutusunu kullanabilirsiniz.

Excel çalışma sayfasından veya Word tablosundan InDesign veya InCopy belgesine verileri de yapıştırabilirsiniz. Pano İşleme tercihi ayarları, farklı bir uygulamadan yapıştırılan metnin nasıl biçimlendirileceğini belirler. Salt Metin seçiliyse, bilgiler, daha sonra tabloya dönüştürebileceğiniz biçimlendirilmemiş sekmeli metin olarak görüntülenir. Tüm Bilgiler seçiliyse, yapıştırılan metin biçimlendirilmiş tablo olarak görüntülenir.

Metni başka bir uygulamadan mevcut tabloya yapıştırıyorsanız, yapıştırılan metni karşılayacak kadar satır ve sütun ekleyin, Pano İşleme tercihlerinde Salt Metin seçeneğini belirleyin ve en az bir hücrenin seçili olduğundan emin olun (yapıştırılan tabloyu bir hücreye gömmek istemiyorsanız).

İçe aktarılan tabloların biçimlendirilmesinde daha fazla kontrol sahibi olmak veya çalışma sayfası biçimlendirmesini korumak istersiniz, tabloyu içe aktarmak için Yerleştir komutunu kullanın. Bir çalışma sayfası bağlantısını korumak isterseniz, Dosya İşleme tercihleri ayarlarından Metin ve Çalışma Sayfası Dosyalarını Yerleştirirken Bağlantılar Oluştur'u seçin.

Not:

Tablo hücrelerinin seçimi boyunca sekmeli metni kopyalayabilir ve yapıştırabilirsiniz. Bu teknik, metni biçimini koruyarak değiştirmenin en iyi yoludur. Örneğin, aylık bir dergide bir biçimlendirme tablosunun içeriğini güncelleştirmek istediğinizi varsayın. Bunu yapmanın bir yolu Excel çalışma sayfasını bağlanmak olabilir. Ancak, içeriğiniz farklı bir kaynaktan geliyorsa, yeni içeriğin bulunduğu sekmeli metni kopyalayabilir, biçimlendirilmiş InDesign tablosunda hücre aralığını seçip yapıştırabilirsiniz.

Tabloya metin ekleme

Tablo hücrelerine metin, bağlantılı nesne, XML etiketleri ve diğer tabloları ekleyebilirsiniz. Tablo satırının yüksekliği, siz sabit satır yüksekliği ayarlamadığınız sürece ek metin satırlarına uymak üzere genişler. Tablolara dipnotlar ekleyemezsiniz.

  1. Yazım aracını  kullanarak aşağıdakilerden birini yapın:
    • Ekleme noktasını bir hücreye yerleştirin ve metni yazın. Aynı satırda yeni paragraf oluşturmak için Enter veya Return tuşuna basın. Hücreler arasında ilerlemek için Sekme tuşuna basın (en son satırda Sekme tuşuna basıldığında yeni satır eklenir). Hücreler arasında geriye doğru ilerlemek için Shift+Sekme tuşlarına basın.

    • Metni kopyalayın, bir hücrede ekleme noktasını yerleştirin ve ardından Düzenle > Yapıştır'ı seçin.

    • Metni yerleştirmek istediğiniz yere, bir hücre içine ekleme noktasını yerleştirin, Dosya > Yerleştir'i seçin ve ardından bir metin dosyasını çift tıklatın.

Tabloya grafik ekleme

Tek başına InCopy belgesine grafik eklemek için Mizanpaj görünümünde olduğunuzdan emin olun. Bağlantılı InDesign belgesindeki tabloya grafik eklemek için InDesign uygulamasını kullanın, böylece metin çerçevesini yeniden boyutlandırmak için daha fazla denetiminiz olur.

  1. Aşağıdakilerden birini yapın:
    • Grafiği yerleştirmek istediğiniz yere ekleme noktasını yerleştirin, Dosya > Yerleştir'i seçin ve ardından grafik dosyasının adını çift tıklatın.

    • Grafiği yerleştirmek istediğiniz yere ekleme noktasını yerleştirin, Nesne > Bağlantılı Nesne > Ekle'yi seçin ve ardından ayarları belirleyin. Bağlantılı nesneye daha sonra da grafik ekleyebilirsiniz.

    • Grafiği veya çerçeveyi kopyalayın, ekleme noktasını yerleştirin ve ardından Düzenle > Yapıştır'ı seçin.

Hücreden daha büyük bir grafik eklediğinizde, hücre yüksekliği grafiğe uymak için genişler ancak hücrenin genişliği değişmez; grafik, sağdaki hücreye genişleyebilir. Grafiğin yerleştirildiği satır için sabit yükseklik belirlenmişse, satır yüksekliğinden daha yüksek olan grafik hücrenin taşmasına neden olur.

Not:

Hücrenin taşmasından kaçınmak için resmi tablonun dışına yerleştirebilir, resmi yeniden boyutlandırabilir ve ardından tablo hücresine yapıştırabilirsiniz.

Tablo üstbilgileri ve altbilgileri ekleme

Uzun bir tablo oluşturduğunuzda, tablo birden fazla sütuna, çerçeveye veya sayfaya yayılabilir. Tablonun bölünen her bölümünün üstünde veya altında bilgilerin yinelenmesi için üstbilgileri veya altbilgileri kullanabilirsiniz.

Tablo oluşturduğunuzda üstbilgi ve altbilgi satırları ekleyebilirsiniz. Üstbilgi ve altbilgi satırları eklemek ve bunların tablodaki görünümlerini değiştirmek için Tablo Seçenekleri iletişim kutusunu da kullanabilirsiniz. Gövde satırlarını üstbilgi veya altbilgi satırlarına dönüştürebilirsiniz.

se_04
Header rows repeated once per frame

Not:

Tabloları sırasıyla, Tablo 1A, Tablo 1B gibi, numaralandırmak için tablo üstbilgisine veya altbilgisine değişken ekleyin. (Bkz. Rakamlar ve tablolar için devam eden resim yazıları oluşturma.)

  1. Üstbilgi satırları oluşturmak için tablonun en üstündeki satırları veya altbilgi satırları oluşturmak üzere tablonun en altındaki satırları seçin.
  2. Tablo > Satırları Dönüştür > Üstbilgi veya Altbilgi öğesini seçin.
  1. Ekleme noktasını tabloya yerleştirin ve ardından Tablo > Tablo Seçenekleri > Üstbilgiler Ve Altbilgiler'i seçin.
  2. Üstbilgi veya altbilgi satırlarının sayısını belirtin. Tablonun üstüne veya altına boş satırlar eklenebilir.
  3. Üstbilgi ve altbilgideki bilgilerin her metin sütununda (metin çerçevelerinin birden fazla sütunu varsa), çerçeve başına bir kez veya sayfa başına sadece bir kez mi görüntüleneceğini belirtin.
  4. Üstbilginin tablonun ilk satırında görüntülenmesini istemiyorsanız, İlkini Atla'yı seçin. Altbilginin tablonun son satırında görüntülenmesini istemiyorsanız, Sonuncuyu Atla'yı seçin.

    Üstbilgi veya altbilginin devam edeceğini belirtmek istiyorsanız, Öncekini Atla seçeneği yararlıdır. Örneğin, birden çok sayfaya yayılan bir tablo için üstbilgi metninin "Tablo 2 Devam Edecek" olmasını isteyebilirsiniz. “(Devam Edecek)” bilgisinin tablonun başında görünmesini istemediğinizde, Öncekini Atla'yı seçin ve tablonun ilk satırına yalnızca Tablo 2 yazın.

  5. Tamam'ı tıklatın.
  1. Aşağıdakilerden birini yapın:
    • Ekleme noktasını üstbilgi veya altbilgi satırına yerleştirin ve ardından Tablo > Satırları Dönüştür> Gövdeye'yi seçin.

    • Tablo > Tablo Seçenekleri > Üstbilgiler Ve Altbilgiler'i seçin ve ardından farklı üstbilgi satırı veya altbilgi satırı sayısı belirtin.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi