Animate 中的逐格動畫

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

建立逐格動畫

逐格動畫會在每個影格中變更「舞台」的內容,最適合用於影像會在每個影格中變更的複雜動畫,而不是影像只在「舞台」移動的簡單動畫。與補間動畫相比,逐格動畫增加檔案大小的速度更快。在逐格動畫中,Animate 會將每個完整影格的數值儲存起來。

若要建立逐格動畫,先將每個影格都定義為關鍵影格,再為每個影格建立不同的影像。一開始時,每個新關鍵影格所包含的內容都和前一個關鍵影格相同,所以您可以用累加方式來修改動畫中的影格。

  1. 按一下圖層名稱,使其成為作用中的圖層,然後在圖層中選取要讓動畫開始播放的影格。
  2. 如果該影格還不是關鍵影格,請選取「插入 > 時間軸 > 關鍵影格」。
  3. 為連續動畫的第一個影格建立圖案。使用繪圖工具、從「剪貼簿」貼上圖像,或者匯入檔案。
  4. 若要加入其內容和第一個關鍵影格相同的關鍵影格,請按一下同一列中右邊的下一個影格。選取「插入 > 時間軸 > 關鍵影格」,或者按一下右鍵 (Windows) 或 Control + 按一下 (Macintosh),然後選取「插入關鍵影格」。

  5. 若要累加下一個動畫,可以在「舞台」上更改此影格的內容。
  6. 若要完成連續逐格動畫,可以重複步驟 4 至 5,直到建立完成所要的移動。
  7. 若要測試連續動畫,請選取「控制 > 播放」或按「控制器」(「視窗 > 工具列 > 控制器」) 上的「播放」按鈕。

轉換傳統或移動補間動畫,藉此建立逐格動畫

您可以將傳統補間動畫或移動補間動畫範圍轉換成逐格動畫。在逐格動畫中,每個影格都包含了不同的關鍵影格 (並非屬性關鍵影格),而其中每一個關鍵影格則都包含了不同的動畫元件實體。逐格動畫不包含內插補屬性值。

  1. 在要轉換的補間動畫範圍上按一下右鍵 (Windows) 或 Ctrl+按一下該範圍 (Macintosh),然後從快顯選單中選擇「轉換成逐格動畫」。

使用描圖紙

通常在「舞台」上每次只會顯示連續動畫的一個影格。為了協助繪製、定位和編輯逐格動畫,描圖紙會顯示舞台上上一個和下一個影格的內容,以提供參考。播放磁頭下的影格會以全彩顯示,並且套用顏色和 Alpha 來區分過去與未來影格。 

描圖紙的上一個和下一個影格具有預設的色調。若要自訂這些顏色,請使用「進階設定」選項。

啟用和停用描圖紙

  • 按一下「描圖紙」按鈕 ,即可啟用和停用描圖紙。
  • 若要排除或包含影格,請在時間軸標題中,以滑鼠右鍵按一下描圖紙範圍內的任何描圖紙影格。
  • 對「描圖紙」按鈕 按住滑鼠,即可檢視和選取選項。

描圖紙中的進階設定

用滑鼠按住「描圖紙」按鈕 並選取「進階設定」。

自訂範圍

自訂顏色,做為描圖紙顯示之用

  1. 若要自訂描圖紙影格的顏色,請選取「時間軸」列中的「描圖紙影格」。
  2. 用滑鼠按住「描圖紙」按鈕 並選取「進階設定」。
  3. 修改先前和之後影格的色調。

外框和填色模式

自訂不透明度

  1. 若要控制使用中影格上任一側描圖紙的不透明度,請按一下並拖曳「起始不透明度」滑桿。

  2. 若要依百分比減少每個描圖紙的差異,請拖曳「遞減」。

僅顯示關鍵影格

  1. 若要自訂描圖紙影格的顏色,請選取「時間軸」列中的「描圖紙影格」。
  2. 選取「編輯 > 偏好設定」。
  3. 在「描圖紙顏色」選項中,選取色票按鈕,以自訂並設定「過去」、「現在」和「未來」影格的顏色。

錨點標記

在舞台上同時檢視數個動畫影格

按一下「描圖紙」按鈕 。所有在「開始描圖紙」和「結束描圖紙」標記 (位於「時間軸」標題) 之間的影格都會在「文件」視窗中重疊成一個影格。

描圖紙標記

具有顏色編碼的描圖紙

描圖紙顏色編碼能幫助您分辨過去、目前和未來的影格。越遠離作用中影格的描圖紙影格會逐漸減少透明度。

時間軸上的描圖紙

具有顏色編碼的描圖紙,顯示過去、目前和未來的影格

描圖紙外框模式

自訂顏色,做為描圖紙顯示之用

  1. 若要自訂描圖紙影格的顏色,請選取「時間軸」列中的「描圖紙影格」。
  2. 選取「編輯 > 偏好設定」。
  3. 在「描圖紙顏色」選項中,選取色票按鈕,以自訂並設定「過去」、「現在」和「未來」影格的顏色。
註解:

顏色編碼也適用於外框模式。

描圖紙時間軸模式

自訂的描圖紙

  • 若要變更任何一個描圖紙標記的位置,可以將其指標拖曳到新位置。描圖紙標記通常會與目前的影格指標一起移動。請使用 Control/Command+拖曳來增加或減少兩邊上的位置。
  • 若要啟用編輯描圖紙標記之間的所有影格,可以按一下「編輯多個影格」按鈕 。通常描圖紙只會讓您編輯目前的影格。您可以顯示描圖紙標記之間每個影格的內容,並進行編輯。
  • 若要將時間軸內的重複範圍移到任何想要的位置,包括播放磁頭位置,請使用時間軸中的標記,按住 Shift 鍵並拖曳範圍。 
  • 若要設定範圍標記,請使用 Shift 鍵並拖曳範圍標記,或使用「時間軸」間的標記來拖曳重複範圍。
註解:

在描圖紙處於開啟的狀態時,無法顯示鎖定的圖層 (具有鎖定圖示)。若要避免大量影像混雜在一起,可以將不要描圖的圖層鎖定或隱藏起來。

預覽您的工作

若要查看描圖紙的出現方式,請將滑鼠停留在時間軸上的整個範圍。您的動畫隨即以彩色外框播放,提供您精準的變更預覽。 

Adobe 標誌

登入您的帳戶