User Guide Cancel

Work with effects

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Toolbar
      4. Default keyboard shortcuts
      5. Customize keyboard shortcuts
      6. Introduction to artboards
      7. Manage artboards
      8. Customize the workspace
      9. Properties panel
      10. Set preferences
      11. Touch Workspace
      12. Microsoft Surface Dial support in Illustrator
      13. Recovery, undo, history, and automation
      14. Rotate view
      15. Rulers, grids, and guides
      16. Accessibility in Illustrator
      17. Safe Mode
      18. View artwork
      19. Use the Touch Bar with Illustrator
      20. Files and templates
    3. Tools in Illustrator
      1. Tools at a glance
      2. Select tools
        1. Selection
        2. Direct Selection
        3. Group Selection
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. Navigate tools
        1. Hand
        2. Rotate View
        3. Zoom
      4. Paint tools
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. Text tools
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. Draw tools
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. Anchor Point
        5. Curvature
        6. Line Segment
        7. Rectangle
        8. Rounded Rectangle
        9. Ellipse
        10. Polygon
        11. Star
        12. Paintbrush
        13. Blob Brush
        14. Pencil
        15. Shaper
        16. Slice
      7. Modify tools
        1. Rotate
        2. Reflect
        3. Scale
        4. Shear
        5. Width
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Map artwork over 3D objects
      4. Create 3D objects
      5. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Add text and work with type objects
      2. Create bulleted and numbered lists
      3. Manage text area
      4. Fonts and typography
      5. Format type
      6. Import and export text
      7. Format paragraphs
      8. Special characters
      9. Create type on a path
      10. Character and paragraph styles
      11. Tabs
      12. Text and type
      13. Find missing fonts (Typekit workflow)
      14. Update text from Illustrator 10
      15. Arabic and Hebrew type
      16. Fonts | FAQ and troubleshooting tips
      17. Create 3D text effect
      18. Creative typography designs
      19. Scale and rotate type
      20. Line and character spacing
      21. Hyphenation and line breaks
      22. Text enhancements
      23. Spelling and language dictionaries
      24. Format Asian characters
      25. Composers for Asian scripts
      26. Create text designs with blend objects
      27. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Place multiple files
      2. Manage linked and embedded files
      3. Links information
      4. Unembed images
      5. Import artwork from Photoshop
      6. Import bitmap images
      7. Import Adobe PDF files
      8. Import EPS, DCS, and AutoCAD files
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash issues
    2. Recover files after crash
    3. File issues
    4. Supported file formats
    5. GPU device driver issues
    6. Wacom device issues
    7. DLL file issues
    8. Memory issues
    9. Preferences file issues
    10. Font issues
    11. Printer issues
    12. Share crash report with Adobe
    13. Improve Illustrator performance

Illustrator includes a variety of effects, which you can apply to an object, group, or layer to change its characteristics.

Once you apply an effect to an object, the effect appears in the Appearance panel. You can edit the effect, move it, duplicate it, delete it, or save it as part of a graphic style. When you use an effect, you must expand the object before you can access the new points.

The effects in the top half of the Effects menu are vector effects. You can apply these effects only to vector objects or to the fill or stroke of a bitmap object in the Appearance panel. The following effects and effects categories from the top section are exceptions to this rule and can be applied to both vector and bitmap objects: 3D effects, SVG Filters, Warp effects, Transform effects, Drop Shadow, Feather, Inner Glow, and Outer Glow.

The effects in the bottom half of the Effects menu are raster effects. You can apply them to either vector or bitmap objects.

Apply an effect

  1. Select the object or group (or target a layer in the Layers panel).

    If you want to apply an effect to a specific attribute of an object, such as its fill or stroke, select the object and then select the attribute in the Appearance panel.

  2. Do one of the following:

    • Choose a command from the Effect menu.

    • Click Add New Effect  in the Appearance panel, and choose an effect.

  3. If a dialog box appears, set options, and then click OK.

    Note:

    To apply the effect and settings that were used last, choose Effect > Apply [Effect Name]. To apply the last used effect and set its options, choose Effect > [Effect Name].

About raster effects

Raster effects are effects that generate pixels, rather than vector data. Raster effects include SVG Filters, all of the effects at the bottom section of the Effect menu, and the Drop Shadow, Inner Glow, Outer Glow, and Feather commands in the Effect > Stylize submenu.

The Resolution Independent Effects (RIE) capability in Illustrator makes it possible to do the following:

  • When the resolution in Document Raster Effects Settings (DRES) changes, the parameters in the effect are interpreted to a different value so that there is minimal or no change in the appearance of the effect. The new modified parameter values are reflected in the Effect dialog box.

  • For effects with more than one parameter, Illustrator reinterprets only those parameters that are related to the document raster effects resolution setting.

    For example, there are different parameters in the Halftone Pattern dialog box. However, only the Size value changes when the DRES changes.

Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi
Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi

Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi
Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi

You set rasterization options for a document by choosing Effect > Document Raster Effects Settings. (See Rasterization options.)

Note:

If an effect looks good on‑screen, but loses detail or appears jagged when printed, increase the document raster effects resolution.

Spot colors and transparency in CS2, CS3 and later

When you use spot colors and transparency, Illustrator sometimes manipulates file content to maintain the appearance of artwork in PostScript and other transparency flattening processes. When Illustrator manipulates content during the flattening process, spot colors involved in specific transparency scenarios sometimes require conversion to process colors. While these cases are less and less common with each successive version of Illustrator, the following items address the remaining limitations to spot color preservation when interacting with transparency in Illustrator CS3 and later and CS2.

Raster effects

In Illustrator CS2 when you apply raster-based effects (for example, Rasterize and Gaussian Blur) at the object, group, or layer level to objects that contain multiple spot colors or a combination of spot and process color, Illustrator converts the object color to either the document's process color space, grayscale, or bitmap. You can choose one of these options in the Raster Effects Settings dialog box. For example, in a simple rectangle with a spot color fill and a process black stroke, the spot color fill convert to a process color. However, if all of the attributes of an object, group, or layer are colored with a single spot color, then the spot color is maintained regardless of where you apply the effect. Illustrator CS3 and later maintain the spot color in any of the above scenarios.

The Preserve Spot Colors When Possible check box (CS2) or the Preserve Spot Colors check box (CS3 and later) in the Raster Effects Settings dialog box is not selected by default when you open Illustrator files created in versions earlier than CS2. This setting ensures that the printing behavior of these files is consistent with earlier versions of Illustrator. The selection in the Preserve Spot Colors When Possible check box in Illustrator CS2 files is maintained when the files are reopened.

Gradients and gradient mesh

Illustrator CS3 and later and CS2 (or Cs2 and later)  preserves spot-color-to-spot-color gradients and spot-color-to-process-color gradients in both opaque and transparent scenarios. To print and export spot colors in gradient scenarios, select Preserve Overprints and Spot Colors in the Object > Flatten Transparency dialog box.

In Illustrator CS2, when a gradient mesh contains more than one spot color, or a process color and a spot color, Illustrator converts the mesh to the document's process color space. Illustrator CS3 and later retain the spot color in both of the preceding gradient mesh scenarios.

Spot-to-spot blends

When you create a blend between two different spot color objects, Illustrator converts all of the intermediate steps to the document's process color space.

Rasterization

In Illustrator CS2, the Object > Rasterize command allows you to convert all spot colors to the document's process color space, grayscale, or bitmap. Spot colors aren't preserved when rasterized. The Effects > Rasterize command is subject to the Effect limitations explained in Raster Effects (above) and will "Preserve Spot Colors When Possible" when you select this option in the Raster Effects Settings dialog box.

Illustrator CS3 and later allows you to retain spot colors when using both the Object > Rasterize and Effects >Rasterize command by selecting the Preserve Spot Colors option in the Object > Rasterize dialog box and the Effects > Document Raster Effects Settings dialog box respectively.

Rasterization options

You can set the following options for all raster effects in a document or when you rasterize a vector object.

Color Model

Determines the color model that is used during rasterization. You can generate an RGB or CMYK color image (depending on the color mode of your document), a grayscale image, or a 1‑bit image (which may be black and white or black and transparent, depending on the background option selected).

Resolution

Determines the number of pixels per inch (ppi) in the rasterized image. When rasterizing a vector object, select Use Document Raster Effects Resolution to use global resolution settings.

Background

Determines how transparent areas of the vector graphic are converted to pixels. Select White to fill transparent areas with white pixels, or select Transparent to make the background transparent. If you select Transparent, you create an alpha channel (for all images except 1‑bit images). The alpha channel is retained if the artwork is exported into Photoshop. (This option anti-aliases better than the Create Clipping Mask option.)

Anti-alias

Applies anti-aliasing to reduce the appearance of jagged edges in the rasterized image. When setting rasterization options for a document, deselect this option to maintain the crispness of fine lines and small text.

When rasterizing a vector object, select None to apply no anti-aliasing and maintain the hard edges of line art when it is rasterized. Select Art Optimized to apply anti-aliasing that is best suited to artwork without type. Select Type Optimized to apply anti-aliasing that is best suited to type.

Create Clipping Mask

Creates a mask that makes the background of the rasterized image appear transparent. You do not need to create a clipping mask if you selected Transparent for Background.

Add Around Object

Adds a padding or border around the rasterized image, using the specified number of pixels. The resulting image’s dimensions appear as the original dimensions plus the Add Around Object setting’s value. You can use this setting, for example, to create a snapshot effect: Specify a value for Add Around Object setting, choose White Background, and do not select Create Clipping Mask. The white boundary added to the original object becomes a visible border on the image. You can then apply a Drop Shadow or Outer Glow effect to make the original artwork look like a photo.

Imported raster formats

Methods for accommodating spot colors imported from raster formats are much improved in both Illustrator CS3 and later and CS2 over earlier versions. Illustrator CS2 retains spot colors in embedded native Photoshop files as a raster opacity mask over a rectangle that is filled with the spot color and set to overprint, and in Illustrator CS3 and later it converts the image to a deviceN raster object (all spot and process colors are retained together in an NChannel format). Illustrator CS3 and later, CS2 (or CS and later) retains spot colors in embedded PDF files as output-friendly non-native art. The only significant raster format limitations remaining are listed below and are all fixed by Illustrator CS3 and later.

  • TIFF: Illustrator CS2 does not import spot colors in TIFF files. Only the CMYK, RGB, or Grayscale portion is imported. Illustrator CS3 and later import spot colors in TIFF files exported from Photoshop.
  • PSD Duotone: You can't link or embed PSD Duotone in Illustrator CS2. These actions cause an error message and the Place function fails with no result. You can successfully link and embed PSD Duotone files in Illustrator CS3 and the spot colors are retained.
  • EPS Duotone: Illustrator CS2 converts spot colors in embedded EPS Duotone files to process colors. Illustrator CS3 and later retain spot colors in embedded EPS Duotone files.
  • DCS 2.0 EPS: Illustrator CS2 does not support spot colors or high-resolution data contained in DCS EPS files when the DCS EPS interacts with transparency. In this case, only composite data is preserved. Illustrator CS2 supports DCS EPS only in non-transparent separated workflows. Illustrator CS3 supports DCS 2.0 EPS files and the retention of spot colors in both transparent and non-transparent host-separated workflows. DCS 1.0 EPS files are still limited to non-transparent host-separated workflows in both Illustrator CS3 and CS2 (CS2 and later).

Note: For more information on non-native art, see Importing monotone, duotone, and tritone images from Adobe PDF files" in Illustrator CS3, CS2 Help.

Alpha channel transparency

Illustrator CS2 and later preserve spot colors that interact with alpha channel transparency (for example, opacity masks, live raster effects, and transparent images). Earlier versions of Illustrator convert spot colors to process colors in these scenarios.

Applying effects to bitmap images

Effects let you apply a special look to bitmap images as well as vector objects. For example, you can apply an impressionistic look, apply lighting changes, distort images, and produce many other interesting visual effects.

Consider the following information when applying effects specifically to bitmap objects:

  • Effects do not work on linked bitmap objects. If you apply an effect to a linked bitmap, it is applied to an embedded copy of the bitmap instead of to the original. To apply the effect to the original, you must embed the original bitmap in the document.

  • Adobe Illustrator supports plug-in effects from Adobe products such as Adobe Photoshop and from non‑Adobe software developers. Once installed, most plug-in effects appear in the Effect menu and work the same way as do built-in effects.

  • Some effects can be memory-intensive, especially when applied to a high-resolution bitmap image.

Improving performance for effects

Some effects are very memory-intensive. The following techniques can help improve performance when applying these effects:

  • Select the Preview option in effect dialog boxes to save time and prevent unintended results.

  • Change the settings. Some commands, such as Glass, are extremely memory-intensive. Try different settings to increase their speed.

  • If you plan to print to a grayscale printer, convert a copy of the bitmap image to grayscale before applying effects. Note, however, that in some cases, applying an effect to a color bitmap image and then converting it to grayscale may not have the same result as applying the same effect directly to a grayscale version of the image.

Modify or delete an effect

You modify or delete an effect by using the Appearance panel.

  1. Select the object or group (or target the layer in the Layers panel) that uses the effect.

  2. Do one of the following:

    • To modify the effect, click its blue underlined name in the Appearance panel. In the effect’s dialog box, make the desired alterations, and then click OK.

    • To delete the effect, select the effect listing in the Appearance panel, and click the Delete button.

Live Trace tool

Illustrator CS3 and later and CS2 preserves spot colors in grayscale raster objects when the spot color has been applied in Illustrator. Spot colors in all other raster format files, whether linked or embedded, are converted to process colors or ignored when you use the Live Trace command.

SVG filters

When you apply any SVG Filter in Illustrator CS2, spot colors are converted to the document's process color space.

Legacy formats

When you save files to Illustrator version 8 or earlier, and select Preserve Appearance and Overprints in the Save dialog box, all spot color objects are converted to process color objects.

More like this

Have a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We would love to hear from you and see your creations.

Adobe logo

Sign in to your account