User Guide Cancel

Map, manage, and export text styles

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Customize your workspace in InDesign
      3. Toolbox
      4. Set preferences
      5. Properties panel
      6. Touch workspace
      7. Default keyboard shortcuts
      8. Document recovery and undo
    3. Generative AI
      1. Text to Image
      2. Generative AI FAQ
  3. Create and layout documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Convert PDFs to InDesign files in InDesign (Beta)
      7. Create book files
      8. Add basic page numbering
      9. Number pages, chapters, and sections
      10. Convert QuarkXPress and PageMaker documents
      11. Share content
      12. Understand a basic managed-file workflow
      13. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
      2. Align and distribute objects using rulers
      3. Measure objects using the Measure tool
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. South-East Asian Scripts
      4. Arabic and Hebrew features in InDesign
      5. Create type on a path
      6. Bullets and numbering
      7. Glyphs and special characters
      8. Text composition
      9. Text variables
      10. Generate QR codes
      11. Edit text
      12. Align text
      13. Wrap text around objects
      14. Anchored objects
      15. Linked content
      16. Format paragraphs
      17. Format characters
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Auto Style text
      3. Work with Style Packs
      4. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Spell check and language dictionaries
      1. Check spelling, autocorrect, and dynamic spelling
      2. Create, add, and manage dictionaries and words
      3. Change dictionary preferences
      4. Duden dictionary
    6. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    7. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    8. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    9. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    10. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Frames and objects
      10. Align and distribute objects
      11. Linked and embedded graphics
      12. Integrate AEM assets
    11. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Understand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Find and replace
    1. Find and replace text
    2. Find and replace fonts
    3. Find and replace glyphs
    4. Find and replace using GREP expressions and queries
    5. Find and replace objects
    6. Find and replace colors
    7. Search options to find and replace
  6. Share
    1. Save and access cloud documents
    2. Organize, manage, and share cloud documents
    3. View and manage versions in cloud documents
    4. Common questions about InDesign cloud documents
    5. Share and collaborate        
    6. Share for Review
    7. Review a shared InDesign document
    8. Manage feedback 
  7. Publish
    1. Place, export, and publish
      1. Publish online
      2. Publish online dashboard
      3. Copy, insert graphics
      4. Export content for EPUB
      5. Adobe PDF options
      6. Export content to HTML
      7. Export to Adobe PDF
      8. Export to JPEG format
      9. Export HTML
      10. DPS and AEM Mobile overview
      11. Supported File Formats
      12. Export and import User Settings
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  8. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  9. Troubleshooting
    1. Fixed issues
    2. Known issues
    3. Crash on launch
    4. Preference folder read-only issue
    5. Troubleshoot file issues
    6. Unable to export PDF
    7. InDesign document recovery

Learn how to map Word styles to InDesign styles, manage styles, and export style tags.

Text styles help reduce the effort and time while you work on large documents. With text styles, you can also maintain consistency throughout a document without any manual error.

Before you proceed with learning how to map, manage, and export style tags, check out how to create and work with paragraph and character styles.

Map Word styles to InDesign styles

Do you want to use your favorite styles and the text from Microsoft Word? Follow these steps to map Word Styles to InDesign Styles, and use them in your InDesign files:

  1. Go to File > Place.

  2. Check Show Import Options and double-click the Word document.

    You'll see the Microsoft Word Import Options dialog.

  3. Select Preserve Styles and Formatting from Text and Tables in the Formatting section.

    You can Import Styles Automatically or Customize Style Import.

  4. You can select any of the following options:

    • Import Styles Automatically: Select the option to Use InDesign Style Definition, Redefine InDesign Style, or Auto Rename if there is a name conflict.
    • Customize Style Import: Select Style Mapping to open the dialog. Map each conflicted Word Style with a new or different InDesign Style, click Ok.
  5. Click Ok.

Map Microsoft Word Styles to InDesign Styles
Map Microsoft Word Styles to InDesign Styles

Convert style bullets and numbering to text

Text styles with bullet or number lists may not be copied or exported to a different application with the bullets or numbers intact. Follow these steps to convert styles with bullets or numbers to text:

  1. Select a Paragraph style.

  2. Select More Options   > Convert "[style name]" Bullets and Numbering to Text.

    You can now copy the bullets or numbers and update them manually.

Convert bullet and number style to text in InDesign
Convert bullet and number style to text

If you convert a parent style with bullets and numbers to text, the change also applies to the child style.

Find and replace text styles

Changed your mind about a style? You can easily find and replace a text style to avoid a manual error. Follow these steps to find and replace text styles:

  1. Go to Edit > Find/Change.

  2. Leave Find what and Change to blank, and select the box for Find Format.

    Select More Options if you can't see Find Format.

  3. You can select the Character or Paragraph Style you want to find and change, and click Ok.

    You can also select from the other format options available.

    Find and change text styles
    Find and change text styles

  4. Select the box for Change Format.

  5. Select a Character or Paragraph Style you want to use in place of the existing style, and click Ok.

  6. Now you can select Find, Change, Change All, or Change/Find to find and replace your text styles.

  7. Click Done.

Map styles to export tags | CC, CS6, CS5.5

Use Export Tagging to define how InDesign text styles are marked up in HTML, EPUB, or a tagged PDF output.

You can also specify CSS class names to add to the exported content. In EPUB/HTML export, CSS classes can be used to differentiate between slight variations in styling. If no class name is added, InDesign automatically generates one based on the Style Name.

You cannot preview Export Tagging within the InDesign layout, as it only impacts the exported EPUB, HTML, or PDF file.

Edit All Export Tags lets you efficiently view and modify the mappings in a single dialog box.

  1. Select a paragraph or character style.

  2. Go to More Options   > Style Options...

    You'll see the Style Options panel.

  3. Select Export Tagging.

    Export style tags
    Export style tags

  4. Update the following options to export style tags:

    • EPUB and HTML: Select a style in Tag. You can also check the Include Classes in HTML, Emit CSS, and Split Document (EPUB Only) options.
    • PDF: Select a style in Tag.
  5. Click Ok.

Edit all export tags

Follow these steps to view and modify all the export tags in a single window:

  1. Go to More Options   > Edit All Export Tags in the Paragraph, Character, or Object style panel menu.

  2. You can select EPUB and HTML or PDF.

  3. Select a tag for each of the styles.

    You can also check Split EPUB, Include In HTML, and Emit CSS options within EPUB and HTML.

    Edit all export tags
    Edit all export tags

  4. Click Ok.

Apply sequential styles to multiple paragraphs

Do you've a sequence of Paragraph styles that you can use one after the other? Do you add a heading, subheading, and paragraph?

Paragraph Styles have the option to add Next Style. Just click Enter(Windows) or Return(macOS)to add text in a different paragraph style. It also lets you apply different styles to multiple paragraphs with a single action.

  1. Select a Paragraph style.

  2. Go to More Options   > Style Options...

  3. In Paragraph Style Options > General, add the style name for Next Style.

    Next Style option in Paragraph Style Options
    Apply sequential styles to multiple paragraphs

    Now you can add any text with this paragraph style, and with the press of Enter (Window) or Return (macOS),  the style will change to the Next Style.

If the text includes formatting overrides or character styles, you can remove them from the context menu.

You can easily break the link between specific sections of text and the associated paragraph style and retain the format. Follow these steps to break the link between text and its style:

  1. Select the text you want to break from the style.

  2. Select More Options   > Break Link to Style.

Once you break the link between text and style, any changes to the style will not reflect in the text. If no text is selected when you select Break Link To Style, any new text you type uses the same formatting as the chosen style, but no style is assigned to that text.


Related topics

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

 Adobe

Get help faster and easier

New user?