User Guide Cancel

Search assets

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
    3. Beta features
      1. New Spectrum UI
      2. Free stock audio from Adobe Stock 
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Best practices for updating Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
    6. Frequently asked questions
    7. Release notes
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Start a new project
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. Import and export FAQs
    3. Working with Panels
    4. Windows touch and gesture controls
    5. Use Premiere Pro in a dual-monitor setup
  7. Frame.io
    1. Install and activate Frame.io
    2. Use Frame.io with Premiere Pro and After Effects
    3. Integrate Adobe Workfront and Frame.io
    4. Share for review with Frame.io
    5. Invite collaborators to co-edit a project
    6. Frequently asked questions
  8. Import media
    1. Importing
      1. Transfer files
      2. Importing still images
      3. Importing digital audio
    2. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    3. File formats
      1. Supported file formats
      2. Support for Blackmagic RAW
    4. Working with timecode
  9. Editing
    1. Edit video
    2. Sequences
      1. Create and change sequences
      2. Set In and Out points in the Source Monitor
      3. Add clips to sequences
      4. Rearrange and move clips
      5. Find, select, and group clips in a sequence
      6. Remove clips from a sequence
      7. Change sequence settings
      8. Edit from sequences loaded into the Source Monitor
      9. Simplify sequences
      10. Rendering and previewing sequences
      11. Working with markers
      12. Source patching and track targeting
      13. Scene edit detection
    3. Cut and trim clips
      1. Split or cut clips
      2. Trim clips
      3. Edit in Trim mode
      4. Perform J cuts and L cuts
      5. Create and play clips
      6. Adjust Trimming and Playback preferences
    4. Video
      1. Synchronizing audio and video with Merge Clips
      2. Render and replace media
      3. Undo, history, and events
      4. Freeze and hold frames
      5. Working with aspect ratios
    5. Audio
      1. Overview of audio in Premiere Pro
      2. Edit audio clips in the Source Monitor
      3. Audio Track Mixer
      4. Adjusting volume levels
      5. Edit, repair, and improve audio using Essential Sound panel
      6. Enhance Speech
      7. Enhance Speech FAQs
      8. Audio Category Tagging
      9. Automatically duck audio
      10. Remix audio
      11. Monitor clip volume and pan using Audio Clip Mixer
      12. Audio balancing and panning
      13. Advanced Audio - Submixes, downmixing, and routing
      14. Audio effects and transitions
      15. Working with audio transitions
      16. Apply effects to audio
      17. Measure audio using the Loudness Radar effect
      18. Recording audio mixes
      19. Editing audio in the timeline
      20. Audio channel mapping in Premiere Pro
      21. Use Adobe Stock audio in Premiere Pro
    6. Text-Based Editing
      1. Text-Based Editing
      2. Text-Based Editing FAQs
    7. Advanced editing
      1. Multi-camera editing workflow
      2. Editing VR
    8. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
      3. Editing workflows for feature films
  10. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Metadata effect in Premiere Pro
      5. Automatically reframe video for different social media channels
      6. Color correction effects
      7. Effects Manager
      8. Change duration and speed of clips
      9. Adjustment Layers
      10. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  11. Titles, Graphics, and Captions    
    1. Overview of the Essential Graphics panel
    2. Graphics and Titles
      1. Create a title
      2. Linked and Track Styles
      3. Working with style browser
    3. Graphics
      1. Create a shape
      2. Draw with the Pen tool
      3. Align and distribute objects
      4. Change the appearance of text and shapes
      5. Apply gradients
      6. Add Responsive Design features to your graphics
      7. Install and use Motion Graphics templates
      8. Replace images or videos in Motion Graphics templates
      9. Use data-driven Motion Graphics templates
    4. Captions
      1. Speech to Text
      2. Download language packs for transcription
      3. Working with captions
      4. Check spelling and Find and Replace
      5. Export text
      6. Speech to Text FAQs
    5. Best Practices: Faster graphics workflows
    6. Retiring the Legacy Titler FAQs
    7. Upgrade Legacy titles to Source Graphics
  12. Fonts and emojis
    1. Color fonts
    2. Emojis
  13. Animation and Keyframing
    1. Adding, navigating, and setting keyframes
    2. Animating effects
    3. Use Motion effect to edit and animate clips
    4. Optimize keyframe automation
    5. Moving and copying keyframes
    6. Viewing and adjusting effects and keyframes
  14. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  15. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Color Settings
    3. Auto Color
    4. Get creative with color using Lumetri looks
    5. Adjust color using RGB and Hue Saturation Curves
    6. Correct and match colors between shots
    7. Using HSL Secondary controls in the Lumetri Color panel
    8. Create vignettes
    9. Looks and LUTs
    10. Lumetri scopes
    11. Display Color Management
    12. Timeline tone mapping
    13. HDR for broadcasters
    14. Enable DirectX HDR support
  16. Exporting media
    1. Export video
    2. Export Preset Manager
    3. Workflow and overview for exporting
    4. Quick export
    5. Exporting for the Web and mobile devices
    6. Export a still image
    7. Exporting projects for other applications
    8. Exporting OMF files for Pro Tools
    9. Export to Panasonic P2 format
    10. Export settings
      1. Export settings reference
      2. Basic Video Settings
      3. Encoding Settings
    11. Best Practices: Export faster
  17. Collaborative editing
    1. Collaboration in Premiere Pro
    2. Get started with collaborative video editing
    3. Create Team Projects
    4. Add and manage media in Team Projects
    5. Invite and manage collaborators
    6. Share and manage changes with collaborators
    7. View auto saves and versions of Team Projects
    8. Manage Team Projects
    9. Linked Team Projects
    10. Frequently asked questions
  18. Long form and Episodic workflows
    1. Long Form and Episodic Workflow Guide
    2. Using Productions
    3. How clips work across projects in a Production
    4. Best Practices: Working with Productions
  19. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  20. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Consolidate, transcode, and archive projects
    8. Managing metadata
    9. Best Practices
      1. Best Practices: Learning from broadcast production
      2. Best Practices: Working with native formats
  21. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset and restore preferences
    3. Recovery Mode
    4. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    5. Check if your system is compatible with Premiere Pro
    6. Premiere Pro for Apple silicon
    7. Eliminate flicker
    8. Interlacing and field order
    9. Smart rendering
    10. Control surface support
    11. Best Practices: Working with native formats
    12. Knowledge Base
      1. Known issues
      2. Fixed issues
      3. Fix Premiere Pro crash issues
      4. Unable to migrate settings after updating Premiere Pro
      5. Green and pink video in Premiere Pro or Premiere Rush
      6. How do I manage the Media Cache in Premiere Pro?
      7. Fix errors when rendering or exporting
      8. Troubleshoot issues related to playback and performance in Premiere Pro
  22. Extensions and plugins
    1. Installing plugins and extensions in Premiere Pro
    2. Latest plugins from third-party developers
  23. Video and audio streaming
    1. Secure Reliable Transport (SRT)
  24. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

Manage media easily in Premiere Pro, even in complex projects! Use powerful search options like metadata-based Search Bins and the handy Timeline Search.

An important post-production task is locating and managing your media clips and assets.

Premiere Pro provides several search options to help find you media files easily even in complex projects, making you spend less time on searching and more time on editing.

Search options in Premiere Pro

Find dialog

You can use the Find dialog in Premiere Pro to search for items in a project. You can specify the search criteria to be a single property or a combination of properties.

You cannot, however, save the searches that you perform using the Find dialog. That is, once you clear the search criteria, you lose the search results.

Search Bins

Premiere Pro provides Search Bins that offer powerful metadata searching capabilities. When you search for items in the Project Panel, you can associate a Search Bin with your search query. The search results stay up to date with items that meet the search criteria.

Search in Timeline

Timeline Search is an invaluable time saver that lets you manage complex Timelines more easily. You can find and select clips within a sequence based on specific search criteria.

Find assets using the Find dialog

The FInd dialog lets you perform both simple and detailed searches. You can locate any assets in your project that meet criteria you specify. For example, you can search for a video clip that has a certain word in its Name column and a phrase in its Comment column.

  1. Do one of the following:
    • Click the Find icon (magnifying glass) at the bottom of the Project panel.
    • Select the Project panel, and press Ctrl + F (Windows), or Command + F (Mac OS).
  2. In the Find dialog box, select the name of the columns to search from the menus under Column.
  3. Select the appropriate operators from the menus under Operator.
  4. Type in the characters you want to find in the specified columns in their respective Find What fields.
  5. If you’re searching for two criteria simultaneously, do one of the following:
    • To find assets that match both criteria, select All from the Match menu.
    • To find assets that match either criteria, select Any from the Match menu.
    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  6. Click Find.

Find assets using Search Bins

You can create a Search Bin that displays a collection of project items matching your search criteria. Search Bins are updated automatically when importing assets, deleting assets, or modifying asset metadata.

Search Bins appear in the Project panel like other regular bins, and are denoted by the Search Bin icon .

Note:

Search Bins display aliases of the original project items and not copied media, so no media duplication occurs.

Create a Search Bin

  1. Do one of the following:

    • Select New Search Bin from the Project panel's pop-up menu or context menu.
    • Select File > New > Search Bin.
  2. In the Search Bin dialog, enter the search criteria in the Find field.

  3. In the Search Bin dialog, you can search across all the metadata used in your project or restrict your search to specific metadata properties.

Important notes about Search Bins

  • If a project item appearing in a Search Bin is deleted from the project. Or, if metadata is changed that causes an item to no longer match the Search Bin's search criteria, the item is removed from the Search Bin.
  • When you specify a single metadata property, the search is restricted only to clip metadata. When you select the following metadata properties, you can search across both clip and file metadata.
    • Name
    • Tape Name
    • Description
    • Comment
    • Log Note
    • Scene
    • Shot
    • Client

Save a search query as a Search Bin

To create a Search Bin from a search query, follow these steps.

  1. Enter your search query in the Search field of the project panel.

    Note:

    As you type each new letter in the search query, the search results update dynamically.

  2. Click the Search Bin icon next to the Search field.

The name of the Search Bin that is created matches the entered search query.

A. Type search query B. Click to create Search Bin from query C. Search Bin displaying assets matching search criteria 

Rename a Search Bin

To rename a Search Bin, right-click (Win) or Ctrl-click (Mac) the Search Bin, and select Rename. The new name that you enter does not change the search criteria of the Search Bin.

Revise the contents of a Search Bin

You cannot modify the contents of a Search Bin like other regular bins in the Project panel. You need to revise the search criteria of a Search Bin to change its contents.

  1. In the Project panel, select Edit Search Bin from the context menu of the Search Bin.
  2. In the Edit Search Bin dialog, revise the search criteria as required.
  3. Click OK after specifying the revised search criteria.

Delete a Search Bin

To delete a Search Bin, select the Search Bin to delete, and select Clear from the context menu. You can drag the Search Bin to the Trash icon , or simply press Delete on your keyboard.

Note:

Deleting a Search Bin deletes only the aliases of the project items and not the original project items.

Find assets using Timeline Search

Timeline Search provides you advanced search options that let you easily find and manage clips in complex Timelines.

With a Timeline panel active, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).

The Find dialog that appears is similar to the Project panel's Find dialog. You can find and select clips within a sequence based on a a single property, like clip name, marker name, or use a combination of properties.

  1. In the Find dialog box, select the name of the columns to search from and the appropriate operators.

  2. Type in the characters you want to find in the specified columns in their respective Find fields.

    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  3. Click Find or press Enter on the keyboard. Premiere Pro selects and moves the playhead to the clip on the Timeline and closes the Find dialog.

  4. To find the next instance of clip matching the search criteria, select Edit > Find Next. The playhead moves to next clip in the Timeline matching the search criteria and selects it.

Find and select all clips in a sequence matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Enter the search criteria.
  3. Press Find All.

Premiere Pro closes the Find Dialog, moves the playhead to the first matching clip, and selects all matching clips.

Find a sequence marker with text matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Select Markers from the Search pop-up menu, and enter the search criteria in the Find field.
  3. Click Find or press Enter on the keyboard. Premiere Pro closes the Find dialog and moves the playhead to the first marker matching the search criteria.
  4. Select Edit > Find Next to move the playhead to the next marker matching the search criteria.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online