Lees wat u kunt doen als het plakken van illustraties langzaam verloopt of u onverwachte gegevens in uw Adobe Illustrator-documenten vindt.

Probleem

Wanneer u illustraties in Illustrator-bestanden plakt, wordt de bewerking veel trager uitgevoerd dan verwacht, of er zijn veel onverwachte globale objecten in het doeldocument (bijvoorbeeld stalen, symbolen en penselen).

Oplossingen

Probeer een of meer van de volgende oplossingen, afhankelijk van de versie van Illustrator die u gebruikt.

Kies uw versie van Illustrator:

Beschadigde namen van globale objecten in invoegtoepassing repareren (Mac en Windows; CS6 en CC)

  1. Zorg ervoor dat u de meest recente versie van Illustrator gebruikt. Kies Help > Updates of werk Illustrator bij via de Creative Cloud-desktopapp.

  2. Download het volgende ZIP-bestand en pak het ingesloten script uit (JSX-bestand).

    Downloaden

  3. Start Illustrator en voer het script uit: kies menu Bestand > Scripts > Andere Scripts of sleep het script naar Illustrator. Het volgende bericht wordt weergegeven: “fixBadPluginGlobalObjectNames-voorkeur is INGESCHAKELD”.

  4. Herhaal het script als dit bericht verschijnt: “fixBadPluginGlobalObjectNames-voorkeur is UITGESCHAKELD".

  5. Sluit Illustrator, start de toepassing opnieuw en open vervolgens het Illustrator-bestand om te controleren of het is hersteld.

Oplossingen voor CS5 en eerder

Voor het oplossen van het probleem met Illustrator CS5 en eerder is een van de twee volgende oplossingen vereist. Als de eerste oplossing niet helpt, probeert u dan de tweede oplossing.

Oplossing 1 (CS5 en eerder): inhoudsherstelmodus activeren 

  1. Sluit Illustrator.

  2. Zoek het voorkeurenbestand voor Adobe Illustrator. De voorkeurenbestanden voor Illustrator CS5 kunt u bijvoorbeeld hier vinden:

    • Mac OS: /[gebruiker]/Library/Preferences/Adobe Illustrator CS5 Settings/[taal]/
    • Windows 7/vista: Gebruikers/[gebruiker]/AppData/Roaming/Adobe/Adobe Illustrator CS5 Settings/[taal] /AIPrefs
    • Windows XP: Documents and Settings/[gebruiker]/Application Data/Adobe/Adobe Illustrator CS5 Settings/AIPrefs

    Opmerking:

    In Windows zijn de Application- en AppData-bestanden standaard verborgen. Als u hulp nodig hebt met het weergeven van verborgen bestanden, raadpleegt u Verborgen bestanden weergeven.

  3. Open het voorkeurenbestand in een eenvoudige teksteditor, zoals TextWrangler (Mac OS) of Kladblok (Windows). (U kunt ook een traditionele tekstverwerkingstoepassing gebruiken. In dit geval moet u het bestand echter opslaan zonder opmaak en geen verborgen TXT-extensie toestaan.)

  4. Zoek in het voorkeurenbestand de sectie op die er ongeveer als volgt uitziet:

    /aiFileFormat {

    /PDFCompatibility 1

    /enableATEReadRecovery 0

    /enableContentRecovery 0

    /enableATEWriteRecovery 0

    /clipboardPSLevel 3

    }

  5. Wijzig de waarde van enableContentRecovery van 0 in 1. Als het gedeelte /aiFileFormat geen regel bevat voor enableContentRecovery, voegt u deze toe. Na uw bewerking ziet de sectie er als volgt uit:

    /enableContentRecovery 1

  6. Sla het voorkeurenbestand op zonder de naam of extensie te wijzigen.

Oplossing 2 (CS5 en eerder): het herstelde bestand bewerken 

  1. Start Illustrator.
  2. Als u het document wilt openen, kiest u Bestand > Openen of drukt u op Command+O.

    Open het document niet door erop te dubbelklikken, via de lijst met Recent geopende bestanden of door het bestand op het pictogram van de Illustrator-app te slepen.  

  3. Selecteer het bestand dat u wilt herstellen in het dialoogvenster voor bestandsnavigatie.

  4. Druk op Command+Option+Shift (Mac OS) of Ctrl+Alt+Shift (Windows) en klik vervolgens op Openen in het dialoogvenster Openen.

  5. Sluit het geopende lege venster zonder het op te slaan.

  6. In Finder (Mac OS) of Windows Verkenner (Windows) zoekt u in dezelfde map als die van het oorspronkelijke bestand een kopie van het bestand dat door een onderstrepingsteken wordt voorafgegaan. Als u bijvoorbeeld BrokenFile.ai hebt geopend, ziet u een nieuw bestand: _BrokenFile.ai.

  7. Open het bestand met het onderstrepingsteken in een editor voor tekst zonder opmaak, zoals TextWrangler (Mac OS) of UltraEdit (Windows). (Windows-gebruikers moeten ook Kladblok of WordPad kunnen gebruiken). Als het beschadigde bestand groot is, kan het even duren voordat deze is geopend. Als uw teksteditor een maximumgrens heeft voor de grootte van bestanden die kunnen worden geopend, kiest u een andere teksteditor.

  8. In het onderstreepte bestand zoekt u naar de volgende exemplaren:

    %AI8_BeginPluginObject

  9. Bekijk de volgende regel om te zien of deze overeenkomt met een van de volgende tekenreeksen:
    (Adobe Calligraphic Brush Tool)
    (Adobe Scatter Brush Tool)
    (Adobe ArtOnPath Brush Tool)
    (Adobe Pattern Brush Tool)

  10. Als de regel niet precies overeenkomt met een van deze vier tekenreeksen (inclusief hoofdletters/kleine letters), selecteert u alle tekst in de%AI8_BeginPluginObject-opmerking en de eerstvolgende %AI8_EndPluginObject-opmerking. Vervolgens verwijdert u de opmerkingen en de selectie.

  11. Herhaal stap 9 en 10 voor elke instantie van de %AI8_BeginPluginObject-opmerking in het bestand.

  12. Sla het bestand op.
  13. Open het bestand in Illustrator.
  14. Verwijder alle symbolen en vervolgens alle penselen. Of, als u vermoedt dat het bestand overbodige symbolen of penseelstreken bevat, voert u de opdracht uit om ongewenste vensteritems te verwijderen (kies Acties > Ongebruikte vensteritems verwijderen en klikt op Huidige selectie afspelen).  

  15. Sla het bestand onder een nieuwe naam op (bijvoorbeeld 'HersteldBestand.ai').

  16. (Belangrijk) Sluit het bestand.

  17. Open het bestand weer in Illustrator. Verifieer of het bestand is hersteld door een object te selecteren, te kopiëren en in een nieuw leeg bestand te plakken.

Aanvullende informatie

Onverwachte inhoud wordt veroorzaakt door problemen van oudere versies van Illustrator die in de huidige versie zijn opgelost. Wanneer u werkt met een document dat in een vorige versie van Illustrator is opgeslagen, kunt u het probleem mogelijk niet oplossen door het bestand in de huidige versie te openen.

Er kunnen in de desbetreffende deelvensters mogelijk onverwachte globale objecten worden weergegeven. Pogingen om onverwachte globale objecten te verwijderen, kunnen mislukken of ertoe leiden dat Illustrator onstabiel wordt en plotseling wordt afgesloten.

Als u het document opslaat, wordt het aanzienlijk groter wegens de hoeveelheid globale objecten die zijn toegevoegd. Deze ongeldige gegevens kunnen lang in een document voorkomen voordat ze worden gedetecteerd. Het probleem wordt dus niet altijd opgelost door het document in een vorige versie te openen. De ongeldige gegevens kunnen zich verspreiden wanneer u illustraties van het ene naar het andere document kopieert.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid