Design and create prototypes faster in Adobe XD using these tips and tricks.

Here are a few tricks to help you while using Adobe XD CC.

General tips and tricks

  • Rather than copy and pasting groups of items in your design, consider using the Repeat Grid tool (available in the Property Inspector).
  • You can duplicate a shape by selecting it, holding the Option key (on Mac), or Alt key (on Windows) and dragging a new copy of it.
  • Elements can be locked with Object > Lock (or Cmd + L) on Mac. This actually toggles lock, so use the same command to unlock the elements. On Windows, right-click an object and select Lock from the context menu.
  • Enable direct selection by holding the Cmd or Ctrl key. This allows you to select nested objects.
  • Quickly mask by dropping an image onto a shape: the shape’s fill becomes the image.
  • Create an editable mask by importing an image, and then draw a shape over it. Select both and then choose Object > Mask with Shape (on Mac), or right-click the objects and choose Mask with Shape from the context menu. You can edit the mask or the image later by double-clicking on the masked group.

Drawing and Text

  • You can turn the snap guides off by holding down the Cmd / Ctrl key.
  • Double-click any anchor point to toggle between a curve and an angle.
  • Press Opt/Alt while dragging a curve handle to make the curve handle independent. (To make them dependent again, double click to return to an angle, then double click again).
  • You can select anchor points when you draw using the pen tool.
  • Double click to enter a group’s edit context (you can add elements in this context), or simply Cmd /Ctrl click an object inside a group to select it.
  • Select a text item, then create a new one to apply all the styles from the first item to the second.
  • Path combinations (Add/Subtract/Intersect/Exclude Overlap) are nondestructive. You can toggle them on and off.

Importing content

  • To bring in content from Illustrator, select the vector shape in Illustrator, copy and then paste into Adobe XD.
  • To bring in bitmap content from Photoshop, select all (Cmd+A or Ctrl + A) in a bitmap or text layer (or first convert a vector layer or group to a Smart Object), copy, and then paste it in Adobe XD. The pasted layer will be a bitmap. You can also copy content from Photoshop by making a selection using the marquee tool. Then, from the menus, choose Edit >Copy (to get the selection on the current layer), or Edit > Copy Merged (to get the selection on all the layers within your selection).
  • To bring in content from Sketch, select one or more layers or groups, and click Make Exportable. Choose SVG as the format, and drag and drop the layer from Sketch into Adobe XD. This gives you editable vector content in Adobe XD.
  • To import assets (PNG, JPG, TIFF, GIF, SVGs), on Mac, you can use File > Import, or drag and drop, or copy and paste images into Adobe XD from Finder.
    On Windows, click the Hamburger menu and click Import, or drag and drop, or copy and paste images from File Explorer.
    You can also copy and paste from the browser to Adobe XD.

Keyboard controls

  • When adjusting corner radius you can hold down the OPTION key to restrict the adjustment to a single corner.
  • To temporarily disable snapping when moving or resizing elements, hold down the Cmd or Ctrl key.
  • Hold the SHIFT key while resizing an element to maintain the aspect ratio of the element.
  • Hold ALT while drawing a shape to draw from center rather than the default (which is in the top left corner).
  • To quickly change the opacity of a selected item, hit the following number keys. Here, 1= 10%, 2 = 20%, and so on; 0 = 100%.
  • When nudging a shape or control point using the arrow keys, hold down the SHIFT key to nudge by 10 px.
  • Hold down the SPACEBAR to engage the hand mode. You can click and drag to span through the canvas.

Artboards

  • To select an artboard, click the art board title, Cmd / Ctrl + Click on its background, or double click on its background.
  • To select an empty artboard, click on the background of the artboard.
  • To duplicate an artboard (and its contents), select the artboard, and press Cmd (on Mac) or Alr (on Windows) while dragging to make a copy.
  • To rename an artboard, double click on its title.

Repeat Grid

  • To adjust padding between repeating items in a Repeat Grid, select the repeat grid, then mouseover the space between elements, and drag. If you are editing an item within the repeat grid, you need to press ESCAPE to exit the editing mode.

Prototyping and Preview

  • Select any object on an artboard (or the whole artboard) and drag a wire to trigger an interaction between artboards.
  • Drag a wire off of a destination to unwire an interaction that you have set.
  • Use the Dissolve transition when designing for web.
  • You can see all the connections between your artboards (except those that are triggered directly from artboards) by pressing Cmd + A (on Mac) or Ctrl + A (on Windows)  in the Prototype mode.
  • The Preview window displays the artboard that has the current selection. If there is no selection, the Preview window opens with the Home artboard first.
  • You can record a video from the Preview window of your interactive prototype. Click on the record icon on the title bar to begin a video.
  • Clicking on the record button again OR press ESC to stop a video recording.

Sharing

  • In order to share, you must be logged in with an Adobe account to either the Adobe Creative Cloud desktop app or any other Adobe application (such as Photoshop, Illustrator, and so on).
    Adobe IDs, Enterprise IDs, and Federated IDs are all supported.
  • If you share your design file without first adding interactions, all your artboards are uploaded and users will be able to navigate using the keyboard arrow keys. The order of your artboards will be from the top left and move to the right.
  • If your design includes interactions, only those artboards connected to the Home artboard will be uploaded and shared.
  • The artboard defined as your Home artboard is the first artboard users see when they view your shared design.
  • You can change the Home artboard by selecting the Home artboard icon next to the artboard, in the prototype mode. This Home artboard icon shows up only for artboards which are selected (or the destination of a selected target).
  • When viewing a prototype in a mobile web browser, you can save a shortcut to it on the device’s home screen. This makes the prototype feel more like a native application when presenting it.

Този материал е лицензиран под лиценз Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  Публикациите в Twitter™ и Facebook не попадат под клаузите на Creative Commons.

Правни бележки   |   Правила за онлайн поверителност