Otimizar resultados usando o Traçado de imagem

Saiba como vetorizar imagens baseadas em pixels automaticamente no Illustrator usando o Traçado de imagem.

Artigo escrito por: Monika Gause

Monika Gause é uma designer de comunicação freelance, escritora técnica e professora em Hamburgo, Alemanha. Gráficos vetoriais têm sido uma constante em sua carreira, que a levou da editoração eletrônica para multimídia, Web design e, atualmente, escrita. Criou animações 3D para museus, elaborou sites de pequenas empresas e ilustrou inúmeros itens de escritório. Como professora e ACP nos fóruns da Adobe, ela adora mergulhar nos fluxos de trabalho e problemas de seus clientes e participantes do fórum e desenvolver soluções para eles.

Com a função Traçado de imagem, você pode vetorizar imagens baseadas em pixels automaticamente no Illustrator. As pessoas geralmente chamam esse tipo de função de traçado automático. Os resultados dependem da natureza, qualidade e tamanho da imagem de origem e as configurações escolhidas no Illustrator. Portanto, para obter bons resultados, você precisa começar pela imagem de origem. 

Preparar arquivos para o Traçado de imagem

Dedique um pouco de tempo para otimizar as imagens para o traçado, assim elas serão processadas melhor e mais rapidamente, pois é difícil editar o resultado após traçá-las.  

É importante excluir tudo que não for necessário nas imagens usando um aplicativo de edição de imagens. Remova imperfeições. Se houver um fundo colorido (incluindo uma cor fraca de papel) e você quiser deixá-lo branco, é melhor removê-lo usando um editor de imagens. É importante isolar retratos caso deseje traçá-los como uma ilustração estêncil de cor única (o estilo icônico do Che Guevara). 

Isolar o objeto do fundo
Isolar o objeto do fundo

Embora o Traçado de imagem não funcione tão bem para imagens de 1 bit, ele funciona muito bem para imagens em tons de cinza. Além disso, ao otimizar rascunhos, pinceladas, lettering ou semelhantes, deixe um pouco de suavização de serrilhado nos contornos da ilustração. O Traçado de imagem funcionará melhor e produzirá curvas mais suaves. 

Preparação de uma imagem com a função de níveis no Photoshop: com suavização de serrilhado nos contornos (superior) versus sem suavização de serrilhado (inferior)

A função Traçado de imagem exibe avisos sobre o tamanho da imagem quando ela tem mais de 1.500 pixels de largura ou altura, mas funciona do mesmo jeito, embora mais lentamente. 

Aviso de imagem grande
Aviso de imagem grande

Salve suas ilustrações gráficas otimizadas sem compactá-las em formatos com perda de dados, como PNG, TIF ou PSD. Para fotos, recomendo JPEG.

Inserir arquivos no Illustrator e aplicar o recurso  

As etapas para aplicar a função a uma imagem rasterizada são as mesmas para todos os tipos de imagem.

  1.  No Illustrator, crie um novo arquivo no modo de cores e tamanho desejados para o documento. 

  2. Arraste a imagem de origem do Finder no macOS ou Explorador no Windows para o aplicativo ou selecione Arquivo > Inserir para importá-la. Para a função de traçado automático, não faz diferença se você incorporou ou vinculou o arquivo. Não marque a opção Modelo ao inserir o arquivo, pois isso inserirá o arquivo em uma camada bloqueada.

  3. Selecione a imagem de origem e abra o painel Traçado de imagem em Janela > Traçado de imagem. Você também pode selecionar uma predefinição no Painel de controle (selecionando-a no menu pequeno à direita do botão Traçado) ou no painel Propriedades (clicando no botão Traçado de imagem e selecionando-a no menu). 

    O menu de predefinições no Painel de controle  

    O botão Traçado de imagem na seção Ações rápidas do painel Propriedades abre o menu de predefinições

    Ao fazer isso, a predefinição é aplicada imediatamente à imagem e ela é traçada. Pode haver lentidão enquanto o Illustrator trabalha.

    Todas as predefinições podem ser ajustadas no painel Traçado de imagem, o que é uma boa ideia. Caso ainda não tenha feito isso, você pode abrir o painel Traçado de imagem clicando no botão no Painel de controle ou na seção Traçado de imagem do painel Propriedades. 

    Para obter informações detalhadas sobre as predefinições que podem ser usadas para gerar um traçado de imagem de boa qualidade, consulte Predefinições de traçado de imagem.

O que fazer se o comando Traçado não estiver ativo? 

O comando Traçado de imagem pode não estar ativo pelos seguintes motivos:

  • A imagem precisa ser selecionada. Selecione a imagem que deseja traçar clicando nela com a ferramenta Seleção.
  • Se não for possível, verifique se a camada ou a própria imagem estão bloqueadas.
  • Se tudo estiver desbloqueado, verifique se a imagem selecionada é um grupo de corte. Caso afirmativo, selecione Objeto > Máscara de corte > Liberar. Depois, exclua a máscara e selecione a imagem. Isso pode acontecer ao copiar/colar a imagem de outro aplicativo pela área de transferência. 
Máscara de corte (exibida como Grupo de corte) no Painel de controle (esquerda) e no painel Propriedades (direita)  

Qual a diferença entre o Traçado de imagem e o traçado em tempo real?

O recurso Traçado de imagem inclui a maioria das opções do traçado em tempo real, mas elas foram implementadas de maneira diferente. As opções de otimização da imagem de origem no lado esquerdo do painel Traçado de imagem, como o desfoque, foram integradas à função e são aplicadas automaticamente com base na análise da imagem. 

Limitações

O Traçado de imagem não é o melhor método recomendado caso deseje vetorizar as seguintes imagens:

  • Formas geométricas: quando precisar traçar um logotipo, ícone, símbolo ou semelhantes que possuem formas geométricas exatas, como triângulos, hexágonos ou até mesmo linhas retas, é melhor fazer isso manualmente. Humanos podem reconhecer essas formas até mesmo em um JPEG mal compactado ou em um papel amassado. Já o software enxerga apenas um monte de pixels, mesmo em arquivos de origem de alta qualidade. 
  • Texto: quando precisar vetorizar texto, é sempre recomendado identificar a fonte, por exemplo, usando o Adobe Capture ou o Adobe Photoshop, para depois usar a fonte em questão para compor o texto. Para textos longos, você pode usar o reconhecimento óptico de caracteres (OCR) do Adobe Acrobat para criar um arquivo de texto. Depois de compor e formatar no Illustrator, contorne o texto se necessário (como para corte de vinil ou geralmente antes de enviar os logotipos).
  • Fotos: usar o traçado automático para conseguir aumentar as fotos geralmente não dá certo. Os pixels na sua imagem só podem ser transformados em formas. Em um tamanho pequeno não é possível enxergar, mas quando a imagem é ampliada, essas formas ficam maiores. Assim como pixels. 
Foto traçada (esquerda), ampliada (centro), exibição de contorno (direita)
Foto traçada (esquerda), ampliada (centro), exibição de contorno (direita)

  • Gradientes: a função não pode gerar degradês. Eles são convertidos em formas vizinhas de cores sólidas.
Os degradês são convertidos em formas de cor única e sólida
Os degradês são convertidos em formas de cor única e sólida

  • Ilustração detalhada: os detalhes das ilustrações quase sempre são perdidos, pois é preciso encontrar um equilíbrio entre resultados exatos e caminhos suaves. Na maioria das vezes, caminhos suaves são mais importantes que detalhes, e não é possível ter caminhos suaves em uma parte da imagem e detalhes em outra.
    Não espere obter uma ilustração vetorial de alta qualidade a partir de um GIF pequeno que mal pode ser visto utilizando o traçado automático.
Um GIF de 70 x 70 pixels (esquerda: origem) não pode ser melhorado com o traçado automático (direita: resultado)

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online