Saiba como solucionar os problemas que podem ocorrer ao imprimir ou exportar para PDF do InDesign.

Trabalhe com as tarefas neste documento na ordem, parando quando você tiver solucionado o problema.

Você também pode encontrar os problemas e soluções de impressão e exportação em https://helpx.adobe.com/br/indesign.html.

Determinar o nível do problema

Ao tentar resolver um problema de impressão ou de exportação, a primeira etapa é determinar as condições sob as quais o problema ocorre. Por exemplo, o erro foi um problema on-line, ou ele pode ser reproduzido
de forma consistente ao imprimir ou exportar todos os documentos, alguns documentos ou um documento específico? As etapas e testes abaixo o ajudarão a definir como e quando seu problema ocorre, para que uma solução possa ser encontrada.

1. Reiniciar seu computador.

Se o erro não voltar a ocorrer, problemas de comunicação temporários, poucos recursos do sistema ou outros fatores ambientais temporários podem ser a causa. Se você puder imprimir ou /exportar sem erros após primeiro reiniciar o computador, mas o erro ocorre novamente mais tarde, solucione o problema no nível do sistema.

2. Ligar e desligar sua impressora.

Se o erro não voltar a ocorrer, problemas com a memória da impressora pode ser a causa do problema. Se o erro voltar a ocorrer, siga para a etapa 3.

3. Criar um novo documento de amostra.

Se você puder imprimir ou exportar um novo documento, mas não o documento original, solucione o erro no nível do documento.

4. Imprimir ou exportar usando um aplicativo diferente.

Se você puder imprimir de outro aplicativo (por exemplo, WordPad, TextEdit), ou exportar/salvar como PDF de outro aplicativo (por exemplo, Illustrator, Photoshop), solucione o problema no nível do aplicativo.

5. Imprima em uma impressora diferente.

Se outra impressora estiver disponível, tente imprimir o documento naquela impressora. Se isso funcionar, certifique-se de que a impressora original esteja ativada e on-line. Remova e reconecte os cabos da impressora, e, a seguir, execute um autoteste na impressora para verificar a existência de falhas mecânicas ou cabos danificados. Se nenhuma destas etapas identificarem o problema, solucione o erro no nível do sistema.

6. Use um método diferente para criar o arquivo PDF.

  • Se o problema ocorrer ao exportar para o formato PDF do InDesign para Acrobat Standard, Pro ou Pro Extended, tente imprimir para a impressora Adobe PDF. (Se você estiver usando o Mac OS v10.6 ou posterior com o Acrobat 9, consulte Suporte para salvar o Acrobat 9 como Adobe PDF.)
  • Se o problema ocorrer quando você usar a função Imprimir para criar seu arquivo PDF, escolha Arquivo > Exportar para PDF.

Solução de problemas de impressão ou exportação no nível do documento

Se o erro não ocorrer quando você imprimir ou exportar um novo documento, as configurações de impressão ou exportação do documento original podem ser inválidas, um determinado objeto ou fonte usado no documento pode estar danificado ou a estrutura do documento pode estar danificada. Tente uma ou mais das seguintes etapas.

Observação:

Dependendo da impressora que você usa, os locais das configurações podem variar e podem ser diferentes do que está listado nos procedimentos a seguir. Verifique a documentação da sua impressora.   

1. Exportar para IDML (InDesign CS4 e posterior) ou INX (InDesign CS3 e anterior).

O documento pode estar danificado. Documentos danificados são especialmente comuns depois de serem convertidos de uma versão anterior do InDesign ou de um documento QuarkXPress. Exportar para IDML (InDesign Markup Language) ou o para o formato InDesign Interchange (INX) pode eliminar dados problemáticos.

2. (Somente Impressoras PostScript) Ative a manipulação de erro de PostScript.

Windows

  1. Escolha Arquivo > Imprimir.
  2. Clique no botão Configurar.
  3. Se a seguinte caixa de diálogo for exibida, clique em OK: “Se a configuração de impressão desejada estiver disponível na caixa de diálogo Imprimir do InDesign, defina a configuração para evitar conflitos de impressão”.
  4. Clique com o botão direito do mouse na impressora e escolha Propriedades.
  5. Na guia Geral, clique em Preferências de impressão.
  6. Clique em Avançado.
  7. Expanda as Opções do documento e, a seguir, expanda as Opções de PostScript. Se Enviar manipulador de erro de PostScript não estiver definido como Sim, clique nele e escolha Sim no menu suspenso.

Mac OS X

  1. Escolha Arquivo > Imprimir.
  2. Clique na impressora.
  3. Escolha Manipulação de erro no menu abaixo do menu Predefinições.
  4. Selecione Imprimir relatório de detalhado e, a seguir, clique em Imprimir.

Se um erro de PostScript estiver causando o problema, o manipulador de erros de PostScript imprimirá uma página com informações do erro. Consulte Solução de problemas de erros de PostScript.

3. Excluir gráficos do documento.

Excluir os gráficos quando você for imprimir o documento

  1. Escolha Arquivo > Imprimir.
  2. Clique em Gráficos e, a seguir, escolha Nenhum no menu Enviar dados.
  3. Clique em Imprimir.

Excluir os gráficos quando você for exportar o documento

  1. Escolha Arquivo > Exportar e selecione Adobe PDF (Imprimir) como o formato ou “Salvar como tipo”.
  2. Escolha um local e clique em Salvar.
  3. Clique em Avançado e selecione todas as três caixas de seleção de omitir para OPI: EPS, PDF e Bitmap.
  4. Alterar o padrão PDF para Nenhum para permitir a exclusão das imagens.
  5. Clique em Exportar.

Se o documento imprimir/exportar com êxito, um ou mais dos elementos gráficos na página podem estar danificados. Remova 50% dos gráficos, excluindo páginas ou quadro de gráficos em uma única página. A seguir, imprima ou exporte o documento após cada alteração para determinar se o gráfico danificado do grupo removido esteja causando o erro. Se o documento imprimir/exportar após uma alteração, reverta a alteração e remova os outros 50% das páginas/gráficos remanescentes. Confirme se o erro ocorre novamente, a seguir, exclua 50% novamente e assim por diante. Uma vez identificado os gráficos que produzem o erro sistematicamente, exclua e substitua-os. Você poderá precisar reexportar um gráfico do aplicativo no qual ele foi criado.

Uma tarefa de impressão bem sucedida sem os gráficos também pode indicar memória inadequada da impressora. Os sintomas incluem as fontes que estão sendo substituídas, gráficos ausentes ou impressões incompletas. Tente imprimir em intervalos de páginas ou simplifique a publicação para ver se ela imprime com menos gráficos. Ou tente imprimir em uma resolução mais baixa.

Observação:

Se o documento contiver somente elementos gráficos, você receberá uma página em branco ao imprimir somente se a opção para imprimir páginas em branco estiver ativada no InDesign. Selecione Imprimir páginas em branco na seção Geral da caixa de diálogo Imprimir.

4. Excluir ou minimizar fontes.

Excluir fontes ao você imprimir

  1. Escolha Arquivo > Imprimir.
  2. Clique em Gráficos.
  3. Na seção Fontes, escolha Nenhuma no menu Download.
  4. Clique em Imprimir.

Minimizar fontes ao exportar para PDF

Não é possível excluir fontes durante a exportação, mas você pode minimizar o número de fontes usadas.

  1. Escolha Tipo > Localizar fonte.
  2. Na lista Fontes no documento, clique na primeira fonte, mantenha pressionada a tecla Shift e clique na última fonte para selecionar todas as fontes na lista.
  3. Em substituir por: na lista da família de fontes, escolha uma fonte que você sabe que funciona em outros documentos, como Arial ou Verdana.
  4. Clique em Alterar tudo.
  5. Clique em Concluído.
  6. Escolha Arquivo > Exportar e selecione Adobe PDF (Imprimir) como o formato.
  7. Escolha um local e clique em Salvar.
  8. Clique em Exportar.

Se o documento imprimir/exportar, o problema poderá estar relacionado a uma das fontes usadas no documento. Se o documento usar um número grande de fontes, excluir as fontes tornará o documento menos complexo. Salve o documento como um novo nome, e, a seguir, teste as fontes uma de cada vez para determinar se elas estão danificadas. Se uma fonte demonstra consistentemente um problema, verifique múltiplas instâncias ativas da fonte ou efetue novamente o download da fonte do fabricante para garantir a fonte não esteja corrompida.

5. Certificar-se de que os links sejam válidos.

Para visualizar o status dos vínculos, escolha Janela > Vínculos. Desvincule ou vincule quaisquer arquivos onde o nome do arquivo for precedido por um ponto de interrogação ou outro símbolo. Para obter mais informações sobre os vínculos do InDesign, consulte Gerenciar vínculos de gráficos.

6. Desativar as configurações.

Algumas vezes, os erros são resultados de uma determinada função no processo de impressão ou exportação, pois ele está manipulado conteúdo específico no documento. Elimine o maior número possível desses tipos de configurações. Se a
eliminação das configurações resolver o problema, ative-as novamente em grupos para isolar o problema para uma determinada configuração.

Observação:

Dependendo da impressora na qual você está usando, algumas das configurações podem não estar disponíveis.

Escolha Arquivo > Imprimir para abrir a caixa de diálogo Imprimir. A seguir, altere as seguintes configurações nos seguintes painéis:

Painel Geral

  • Defina cópias como 1.
  • Selecione Páginas para desativar Espalhadas.
  • Desmarque Imprimir páginas máster, Imprimir objetos não imprimíveis e Imprimir guias visíveis e eixos da linha base.
  • Defina as camadas de impressão como Camadas visíveis e imprimíveis.

Painel Instalação

  • Defina o tamanho do papel como Definido pelo driver.
  • Defina a largura e altura da escala como 100%.
  • Desative Miniaturas e Lado a lado.

Painel Marcas e Sangramento

  • Desative Marcas, Sangramento e Espaçador.

Painel Saída

  • Defina a cor como Deixar composto inalterado.
  • Desative Trapping,Texto como preto e Simular sobreimpressão.
  • No Gerenciador de tintas, desative Suavização de serrilhado de tinta.

Painel Gráficos

  • Defina as imagens como Enviar dados para nenhuma ou todas.
  • Defina as fontes como Download para nenhuma ou todas.
  • Defina PostScript como Nível 2.
  • Defina o formato dos dados como ASCII.

Painel Gerenciamento de cores

  • Selecione Tratamento de cor para Permitir que a impressora PostScript determine as cores.
  • Ative Preservar números CMYK.

Painel Páginas (fora da caixa de diálogo Imprimir)

Selecione todas as páginas, clique com o botão direito do mouse e escolha Atributos da página > Espalhada nivelada > Nenhum (Ignorar transparência).

7. Solução para problemas de plug-ins.

Remova plug-ins de terceiros da pasta Plug-ins do InDesign e, a seguir, reinicie o InDesign. Se o problema ocorrer novamente, mova os plug-ins de volta para a pasta Plug-ins do InDesign. Se o problema não ocorrer novamente, identifique plug-ins conflitantes:

  1. Escolha Ajuda > Configurar plug-ins (Windows) ou InDesign > Configurar plug-ins (Mac OS).
  2. Selecione Todos plug-ins para o conjunto e, a seguir, desmarque todas as opções na seção Exibição, exceto Terceiros. Crie uma lista destes plug-ins.
  3. Saia do InDesign e mova estes plug-ins para fora da pasta Plug-in:
    • Windows: /Program Files/Adobe/Adobe InDesign [Versão]/Plug-Ins
    • Mac OS: /Applications/Adobe InDesign [Versão]/Plug-Ins
  4. Reinicie o InDesign e tente recriar o problema.
    • Se o problema não voltar a ocorrer, repita as etapas 3 e 4, adicionando alguns plug-ins de terceiros de volta à pasta Plug-ins.
    • Se o problema ocorrer novamente, entre em contato com o desenvolvedor do último plug-in movido para verificar a existência de uma atualização.

Para obter mais informações, consulte Solução de problemas de plug-ins de terceiros do InDesign.

8. Imprimir ou exportar de uma nova conta de usuário.

Algumas vezes, uma conta de usuário pode ser corrompida e impedir que o aplicativo leia ou grave nos arquivos e pastas necessários. Crie uma nova conta de usuário (não exclua a original), efetue o login na nova conta e tente imprimir outra vez ou exportar o documento.

Windows

Escolha Iniciar > Painel de controle > Contas de usuário.

Mac OS X

Escolha o menu Apple > Preferências do sistema > Usuários e grupos.

9. Determinar se o documento está danificado.

Solução de problemas de impressão ou exportação no nível do aplicativo

Se você receber um erro ao imprimir qualquer documento do InDesign, tente uma ou mais das seguintes tarefas para identificar a causa do problema no nível do aplicativo.

1. Recriar seus arquivos de preferências do InDesign.

Quando o InDesign tiver um comportamento errático, a exclusão das preferências (também referidas como “colocar as preferências na lixeira” ou “remover preferências”) e a sua recriação com frequência soluciona o problema.

Há duas maneiras para recriar as preferências:

  • Automaticamente: esse método exclui rapidamente seus arquivos de preferências atuais e, a seguir, gera novamente um novo conjunto de arquivos de preferência padrão. No entanto, todas as configurações personalizadas que você possa serão perdidas.

-ou-

  • Manualmente: se você não quiser perder suas configurações personalizadas, renomeie seus arquivos de preferências atuais antes de gerar um novo conjunto de arquivos de preferência padrão. Dessa maneira, se as novas preferências não resolverem o problema de impressão ou exportação, você terá um backup dos arquivos de preferências originais (incluindo todas as configurações personalizadas), que podem ser usados para substituir os novos arquivos de preferências.

Recriar automaticamente os arquivos de preferências do InDesign

Observação:

A recriação dos arquivos de preferências do InDesign exclui os dados anteriores de preferência, incluindo todas as configurações personalizadas. Se você não quiser perder suas configurações personalizadas, recrie seus arquivos de preferências manualmente.

  1. Saia do InDesign.
  2. Reinicie o InDesign e imediatamente mantenha pressionadas as teclas apropriadas para o seu sistema operacional:
    • Mac OS: Control+Option+Command+Shift
    • Windows: Control+Alt+Shift
  3. Uma caixa de diálogo é exibida, perguntando se você deseja excluir os arquivos de preferências do InDesign. Clique em Sim. O InDesign é iniciado com as preferências padrão regeneradas.

Recriar manualmente os arquivos de preferências do InDesign

Renomeie os dois arquivos de preferências (por exemplo, altere “SavedData” para “SavedData Backup,” e “InDesign Defaults” para “InDesign Defaults Backup”). Os arquivos de preferências estão aqui localizados:

  • Mac OS X

    InDesign Defaults: 

    Users/[usuário]/Library/Preferences/Adobe InDesign/Version [versão]/[idioma]/InDesign Defaults

InDesign SavedData:

Users/[usuário]/Library/Caches/Adobe InDesign/Version [versão]/[idioma]/InDesign SavedData

  • Windows XP

    InDesign Defaults:

    /Documents and Settings/[usuário]/Application Data/Adobe/InDesign/Version [versão]/InDesign Defaults

Oculta por padrão. Saiba como exibir arquivos ocultos.

InDesign SavedData:

/Documents and Settings/[usuário]/Local Settings/Application Data/Adobe/InDesign/Version[versão]/Caches/InDesign SavedData

  • Windows 7 e 8

InDesign Defaults:

C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[idioma]\InDesign Defaults

Oculta por padrão. Saiba como exibir arquivos ocultos.

InDesign SavedData:

/Users/[uuário]/AppData/Local/Adobe/InDesign/Version[versão]/[idioma]/Caches/InDesign SavedData

Reinicie o InDesign. O InDesign cria um novo conjunto de arquivos de preferência padrão.

Se o seu problema de impressão ou de exportação persistir, poderá restaurar suas preferências originais ao renomear seus arquivos de preferências antigos de volta aos seus nomes originais: InDesign SavedData e InDesign Defaults.

2. (Somente Windows) Certifique-se de que seu driver de impressão esteja atualizado.

Instale o driver mais recente para sua impressora:

3. (Windows, somente impressora PostScript) Otimize o PostScript para velocidade.

  1. Escolha Arquivo > Imprimir.
  2. Clique em Configurar, selecione uma impressora, clique em Preferências e, a seguir, clique em Avançado.
  3. Expanda as Opções do documento e, a seguir, expanda as Opções de PostScript.
  4. Escolha Opção de saída PostScript.
  5. Escolha Otimizar para velocidade no menu suspenso e, a seguir, clique em OK.
  6. Clique em OK e, a seguir, clique em Imprimir.

4. Desativar a página de proteção em sua impressora.

Consulte a documentação que acompanha a impressora para obter instruções sobre como desabilitar este recurso.

5. Conectar seu computador à impressora.

Se o problema ocorrer ao imprimir em rede, conecte o computador diretamente à impressora e tente imprimir novamente.

Se você não puder se conectar diretamente à impressora, salve o documento como um arquivo PostScript. Usando o prompt de comando em um computador que possa estar diretamente conectado a uma impressora, envie o arquivo para a impressora. 

6. Salvar como PDF em um disco rígido local.

Se o problema ocorrer quando você exportar como PDF para um local de rede, tente salvar como PDF em um unidade de disco rígido local.

A instabilidade da rede ou questões de permissões poderão causar problemas ao exportar para volumes de rede montados. Se você puder exportar o arquivo para uma unidade local, mas não em um local de rede, entre em contato com o seu departamento de TI para investigar o problema.

Solução de problemas de impressão no nível da impressora

Resolver problemas de impressão para uma impressora PostScript

Se você estiver enfrentando problemas ao imprimir em uma impressora PostScript, tente uma ou mais das seguintes tarefas. Imprima o documento após cada uma das tarefas.

1. Use um driver de impressora atualizado.

Efetue o download do driver de impressora PostScript mais recente para Mac ou Windows.

Observação:

Se você usar uma impressora da rede, poderia usar um driver de impressão que seja compatível com o sistema operacional servidor de impressora mas não com o sistema operacional do seu computador. Para instalar um driver de impressora que seja compatível com seu sistema operacional, reconfigure a impressora de rede usando o Assistente para adicionar impressora. Consulte Instalar um driver de impressora que seja compatível com seu sistema operacional.

2. Use um arquivo PPD atualizado.

O arquivo Descrição da impressora PostScript (PPD) descreve as capacidades de uma impressora PostScript para configurações como margens, cor e resolução. Arquivos PPD incorretos ou desatualizados podem prolongar o tempo de impressão. Configure sua impressora com o arquivo PDF que o fabricante da impressora recomendar.

Para obter um arquivo PPD, entre em contato com o fabricante da impressora ou baixe-o do site da Adobe.

3. (Somente Windows) Defina o driver da impressora como código de saída PostScript otimizado.

Para o Windows 7:

  1. Escolha Iniciar > Dispositivos e impressoras.
  2. Clique com o botão direito do mouse e escolha Preferências de impressão > Avançado.
  3. Expanda as opções do documento e, a seguir, expanda as opções PostScript.
  4. Defina a opção de saída para PostScript como Otimizar para portabilidade.

4. Crie mais espaço livre em disco.

Certifique-se de que haja espaço livre suficiente disponível no disco rígido. Tente manter pelo menos 10 por cento do espaço total de seu disco rígido livre. Para criar mais espaço, localize e exclua os arquivos temporários (.tmp) no computador e limpe o cache de disco utilizado pelo seu navegador da Web. Para obter instruções sobre como limpar o cache do disco, consulte a documentação de seu navegador.

Para conhecer outros meios para liberar espaço em disco, consulte a documentação de seu sistema operacional (por exemplo, Dicas para liberar espaço da unidade em seu PC para Windows, ou Aumentar o espaço em disco para o Mac OS).

5. Imprima em uma impressora local.

Se você imprimir para uma impressora de rede, tente imprimir o arquivo de um computador que esteja conectado diretamente a uma impressora local. Se o arquivo imprimir corretamente, problemas relacionados à rede podem ser a causa. Entre em contato com o administrador de rede para obter ajuda.

6. (Somente Windows) Instale um driver de impressora que seja compatível com seu sistema operacional.

Se usar uma impressora de rede, instale um driver de impressora que seja compatível com seu sistema operacional. Servidores de impressão nem sempre fornecem drivers para sistemas operacionais em execução nos computadores cliente. Assim, você poderia estar usando um driver de impressora apropriado para o sistema operacional do servidor de impressão, mas não para o sistema operacional do seu computador.

Para o Windows 7:

  1. Escolha Iniciar > Dispositivos e impressoras.
  2. Clique em Adicionar um impressora.
  3. Selecione Adicionar uma impressora local.
  4. Escolha Criar uma nova porta > Porta local > Avançar.
  5. Insira o nome da porta (por exemplo,\\] [nome do servidor de impressão\ [nome da impressora]) e clique em OK.
  6. Siga as instruções na tela para instalar um driver que corresponda à marca e ao modelo de sua impressora de rede.

Resolver problemas de impressão para uma impressora não PostScript

Se você tiver problemas ao imprimir para uma impressora não PostScript, tente executar uma ou das seguintes tarefas. Imprima o documento após cada uma das tarefas.

Observação:

Algumas destas soluções requerem que você altere as propriedades do driver da impressora. Os locais para propriedades específicas variam dependendo da impressora e do driver da impressora. Entre em contato com o fabricante da impressora ou consulte a documentação da impressora para obter mais informações.

1. Imprimir como bitmap.

  1. Escolha Arquivo > Imprimir.
  2. Assegure que você tenha uma impressora não PostScript selecionada, e selecione o painel Avançado.
  3. Selecione a caixa de seleção Imprimir como bitmap e selecione uma resolução apropriada para sua impressora.

2. Assegure-se de que a impressora tenha memória suficiente.

Para imprimir a 300 dpi, a impressora deverá ter pelo menos 2 MB de RAM disponível. Para imprimir a 600 dpi, a impressora deverá ter pelo menos 4 a 6 MB de RAM. Para obter instruções sobre como determinar a memória disponível da impressora, consulte a documentação da impressora.

3. Usar o modo de PostScript da impressora, se disponível.

Para obter detalhes, consulte a documentação da impressora.

4. (Somente Windows) Alterne para um driver padrão SVGA.

Alterne para o driver SVGA padrão do Windows, para descobrir se a causa do problema é o seu driver de vídeo de terceiros. Se o erro não ocorrer ao usar o driver SVGA padrão, entre em contato com o fabricante da placa de vídeo para obter um driver atualizado. Se você já usa a versão atual, então tente usar uma resolução de vídeo diferente (por exemplo, 1024 x 768 ao invés de algo maior).

Solução de problemas de impressão no nível da impressora

Se você não puder obter qualquer coisa para imprimir ou exportar como PDF de qualquer aplicativo, contate o suporte técnico da Apple, contate o Suporte técnico da Microsoft ou do fabricante da impressora. Sempre verifique a conexão física entre a impressora e o computador antes de telefonar, pois a solução poderá ser simplesmente reconectar um cabo solto.

Além disso, considere o que foi alterado no sistema recentemente que possa estar impactando no processo de exportação. Por exemplo, você realizou alguma das seguintes tarefas recentemente?

  • Seu hardware foi atualizado ou componentes de hardware foram adicionados ou removidos
  • Software adicionado, atualizado ou excluído
  • Instalou ou excluiu fontes
  • Conectado a uma rede
  • Arquivos excluídos ou apagados do disco rígido
  • Foram encontrados erros aleatórios do sistema ou erros em outros aplicativos

Frequentemente, uma alteração no sistema corresponde diretamente ao aparecimento de um problema de impressão. Mantenha um registro das alterações feitas ao sistema como um recurso para solução de problemas de impressão e de outros problemas.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online