O que é abordado
Saiba como solucionar os arquivos do InDesign danificados ou corrompidos.
Nesta página

    Um documento do InDesign pode ser danificado se um erro ou outro comportamento inesperado ocorrer somente enquanto você trabalha nesse documento. O InDesign tem um recurso automático de recuperação de documento que pode evitar os danos que uma falha de sistema ou falta de energia podem causar. No entanto, ele não pode impedir danos causados por outros problemas a nível de sistema, como conflitos de software, espaço em disco insuficiente ou vírus. Este guia de solução de problemas pode ajudá-lo a determinar e solucionar problemas de danos em documentos do InDesign. Também pode ajudá-lo a determinar e resolver problemas a nível do sistema que parecem ser um dano do documento, mas estão relacionados a outras causas.


    Problemas em nível do sistema podem causar erros e outros comportamentos inesperados. Antes de assumir que um documento está danificado, certifique-se de que o sistema está relativamente livre de problemas. Por exemplo, considere executar um utilitário de reparo do disco e, a seguir, reabra o documento para ver se ele foi corrigido, antes de percorrer pelas tarefas abaixo de solução de problemas de documento danificado.

    Windows: consulte Verificar seu disco rígido quanto a erros.

    Mac OS: Consulte Solucionar problemas de inicialização e executar a manutenção do disco.


    Dica:

    Após cada tarefa de solução de problemas ter sido concluída, reinicie o InDesign e abra seu documento para ver se o problema foi corrigido. Abra o documento da seguinte maneira:

    Escolha Arquivo > Abrir, escolha seu documento e, a seguir, escolha Copiar. Salve o documento como um novo nome e veja se ele está corrigido.

    1. Fazer backup de seu documento.

    Antes de começar a solução de problemas, crie uma cópia de backup do seu documento danificado. Algumas das seguintes tarefas exigem que você altere ou exclua informações contidas no documento. Uma cópia de backup do documento permite restaurar facilmente as informações. Se o documento estiver em um volume de rede ou em uma mídia removível (por exemplo, um CD ou uma unidade removível), mova o backup para uma unidade local.

    2. Instale a atualização mais recente do InDesign.

    • No InDesign, escolha Ajuda > Atualizações.

    -ou-

    -ou-

    • Efetue o download das atualizações a partir do site da Adobe.

    3. Recriar seus arquivos de preferências.

    O InDesign armazena informações sobre plug-ins, recursos e do próprio aplicativo em seus arquivos de preferências: os arquivos InDesign SavedData e InDesign Defaults. Um arquivo de preferências do InDesign danificado poderá causar comportamento inesperado com um documento do InDesign. É possível determinar facilmente se o problema está relacionado a arquivos de preferências recriando-os.

    Alerta:

    recriar os arquivos de preferências do InDesign restaura as configurações para os valores padrão, de modo que as configurações personalizadas associadas aos arquivos de preferências antigos serão perdidas. Para manter essas configurações personalizadas, renomeie os arquivos de preferências antigos.

    Para recriar arquivos de preferência do InDesign:

    1. Saia do InDesign.

    2. Reinicie o InDesign e mantenha pressionadas as teclas apropriadas para o seu sistema operacional:

      • Mac OS X: Control+Option+Comando+Shift
      • Windows: Control+Alt+Shift
    3. Quando solicitado para excluir arquivos de preferência do InDesign, clique em Sim. O InDesign é iniciado com padrões e arquivos de preferências regenerados.

      Observação:

      Se você não for solicitado a excluir os arquivos de preferências, poderá excluir suas preferências manualmente.

    4. Abra o documento e veja se ele foi corrigido. Se o problema persistir, siga para a tarefa 4 abaixo.

      Excluir ou renomear manualmente seus arquivos de preferências

      Como alternativa, ou além disso, você pode:

      • Exclua manualmente seus arquivos de preferências (por exemplo, se você não for solicitado automaticamente a excluir as preferências ao iniciar o InDesign, como mostrado no procedimento anterior)

      -ou-

      • Renomeie manualmente seus arquivos de preferências (por exemplo, se você tiver configurações personalizadas associadas aos arquivos de preferências antigos que não desejar perder)

      Localize seu SO na tabela a seguir para ver onde esses arquivos estão localizados.

      SO Locais dos arquivos de preferência
      Mac OS X

      InDesign Defaults

      Users/[usuário]/Library/Preferences/Adobe InDesign/Version [versão]/[idioma]/InDesign Defaults

      InDesign SavedData

      Users/[usuário]/Library/Caches/Adobe InDesign/Version [versão]/InDesign SavedData

      Windows XP

      InDesign Defaults

      C:\Documents and Settings\[usuário]\Application Data\Adobe\InDesign\Version [versão]\InDesign Defaults

      Oculta por padrão. Saiba como exibir arquivos ocultos.

      InDesign SavedData

      C:\Documents and Settings\[usuário]\Local Settings\Application Data\Adobe\InDesign\Version[versão]\Caches\InDesign SavedData

      Windows 7/8

      InDesign Defaults

      C:\Users\[usuário]\AppData\Adobe\InDesign\Version[versão]\[idioma]\InDesign Defaults

      Oculta por padrão. Saiba como exibir arquivos ocultos.

      InDesign SavedData

      C:\Users\[usuário]\AppData\Local\Adobe\InDesign\Version[versão]\[idioma]\Caches\InDesign SavedData

      Depois de concluir a exclusão ou renomeação, reinicie o InDesign para recriar seus arquivos de preferências e, a seguir, abra o documento para ver se ele foi corrigido.

      Se o problema persistir, restaure as preferências originais excluindo os novos arquivos e renomeando os arquivos de preferências antigos com os nomes originais.

    4. Salve o documento no formato IDML (InDesign CS4 e posterior) ou INX (InDesign CS3 e anterior).

    1. Abra o arquivo no InDesign.

    2. Escolha Arquivo > Exportar.

    3. No menu Salvar como tipo, escolha InDesign Markup (CS4 e posterior) ou InDesign Interchange (CS3 e anterior).

    4. Nomeie o arquivo e defina um local e, a seguir, clique em Salvar.

    5. No InDesign, abra o arquivo IDML ou INX exportado.

      Se o problema não mais correr, continue a usar o arquivo IDML ou INX como uma substituição do documento original. Se o problema persistir, siga para outra etapa.

    5. Solução de problemas de um documento convertido em seu aplicativo de origem.

    Se o documento foi convertido do Adobe PageMaker, QuarkXPress ou uma versão anterior do InDesign, tente converter novamente o documento. Se o problema voltar a ocorrer, solucione o problema do documento original quanto ao dano em seu aplicativo de origem antes de convertê-lo novamente. Um documento do PageMaker ou do QuarkXPress danificado possivelmente permanecerá danificado após você o converter.

    Para obter mais informações sobre a solução de problemas de uma publicação danificada do PageMaker, consulte Solução de problemas de publicações danificadas. Para obter mais informações sobre a solução de problemas de documento danificado do QuarkXpress, visite o site do Quark.

    6. Exclua os estilos de caractere e parágrafo.

    Os estilos que você criou no InDesign ou importou com os arquivos criados em outros aplicativos podem estar danificados. Para saber se este é o caso, exclua os estilos e salve o documento novamente.

    Para excluir estilos de caractere:

    1. No InDesign, abra o documento e escolha Tipo > Estilos de caracteres.

    2. No painel Estilos de caracteres, selecione todos os estilos exceto [Nenhum estilo de caractere]. Para selecionar vários estilos, pressione Ctrl (Windows) ou Command (Mac OS) ao selecionar os estilos.

    3. No menu Estilos de caracteres, escolha Excluir estilos.

    4. Salve o documento e veja se ele foi corrigido. Se o problema persistir, tente excluir os estilos de parágrafo.

    Para excluir estilos de parágrafo:

    1. No InDesign, abra o documento e escolha Tipo > Estilos de parágrafos.

    2. No painel Estilos de parágrafo, selecione todos os estilos exceto [Nenhum estilo de parágrafo]. Para selecionar vários estilos, pressione Ctrl (Windows) ou Command (Mac OS) ao selecionar os estilos.

    3. No menu Estilos de parágrafos, escolha Excluir estilos.

    4. Salve o documento e veja se ele foi corrigido. Se o problema persistir, siga para a tarefa 7 abaixo.

    7. Verifique se há danos na fonte.

    Para determinar se o problema está relacionado a uma fonte danificada, substitua todas as fontes usadas no documento por uma fonte padrão (por exemplo, Arial ou Times New Roman).

    Se o problema voltar a ocorrer após você alterar as fontes, ele não é relativo as fontes. Se o problema não voltar a ocorrer, a fonte ou as fontes originais podem estar danificada ou desatualizadas. Tente reinstalar as fontes originais ou obter versões atualizadas do fabricante da fonte.

    8. Verifique se objetos e gráficos estão danificados.

    Tente determinar se um elemento específico em uma página mestre ou uma página de documento causa o problema. Para isolar elementos, primeiro apague páginas vazias e elementos desnecessários, como aqueles em uma área de trabalho ou camada oculta.

    Para excluir páginas:

    1. No InDesign, abra o documento e escolha Janela > Páginas'.

    2. No painel Páginas, use a ferramenta Seleção para selecionar as páginas que deseja excluir. Pressione Ctrl (Windows) ou Command (Mac OS) para selecionar várias páginas, ou pressione a tecla Shift para selecionar uma faixa contínua de páginas.

      Excluir páginas
    3. No painel Páginas, clique no ícone Excluir.

    4. Clique em OK para confirmar a exclusão.

    Se o problema voltar a ocorrer após você excluir algumas páginas, exclua metade das páginas remanescentes e salve o documento com um novo nome. A seguir, tente recriar o problema.

    • Se o problema ocorrer novamente, uma das páginas restantes pode conter um elemento danificado. Continue a excluir páginas até conseguir determinar a página que causa o problema.
    • Se o problema não ocorrer novamente, uma das páginas excluídas pode conter um elemento danificado. Substitua as páginas excluídas até que você consiga determinar a página que causa o problema.

    Depois de determinar a página que causa o problema, remova e substitua elementos nela, incluindo gráficos importados, objetos desenhados no InDesign e quadros de texto na página.

    9. Copie elementos da página em um novo documento.

    Copiar elementos da página em um novo documento deixa para trás danos estruturais (internos). Se o problema voltar a ocorrer depois que você copiar os elementos da página em um novo documento, exclua os elementos, um a um, para verificar se um destes elementos é o problema.

    Para copiar elementos da página em um novo documento.

    1. No InDesign, abra o documento original.

    2. Escolha Arquivo > Novo e clique em OK na caixa de diálogo Novo documento.

    3. Escolha Janela > Lado a lado para exibir ambos os documentos.

    4. Clique no documento original para ativá-lo.

    5. Escolha Janela > Páginas para ativar o painel Páginas.

    6. Arraste uma página ou expansão para a janela do novo documento. O InDesign copia a página ou expansão no novo documento, adicionando páginas conforme necessário.

    7. Salve o novo documento como um novo nome (diferente do nome do documento original) e tente recriar o problema.

      • Se o problema voltar a ocorrer, o dano não é estrutural (por exemplo, nas páginas master ou nas páginas do documento). Exclua os elementos, um a um, para verificar se um dos elementos está causando o problema.
      • Se o problema não voltar a ocorrer, o dano é provavelmente estrutural. Repita as etapas de 4 a 7 para cada página remanescente ou espalhada.

    10. Obtenha outra cópia do documento.

    Se você recebeu o documento por e-mail, FTP ou mídia removível (como um CD), obtenha uma cópia de outra forma. Ou, peça que o documento seja reenviado. Mídias danificadas ou uma transmissão de e-mail com problemas podem danificar um documento. Se o documento for enviado por e-mail, peça que o remetente compacte-o primeiro (por exemplo, usando WinZip ou Smith Micro's StuffIt) para proteger os dados.


    Remova os plug-ins de terceiros.

    Considere desinstalar os plug-ins de terceiros do InDesign. Os plug-ins às vezes podem causar danos ao arquivo. Consulte Solucionar problemas relacionados aos plug-ins de terceiros do InDesign.

    Use um computador diferente para abrir o documento.

    Ao mudar para um ambiente de sistema diferente, você poderá remover variáveis que causem o problema.

    Visite os fóruns de usuário para usuário da Adobe

    Você não está sozinho! Outros usuários podem ter tido problemas semelhantes com um documento e publicaram uma solução. Consulte os Fóruns do InDesign.

    Recrie o documento.

    Se tudo o mais falhar, recrie o documento. Faça cópias backup frequentes e periodicamente teste o documento para assegurar que os elementos importados não sejam a causa do problema.


     
    Voltar ao início