Boletim de segurança da Adobe

Atualizações de segurança disponíveis para Adobe Illustrator | APSB22-26

ID do boletim

Data de publicação

Prioridade

ASPB22-26

14 de junho de   2022     

3

Resumo

A Adobe lançou uma atualização para o Adobe Illustrator 2022. Esta atualização resolve vulnerabilidades críticas e importantes que poderiam levar à execução arbitrária de código e vazamento de memória.
             

Versões afetadas

Produto

Versão

Plataforma

Illustrator 2022

26.0.2 e versões anteriores 

Windows e macOS

Illustrator 2021

25.4.5 e versões anteriores 

Windows e macOS

Solução

A Adobe categoriza essas atualizações com as seguintes classificações de prioridade e recomenda que os usuários atualizem as suas instalações para a versão mais recente usando o mecanismo de atualização de aplicativo de desktop do Creative Cloud.  Para mais informações, consulte esta página de ajuda.

Produto

Versão

Plataforma

Prioridade

Disponibilidade

Illustrator 2022    

26.3.1

Windows e macOS

3

Illustrator 2021    

25.4.6

Windows e macOS

3

Detalhes da vulnerabilidade

Categoria da vulnerabilidade

Impacto da vulnerabilidade

Severidade

Pontuação base de CVSS 

Números CVE

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30637

Validação de entrada inadequada (CWE-20)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30638

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30639

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30640

Escrita fora dos limites (CWE-787)

Execução de código arbitrária

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30641

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30642

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30643

Usar após período gratuito (CWE-416)

Execução de código arbitrária

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30644

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30645

Validação de entrada inadequada (CWE-20)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30646

Usar após período gratuito (CWE-416)

Execução de código arbitrário

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30647

Usar após período gratuito (CWE-416)

Execução de código arbitrária

Crítico

7.8

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30648

Escrita fora dos limites (CWE-787)

Execução de código arbitrário

Crítico

7.8

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-30649

Out-of-bounds Read (CWE-125)

Vazamento de memória

Importante

5.5

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-30666

Out-of-bounds Read (CWE-125)

Vazamento de memória

Importante

5.5

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-30667

Out-of-bounds Read (CWE-125)

Vazamento de memória

Importante

5.5

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-30668

Out-of-bounds Read (CWE-125)

Vazamento de memória

Importante

5.5

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-30669

Agradecimentos

A Adobe gostaria de agradecer aos seguintes pesquisadores por terem relatado esses problemas e trabalhado conosco para proteger nossos clientes:   

  • Yonghui Han (tmgr), dos Laboratórios FortiGuard da Fortinet (CVE-2022-30649, CVE-2022-30666, CVE-2022-30667, CVE-2022-30668, CVE-2022-30669)
  • Mat Powell, da Zero Day Initiative da Trend Micro (CVE-2022-30637, CVE-2022-30638, CVE-2022-30639, CVE-2022-30640, CVE-2022-30641, CVE-2022-30642, CVE-2022-30643, CVE-2022-30644, CVE-2022-30645, CVE-2022-30646, CVE-2022-30647, CVE-2022-30648)

Revisões

16 de março de 2022: Adição das versões afetadas e corrigidas do Illustrator v25.x


Para mais informações, acesse https://helpx.adobe.com/br/security.html ou envie um email para PSIRT@adobe.com

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?