Panoramica dell’interfaccia

Scoprite l’interfaccia e l’area di lavoro di Substance 3D Designer.

Designer potrebbe sembrare complicato all’inizio, ma una volta che sapete a cosa serve ogni parte dell’interfaccia, diventa molto più facile da capire.

Diagramma che mostra una versione semplificata del layout dell’interfaccia utente di Designer, con etichette che puntano a ciascuna sezione.

A. Barra degli strumenti principale B. Esplora risorse C. Grafico D. Proprietà E. Vista 2D F. Vista 3D G. Libreria 

Nota:

potreste non riconoscere alcuni dei termini in questa pagina. Se trovate una parola o un concetto che non conoscete, consultate il Glossario per le definizioni o leggete i Concetti fondamentali di Substance Designer.

Barra degli strumenti principale

Trovate i menu principali e gli utili pulsanti ad accesso rapido.

Il menu File consente di:

  • Salvare e aprire i pacchetti
  • Creare pacchetti e grafici
  • Ricaricare tutti i contenuti
  • Uscire dall’applicazione

Il menu Modifica consente di annullare e ripetere azioni. Il menu Modifica consente inoltre di accedere a Preferenze in cui è possibile regolare le impostazioni dell’applicazione.

Il menu Strumenti consente di regolare le opzioni di Substance Engine. Substance Engine è il processo che calcola i grafici Substance. Nel menu Strumenti , potete mettere in pausa, ripristinare e regolare le impostazioni di Engine. Il menu Strumenti consente inoltre di accedere a Gestione plug-in.

Il menu Windows consente di gestire le finestre che compongono l’interfaccia di Designer. Potete aprire nuove finestre, attivare o disattivare la visibilità delle singole finestre oppure utilizzare Windows > Ripristina layout per ripristinare lo stato predefinito di Designer.

Dal menu Guida potete accedere a risorse quali la documentazione di Designer, esercitazioni e note sulla versione. Potete anche inviarci feedback e segnalare bug oppure trovare ulteriori informazioni sulle licenze e sulle versioni.

Pannello Esplora risorse

Consente di gestire pacchetti e risorse.

Due esempi del menu di scelta rapida aperto nel pannello Esplora risorse. La prima immagine mostra il menu di scelta rapida per un pacchetto, la seconda immagine mostra il menu di scelta rapida per un grafico.
Il menu di scelta rapida cambia a seconda del tipo di risorsa su cui fate clic. A sinistra è visualizzato il menu di scelta rapida per un pacchetto, mentre a destra c’è il menu di un grafico.

Il pannello Esplora risorse è il modo principale di interagire con file e risorse in Designer. 

Il pannello Esplora risorse elenca tutti i pacchetti aperti e ne visualizza il contenuto. Fate clic con il pulsante destro del mouse su pacchetti, grafici o altre risorse per visualizzare un menu contestuale. Tutte le risorse dispongono di una serie di opzioni standard tra cui:

  • Apertura
  • Chiusura
  • Ridenominazione
  • Copia e incolla

Alcune risorse dispongono di opzioni univoche disponibili solo nel menu di scelta rapida. Potete anche fare clic con il pulsante destro del mouse su uno spazio vuoto nel pannello Esplora risorse per creare un nuovo pacchetto vuoto.

Nella parte superiore del pannello Esplora risorse sono presenti alcuni pulsanti per gestire le risorse. Per attivare questi pulsanti, selezionate prima un pacchetto o un grafico.

Se fate clic su una risorsa, il pannello Proprietà si aggiorna e mostra le proprietà della selezione corrente.

Potete aprire più pannelli Esplora risorse. Utilizzate Windows > Nuovo Esplora risorse per aprire un altro pannello Esplora risorse.

Riquadro di visualizzazione grafico

Consente di creare e costruire grafici basati su nodi.

Schermata della finestra del grafico di Designer. Questa immagine mostra la barra degli strumenti del grafico nella parte superiore della finestra e il riquadro di visualizzazione del grafico sotto la barra degli strumenti.
Il riquadro di visualizzazione Grafico è costituito dalla barra degli strumenti Grafico e dalla visualizzazione Grafico. La barra degli strumenti Nodo fa parte della barra degli strumenti Grafico

Nel riquadro di visualizzazione Grafico trascorrerete la maggior parte del vostro tempo in Designer. Qui vengono visualizzati i grafici creati o aperti con Designer ed è il punto in cui è possibile aggiungere, rimuovere e organizzare i nodi.

Sono disponibili due aree distinte: barra degli strumenti e riquadro di visualizzazione.

Barra degli strumenti Grafico

Schermata ritagliata della barra degli strumenti Grafico.

La barra degli strumenti Grafico contiene gli strumenti per gestire il grafico e molti dei nodi più utilizzati. Per semplificare le operazioni, i pulsanti con sfondi colorati sono nodi, mentre gli altri pulsanti sono strumenti. 

Nella barra degli strumenti principale sono disponibili i seguenti strumenti:

  •  Messa a fuoco : riporta in vista la selezione. Se non è selezionato un nodo, Messa a fuoco mostra invece l’intero grafico. Messa a fuoco consente di navigare o trovare rapidamente la selezione. Il tasto di scelta rapida F ha la stessa funzione.
  •  Reimposta zoom: reimposta il livello di zoom sul valore predefinito 1:1. Il tasto di scelta rapida Z ha la stessa funzione.
  •  Cattura di schermata: salva una schermata PNG dell’intero grafico, con trasparenza. Viene aperta una finestra di dialogo per impostare il nome e il percorso del file.
  •  Informazioni: apre un menu a discesa in cui è possibile attivare/disattivare Nomi connettori, Badge nodi, Dimensioni nodo e Tempistiche nodi. Quando sono attivate, queste opzioni aggiungono informazioni ai nodi nell’area di visualizzazione.
  •  Cerca: cerca i nodi e i parametri all’interno del grafico filtrando il tipo e il testo.
  •  Evidenzia flusso: consente di chiarire quali nodi sono collegati alla selezione corrente. I nodi non collegati sono disattivati.
  •  Barra degli strumenti Nodo: consente di attivare/disattivare la visualizzazione dei pulsanti per i nodi atomici. 
  •  Barra degli strumenti principale: consente di attivare/disattivare la visualizzazione del controllo Risoluzione principale nella barra degli strumenti.
  •  Modalità di creazione dei collegamenti: consente di scegliere quale dei tre metodi di collegamento utilizzare (Standard, Materiale o Materiale compatto). Le scelte rapide da tastiera 1, 2 e 3 eseguono le stesse funzioni.
  •  Collegamenti rettangolari: consente di scegliere se i collegamenti sono curve uniformi o angoli rettangolari.
  •  Controllo tempistica: consente di reimpostare i display di sincronizzazione. Controllo tempistica è pertinente solo se Tempistiche nodi è abilitato nel menu a discesa Informazioni.
  •  Strumenti: consente di accedere a un elenco a discesa con varie opzioni. 
    • Pulisci rimuove i nodi inutilizzati dal grafico.
    • Esporta output richiama la finestra di dialogo Esporta che consente di esportare i file bitmap.
    • Riesporta output esegue nuovamente un output precedente con le stesse opzioni, senza visualizzare la finestra di dialogo.
    • Esportatore PSD apre il pannello Esportatore PSD aggiuntivo. Il pannello Esportatore PSD viene visualizzato a destra della vista del grafico.
  •  Barra degli strumenti Miniature attiva o disattiva la visualizzazione del menu a discesa delle opzioni delle miniature nella barra degli strumenti.
  •  Strumenti di allineamento: attiva/disattiva la visualizzazione degli strumenti di allineamento nella barra degli strumenti. Gli strumenti di allineamento consentono di allineare e organizzare i nodi sulla griglia del grafico.

 

Barra degli strumenti Nodo

Barra degli strumenti Nodi

Fate clic su un nodo nella barra degli strumenti Nodi per aggiungerlo al grafico. la barra degli strumenti Nodi contiene i nodi atomici di Designer. I nodi atomici sono i nodi fondamentali dei grafici di Designer, sono gli elementi di base che si possono usare per creare reti complesse. Per ulteriori informazioni sui nodi, vedere la pagina Panoramica dei nodi.

Nota:

La barra degli strumenti Nodi è solo uno dei modi per aggiungere nodi e ci sono molti altri nodi disponibili oltre a quelli della barra degli strumenti. L’articolo Creare un grafico contiene ulteriori informazioni.

Visualizzazione grafico

Visualizzazione grafico

L’area di visualizzazione del grafico contiene i nodi che compongono il grafico. Posizionate e collegate i nodi per creare un grafico che generi le vostre texture. 

Fate riferimento alla pagina Creare un grafico per ulteriori informazioni sull’uso del grafico.

Pannello Proprietà

Consente di modificare le proprietà sensibili al contesto.

Schermate affiancate del pannello Proprietà. La prima immagine mostra come appare il pannello Proprietà quando il grafico è selezionato. La seconda immagine mostra come appare il pannello quando è selezionato un nodo di fusione.
Il pannello Proprietà cambia aspetto a seconda della risorsa selezionata. L’immagine a sinistra mostra l’aspetto del pannello Proprietà con un grafico selezionato. L’immagine a destra mostra l’aspetto del pannello Proprietà con un nodo di fusione selezionato.

Il Pannello Proprietà è sensibile al contesto e visualizza parametri che modificano il comportamento della risorsa o del nodo selezionato. Combinati, i pannelli Grafico e Proprietà sono le aree dove trascorrerete la maggior parte del vostro tempo in Designer.

A causa dell’elevato numero di controlli che è possibile visualizzare contemporaneamente, il pannello Proprietà dispone di categorie per mantenere organizzati i controlli. Di seguito è riportata una descrizione delle categorie principali:

  • Parametri di base è una categoria presente nelle risorse dei grafici e in ogni nodo. Consente di modificare i parametri principali relativi alla risoluzione e alla configurazione dei grafici. Alcuni importanti sono elencati di seguito.
    • Dimensioni output: imposta la risoluzione del grafico o del nodo. 
    • Formato di output: imposta il formato o la precisione del grafico o del nodo. 
    • Modalità affiancamento: imposta se un’immagine andrà a capo al di fuori dai relativi limiti.
    • Seme casuale: modifica il seme casuale utilizzato per la generazione procedurale.

Il comportamento dei parametri di base dipende dal metodo di ereditarietà (). Relativo significa che il comportamento del nodo è definito altrove (o dal grafico, o da un nodo precedentemente connesso). Assoluto significa che è impostato mediante i controlli dei parametri. Se un parametro di base è disattivato, probabilmente è dovuto al fatto che la modalità di ereditarietà è impostata su Relativa.

  • Attributi contiene i metadati relativi al grafico o al nodo. Potete utilizzare i metadati per creare categorie nella libreria.
  • Parametri di input è visibile solo per i grafici. Qui potete trovare tutti i parametri esposti.
  • Parametri di istanza/specifici è visibile solo per i nodi. Il nome tra i nodi atomici e di istanza è diverso, ma la funzionalità è la stessa: consente di modificare le impostazioni specifiche di questo nodo. Potete modificare il colore dell’output di un nodo, l’opacità di un’operazione di fusione o la scala di un disturbo.
  • Input è visibile solo per i grafici. Elenca tutti i nodi di input o i parametri esposti e consente di impostarne i nomi e le proprietà. 
  • Valori di input è visibile solo per i nodi. Consente di aggiungere input di valore a un nodo. I valori di input vengono utilizzati solo nei flussi di lavoro avanzati.
  • Output è visibile solo per i grafici. Elenca tutti i nodi di output (o gli slot) e consente di impostarne i nomi e le proprietà da una posizione centrale.

Riquadro di visualizzazione 2D

Consente di visualizzare un’anteprima dell’immagine sensibile al contesto.

Vista 2D

Il Riquadro di visualizzazione 2D visualizza il contenuto dei nodi. Facendo doppio clic su un nodo di immagine nel grafico, nella vista 2D viene visualizzato l’output del nodo.

La vostra interazione con il Riquadro di visualizzazione 2D si limita allo zoom e alla panoramica quando si esegue lo zoom in avanti. Potete ingrandire e ridurre scorrendo. Usate i pulsanti in basso a destra del Riquadro di visualizzazione 2D per controllare lo zoom. Potete anche ripristinare lo zoom con la scelta rapida Z o la messa a fuoco sull’area di lavoro con F.

Nella parte superiore del Riquadro di visualizzazione 2D sono disponibili i seguenti controlli:

  •  Immagine di sfondo: consente di impostare un’immagine di sfondo per mostrare se sono presenti pixel trasparenti.
  •  Salva vista: consente di salvare l’immagine corrente nel Riquadro di visualizzazione 2D in un file bitmap.
  •  Copia negli Appunti: copia il contenuto del Riquadro di visualizzazione 2D negli Appunti. 
  •  Seleziona output: consente di passare da un output all’altro del nodo.
  •  Seleziona set UV: consente di selezionare il canale UV da visualizzare. Questo pulsante è disattivato a meno che Visualizza UV in Vista 2D del menu Scena del Riquadro di visualizzazione 3D non sia attivo.

Nella parte inferiore sinistra della vista 2D, sono disponibili pulsanti con funzioni aggiuntive:

  •  Visualizzazione canale: consente di attivare o disattivare i canali R, G e B. È ideale da utilizzare in scala di grigi.
  •  Visualizzazione trasparenza: consente di visualizzare i pixel trasparenti come texture a scacchi o nero semplice.
  •  Alterna scala di grigi/colore: consente di scegliere tra il Riquadro di visualizzazione 2D a colori o in scala di grigi.
  •  Affiancamento ripetuto: affianca l’immagine nel Riquadro di visualizzazione 2D. In questo modo è possibile trovare facilmente artefatti di affiancamento. Quando il mouse si trova sopra il Riquadro di visualizzazione 2D, la barra spaziatrice funge da scelta rapida.
  •  Usa dimensioni fisiche: attiva/disattiva l’uso delle informazioni sulle dimensioni fisiche per la visualizzazione dell’anteprima.
  •  Informazioni immagine: apre un pannello informazioni immagine, in cui sono visualizzati i valori esatti dei pixel su cui passate il cursore.
  •  Istogramma: apre un pannello contenente un’analisi dell’istogramma dell’anteprima corrente.
  •  Attiva/disattiva sRGB: attiva o disattiva la visualizzazione nello spazio cromatico sRGB.
  •  Attiva/disattiva premoltiplicazione: attiva/disattiva la premoltiplicazione dei pixel con un canale alfa, con il colore di sfondo.

Riquadro di visualizzazione 3D

Consente di interagire con un’anteprima 3D del materiale completo.

Vista 3D

Il Riquadro di visualizzazione 3D visualizza il materiale. A differenza del Riquadro di visualizzazione 2D, per impostazione predefinita utilizza le mappe di output del grafico per eseguire il rendering di un materiale completo. Nel Riquadro di visualizzazione 3D potete visualizzare come si combinano i vostri canali, come colore di base, normale e ruvidità, per creare un risultato finale.

Per visualizzare il materiale nel Riquadro di visualizzazione 3D, fate clic con il pulsante destro del mouse su un punto vuoto nell’area di visualizzazione del grafico e selezionate Visualizza output nella vista 3D. Potete anche inviare singole mappe alla vista 3D facendo clic con il pulsante destro del mouse sul nodo e selezionando Visualizza nella vista 3D

Per interagire con il riquadro di visualizzazione, potete usare un mouse a 3 pulsanti e una tastiera come segue:

  • Il trascinamento con il pulsante sinistro del mouse fa ruotare la fotocamera attorno alla mesh.
  • Trascinate con il pulsante centrale del mouse per eseguire la panoramica con fotocamera.
  • Trascinate o scorrete con il pulsante destro del mouse per ingrandire o ridurre la mesh.
  • La scelta rapida da tastiera F rimette a fuoco la fotocamera sulla mesh centrale, nel caso in cui ne perdiate traccia.
  • Ctrl + Maiusc + pulsante destro del mouse (Cmd + Maiusc + pulsante destro del mouse su Mac) ruota le luci ambiente.

I sette menu principali sono descritti di seguito:

  • Scena consente di modificare la mesh visualizzata nel riquadro di visualizzazione. Potete anche salvare e caricare lo stato del riquadro di visualizzazione. Per visualizzare la mesh personalizzata nel Riquadro di visualizzazione 3D, fate doppio clic su di esso nel pannello Esplora risorse.
  • Materiali mostra tutti gli slot di materiale sulla mesh e consente di scegliere quali shader e parametri vengono utilizzati. In questo menu potete impostare opzioni quali la suddivisione in porzioni UV, lo spostamento dell’altezza e il rendering non PBR.
  • Luci è un menu dalle prime versioni di Designer. Le luci in questo menu sono disattivate per impostazione predefinita e si consiglia di non utilizzarle a meno che non si aprano file non recenti. Scegliete l’opzione Modifica per accedere alle impostazioni della luce.
  • Fotocamera consente di passare da un’angolazione predefinita all’altra. Permette inoltre di salvare le acquisizioni sottoposte a rendering dal riquadro di visualizzazione 3D. Scegliete Modifica per cambiare le impostazioni di post-elaborazione.
  • Ambiente dispone di opzioni per regolare l’illuminazione basata su immagini della scena. Per modificare l’immagine HDR nella vista 3D, trascinate una risorsa dalla categoria Riquadro di visualizzazione 3D del pannello Libreria.
  • Visualizzazione consente di modificare alcune impostazioni varie per il riquadro di visualizzazione, ad esempio reticolo e risoluzione della visualizzazione.
  • Renderer è un menu importante che consente di passare dal rendering OpenGL in tempo reale al tracciamento dei raggi IRay con accelerazione GPU. Quando si sceglie IRay come renderer, diventano disponibili più opzioni IRay.

Pannello Libreria

Trovate risorse per i vostri grafici.

Vista Libreria

Nel pannello Libreria, potete accedere a tutti i contenuti predefiniti di Designer. Per comprendere meglio i diversi tipi di nodi nella libreria, consultate la sezione Panoramica dei nodi.

È possibile aggiungere contenuto dalla Libreria nel grafico semplicemente trascinandolo nell’area di visualizzazione del grafico. Potete anche usare la barra spaziatrice o le scelte rapide da tastiera con il tabulatore quando passate il cursore del mouse sull’area di visualizzazione grafico per aprire un menu per cercare rapidamente i nodi.

Le miniature di grandi dimensioni del pannello Libreria possono aiutarvi nella ricerca di contenuti. Regolate le dimensioni delle miniature con il menu a discesa in alto a destra ().

Passaggi successivi

Con l’interfaccia coperta, è possibile passare direttamente ai Concetti fondamentali di Designer. 

Avete domande o suggerimenti?

Se avete domande o un’idea da condividere, unitevi agli altri utenti di Designer nella Community di Substance 3D Designer. Ricevete assistenza, date suggerimenti da poter integrare in Designer o mostrate il vostro lavoro e le vostre tecniche.

Se avete nuove idee per i nodi o le funzioni di Designer, condividetele qui!

 Adobe

Ottieni supporto in modo più facile e veloce

Nuovo utente?