错误:尝试打开帮助时出现"无法启动帮助系统" | Dreamweaver CS4 | Windows

上次更新日期: 2021年4月27日

问题

当您尝试在 Windows 上打开 Adobe Dreamweaver CS4 中的帮助时,该应用程序返回错误"由于帮助文件夹缺失,无法启动帮助系统。请安装帮助文件夹或重新安装 Dreamweaver。

原因

存储超文本传输协议 (HTTP) 设置的 Windows 注册表项缺失或损坏。

解决方案

以管理员身份登录您的计算机。然后执行以下一种或两种解决方案。

解决方案 1:将您的首选 web 浏览器设置为系统默认浏览器。

在 Windows 7/Vista 上设置系统默认 Web 浏览器:

关闭所有应用程序。
选择“开始”>“控制面板”。
执行以下操作之一:
  • 如果控制面板处于控制面板主页或类别视图中,请单击"程序"。在下一屏幕上,单击"默认程序"。
  • 如果控制面板处于经典视图中,请双击"默认程序"。
选择"设置程序访问权限和计算机默认值"。
在"选择配置"列表中,单击"自定义"。
在"选择默认 web 浏览器"下,选择 Internet Explorer、Firefox、Google Chrome 或 Opera。
单击“确定”。

要在 Windows XP 上设置系统默认 Web 浏览器:

关闭所有应用程序。
选择“开始” > “控制面板”(或开始 > 设置 > 控制面板)。
双击“添加或删除程序”。
在"添加或删除程序"的左侧面板中,选择"设置程序访问权限和默认值"。
在"选择配置"列表中,单击"自定义"。
在"选择默认 web 浏览器"下,选择 Internet Explorer、Firefox、Google Chrome、Opera 或 Safari。
单击“确定”。

解决方案 2:在 Windows 注册表中重新创建 HTTP 项。

免责声明:此解决方案中的步骤需要您修改 Windows 注册表。注册表包含对计算机和应用程序至关重要的系统相关信息。 在修改注册表之前,务必为其创建备份副本。 因不正确地修改注册表而引起的问题,Adobe 不提供支持。 有关 Windows 注册表的信息,请参阅 Windows 的相关文档,或联系 Microsoft 技术支持人员或计算机制造商。

关闭所有应用程序。
执行下列操作之一:
  • Windows 7/Vista:选择"开始">"所有程序">"附件"。然后右键单击"命令提示符"并选择"以管理员身份运行"。
  • Windows XP:选择"开始">"所有程序">"附件">"命令提示符"。
在"命令提示符"窗口中,按如下所示准确键入以下命令,然后按 Enter 键:



reg export HKCR\\http \"%userprofile%\\AdobeHelpBackup.reg\"

注意"命令提示符"可能会返回错误"系统无法找到指定的注册表项或值"。如果 Windows 注册表中缺少 HTTP 键,则会出现此预期消息。如果出现此错误,请转至步骤 6;否则,请继续执行步骤 5。

 
按如下所示准确键入以下命令,然后按 Enter 键:



reg delete HKCR\\http /f
准确输入以下命令之一,然后按 Enter 键(输入与您希望用来查看 Dreamweaver CS4 帮助的浏览器相对应的命令):



注意如果您选择 Internet Explorer 之外的浏览器,则必须在输入命令前先安装该浏览器。



  • Internet Explorer

    reg add HKCR\http\shell\open\command /ve /f /d "\"%programfiles%\Internet Explorer\iexplore.exe\" "\"%1\""
  • Firefox

    reg copy HKCR\FirefoxURL\shell HKCR\http\shell /s /f
  • Opera

    reg copy HKCR\Opera.HTML\shell HKCR\http\shell /s /f
  • Safari

    reg copy HKCR\SafariURL\shell HKCR\http\shell /s /f
  • Google Chrome

    reg copy HKCR\ChromeHTML\shell HKCR\http\shell /s /f
关闭“命令提示符”窗口。