弄清粘贴图稿变得缓慢或者在 Illustrator 文件中发现意外数据时采取什么措施。

问题

在 Illustrator 文件中或文件之间执行图稿粘贴操作时,速度要比预期缓慢得多;或者,在目标文档(例如,色板、符号和画笔)中发现意外的全局对象。

解决方案

根据您正在使用的 Illustrator 版本,尝试下面的一个或多个解决方案。

请选择您的 Illustrator 版本:

修复错误增效工具全局对象名称(Mac 和 Windows;CS6 和 CC)

  1. 确保您使用的是最新版本的 Illustrator。选择“帮助”>“更新”或者通过 Creative Cloud 桌面应用程序更新 Illustrator。

  2. 下载以下 ZIP 文件,并提取所含脚本(JSX 文件)。

    下载

  3. 启动 Illustrator 并运行该脚本:选择“文件菜单”>“脚本”>“其他脚本”或者将该脚本拖动到 Illustrator 中。此时将显示以下消息:“fixBadPluginGlobalObjectNames 首选项已打开”。

  4. 如果显示以下消息,请重新运行该脚本:“fixBadPluginGlobalObjectNames 首选项已关闭”。

  5. 退出并重新启动 Illustrator,然后打开受影响的 Illustrator 文件以验证是否已修复。

针对 CS5 及更低版本的解决方案

针对 Illustrator CS5 及更低版本解决该问题需要以下两个解决方案之一。如果第一个解决方案无法解决问题,请尝试第二个。

解决方案 1(CS5 及更低版本):启用内容恢复模式

  1. 退出 Illustrator。

  2. 查找 Adobe Illustrator 首选项文件。例如,Illustrator CS5 的首选项文件位于:

    • Mac OS:/[用户]/Library/Preferences/Adobe Illustrator CS5 Settings/[语言]/
    • Windows 7/Vista:Users/[用户]/AppData/Roaming/Adobe/Adobe Illustrator CS5 Settings/[语言]/AIPrefs
    • Windows XP:Documents and Settings/[用户]/Application Data/Adobe/Adobe Illustrator CS5 Settings/AIPrefs

    注意:

    在 Windows 上,Application 和 AppData 文件默认处于隐藏状态。如果您在显示隐藏文件方面需要帮助,请参阅显示隐藏文件

  3. 在 TextWrangler (Mac OS) 或记事本 (Windows) 等纯文本编辑器中打开首选项文件。(您也可以使用更传统的文字处理应用程序。如果您这样做,请将文件另存为不带隐藏 .txt 扩展名的纯文本文件。)

  4. 在首选项文件中,查找类似于以下内容的部分:

    /aiFileFormat {

    /PDFCompatibility 1

    /enableATEReadRecovery 0

    /enableContentRecovery 0

    /enableATEWriteRecovery 0

    /clipboardPSLevel 3

    }

  5. 将 enableContentRecovery 值从 0 更改为 1。如果 /aiFileFormat 部分没有 enableContentRecovery 行,请进行添加。编辑后,应该如下所示:

    /enableContentRecovery 1

  6. 保存首选项文件,不要更改文件名或扩展名。

解决方案 2(CS5 及更低版本):编辑恢复的文件

  1. 启动 Illustrator。
  2. 要打开文档,请选择“文件”>“打开”或按 Command+O 键。

    不要通过双击文件、使用“最近打开的文件”列表或将文件拖动到 Illustrator 应用程序图标上来打开文档。 

  3. 在文件导航对话框中,选择您要修复的文件。

  4. Command+Option+Shift 键 (Mac OS) 或 Ctrl+Alt+Shift 键 (Windows),然后在“打开”对话框中单击“打开”。

  5. 关闭空白窗口,不要保存。

  6. 在 Finder (Mac OS) 或 Windows 资源管理器 (Windows) 中,在包含原始文件的同一目录中,查找前面带下划线的文件副本。例如,如果打开“BrokenFile.ai”,会看到名为“_BrokenFile.ai”的新文件。

  7. 在 TextWrangler (Mac OS) 或文本编辑器 (Windows) 等纯文本编辑器中打开带下划线的文件。(Windows 用户应该也能使用写字板或记事本)。如果损坏的文件很大,可能需要一段时间才能打开。如果您的文本编辑器对可以打开的文件大小有最大值限制,请使用其他文本编辑器。

  8. 在带下划线的文件中,搜索以下内容的每个实例:

    %AI8_BeginPluginObject

  9. 检查以下行确认其是否与这些字符串之一匹配:
    (Adobe Calligraphic Brush Tool)
    (Adobe Scatter Brush Tool)
    (Adobe ArtOnPath Brush Tool)
    (Adobe Pattern Brush Tool)

  10. 如果该行不与这四个字符串之一完全匹配(包括大小写),则选择 %AI8_BeginPluginObject 注释和第一个后续 %AI8_EndPluginObject 注释中的所有文本。然后删除注释,并删除所选内容。

  11. 对文件中 %AI8_BeginPluginObject 注释的每个实例重复第 9 步和第 10 步。

  12. 保存此文件。
  13. 在 Illustrator 中打开文件。
  14. 删除所有符号,然后删除所有画笔。或者,如果您怀疑文件包含必要的符号或画笔描边,请运行“删除未使用的面板项目”操作(选择“操作”>“删除未使用的面板项目”,然后单击“执行当前选中的部分”)。

  15. 以新名称(例如“Fixed File.ai”)保存文件。

  16. (重要)关闭文件。

  17. 在 Illustrator 中重新打开文件。通过选择任何对象,并将其复制粘贴到新的空白文件,确认该文件已得到修复。

其他信息

意外内容由以前版本的 Illustrator 中的问题引起,这些问题在当前的版本中已修复。如果您处理的文档是在以前版本的 Illustrator 中保存的,在当前的版本中打开文件可能无法修复问题。

意外的全局对象可能会出现在各自的面板中,也可能不会。尝试删除意外的全局对象可能会失败,或者可能会导致 Illustrator 变得不稳定并突然退出。

如果保存文档,则会因为将大量全局对象添加到文档中而造成文档大小显著增长。这些无效数据可能在注意到它之前早已存在于文档中,因此,在以前的版本中打开文档并不总是能够修复问题。当您将图稿从一个文档复制到另一个文档时,无效数据可以传递。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略