了解如何使 Illustrator 在 Windows 上快速高效地运行。

若干因素会影响 Adobe Illustrator 运行的速度和效率,例如操作系统、硬件配置、工作流程和选择的选项等等。如果您注意到 Illustrator 运行速度比平常要慢,请尝试下面的技巧,它们不仅可以优化 Illustrator 的性能,而且还能优化其他应用程序的性能。(在处理大型文件时,性能的改进更加显著。)

准备事项

在执行以下任务之前,请确保安装最新版本的 Illustrator 或您当前所用版本的所有更新。软件更新通常包含与性能相关的修复或增强。 

如果您使用的是 Illustrator CC,您可以通过 Creative Cloud 桌面应用程序更新 Illustrator。

注意:

本文档中的过程基于默认 界面。如果界面是自定义的,则某些过程会有所不同。例如,导航到控制面板的路径可能有所不同。根据您的 Windows 版本,选择“开始”>“设置”>“控制面板”“开始”>“控制面板”有关 Windows 的故障诊断提示和常规信息,请咨询 Adobe 技术支持Microsoft 技术支持

优化 Windows

通过将操作系统配置为高效运行,您可以增加应用程序可用的内存量,这样有助于它们顺畅地运行。下面是优化 Windows 并改进 Illustrator 性能的几个技巧。

增加可用内存

虚拟内存允许您使用硬盘空间存储通常存储在 RAM 中的信息。但是,访问硬盘上的信息比访问内存中的信息所需时间要长。所以,如果系统不得不过于依赖虚拟内存,就会降低性能。

要提高性能,请为分页文件(存储虚拟内存的硬盘驱动器区域)选择适当的大小。必须具有管理员权限才能更改分页文件大小。当分页文件的最大大小约为已安装 RAM 量的三倍时,Illustrator 性能最高。

  1. 退出所有应用程序。

  2. 选择开始”>“控制面板>“系统”>“高级系统设置”。

  3. 在“系统属性”对话框中,选择“高级”选项卡。

  4. 单击“性能”部分中的“设置”,然后选择“高级”选项卡。

  5. 在“虚拟内存”部分中,单击“ 更改”。

  6. 清除“自动管理所有驱动器的分页文件大小”复选框。

  7. 从“驱动器”列表中,选择可用空间至少为计算机已安装 RAM 量的三倍的硬盘驱动器。例如,如果计算机安装有 64 MB 的 RAM,则选择至少具有 192 MB 可用空间的硬盘驱动器。为获得最佳性能,请选择不用作 Illustrator 暂存盘的硬盘驱动器。

禁用驱动程序功能

某些视频适配器驱动程序提供了用于加速或修改图形显示器的高级设置。有时,这些设置可能会对 Illustrator 的屏幕重绘性能产生不利影响。请尝试禁用特定于驱动程序的功能,以确定与 Illustrator 一起使用的最佳设置。有关更多信息,请参阅视频适配器的文档。

管理字体

您具有的每种字体都会增加 Windows 使用的 RAM 量。仅安装所需的字体,以改进系统性能以及访问字体的应用程序的性能。使用字体管理实用程序帮助您管理多种字体。

限制启动应用程序

在 Windows 上自动启动的应用程序会与 Illustrator 争用可用的 RAM。要阻止应用程序自动启动,请执行以下操作:

  1. 退出所有应用程序。

  2. 启动 Windows 资源管理器。
  3. 将 StartUp 文件夹 (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) 中的所有图标和快捷方式移至另一文件夹,以禁用启动应用程序。

  4. 重新启动 Windows。

要关闭在注册表中指定为自动启动的应用程序,请执行以下操作:

  1. 重新启动 Windows。
  2. Ctrl+Shift+Esc 键。

  3. 选择“进程”选项卡。

  4. 选择应用程序名称,然后单击“结束任务”。

  5. 重新启动 Illustrator。如果 Illustrator 性能有所改进,请与应用程序的制造商联系,让其帮助永久禁止应用程序自动启动。对剩余的每个启动应用程序重复执行步骤 2 到 5。

重新启用图标和快捷方式

如果重新启动后 Illustrator 性能没有改进,请在 Windows 资源管理器中将图标和快捷方式放回“Startup”文件夹,由此重新启用它们。

如果 Illustrator 性能有所改进,请找出导致性能问题的一个或多个程序,并在 Windows 资源管理器中将其图标和快捷方式放入“Startup”文件夹,由此重新启用它们。

在重新启用每组图标和快捷方式后重新启动计算机,并测试 Illustrator 的性能。

重复此过程,直至 Illustrator 的性能下降。找出导致性能问题的图标或快捷方式后,再次将其删除。请与程序的制造商联系,以查看是否有更新。

优化硬件

您使用的硬件会影响 Illustrator 的性能:处理器或硬盘驱动器越快,Illustrator 处理信息的速度就越快。其他硬件增强功能(例如安装额外的 RAM、使用多处理器系统或对驱动器进行优化和碎片整理)也可以改进性能。请尝试以下技巧来优化硬件。

使用更快的处理器

计算机中央处理器 (CPU) 的速度会影响 Illustrator 的速度。由于 Illustrator 处理大量的数据并执行许多计算,因此其速度取决于处理器的速度。请考虑使用处理器速度更快的计算机。

安装额外的 RAM

如果 Illustrator 的 RAM 不足,它将使用硬盘空间(虚拟内存、暂存盘或两者)来处理信息。当 Illustrator 可以处理内存中的信息而不使用硬盘时,处理速度最快。

优化磁盘空间

下面是优化磁盘空间的几种方式:

  • 使用 CHKDSK.exe 和磁盘碎片整理程序,检查硬盘是否存在错误、对文件进行碎片整理,并充分利用可用的硬盘空间。有关信息,请参阅 Windows 文档或改进 Windows 的性能
  • 将文件保存到访问速度较快的驱动器上。例如,使用内部硬盘驱动器而非网络服务器(网络驱动器)或外部驱动器。
  • 如果要将文件保存到网络或外部驱动器上,首先将文件保存到内部硬盘驱动器上。然后关闭文件,并使用 Windows 资源管理器将其复制到网络或外部驱动器上。

使用 PostScript 打印机

当从 Illustrator 打印时,要获得最佳效果,请使用 PostScript 打印机。大多数非 PostScript 打印机依靠显示信息、主机计算机资源和专有打印机驱动程序将打印信息传送到打印机。因此,它们打印所需的时间比 PostScript 打印机要长得多。

有效地使用 Illustrator 功能

您在 Illustrator 中的工作方式(尤其是查看图稿的方式)会影响 Illustrator 的性能。下面是高效使用 Illustrator 功能的一些方式。

在大纲视图中工作

大纲视图会隐藏涂色属性,将图稿显示为未填色的路径。在大纲视图中工作可以加快复杂图稿(例如包含渐变或图案的对象)的显示。在大纲视图中还可以更轻松地编辑隐藏在其他已填色对象后面的对象。

要在大纲视图中显示 Illustrator 文档,请选择“视图”>“大纲”

创建自定义视图

您可以创建文档的自定义视图。自定义视图允许您快速更改视图模式、放大率、滚动位置和图层选项。

要创建 Illustrator 文档的自定义视图,请设置要保存的视图属性。然后选择“视图”>“新建视图”,并在“新建视图”对话框中输入名称。自定义视图将显示在“视图”菜单中。

更改栅格效果设置

您可以更改栅格效果的分辨率以优化 Illustrator 的性能。

要更改栅格效果的分辨率,请选择“效果”>“文档栅格效果设置”。在“分辨率”弹出菜单中,执行以下任一操作:

  • 如果您正在编辑文件,请选择“屏幕”。Illustrator 将对栅格效果使用 72 ppi 的分辨率,从而提高显示速度。
  • 如果您正在打印文件,请选择“”。Illustrator 将对栅格效果使用 300 ppi 的分辨率,从而降低打印速度,但是提高打印质量。

然后,单击“确定”。

隐藏图层并删除缩览图

使用“图层”面板可以组织和修改图稿。隐藏包含复杂图稿或高分辨率位图图像的图层后,Illustrator 重绘屏幕的速度较快。

要隐藏一个图层,请单击图层名称左侧的眼睛图标。要隐藏除选定图层之外的所有图层,请在按住 Alt 键的同时单击(在 Mac 上是在按住 Option 键的同时单击)眼睛图标。

“图层”面板可以显示顶层图层、嵌套图层、组和对象的缩览图。要减少缩览图的数目以使 Illustrator 重绘屏幕的速度更快,请从“图层”面板菜单中选择“面板选项”,然后减少缩览图的数目。

“选项”面板

禁用叠印预览

叠印预览提供“油墨预览”,大体呈现混合、透明和叠印在分色输出中的显示效果。要增强性能,请避免使用叠印预览。

要启用和禁用叠印预览,请选择“视图”>“叠印预览”

删除未使用的画板

画板表示可以包含可打印图稿的区域。要优化性能,请考虑删除未使用或不必要的画板。

要管理画板,请选择“窗口”>“画板”。选择要删除的画板,并单击“删除”。

更改暂存盘首选项

当您处理嵌入式位图图像而系统没有足够的 RAM 时,Illustrator 将使用硬盘空间作为暂存盘。访问硬盘上的信息比访问内存中的信息所需时间要长。因此,使用硬盘的一部分作为虚拟内存会降低性能。如果您需要更多内存才能在 Illustrator 中工作,Adobe 建议安装更多 RAM。

默认情况下,Illustrator 使用系统驱动器作为其主暂存盘。请将 Illustrator 主暂存盘设置更改为最快的硬盘驱动器。

要更改暂存盘首选项,请执行以下操作:

  1. 选择编辑”>“首选项”>“增效工具和暂存盘

  2. 从“主要”弹出菜单中选择一个硬盘。如果您处理大型图像并且具有多个硬盘,请从“辅助”弹出菜单中再选择一个磁盘。

  3. 单击“确定”,然后重新启动 Illustrator。

从文档配置文件中删除未使用的元素

Illustrator 文档配置文件包含显示在新 Illustrator 文档中的默认图案、渐变、图形设计、颜色、颜色库和画笔。这些文件还可以确定新文档的缩放级别、窗口大小、查看首选项和滚动位置。请从 Illustrator 新文档配置文件中删除不必要的色板和画笔,由此最大限度地减小新文档的文件大小。

有关在 Illustrator 中创建自定义文档配置文件的说明,请参阅启动配置文件:自定义新文档的出色工具

从模板中删除未使用的元素

您可以使用模板创建具有通用设置和设计元素的文档。您可以从模板中删除不必要的色板、符号、图形样式和画笔,由此最大限度地减小新文档的文件大小。

有关创建模板文件的说明,请参阅文件和模板

启用图像链接

嵌入式位图图像(例如 TIFF、BMP 或 Photoshop EPS)会显著增加 Illustrator 文档的大小,从而导致性能降低。要改进性能,请在放置位图图像时启用“链接”选项。“链接”选项引用硬盘上放置的图像。

  • 选择文件”>“放置。在“放置”对话框中,选择“链接”。

如果服务机构需要嵌入式图像,则保存文件的副本。在“Illustrator 原生格式选项”或“EPS 格式选项 ”对话框中,选择“包括链接的文件 ”。

使用低分辨率 EPS 预览

如果文档包含具有高分辨率预览的 EPS 链接图像,则当您编辑图稿时,Illustrator 重绘屏幕的速度较慢。要使 Illustrator 更快地重绘屏幕,请使用低分辨率 EPS 预览。执行以下操作:

  1. 选择编辑”>“首选项”>“文件处理和剪贴板

  2. 选择“对链接的 EPS 使用低分辨率代理”,然后单击“确定”。

禁用“显示 DCS 的透明度效果”

“链接面板选项”对话框中包含“显示 DCS 的透明度效果”选项。如果选中该选项,“链接”面板上将显示一个黄色图标,以标识作为透明对象或重叠透明对象的 DCS EPS 链接图形。由于该选项强制 Illustrator 定期确定 EPS 链接文件是否具有透明度效果,因此会降低性能。

要禁用“显示透明度效果”选项,请执行以下操作:

  1. 选择窗口”>“链接。从“链接”面板菜单中,选择“面板选项”。

  2. 清除“显示 DCS 的透明度效果”,然后单击“确定”。

隐藏“导航器”面板

“导航器”面板显示当前图稿的缩览图视图以便于导航。每次您更改文档时更新缩览图所需的处理时间取决于图稿的复杂性。要改进复杂文档中的屏幕重绘速度,请隐藏“导航器”面板。在“窗口”菜单下,取消选中“导航器”。

您可以设置自定义视图以更高效地放大文档的特定区域。

禁用“消除图稿锯齿”

“消除图稿锯齿”选项通过混合对象边缘像素的颜色与相邻像素的颜色使文本和图形变得平滑。但是,此过程会导致屏幕重绘速度减慢。要禁用此选项,请执行以下操作:

  1. 选择编辑”>“首选项”>“常规

  2. 清除“消除图稿锯齿 ”,然后单击“确定”。

应用“简化”命令

“简化”命令可以减少路径和路径形状中锚点的数量,从而减小文件大小并提高性能。要应用“简化”命令,请选择所需的路径或对象,然后选择对象”>“路径”>“简化

有关“简化”命令的更多信息,请参阅 Illustrator 帮助

禁用“智能参考线”

借助“智能参考线”,您可以相对于其他对象创建、对齐、编辑和转换 Illustrator 对象。如果图稿中包含多个对象,则 Illustrator 需要较多的时间来显示“智能参考线”。要禁用“智能参考线”,请从“视图”菜单中取消选中“智能参考线”。

有关“智能参考线”的更多信息,请参阅标尺、网格、参考线和剪切记号

栅格化毛刷画笔路径并禁用 PDF 功能

毛刷画笔描边由一些重叠的已填色透明路径组成。这些路径就像 Illustrator 中的其他任何已填色路径一样,会与其他对象(包括其他毛刷画笔路径)的涂色进行混合。

在着手处理大型图稿之前,要对毛刷画笔和涂色渲染进行测试和试验。更改画笔属性并重新应用它们会重新渲染使用的所有画笔。

使用毛刷画笔时,您可以通过执行以下操作来降低文档的复杂性并减小文档的文件大小:

  • 栅格化一些毛刷画笔路径。在栅格化之前,务必保存原始图稿的副本。

如果文稿包含大量的(大于 30 个)毛刷画笔,可以降低毛刷画笔路径的复杂性并减少路径数量。选择毛刷画笔路径,然后选择对象”>“栅格化

  • 禁用 PDF 功能。

默认情况下,Illustrator 会保存可使 Illustrator (*ai) 文件与其他 Adobe 应用程序兼容的 PDF 数据。选择文件”>“保存”,或选择文件”>“另存为,然后单击“保存”。在“Illustrator 选项”对话框中,取消选中“ 创建 PDF 兼容文件”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略