了解您可以采取什么措施来使 Illustrator 在 macOS 上快速而高效地运行。

若干因素会影响 Adobe Illustrator 运行的速度和效率,例如操作系统和硬件配置、工作流程、您选择的选项等等。如果您注意到 Illustrator 运行速度比平常要慢,您可以尝试多种技巧,它们不仅可以优化 Illustrator 的性能,而且还能优化其他应用程序的性能。

在处理大型文件时,性能的改进更加显著。

准备事项

在执行以下任务之前,请确保您拥有最新版本的 Illustrator 或您当前所用版本的所有更新。软件更新通常包含与性能相关的修复或增强。

如果您使用的是 Illustrator CC,您可以通过 Creative Cloud 桌面应用程序更新 Illustrator。

优化 macOS

将操作系统配置为高效运行可以增加应用程序可用的内存量,这样有助于它们顺畅地运行。请尝试以下技巧来优化 macOS 并改进 Illustrator 性能。

管理字体

您安装的每种字体都会增加 macOS 使用的 RAM 量。仅安装所需的字体,以改进系统性能以及访问字体的应用程序的性能。使用字体管理实用程序帮助您管理多种字体。

使用 PostScript 打印机驱动程序

非 PostScript 打印机驱动程序可能会与 Illustrator 冲突。因此,Adobe 建议您在 macOS 中将 PostScript 打印机驱动程序设置为默认打印机。

步骤 1. 将 PostScript 打印机设置为默认打印机

注意:

要完成此过程,请确保一台 PostScript 打印机直接或通过网络连接到您的计算机。

  1. 从 Apple 菜单中,选择“系统偏好设置”,然后单击“打印机与扫描仪”。

  2. 如果未列出 PostScript 打印机,请单击“+”,浏览到一台 PostScript 打印机,然后单击“添加”。

  3. 从“默认打印机”弹出菜单中选择 PostScript 打印机。

步骤 2. 将 Illustrator 配置为使用非默认打印机进行打印

  1. 在 Illustrator 中打开任意文档,然后选择“文件”>“打印”。

  2. 在“打印”对话框中,选择“Adobe PostScript 文件 ”或从“打印机”菜单中选择打印机的名称

  3. 单击“存储”。

优化硬件配置

您使用的硬件会影响 Illustrator 的性能:处理器或硬盘驱动器越快,Illustrator 处理信息的速度就越快。其他硬件增强功能(例如安装额外的 RAM、使用多处理器系统或对驱动器进行优化和碎片整理)也可以改进性能。您可以尝试以下任务来优化硬件配置并改进 Illustrator 的性能。

使用更快的处理器

计算机中央处理器 (CPU) 的速度会影响 Illustrator 的速度。由于 Illustrator 处理大量的数据并执行许多计算,因此其速度取决于处理器的速度。请考虑使用处理器速度更快的计算机。

安装额外的 RAM

如果 Illustrator 的 RAM 不足,它将使用硬盘空间(即暂存盘)来处理信息。当 Illustrator 可以处理内存中的信息而不使用硬盘时,处理速度最快。

优化磁盘空间

下面是优化磁盘空间的几种方式:

  • 检查硬盘是否存在错误或使用第三方磁盘实用程序(例如 Norton Utilities)对文件进行碎片整理。如果您运行的是 macOS,则驱动器应该不需要进行碎片整理,但是可能需要使用第三方磁盘实用程序进行修复。
  • 将文件保存到访问速度较快的驱动器上。例如,使用内部硬盘驱动器而非网络服务器(网络驱动器)或外部驱动器。

有效地使用 Illustrator 功能

您在 Illustrator 中的工作方式(尤其是查看图稿的方式)会影响 Illustrator 的性能。按照下面的方式使用 Illustrator 功能有助于确保 Illustrator 顺畅地运行。

在大纲视图中工作

大纲视图会隐藏涂色属性,将图稿显示为未填色的路径。在大纲视图中工作可以加快复杂图稿(例如包含渐变或图案的对象)的显示。在大纲视图中还可以更轻松地编辑隐藏在其他已填色对象后面的对象。

要在大纲视图中显示 Illustrator 文档,请选择“视图”>“大纲”。

创建自定义视图

您可以创建文档的自定义视图。自定义视图允许您快速更改视图模式、放大率、滚动位置和图层选项。

要创建 Illustrator 文档的自定义视图,请设置要保存的视图属性。然后,选择“视图”>“新建视图”,并在“新建视图”对话框中输入名称。自定义视图将显示在“视图”菜单中。

更改栅格效果设置

您可以更改栅格效果的分辨率以优化 Illustrator 的性能。

要更改栅格效果的分辨率,请选择“效果”>“文档栅格效果设置”,然后从“分辨率 ”下拉列表中选择以下任一项:

  • 如果您正在编辑文件,请单击“屏幕”。Illustrator 将对栅格效果使用 72 ppi 的分辨率,从而提高显示速度。
  • 如果您正在打印文件,请单击“”。Illustrator 将对栅格效果使用 300 ppi 的分辨率,从而降低打印速度,但是提高打印质量。

然后,单击“确定”。

隐藏图层并删除缩览图

隐藏包含复杂图稿或高分辨率位图图像的图层后,Illustrator 重绘屏幕的速度较快。

要隐藏图层,请单击图层名称左侧的眼睛图标,清除“显示图层”,然后单击“确定”。要隐藏除选定图层之外的所有图层,请在按住 Alt 键的同时单击眼睛图标。

“图层”面板可以显示顶层图层、嵌套图层、组和对象的缩览图。要减少缩览图的数目以使 Illustrator 重绘屏幕的速度更快,请从“图层”面板菜单中选择“面板选项 ”,然后减少缩览图的数目。

  • 要从“图层”面板中删除所有缩览图,请在“行大小”部分中选择“ ”,然后单击“确定”。
  • 要在“图层”面板中删除特定元素的缩览图,请在“缩览图”部分中取消选中“图层”、“”或“对象 ”,然后单击“确定”。

禁用叠印预览

叠印预览提供“油墨预览”,大体呈现混合、透明和叠印在分色输出中的显示效果。要增强性能,请避免使用叠印预览。

要启用和禁用叠印预览,请选择“视图”>“叠印预览”。

删除未使用的画板

画板表示可以包含可打印图稿的区域。要优化性能,请考虑删除未使用或不必要的画板。

要管理画板,请选择“窗口”>“画板”。然后,选择要删除的画板,并单击“删除”。

更改暂存盘首选项

当您处理嵌入式位图图像而系统没有足够的 RAM 时,Illustrator 将使用硬盘空间作为暂存盘。访问硬盘上的信息比访问内存中的信息所需时间要长。因此,使用硬盘的一部分作为虚拟内存会降低性能。如果您需要更多内存才能在 Illustrator 中工作,请尝试添加更多 RAM。

默认情况下,Illustrator 使用系统驱动器作为其主暂存盘。请将 Illustrator 主暂存盘设置更改为最快的硬盘驱动器。

要更改暂存盘首选项,请执行以下操作:

  1. 选择“Illustrator”>“首选项”>“增效工具和暂存盘”。

  2. 从“主要”弹出菜单中选择一个硬盘。如果您打算处理大型图像并且具有多个硬盘,请从“辅助”弹出菜单中再选择一个磁盘。
  3. 单击“确定”,然后重新启动 Illustrator。

从文档配置文件中删除未使用的元素

Illustrator 文档配置文件包含显示在新 Illustrator 文档中的默认图案、渐变、图形设计、颜色、颜色库和画笔。这些文件还可以确定新文档的缩放级别、窗口大小、查看首选项和滚动位置。请从 Illustrator 新文档配置文件中删除不必要的色板和画笔,由此最大限度地减小新文档的文件大小。

有关创建自定义文档配置文件的说明,请参阅启动配置文件:自定义新文档的出色工具

从模板中删除未使用的元素

您可以使用模板创建具有通用设置和设计元素的文档。您可以从模板中删除不必要的色板、符号、图形样式和画笔,由此最大限度地减小新文档的文件大小。

有关创建模板文件的说明,请参阅文件和模板

启用图像链接

嵌入式位图图像(例如 TIFF、BMP 或 Photoshop EPS)会显著增加 Illustrator 文档的大小,从而导致性能降低。要改进性能,请在放置位图图像时启用“链接”选项。“链接”选项引用硬盘上放置的图像。

  • 转至“文件”>“放置”。在“放置”对话框中,选择“链接”。

如果服务机构需要嵌入式图像,则保存文件的副本。在“Illustrator 原生格式选项”或“ EPS 格式选项”对话框中,选择“包括链接的文件”。

使用低分辨率 EPS 预览

如果文档包含具有高分辨率预览的 EPS 链接图像,则当您编辑图稿时,Illustrator 重绘屏幕的速度较慢。要使 Illustrator 更快地重绘屏幕,请使用低分辨率 EPS 预览。执行以下操作:

  1. 选择“Illustrator”>“首选项”>“文件处理和剪贴板”。

  2. 选择“对链接的 EPS 使用低分辨率代理”,然后单击“确定”。

禁用“显示 DCS 的透明度效果”

“链接面板选项”对话框中包含“显示 DCS 的透明度效果”选项。如果选中该选项,“链接”面板上将显示一个黄色图标,以标识作为透明对象或重叠透明对象的 DCS EPS 链接图形。由于该选项强制 Illustrator 定期确定 EPS 链接文件是否具有透明度效果,因此会降低性能。

要禁用“显示透明度效果”选项,请执行以下操作:

  1. 选择“窗口”>“链接”。从“链接”面板菜单中,选择“面板选项”。

  2. 清除“显示 DCS 的透明度效果 ”,然后单击“确定”。

隐藏“导航器”面板

“导航器”面板显示当前图稿的缩览图视图以便于导航。每次您更改文档时更新缩览图所需的处理时间取决于图稿的复杂性。要改进复杂文档中的屏幕重绘速度和性能,请隐藏“导航器”面板。

  • 在“窗口”菜单下,取消选中“导航器”。

您可以设置自定义视图以更高效地放大文档的特定区域。

禁用“消除图稿锯齿”

“消除图稿锯齿”选项通过混合对象边缘像素的颜色与相邻像素的颜色使文本和图形变得平滑。但是,此过程会导致屏幕重绘速度减慢。要禁用此选项,请执行以下操作:

  1. 选择“Illustrator”>“首选项”>“常规”。

  2. 清除“消除图稿锯齿”,然后单击“确定”。

应用“简化”命令

“简化”命令可以减少路径和路径形状中锚点的数量,从而减小文件大小并提高性能。要应用“简化”命令,请选择所需的路径或对象,然后选择“对象”>“路径”>“简化”。

有关“简化”命令的更多信息,请参阅编辑路径

禁用“智能参考线”

借助“智能参考线”,您可以相对于其他对象创建、对齐、编辑和转换 Illustrator 对象。如果图稿中包含多个对象,则 Illustrator 需要较多的时间来显示“智能参考线”。

  • 要禁用“智能参考线”,请单击“视图”菜单,然后取消选择“智能参考线”。

请了解有关智能参考线的更多信息。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略