Select and edit tables

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with master pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Object styles
      3. Drop caps and nested styles
      4. Work with styles
      5. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
      11. Forms
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Share and collaborate        
    2. Share for Review
    3. Review a shared InDesign document
    4. Manage feedback 
  6. Publish
    1. Export and publish
      1. Publish Online
      2. Export content for EPUB
      3. Adobe PDF options
      4. Export content to HTML
      5. Export to Adobe PDF
      6. Export to JPEG format
      7. Export HTML
      8. DPS and AEM Mobile overview
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Scripting

Select table cells, rows, and columns

When you select part or all of the text in a cell, that selection has the same appearance as would text selected outside a table. However, if the selection spans more than one cell, the cells and their contents are both selected.

If a table spans more than one frame, holding the mouse pointer over any header or footer row that is not the first header or footer row causes a lock icon to appear, indicating that you cannot select text or cells in that row. To select cells in a header or footer row, go to the beginning of the table.

Select cells

  1. Using the Type tool  , do any of the following:
    • To select a single cell, click inside a cell, or select text, and then choose Table > Select > Cell.

    • To select multiple cells, drag across a cell border. Be careful not to drag the column or row line so that you don’t resize the table.

Märkus.

To switch between selecting all of the text in a cell and selecting the cell, press Esc.

Select entire columns or rows

  1. Using the Type tool  , do any of the following:
    • Click inside a cell, or select text, and then choose Table > Select > Column or Row.

    • Move the pointer over the top edge of a column or the left edge of a row so that the pointer becomes an arrow shape ( or ), and then click to select the entire column or row.

Before and after selecting Row

  1. Click inside a table, or select text.
  2. Choose Table > Select > Header Rows, Body Rows, or Footer Rows.

Select the entire table

  1. Using the Type tool  , do any of the following:
    • Click inside a table, or select text, and then choose Table > Select > Table.

    • Move the pointer over the upper left corner of the table so that the pointer becomes an arrow shape , and then click to select the entire table.

    Before and after selecting table

    • Drag the Type tool across the entire table.
Märkus.

You can also select a table in the same way you select an anchored graphic—place the insertion point immediately before or after a table, and then hold down Shift while pressing the Right Arrow key or Left Arrow key, respectively, to select the table.

Insert rows and columns

You can insert rows and columns using a number of different methods.

Insert a row

  1. Place the insertion point in a row below or above where you want the new row to appear.
  2. Choose Table > Insert > Row.
  3. Specify the number of rows you want.
  4. Specify whether the new row or rows should appear before or after the current row, and then click OK.

The new cells have the same formatting as the text in the row in which the insertion point was placed.

Märkus.

You can also create a new row by pressing Tab when the insertion point is in the last cell.

Insert a column

  1. Place the insertion point in a column next to where you want the new column to appear.
  2. Choose Table > Insert > Column.
  3. Specify the number of columns you want.
  4. Specify whether the new column or columns should appear before or after the current column, and then click OK.

The new cells have the same formatting as the text in the column in which the insertion point was placed.

Insert multiple rows and columns

  1. With the insertion point in a cell, choose Table > Table Options > Table Setup.
  2. Specify a different number of rows and columns, and then click OK.

New rows are added to the bottom of the table; new columns are added to the right side of the table.

Märkus.

You can also change the number of rows and columns using the Table panel. To display the Table panel, choose Window > Type & Tables > Table.

Insert a row or column by dragging

When adding columns, if you drag more than one and one‑half times the width of the column being dragged, new columns are added that have the same width as the original column. If you drag to insert only one column, that column can have a narrower or wider width than the column from where you dragged. The same behavior is true of rows, unless the Row Height for the row being dragged is set to At Least. In this case, if you drag to create only one row, InDesign will resize the new row, if necessary, so that it’s tall enough to contain text.

  1. Position the Type tool  over the border of a column or row so that a double-arrow icon ( or  ) appears.
  2. Hold down the mouse button, and then hold down Alt (Windows) or Option (Mac OS) while dragging down to create a new row, or to the right to create a new column. (If you press Alt or Option before holding down the mouse button, the Hand tool appears—so make sure you begin dragging before you press Alt or Option.)
Märkus.

Dragging to insert rows or columns doesn’t work at the top or left edges of a table. These fields are used to select rows or columns.

Delete rows, columns, or tables

  • To delete a row, column, or table, place the insertion point inside the table, or select text in the table, and then choose Table > Delete > Row, Column, or Table.
  • To delete rows and columns by using the Table Options dialog box, choose Table > Table Options > Table Setup. Specify a different number of rows and columns, and then click OK. Rows are deleted from the bottom of the table; columns are deleted from the right side of the table.
  • To delete a row or column by using the mouse, position the pointer over the border of the bottom or right side of the table so that a double-arrow icon ( or ) appears; hold down the mouse button; and then hold down Alt (Windows) or Option (Mac OS) while dragging either up to delete rows, or to the left to delete columns.
Märkus.

If you press Alt or Option before holding down the mouse button, the Hand tool will appear—so press Alt or Option after you begin dragging.

  • To delete cell contents without deleting cells, select the cells containing the text you want to delete, or use the Type tool to select the text within the cells. Press Backspace or Delete, or choose Edit >Clear.

Change the alignment of a table within a frame

A table assumes the width of the paragraph or table cell in which it is created. However, you can change the size of the text frame or table so that the table is wider or narrower than the frame. In such a case, you can decide where you want the table to be aligned within the frame.

  1. Place the insertion point to the right or left of the table. Make sure that the text insertion point is placed on the table paragraph and not inside the table. The insertion point becomes as tall as the table in the frame.
  2. Click an alignment button (such as Align Center) in the Paragraph panel or Control panel.

Navigate within a table

Use the Tab or arrow keys to move within a table. You can also jump to a specific row, especially useful in long tables.

Move within a table using Tab

  • Press Tab to move to the next cell. If you press Tab in the last table cell, a new row is created. For information on inserting tabs and indents in a table, see Format text within a table.
  • Press Shift+Tab to move to the previous cell. If you press Shift+Tab in the first table cell, the insertion point moves to the last table cell.

Move within a table using arrow keys

Press the arrow keys to navigate within and between table cells. If you press the Right Arrow key when the insertion point is at the end of the last cell in a row, the insertion point moves to the beginning of the first cell in the same row. Similarly, if you press the Down Arrow key when the insertion point is at the end of the last cell in a column, the insertion point moves to the beginning of the first cell in the same column.

Jump to a specific row in a table

  1. Choose Table > Go To Row.
  2. Do any of the following:
    • Specify the row number you want to jump to, and then click OK.

    • If a header or footer row is defined in the current table, choose Header or Footer from the menu, and then click OK.

Cut, copy, and paste table contents

When text is selected within a cell, cutting, copying, and pasting actions are the same as for text selected outside a table. You can also cut, copy, and paste cells and their contents. If the insertion point is in a table when you paste, multiple pasted cells appear as a table within a table. You can also move or copy the entire table.

  1. Select the cells you want to cut or copy, and then choose Edit > Cut or Copy.
  2. Do any of the following:
    • To embed a table within a table, place the insertion point in the cell where you want the table to appear, and then choose Edit > Paste.

    • To replace existing cells, select one or more cells in the table—making sure that there are sufficient cells below and to the right of the selected cell—and then choose Edit > Paste.

Move or copy a table

  1. To select the entire table, place the insertion point in the table and choose Table > Select > Table.
  2. Choose Edit > Cut or Copy, move the insertion point where you want the table to appear, and then choose Edit > Paste.

Convert tables to text

  1. Using the Type tool  , place the insertion point inside the table, or select text in the table.
  2. Choose Table > Convert Table To Text.
  3. For both Column Separator and Row Separator, specify the separators you want to use.

    For best results, use a different separator for columns and rows, such as tabs for columns and paragraphs for rows.

  4. Click OK.

When you convert a table to text, the table lines are removed and the separator you specify is inserted at the end of each row and column.

Combine tables

Use the Paste command to merge two or more tables into a single table.

  1. In the target table, insert at least as many blank rows as you’ll be pasting from the other tables. (If you insert fewer rows than are copied, you cannot paste.)
  2. In the source table, select the cells you want to copy. (If you copy more column cells than are available in the target table, you cannot paste.)
  3. Select at least one cell where you want the incoming rows to be inserted, and then choose Edit > Paste.
Märkus.

If the pasted rows use different formatting than the rest of the table, define one or more cell styles, and then apply the cell styles to the pasted cells. Hold down Alt (Windows) or Option (Mac OS) while clicking the cell style to override existing formatting.

Anne-Marie Concepcion provides an article about combining tables at Joining Tables.

Working with tables in Story Editor

When you choose Edit > Edit In Story Editor, tables and their contents appear in Story Editor. You can edit tables in Story Editor.

Editing tables in Story Editor

A. Table icon B. Overset graphic 

  • To expand or collapse the table in Story Editor, click the triangle to the left of the table icon at the top of the table.

  • To determine whether the table is sorted by rows or columns, right-click (Windows) or Ctrl-click (Mac OS) the table icon and choose Arrange By Rows or Arrange By Columns.

  • Use Layout view to modify and format the table. You cannot select columns or rows in Story Editor.

Adobe logo

Logige oma kontole sisse