Kasutusjuhend Tühista

How to add and edit text in Photoshop

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Photoshop and Adobe Stock
    5. Use the Capture in-app extension in Photoshop
    6. Creative Cloud Libraries
    7. Creative Cloud Libraries in Photoshop
    8. Use the Touch Bar with Photoshop
    9. Grid and guides
    10. Creating actions
    11. Undo and history
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web beta
    1. Common questions | Photoshop on the web beta 
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web beta
    4. Keyboard shortcuts | Photoshop on the web beta
    5. Supported file types | Photoshop on the web beta
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
    9. Share files and comment in-app
  7. Workspace
    1. Workspace basics
    2. Learn faster with the Photoshop Discover Panel
    3. Create documents
    4. Use the Touch Bar with Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Default keyboard shortcuts
    13. Touch capabilities and customizable workspaces
    14. Place Photoshop images in other applications
    15. Preferences
    16. Default keyboard shortcuts
    17. Rulers
    18. Show or hide non-printing Extras
    19. Specify columns for an image
    20. Undo and history
    21. Panels and menus
    22. Place files
    23. Position elements with snapping
    24. Position with the Ruler tool
    25. Presets
    26. Customize keyboard shortcuts
    27. Grid and guides
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
  17. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
    14. Text Engine error using Type tool in Photoshop | Windows 8
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors
  24. Content authenticity
    1. Learn about content credentials
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  25. 3D and technical imaging
    1. Photoshop 3D | Common questions around discontinued 3D features
    2. Creative Cloud 3D Animation (Preview)
    3. Print 3D objects
    4. 3D painting
    5. 3D panel enhancements | Photoshop
    6. Essential 3D concepts and tools
    7. 3D rendering and saving
    8. Create 3D objects and animations
    9. Image stacks
    10. 3D workflow
    11. Measurement
    12. DICOM files
    13. Photoshop and MATLAB
    14. Count objects in an image
    15. Combine and convert 3D objects
    16. 3D texture editing
    17. Adjust HDR exposure and toning
    18. 3D panel settings

New to Photoshop? Want to learn how to use the Type tool? You’ve come to the right place.

Find quick and easy answers, tips, and video tutorials for the most frequently asked questions about the Type tool.

How to add and edit text in Photoshop

Download sample file and fonts to try

To help you practice and create something nice, here’s a sample file. Download and open this PSD (ZIP, 1.35 MB) and try out all the tasks in your own file. Play with font size, font color, and placement of text to get the results you want.

If you don't have the fonts used in the sample file, you can substitute them with default fonts you have. You can also get the fonts used in the file - Nunito and Roboto. See Activate fonts for details.

Leave a comment in case your question isn’t covered here!

How to add or place text

  1. Open a photo or Photoshop document (PSD).

  2. From the toolbar, select the Type tool  or simply press ‘T’ to quickly select it. The Horizontal Type Tool with which you can add text horizontally is selected by default. If you want to add text vertically, click the Type tool again and select Vertical Type Tool from the context menu. 

    Select the Type tool from the toolbar

  3. Do you want to add a few words like a heading or title? Click anywhere on the canvas to type it. In Photoshop, this is called point text.

    The other type of text in Photoshop is called paragraph text. As the name suggests, this is used when you want to type a paragraph. Click and drag the cursor on the canvas to create a bounding box in which you can type your paragraph. This helps you efficiently edit and align the paragraph later.

    Add titles or headings with point text
    Add titles or headings with point text

    Add paragraphs with paragraph text
    Add paragraphs with paragraph text

    Märkus.

    A type layer gets automatically created when you create point or paragraph text and can be identified in the Layers panel with the T icon.

    Type layer in the Layers panel
    A type layer in the Layers panel

  4. Type your text. To save your changes, click  in the options bar or press Esc and you're good to go!

    The options bar in Photoshop on macOS
    The options bar in macOS

    The options bar in Photoshop on Windows
    The options bar in Windows

Märkus.
  • To change the font size and color, see how to resize text and how to change color of text.
  • Don't like the Lorem ipsum text while typing? You can turn off the sample text. Simply choose Edit > Preferences > Type, deselect Fill new type layers with placeholder text, and click OK.

How to select text

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. To select the entire text or paragraph on a type layer, select the Move tool  in the toolbar and double-click the text you want to select.

    Märkus.

    If you are unable to do this step, you may not have the latest version of Photoshop. In this case, select the Type tool in the toolbar, click the text you want to select, and choose Select > All in the menu bar.

  3. To select one or more characters on a type layer, simply select the Type tool in the toolbar and then click and drag the cursor over the characters you want to select. 

Once you have selected your text, you can edit your text, change color of text, resize text, copy and paste text, and more.

How to edit text

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Type tool in the toolbar.

  3. Select the text you want to edit. 

  4. The options bar in the top has options to edit your font type, font size, font color, text alignment, and text style. For details, see this video tutorial.

    Options bar in Photoshop on macOS
    Options bar in Photoshop on macOS

    A. Change horizontal text to vertical text and vice-versa B. Change font style C. Change font size D. Change pixelation of text edge (anti-aliasing) E. Change text alignment F. Change text color  G. Warp text H. View Character and Paragraph panel I. Cancel changes J. Save changes 

    Options bar in Photoshop on Windows
    Options bar in Photoshop on Windows

    A. Change horizontal text to vertical text and vice-versa B. Change font style C. Change font size D. Change pixelation of text edge (anti-aliasing) E. Change text alignment F. Change text color  G. Cancel changes H. Save changes 

    You can also use the Character panel and the Paragraph panel to further edit your text.

  5. Finally, click  in the options bar to save your edits.

How to copy and paste text

You can copy and paste text in your Photoshop document (PSD) from other documents. For example, from a Word file, a PDF file, a web page, or another Photoshop file (PSD).

Copy and paste text from a non-Photoshop file

  1. In your non-Photoshop file such as a Word file, PDF, or web page, click and drag the cursor over the text to select it.

  2. Press Command+C (on macOS) or Control+C (on Windows) to copy the selected text.

  3. Open the Photoshop document (PSD) in which you want to paste the copied text and then select the Type tool in the toolbar.

  4. Select the type layer from the Layers panel in which you want to paste the text. If you don't have type layers or want to add another type layer, see steps 2 and 3 in how to add text.

  5. Choose Edit > Paste or press Command+V (on macOS) or Control+V (on Windows) to paste your text. To undo, choose Edit > Undo Paste Text.

Copy and paste from another Photoshop document (PSD)

  1. Open the PSD you want to copy the text from. 

  2. Select the text you want to copy and choose Edit > Copy or simply press Command+C (on macOS) or Control+C (on Windows).

  3. Open the PSD you want to paste the text in and select a type layer. If you don't have type layers or want to add another type layer, see steps 2 and 3 in how to add text.

  4. Choose Edit > Paste to paste your text in the center of your canvas. You can also choose Edit > Paste Special > Paste in Place to place the text as it was in the PSD from which you had copied.

How to resize text

Struggling to change the size of your text? Here’s how you can easily do it:

Resize the entire text on a type layer

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Move tool  in the toolbar.

  3. In the options bar, do this:

    (macOS users) Check that Auto-select: Layer and Show Transform Controls are selected.

    Options bar in macOS
    Select Auto-Select Layer and Show Transform Controls in macOS

    (Windows users) Check that Layer and  icon are selected.

    Options bar in Windows
    Ensure that the highlighted fields are selected in Windows

  4. Click to select the text you want to resize.

  5. In the transform box that appears, drag one of the anchor points to resize your text proportionally. You can also do the following when you drag an anchor point:

    • Hold down the Shift key to resize your text non-proportionally.
    • Hold down the Alt key to keep the center of your text in the same place when you resize text.
    • Hold down the Command (on macOS) or Control (on Windows) to explore skewed angles when you resize your text.
  6. Finally, click  in the options bar to save your edits.

That's it! Your entire text is now resized.

Resize one or more characters on a type layer

To change the size of specific letters, numbers, or words in your text, you can do this:

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Type tool in the toolbar.

  3. Select text that you want to resize. 

  4. In the  field of the options bar, select the text size option you want. You can see the changes in real time.

    Märkus.

    If you have a paragraph text and are unable to view the entire paragraph after resizing it, drag the corners of the bounding box.

  5. Click  in the options bar and you're done! To cancel your changes, click  in the options bar.

Resize text in two ways - use the Move tool or specify a text size value
Resize text in two ways - use the Move tool or specify a text size value in the options bar

How to move text

To move your text around on the Photoshop canvas:

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the type layer that has the text you want to move.

  3. Select the Move tool  in the toolbar.

  4. In the options bar, ensure that Auto Select Layer (on macOS) or Layer (on Windows) is selected and then click the text you want to move. You can then view the transform box with the dark arrow.

  5. Click and move the transform box and then release it to place the text where you want.

How to change color of text

Change the color of your entire text

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Type tool in the toolbar and click the text for which you want to change color. The entire text in the type layer is selected.

  3. Click the Color Picker (Text Color) icon in the options bar. 

    Color picker icon in the options bar
    Click the Color picker icon in the options bar

  4. Move the color slider as you want and pick your color. You can see your text color change in real time as you pick different colors.

  5. Once you’re happy with your text color, click OK.

Change the color of one or more characters in your text

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Type tool in the toolbar.

  3. Click and drag the cursor over the characters you want to select.

  4. Click the Color Picker (Text Color) icon in the options bar. 

    Color picker icon in the options bar
    Click the Color picker icon in the options bar

  5. Move the color slider as you want and pick your color. You can see your text color change in real time as you pick different colors.

  6. Once you're happy with the text color, click OK.

Voila! You're done.

How to align and justify text

Unable to align your text properly? Here's how you can justify and align your text:

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the type layer from the Layers panel that has the paragraph you want to justify. If you want to justify a specific paragraph on a type layer, then select it.

    Märkus.

    If you have a word or a few words (that is point text), you need to convert it to paragraph text first to justify it. To change point text to paragraph text, select the type layer and choose Type > Convert To Paragraph Text from the menu bar.

  3. Choose Window > Paragraph to view the Paragraph panel.

  4. In the Paragraph panel, you can view the various Justify options. Select an option to view the changes in real time.

    Align your paragraph text with Justify options in the Paragraph panel
    Align your paragraph text with Justify options in the Paragraph panel

  5. After you’ve finalized your Justify option, click  in the options bar and you’re set! 

How to rotate text

Want to tilt or rotate your text to a certain angle? Here’s how you can do it:

  1. Open the Photoshop document with the text you want to edit.

    Märkus.

    The text must be on a type layer. Don’t see type layers in your document? See steps 2 and 3 in how to add text.

  2. Select the Move tool  in the toolbar.

  3. In the options bar, do this:

    (macOS users) Check that Auto-select: Layer and Show Transform Controls are selected.

    Options bar in macOS
    Select Auto-Select Layer and Show Transform Controls in macOS

    (Windows users) Check that Layer and  icon are selected.

    Options bar in Windows
    Select Layer and Show transform controls icon in Windows

  4. Click the text you want to rotate. You can then view the transform box around your text.

  5. Hover near the corners of the transform box. The cursor changes to a two‑sided arrow.

    Transform box
    Double-sided arrow near the transform box

  6. Click and drag the curved arrow to rotate the text the way you want. You can also specify values in the options bar to get a more precise rotation.

    Enter values to rotate your text in the options bar
    Enter values to rotate your text in the options bar

  7. Click  in the options bar and you’re done! 

Adobe logo

Logige oma kontole sisse