Käyttöopas Peruuta

Captions workflow in Premiere Pro | Adobe

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
    6. Long Form and Episodic Workflow Guide
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Start a new project
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. FAQ | Import and export in Premiere Pro
    3. Working with Panels
    4. Windows touch and gesture controls
    5. Use Premiere Pro in a dual-monitor setup
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transfer files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Source patching and track targeting
      10. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Edit, repair, and improve audio using Essential Sound panel
      5. Automatically duck audio
      6. Remix audio
      7. Monitor clip volume and pan using Audio Clip Mixer
      8. Audio balancing and panning
      9. Advanced Audio - Submixes, downmixing, and routing
      10. Audio effects and transitions
      11. Working with audio transitions
      12. Apply effects to audio
      13. Measure audio using the Loudness Radar effect
      14. Recording audio mixes
      15. Editing audio in the timeline
      16. Audio channel mapping in Premiere Pro
      17. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Set up and use Head Mounted Display for immersive video in Premiere Pro
      3. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
      3. Editing workflows for feature films
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Titles, Graphics, and Captions    
    1. Overview of the Essential Graphics panel
    2. Titles
      1. Create a title
    3. Graphics
      1. Create a shape
      2. Align and distribute objects
      3. Apply gradients
      4. Add Responsive Design features to your graphics
      5. Install and use Motion Graphics templates
      6. Replace images or videos in Motion Graphics templates
      7. Use data-driven Motion Graphics templates
    4. Captions
      1. Speech to Text
      2. Working with captions
      3. Check spelling and Find and Replace
      4. Export text
      5. Speech to Text in Premiere Pro | FAQ
    5. Best Practices: Faster graphics workflows
    6. Retiring the Legacy Titler in Premiere Pro | FAQ
    7. Upgrade Legacy titles to Source Graphics
  11. Animation and Keyframing
    1. Adding, navigating, and setting keyframes
    2. Animating effects
    3. Use Motion effect to edit and animate clips
    4. Optimize keyframe automation
    5. Moving and copying keyframes
    6. Viewing and adjusting effects and keyframes
  12. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  13. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Auto Color
    3. Get creative with color using Lumetri looks
    4. Adjust color using RGB and Hue Saturation Curves
    5. Correct and match colors between shots
    6. Using HSL Secondary controls in the Lumetri Color panel
    7. Create vignettes
    8. Looks and LUTs
    9. Lumetri scopes
    10. Display Color Management
    11. HDR for broadcasters
    12. Enable DirectX HDR support
  14. Exporting media
    1. Export video
    2. Export Preset Manager
    3. Workflow and overview for exporting
    4. Quick export
    5. Exporting for the Web and mobile devices
    6. Export a still image
    7. Exporting projects for other applications
    8. Exporting OMF files for Pro Tools
    9. Export to Panasonic P2 format
    10. Export settings
      1. Export settings reference
      2. Basic Video Settings
      3. Encoding Settings
    11. Best Practices: Export faster
  15. Collaboration: Frame.io, Productions, and Team Projects
    1. Collaboration in Premiere Pro
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Productions
      1. Using Productions
      2. How clips work across projects in a Production
      3. Best Practices: Working with Productions
    4. Team Projects
      1. Get started with Team Projects
      2. Create a Team Project
      3. Add and manage media in Team Projects
      4. Collaborate with Team Projects
      5. Share and manage changes with Team Project collaborators
      6. Archive, restore, or delete Team Projects
  16. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  17. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Consolidate, transcode, and archive projects
    8. Managing metadata
    9. Best Practices
      1. Best Practices: Learning from broadcast production
      2. Best Practices: Working with native formats
  18. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Known issues
      2. Fixed issues
      3. Fix Premiere Pro crash issues
      4. Green and pink video in Premiere Pro or Premiere Rush
      5. How do I manage the Media Cache in Premiere Pro?
      6. Fix errors when rendering or exporting
      7. Troubleshoot issues related to playback and performance in Premiere Pro
  19. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline medInstia

Learn how to work with captions in Premiere Pro. See Speech to Text to learn how to create transcripts.

 If you are using Premiere Pro versions 14.9 or earlier, see the Captions documentation for these releases.

Speech to Text and the Captions workflow in Premiere Pro

Captions and subtitles add value to videos, making them more accessible for more people – and helping to drive viewer engagement.

Premiere Pro provides a comprehensive toolset that lets you create edit, stylize, and export captions and subtitles in all supported formats.

Start by creating a transcript of your video. Edit the transcript in the Text panel and then use Create captions to add your captions to the Premiere Pro timeline. There you can adjust them like any other media using the editing tools. Edit the text in the Text panel or right on-screen in the Program Monitor. Stylize captions using the design tools in the Essential Graphics panel.

When your video is ready, you can export the captions as stylized, burned-in subtitles, a .srt sidecar text file, or embedded in a QuickTime or MXF file.

Where do Captions fit in the workflow?

Captions workflow in Premiere Pro

Usually it’s best to add captions when your edit is finished, or close to finished. You can fine-tune and edit along with a caption track.

However, if you delete caption segments, you will need to recreate them manually if you need to restore a part of a clip to your final edit.

The Captions and Graphics workspace

To access the Captions and Graphics workspace: Select Window > Workspaces > Captions and Graphics from the header bar.

Elements of the Captions workspace
Elements of the Captions workspace

The Captions and Graphics workspace consists of (A) the Text panel where you can edit text. You can see the captions displayed on (B) the Program Monitor, and you can edit the appearance of the captions in (C) the Essential Graphics panel. Captions have their own (D) caption track on the timeline where you can edit them.

Add captions to your sequence

Use a third-party service

If you already have a workflow that uses a third-party transcription service, you can bring in that file. 

  1. Import the SRT file into your Premiere Pro project just like any piece of media.
  2. Drag the SRT from the Project panel into your sequence and drop it anywhere in the sequence.

Premiere Pro creates a new caption track, and the captions are placed on the track.

Manually transcribe captions

If you have short sequences, you can choose to manually transcribe sequences.

  1. Open the Captions and Graphics workspace (Window > Workspaces > Captions and Graphics).  This opens the Text panel (where you create and edit caption text) and the Essential Graphics panel (where you stylize your text).  In the Text panel, click Create new caption track (macOS: Opt + Cmd + A | Win: Ctrl + Alt + A).

  2. In the New Caption Track dialog that opens, you can choose your caption track format and style.

    Creating a captions track
    Creating a captions track

    The default format option is Subtitle that allows you to create nice looking stylized subtitles that get burned into the video image, or can be exported as a sidecar.

     Optional: If you have created and saved any text styles previously, you can choose a style from the Style drop-down list.

    Click OK to create the track.

    Premiere Pro adds a new caption track to your current sequence.

    You can change your track format later if you want.

  3. Place the playhead at the beginning of your first piece of dialog.

     Use the waveforms in the audio to help align the text caption to the audio.

  4. Click the + icon in the Text panel to add a blank caption. Or use these keyboard shortcuts (macOS: Opt + Cmd + C | Win: Ctrl +Alt + C).

  5. Double-click New Caption in the Text panel or the Program Monitor to start editing the caption. Then type in the caption text.

  6. Trim the end of the caption in the timeline to align with the end of the spoken dialog. Continue adding captions in the same way to the rest of the audio in the sequence. 

 Check out the keyboard shortcuts at the bottom of this page to find out how you can make manually transcribing captions a breeze.

Working with captions in the timeline

Captions have their own track on the timeline where you can edit them like any other video track. Additionally, you can modify the display of the caption track.

Toggle the eye icon to turn the caption track on or off.

Click the CC icon to see options to hide or show all caption tracks, or to show just the active caption track.

Set label colors with captions.

To set label colors for all the caption items in a Captions track, select the track in the Project panel, then select Edit > Label and choose a label color.

To set a label color for an item(s) in the Captions track, select the track(s) in the timeline, then select Edit > Label and choose a label color.

 

Trim video tracks along with their linked caption tracks simultaneously.

Just select the caption track and its linked audio or video track and move it to trim both tracks at the same time. 

To turn off linking, click the Linked Selection tool in the Timeline panel.

Varoitus:

Unlike video or audio clips, if you remove a Captions item during an edit, it is deleted from the Captions track. You will need to recreate it manually if you restore that clip or clip section.

Stylize captions

You can stylize your captions using the various styling options (such as font, size, and location) in the Essential Graphics panel.

  1. In the Captions and Graphics workspace (Window > Workspaces > Captions and Graphics), select a caption on the captions track.

  2. Change font. 

    Use the Text options in the Essential Graphics panel to change the font, text alignment and tracking for your caption.

    • Font: Set font, font style and font size.

    • Paragraph Alignment: For horizontal alignment use Left align text, Center align text, Right align text and Justify. For Vertical alignment, use  Top align text, Center text vertically and Bottom align text. This defines how a caption grows when adding additional lines. 

    • Tracking: Loosen or tighten the space between characters.

    Change font properties
    Change font properties

    • Leading: Loosen or tighten the vertical space between lines.

    • Faux Styles: Bold, Italic, All Caps, Small Caps, Superscript, Subscript, Underline.

  3. Change text position.

    Align and transform text
    Align and transform text

    Use the Align and Transform options to align your text and change its position.

    • Position captions with zones: You can choose from different zones to position your caption in different areas on screen.

    • Fine tune position: Through Set Horizontal and Set Vertical Position you can add an offset to your zone setting.
       Vertical and horizontal text alignment are automatically set according to the zone position as well. 

    • Change the text box size: If you want to shrink or expand the text box size you can do this through Set Horizontal Scale and Set Vertical Scale. This will affect text wrapping and paragraph align settings. You can also change the text. box size using the text box controls on the Program Monitor.
  4. Change text appearance.

    Options to change text appearance
    Options to change text appearance

    Change the appearance of your text by playing around with the fill and stroke, background, and shadow.

    • Fill: Change the color of your captions.

    • Stroke: Add single or multiple strokes. The Graphics Properties menu under the wrench menu gives you more control over stroke styling.

    • Background: Add a background box. You can choose the color, add additional padding and change the opacity.

    • Shadow: You can add a shadow and fine tune with controls such as opacity, angle, distance and more.

Create styles for your captions

Create Track Styles for consistent styling across the entire captions track. A style saves all the settings made in the Essential Graphics panels, including font, alignment, color and more. Setting a Track Style to one caption applies it to all captions on the track. You can have different styles for different tracks.

To create a style:

  1. Edit the style of the caption text.

  2. Creating a style
    Creating a style

    Save it as a new style.

    In the Track Style section of the Essential Graphic panel, select Create Style.

    In the New Text Style dialog box that opens, give your style a name. Click OK.

    Premiere Pro saves your changes as a new text style and it is available for you to apply from the Track Style drop down list.

  3. Use the Push and Pull options when you want to make changes to a style.

    Push style to all captions on track
    Push style to all captions on track

    If you need to make changes to the style, this is easy.  First adjust the settings to your new desired look.

    Then push this style to all captions on track by clicking the Push to Track or Style icon.

    You can then choose to push to:

    • All captions on track: Only updates the captions on this track.
    • Style in project: Updates all uses of this style in project. This affects every use of the style in your project, even in other sequences.
  4. Use Sync from Style when you have made changes and want to revert those changes back to the saved style.

    Sync from Style
    Sync from Style

Supported file formats

Closed captioning

Sidecar files

  • SCC
  • MCC
  • XML
  • STL
  • SRT
  • DFXMP

XML files

  • W3C TTML (also known as DFXP)
  • SMPTE-TT
  • EBU-TT
Huomautus:

For XML files, besides viewing the captions in the Captions panel, the captions are also viewable from a text editor.

Premiere Pro supports embedding into and decoding from the following file formats:  

  • MOV
  • DNxHD MXF Op1a
  • MXF Op1a

Keyboard shortcuts

Command

macOS

Windows

Create new captions track

Opt + Cmd + A

Ctrl + Alt + A

Add a new caption segment at the playhead

Opt + Cmd + C

Ctrl + Alt + C

Go to previous caption segment in the timeline

Opt + Cmd + Up

Ctrl + Alt + Up

Go to next caption segment in the timeline

Opt + Cmd + Down

Ctrl + Alt + Down

Try it out!

Download this sample project and try experimenting with our new captions workflow!

Adobe-logo

Kirjaudu sisään tiliisi