Résolution des erreurs d’impression et d’exportation PDF dans InDesign

Découvrez comment résoudre les erreurs lorsque vous imprimez ou exportez au format PDF depuis InDesign.

Dépannage préliminaire

Essayez les solutions dans l’ordre indiqué ci-dessous pour comprendre la nature du problème. Il est possible que votre problème soit résolu dans ce processus sans recours à un dépannage avancé.

Solution

Explication

Redémarrez l’ordinateur

L’erreur ne se reproduit pas : un problème de communication temporaire, des ressources système insuffisantes ou des facteurs environnementaux tels qu’une tempête peuvent en être la cause. 

L’erreur se reproduit lors de l’impression ou de l’exportation après le redémarrage : suivez les solutions répertoriées dans l’onglet des problèmes au niveau du système.

Redémarrez l’imprimante

L’erreur ne se reproduit pas : un problème lié à la mémoire de l’imprimante pourrait être à l’origine du problème.

Créez un nouveau document type

Si vous parvenez à imprimer ou à exporter un nouveau document, mais pas le document d’origine, suivez les solutions de l’onglet des problèmes au niveau du document.

Imprimez ou exportez à partir d’une application différente

Si vous pouvez imprimer depuis une autre application (WordPad ou TextEdit, par exemple) ou exporter/enregistrer au format PDF depuis une autre application (Illustrator ou Photoshop, par exemple) mais que vous rencontrez des erreurs, suivez les solutions dans l’onglet des problèmes au niveau de l’application.

Imprimez sur une autre imprimante

Si une autre imprimante est disponible, essayez d’imprimer le document sur cette imprimante. Si cela fonctionne, vérifiez que l’imprimante d’origine est sous tension et connectée. Débranchez et reconnectez les câbles de l’imprimante, puis lancez une autovérification de l’imprimante pour détecter d’éventuelles défaillances mécaniques ou des câbles endommagés. Si le problème persiste, suivez les solutions de l’onglet des problèmes au niveau du système.

Utilisez une méthode différente pour la création du fichier PDF

Si le problème se produit :

  • Lorsque vous utilisez la fonction d’impression pour créer votre fichier PDF, choisissez plutôt Fichier > Exporter au format PDF.

Sélectionnez votre problème dans les onglets suivants et implémentez les solutions.

Si l’erreur se produit lorsque vous imprimez ou exportez un nouveau document, il se peut que les paramètres d’impression ou d’exportation du document d’origine ne soient pas valides, qu’un objet ou une police utilisé dans le document soit endommagé, ou que la structure du document soit endommagée. Essayez une ou plusieurs des étapes suivantes.

 Selon l’imprimante que vous utilisez, l’emplacement des paramètres peut varier et être différent de ce qui est indiqué dans les procédures suivantes. Consultez la documentation de votre l’imprimante.

Solution 1 : Exportez au format IDML (InDesign CS4 et versions ultérieures) ou INX (InDesign CS3 et versions antérieures).

Le document est probablement endommagé à la suite d’une conversion incorrecte à partir de versions précédentes de documents InDesign ou QuarkXpress. 

Suggestion : L’exportation au format InDesign Markup Language (IDML) ou InDesign Interchange (INX) peut éliminer les données qui posent problème.

Solution 2 : (Pour les imprimantes PostScript uniquement) Activez la gestion des erreurs Postscript.

Windows

macOS

  1. Choisissez Fichier > Imprimer.

  2. Cliquez sur le bouton Configurer.

  3. Si la boîte de dialogue suivante apparaît, cliquez sur OK : « Si le paramètre d’impression souhaité est disponible dans la boîte de dialogue d’impression d’InDesign, veuillez l’y définir afin d’éviter les conflits d’impression ».

  4. Faites un clic droit sur l’imprimante et choisissez Propriétés.

  5. Dans l’onglet Général, cliquez sur Préférences d’impression.

  6. Cliquez sur Avancé.

  7. Développez les options du document , puis développez les options de PostScript. Si l’option Envoyer le gestionnaire de traitement d’erreur PostScript n’est pas défini sur Oui, cliquez dessus et sélectionnez Oui dans le menu contextuel.

  1. Choisissez Fichier > Imprimer.

  2. Sélectionnez l’imprimante.

  3. sélectionnez Gestion d’erreur dans le menu au bas du menu Paramètres prédéfinis.

  4. Sélectionnez Imprimer le rapport détaillé, puis cliquez sur Imprimer.

Si une erreur PostScript est à l’origine du problème, le gestionnaire d’erreurs PostScript imprime une page contenant des informations sur l’erreur. Voir Dépannage des erreurs PostScript.

Solution 3 : Excluez les images du document.

Lorsque vous imprimez

Lorsque vous exportez au format pdf

  1. Choisissez Fichier > Imprimer.

  2. Cliquez sur Images, puis sélectionnez Aucune dans le menu Envoi des données.

  3. Cliquez sur Imprimer.

  1. Choisissez Fichier > Exportation, puis sélectionnez Adobe PDF (impression) comme format ou Type de fichier.

  2. Choisissez un emplacement et cliquez sur Enregistrer.

  3. Cliquez sur Avancées, puis sélectionnez les trois cases à cacher Omettre pour OPIEPS, PDF et Bitmap.

  4. Changez la norme PDF en Aucune pour autoriser l’exclusion des images.

  5. Cliquez sur Exporter.

Si l’impression ou l’exportation du document réussit, un élément graphique de la page peut être endommagé. Procédez comme suit :

  1. Supprimez un pourcentage d’images et essayez d’imprimer. Répétez le processus jusqu’à ce que vous isoliez les images ayant provoqué l’erreur.

  2. Une fois que vous avez identifié les graphiques qui produisent systématiquement l’erreur, supprimez-les et remplacez-les. Vous devrez peut-être réexporter un graphique depuis l’application dans laquelle vous l’avez créé.

Un travail d’impression qui aboutit mais qui ne contient pas d’images peut également indiquer que la mémoire d’imprimante est inadaptée. Parmi les symptômes figurent la substitution de polices, l’absence d’images ou des impressions incomplètes. Procédez comme suit :

  1. Imprimez en utilisant une plage de pages.

  2. Imprimez avec un nombre réduit d’images.

  3. Imprimez à une résolution inférieure.

 Si le document ne contient que des éléments graphiques, vous obtenez uniquement une page vierge à l’impression si l’option d’impression des pages vides est activée dans InDesign. Sélectionnez Imprimer les pages vides dans la section Général de la boîte de dialogue d’impression.

Solution 4 : Excluez ou réduisez des polices.

Lorsque vous imprimez

Lorsque vous exportez au format PDF

  1. Choisissez Fichier > Imprimer.

  2. Cliquez sur Images.

  3. Dans la section Polices, choisissez Aucune dans le menu Téléchargements.

  4. Cliquez sur Imprimer.

Vous ne pouvez pas exclure de polices lors de l’exportation, mais vous pouvez réduire le nombre de polices utilisées.

  1. Sélectionnez TexteRechercher une police.

  2. Dans la liste Polices du document, maintenez la touche Maj enfoncée, puis sélectionnez la première police et la dernière police pour sélectionner toutes les polices de la liste.

  3. Dans la liste Remplacer par famille de polices, choisissez une police dont vous savez qu’elle fonctionne dans d’autres documents, comme Arial ou Verdana.

  4. Cliquez sur Remplacer tout

  5. Cliquez sur Terminé.

  6. Choisissez Fichier > Exporter et sélectionnez Adobe PDF (Impression) comme format.

  7. Choisissez un emplacement et cliquez sur Enregistrer.

  8. Cliquez sur Exporter.

Créez une copie du document, puis testez les polices une par une pour isoler la police corrompue ou endommagée. Vous pouvez remplacer les polices corrompues en les téléchargeant à nouveau à partir du site du fabricant.

Solution 5 : Vérifiez les liens non valides.

Pour afficher l’état des liens, choisissez Fenêtre > Lien. Dissociez ou associez à nouveau les fichiers dont le nom est précédé d’un point d’interrogation ou de tout autre symbole. Pour plus d’informations sur les liens InDesign, consultez Gérer les liens des images.

Solution 6 : Désactivez les paramètres.

Désactivez autant de paramètres que possible. Si la désactivation des paramètres permet de résoudre le problème, activez-les de nouveau par petits groupes pour pouvoir lier le problème à un paramètre particulier.

 La disponibilité de ces paramètres dépend de l’imprimante que vous utilisez.

Choisissez Fichier > Imprimer pour ouvrir la boîte de dialogue Imprimer. Modifiez ensuite les paramètres dans les volets respectifs :

Volet Général

  • Définissez copies sur 1.
  • Sélectionnez Pages pour désactiver les Engraissements.
  • Effacez Imprimer les gabarits, Imprimer les objets non imprimés, et Imprimer les guides et les grilles de ligne de base visibles.
  • Définissez les calques d’impression sur Calques visibles et imprimables.

Configurer (panneau)

  • Définissez le format du papier sur Défini par le pilote.
  • Définissez Largeur et hauteur de l’échelle sur 100 %.
  • Désactivez Vignettes et Mosaïque.

Volet Repères et fonds perdus

  • Désactivez les Repères, les Fonds perdus et les Lignes-blocs.

Volet de sortie

  • Définissez la couleur sur Composite (ne pas modifier).
  • Désactivez Recouvrement, Texte en noir et Simuler la surimpression.
  • Dans le Gestionnaire d’encres, désactivez Pseudonymes d’encre.

Volet des images

  • Pour les images, définissez Envoi de données sur Aucun ou Tout.
  • Pour les polices, définissez Télécharger sur Aucun ou Tout.
  • Définissez PostScript sur Niveau 2.
  • Définissez le format des données sur ASCII

Volet Gestion des couleurs

  • Définissez la gestion des couleurs sur Laisser l’imprimante PostScript déterminer les couleurs.
  • Activez Préserver les numéros CMYK.

Panneau Pages (en-dehors de la boîte de dialogue Impression).

Sélectionnez toutes les pages, cliquez avec le bouton droit de la souris, puis choisissez Attributs de la page > Etendre l’aplatissement > Aucun (ignorer la transparence).

Solution 7 : Dépannez les problèmes liés aux modules externes.

Supprimez les plug-in tiers du dossier Plug-in d’InDesign, puis redémarrez InDesign. Si le problème persiste, déplacez de nouveau les plug-in vers le dossier Plug-in d’InDesign. Si le problème disparaît, identifiez les modules externes en conflit:

  1. Choisissez Aide > Configurer les plug-in (Windows) ou InDesign > Configurer les plug-in (macOS).

  2. Sélectionnez Tous les plug-ins du jeu, puis décochez toutes les options dans la section Affichage, sauf Tiers. Créez une liste de ces plug-in.

  3. Quittez InDesign et déplacez ces plug-in à l’extérieur du dossier des plug-in.

    • Windows : /Programmes/Adobe/Adobe InDesign [Version]/Plug-Ins
    • macOS : /Applications/Adobe InDesign [Version]/Plug-Ins
  4. Redémarrez InDesign, essayez de recréer le problème et procédez comme suit :

    • Si le problème ne se reproduit pas, répétez les étapes 3 et 4, en ajoutant quelques modules externes tiers au dossier Plug-Ins.
    • Si le problème survient de nouveau, contactez le développeur du module externe que vous avez déplacé la dernière fois pour rechercher une mise à jour.

Pour plus d’informations, voir Dépannage des plug-ins tiers InDesign.

Solution 8 : Imprimez ou exportez à partir d’un nouveau compte d’utilisateur.

Les comptes d’utilisateur peuvent parfois être corrompus et empêcher une application de lire ou d’écrire sur certains fichiers ou dossiers. Créez un nouveau compte utilisateur (ne supprimez pas l’original), connectez-vous et essayez d’imprimer ou d’exporter à nouveau le document.

Windows

macOS

Choisissez Démarrer > Panneau de configuration > Comptes d’utilisateurs.

Sélectionnez le menu Apple > Préférences système > Utilisateurs et groupes.

Solution 9 : Déterminez si le document est endommagé.

Si vous recevez une erreur lors de l’impression d’un document InDesign quelconque, essayez une ou plusieurs des tâches suivantes pour identifier la cause d’un problème au niveau de l’application.

Solution 1 : Recréez les préférences InDesign.

Dans les cas où InDesign se comporte de façon imprévisible, la suppression des préférences est souvent un bon moyen de résoudre le problème.

Il y a deux façons de recréer les préférences :

Automatiquement

Cette méthode supprime rapidement vos fichiers de préférences actuels puis régénère un nouveau jeu de fichiers de préférences par défaut. Toutefois, tous les paramètres personnalisés que vous avez pu définir sont perdus.

Manuel

Si vous ne souhaitez pas perdre vos paramètres personnalisés, renommez vos fichiers de préférences actuels avant de régénérer un nouveau jeu de fichiers de préférences par défaut. Ainsi, si les nouvelles préférences ne résolvent pas votre problème d’impression ou d’exportation, vous disposez d’une sauvegarde de vos fichiers de préférences d’origine (y compris les paramètres personnalisés), que vous pouvez utiliser pour remplacer les nouveaux fichiers de préférences.

Recréation automatique des fichiers de préférences InDesign

 La recréation des fichiers de préférences InDesign supprime les données de préférence, y compris tous les paramètres personnalisés. Si vous ne voulez pas perdre vos paramètres personnalisés, recréez vos fichiers de préférences manuellement.

  1. Quittez InDesign.

  2. Redémarrez InDesign et maintenez immédiatement enfoncées les touches correspondantes de votre système d’exploitation :

    • macOS : Contrôle + Option + Commande + Maj
    • Windows : Contrôle + Alt + Maj
  3. Dans la boîte de dialogue qui s’affiche et vous demande si vous souhaitez supprimer les fichiers de préférence InDesign, cliquez sur Oui. InDesign se lance avec les préférences par défaut régénérées.

Recréation manuelle des fichiers de préférences InDesign

Renommez les deux fichiers de préférences (par exemple, remplacez « InDesign SavedData » par « InDesign SavedData backup » et « InDesign Defaults » par « InDesign Defaults backup »). Les fichiers de préférences ont pour emplacements :

macOS

InDesign Defaults : 
Users/[utilisateur]/Library/Preferences/Adobe InDesign/Version [version]/[langue]/InDesign Defaults

 

InDesign SavedData :

Users/[user]/Library/Caches/Adobe InDesign/Version [version]/[language]/InDesign SavedData

Windows XP

InDesign Defaults :
/Documents and Settings/[utilisateur]/Application Data/Adobe/InDesign/Version [version]/InDesign Defaults

Fichiers cachés par défaut. Découvrez comment afficher les fichiers masqués.

InDesign SavedData :
/Documents and Settings/[utilisateur]/Local Settings/Application Data/Adobe/InDesign/Version[version]/Caches/InDesign SavedData

Windows 7 et 8

InDesign Defaults:

C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[language]\InDesign Defaults

Fichiers cachés par défaut. Découvrez comment afficher les fichiers cachés.

InDesign SavedData :

/Users/[utilisateur]/AppData/Local/Adobe/InDesign/Version[version]/[langue]/Caches/InDesign SavedData

Relancez InDesign. InDesign crée un nouveau jeu de fichiers de préférences par défaut.

Si votre problème d’impression ou d’exportation persiste, vous pouvez alors restaurer vos préférences d’origine en renommant les anciens fichiers de préférences avec leurs noms d’origine : InDesign SavedData et InDesign Defaults.

Solution 2 : (Sous Windows uniquement) Vérifiez que le pilote de l’imprimante est à jour.

Installez le pilote le plus récent pour votre imprimante :

Solution 3 : (Pour Windows et imprimante PostScript uniquement) Optimisez la vitesse de PostScript.

  1. Choisissez Fichier > Imprimer.

  2. Cliquez sur Configuration, sélectionnez une imprimante, cliquez sur Préférences, puis sur Avancées.

  3. Développez les options du document, puis développez les options de PostScript.

  4. Choisissez Option de sortie PostScript.

  5. Choisissez Optimiser la vitesse dans le menu contextuel, puis cliquez sur OK.

  6. Cliquez sur OK puis sur Imprimer.

Solution 4 : Désactivez la protection des pages sur votre imprimante.

Pour plus d’instructions sur la façon de désactiver cette fonction, consultez la documentation accompagnant l’imprimante.

Solution 6 : Enregistrez le fichier PDF sur un disque dur local.

Si le problème survient alors que vous exportez au format PDF sur un emplacement du réseau, essayez d’enregistrer au format PDF sur un disque dur local.

L’instabilité du réseau ou les problèmes de permission peuvent provoquer des problèmes lors des exportations Si vous pouvez exporter le fichier vers un disque local, mais pas vers un emplacement réseau, demandez à votre service informatique d’élucider le problème.

Si vous rencontrez des problèmes d’impression sur une imprimante PostScript, essayez une ou plusieurs des tâches suivantes. Imprimez après chaque tâche effectuée.

Solution 1 : Utilisez un pilote d’imprimante à jour.

Téléchargez le dernier pilote d’imprimante PostScript pour macOS ou Windows.

 Si vous utilisez une imprimante réseau, il est possible que vous utilisiez un pilote de l’imprimante compatible avec le système d’exploitation du serveur d’impression mais pas avec le système d’exploitation de votre ordinateur. Pour installer un pilote d’imprimante compatible avec le système d’exploitation, reconfigurez l’imprimante réseau avec l’Assistant Ajouter une imprimante.

Solution 2 : Utilisez un fichier PPD mis à jour.

Un fichier de description d’imprimante PostScript (PPD) décrit les capacités d’une imprimante PostScript pour des paramètres tels que les marges, la couleur et la résolution. Les fichiers PPD incorrects ou périmés peuvent augmenter les délais d’impression. Configurez votre imprimante avec le fichier PPD recommandé par le fabricant.

Pour obtenir un fichier PPD, contactez le fabricant de l’imprimante ou téléchargez-le sur site Web d’Adobe.

Solution 3 : (Pour Windows uniquement) Installez l’imprimante pour émettre un code PostScript optimisé.

Pour Windows 7 :

  1. Sélectionnez Démarrer > Périphériques et imprimantes.

  2. Cliquez avec le bouton droit de la souris et choisissez Préférences d’impression > Avancées.

  3. Développez les options du document, puis les options PostScript.

  4. Définissez l’option de sortie PostScript sur Optimiser pour la portabilité.

Solution 4 : Libérez de l’espace disque.

Assurez-vous de disposer de suffisamment d’espace libre sur votre disque dur. Essayez de garder libre au moins 10 % de votre espace disque total. Pour libérer plus d’espace, recherchez les fichiers temporaires (.tmp), supprimez-les de votre ordinateur et nettoyez le cache disque qu’utilise votre navigateur Web. Pour des instructions sur le nettoyage du cache disque, voir la documentation de votre navigateur.

Solution 5 : Imprimez à partir d’une imprimante locale.

Si vous imprimez un fichier sur une imprimante réseau, procédez à partir d’un ordinateur directement relié à l’imprimante locale. Si le fichier s’imprime correctement, des dysfonctionnements liés au réseau peuvent être la cause de votre problème. En cas d’assistance, contactez l’administrateur réseau.

Solution 6 : (Sous Windows uniquement) Installez un pilote d’imprimante compatible avec votre système d’exploitation.

Si vous utilisez une imprimante réseau, installez un pilote d’imprimante compatible avec votre système d’exploitation. Les serveurs d’impression ne prennent pas toujours en charge les pilotes pour les systèmes d’exploitation sur les ordinateurs client. Vous pouvez donc utiliser un pilote d’imprimante adapté au système d’exploitation du serveur d’impression mais pas au système d’exploitation de l’ordinateur.

Pour Windows 7 :

  1. Sélectionnez Démarrer > Périphériques et imprimantes.

  2. Cliquez sur Ajouter une imprimante.

  3. Sélectionnez Ajouter une imprimante locale.

  4. Choisissez Créer un nouveau port > Port local > Suivant.

  5. Saisissez le nom du port (par exemple, \\[nom_serveur_impression]\[nom_imprimante]), puis cliquez sur OK.

  6. Suivez les instructions à l’écran pour installer un pilote dont la marque et le modèle correspondent à l’imprimante réseau.

Si vous rencontrez des problèmes d’impression sur une imprimante autre que PostScript, essayez d’exécuter une ou plusieurs des tâches suivantes. Imprimer après chaque tâche effectuée.

 Certaines des solutions proposées nécessitent que vous changiez les propriétés du pilote de l’imprimante. Les emplacements pour les propriétés spécifiques varient en fonction de l’imprimante et du pilote de l’imprimante. Pour plus d’informations, contactez le fabricant de l’imprimante ou reportez-vous à la documentation de l’imprimante.

Solution 1 : Imprimez au format bitmap.

  1. Choisissez Fichier > Imprimer.

  2. Vérifiez que vous avez sélectionné une imprimante autre que PostScript, puis sélectionnez le volet Avancées.

  3. Cochez la case Imprimer au format bitmap et sélectionnez la résolution adéquate pour l’imprimante.

Solution 2 : Vérifiez que l’imprimante dispose de suffisamment de mémoire.

Pour imprimer en 300 ppp, l’imprimante doit disposer d’au moins 2 Mo de RAM disponible. Pour imprimer en 600 ppp, l’imprimante doit disposer d’au moins 4 à 6 Mo de RAM disponible. Pour savoir comment déterminer la mémoire disponible de l’imprimante, reportez-vous à la documentation de l’imprimante.

Solution 3 : Si votre imprimante en est équipée, utilisez le mode PostScript.

Pour plus de détails, consultez la documentation de l’imprimante.

Solution 4 : (Sous Windows uniquement) Passez à un pilote SVGA standard.

Basculez vers le pilote SVGA Windows standard pour déterminer si le pilote vidéo tiers est à l’origine du problème. Si l’erreur ne se produit pas lorsque vous utilisez un pilote SVGA standard, contactez le fabricant de la carte vidéo pour obtenir un pilote à jour. Si vous utilisez déjà la version actuelle, essayez d’utiliser une résolution vidéo différente (par exemple, 1024 x 768 plutôt qu’une résolution plus importante).

Si vous ne parvenez à imprimer ou exporter au format PDF à partir d’aucune application, contactez l’Assistance Technique d’Apple, l’Assistance Technique de Microsoft ou le fabricant de l’imprimante. Vérifiez systématiquement la connexion physique entre l’imprimante et l’ordinateur avant de contacter un service d’assistance. En effet, la solution peut consister simplement à reconnecter un câble.

Prenez également en compte les changements récents sur le système, qui pourraient affecter le processus d’impression ou d’exportation. Par exemple, avez-vous récemment :

  • Mis à jour votre matériel, ou ajouté ou supprimé des matériels
  • Ajouté, mis à jour ou supprimé des logiciels ?
  • Installé ou supprimé des polices ?
  • Effectué une connexion à un réseau ?
  • Nettoyé ou effacé des fichiers du disque dur
  • Erreurs système aléatoires ou erreurs dans d’autres applications

Souvent, une modification sur le système entraîne directement l’affichage d’un problème d’impression. Conservez un enregistrement des modifications effectuées sur le système en tant que référence pour le dépannage des problèmes d’impression ou autres.

Ressources associées

Nous sommes à votre écoute

Nous serions ravis d’avoir votre avis. Partagez votre opinion avec la Communauté Adobe InDesign

Si vous ne parvenez à imprimer ou exporter au format PDF à partir d’aucune application, contactez l’Assistance Technique d’Apple, l’Assistance Technique de Microsoft ou le fabricant de l’imprimante. Vérifiez systématiquement la connexion physique entre l’imprimante et l’ordinateur avant de contacter un service d’assistance. En effet, la solution peut consister simplement à reconnecter un câble.

Prenez également en compte les changements récents sur le système, qui pourraient affecter le processus d’impression ou d’exportation. Par exemple, avez-vous récemment :

  • Effectué des mises à jour matérielles, ajouté ou supprimé des composants matériels ? 
  • Ajouté, mis à jour ou supprimé des logiciels ?
  • Installé ou supprimé des polices ?
  • Effectué une connexion à un réseau ?
  • Nettoyé ou effacé des fichiers du disque dur ?
  • Trouvé des erreurs système aléatoires ou des erreurs dans d’autres applications ?

Souvent, une modification sur le système entraîne directement l’affichage d’un problème d’impression. Conservez un enregistrement des modifications effectuées sur le système en tant que référence pour le dépannage des problèmes d’impression ou autres.

Logo Adobe

Accéder à votre compte