註解:

在 Photoshop CS6 中,MATLAB 相關功能是 Photoshop Extended 的一部分。以往 Photoshop Extended 中提供的所有功能,現在都屬於 Photoshop CC 的一部分。Photoshop CC 沒有個別的 Extended 供應項目。

關於 Photoshop 與 MATLAB

MATLAB 是一種高階的技術運算語言,能夠讓使用者在互動式環境下進行演算規則研發、資料視覺化、資料分析以及數學運算。有了 Photoshop ,您除了可以在 Photoshop 中檢視 MATLAB 影像處理的結果,還可以將 MATLAB 指令與 Photoshop 的影像編輯功能組合在一起。

從 MATLAB 連線到 Photoshop 之後,只要在 MATLAB 指令提示字元中輸入指令,便能在 Photoshop 中執行相關作業。您可以執行 MATLAB 運算規則,並在 Photoshop 中檢視影像結果。

註解:

Photoshop 和 MATLAB 之間的通訊是使用 Photoshop JavaScript 介面與 MATLAB 程式庫介面。

設定 MATLAB 與 Photoshop

請在電腦中安裝 Photoshop 和 MATLAB,並在安裝完 Photoshop 與 MATLAB 之後,確認與 MATLAB 的整合。

針對 64 位元系統,請安裝正確的編譯器

若要在 64 位元系統上使用 Photoshop 介面,必須安裝 C 編譯器:

  • 在 Windows 上,請安裝 Microsoft Developer Studio。

  • 在 Mac OS 上,請安裝 XCode。

如需詳細資訊,請參閱 Photoshop 應用程式檔案夾中的 MATLAB Photoshop 讀我檔案。

註解:

在 Windows 中,請使用 64 位元的 Photoshop 搭配 64 位元 的 MATLAB,及使用 32 位元的 Photoshop 搭配 32 位元的 MATLAB。

確認與 MATLAB 的整合

  1. 先啟動 Photoshop ,再啟動 MATLAB。

  2. 在 MATLAB 中,增加路徑 Photoshop/MATLAB,包含次檔案夾。
  3. 在 MATLAB 指令提示字元中,開啟 MATLAB 檔案夾,再找出並開啟 Tests 檔案夾,然後輸入 testall
  4. Photoshop 與 MATLAB 便會開始執行一連串的測試,確認兩個應用程式之間的整合狀況,並會顯示摘要報告。

(選擇性) 設定從 MATLAB 存取 Photoshop

您可以設定連結至 Photoshop 的路徑,以便直接從 MATLAB 存取 Photoshop 的指令。

  1. 從 MATLAB 選單中選擇「File > Set Path」。
  2. 按一下「Add Folder」,並選取安裝了 Photoshop 的 MATLAB 檔案夾。

  3. 按一下「Save」,然後按「Close」。
  4. 從 MATLAB 選單,選擇「File > Preferences」。
  5. 在「偏好設定」對話框中,按一下左上方的「一般」樹狀結構。
  6. 按一下「Update Toolbox Path Cache」按鈕。
  7. 按一下「Apply」,然後按「OK」。

從 MATLAB 連接或中斷連接 Photoshop

  1. 在 MATLAB 中,執行下列任一項作業:
    • 若要啟動或連線到 Photoshop,請輸入 pslaunch,然後按 Enter 鍵 (Windows) 或 Return 鍵 (Mac OS)。

    • 若要中斷和 Photoshop 的連線並結束,請輸入 psquit,然後按 Enter 鍵 (Windows) 或 Return 鍵 (Mac OS)。

使用 MATLAB 說明

MATLAB 的說明系統包括 MATLAB/Photoshop 工作流程的範例。

  1. 選擇「Help > Full Product Family Help」。

    您會看到一個具有次選單項目的 Photoshop 工具箱,其中包含了有助於您快速入門的「Examples」。如果沒有看到 Photoshop 工具箱,請嘗試執行下列步驟。

  2. 按一下「Start」按鈕。
  3. 選擇「Desktop Tools > View Source Files」。
  4. 按一下「Refresh Start」按鈕,接著按「Close」,然後再查看「Help」選單中是否出現所需的項目。

MATLAB 指令

在 MATLAB 指令行中輸入指令可讓您連線到 Photoshop 或中斷連線,以及產生可在 Photoshop 文件中檢視的像素。

如需查看完整清單,瞭解 MATLAB 中所有的 Photoshop 指令,請瀏覽安裝 Photoshop 的目錄,前往 MATLAB 檔案夾查看檔案 psfunctionscat.html。在 MATLAB 指令提示字元中輸入 help (指令名稱),可顯示各個指令的完整說明,包括語法、引數以及範例。

註解:

所有 MATLAB 指令都支援日文字元。MATLAB for Windows 支援日文 Windows XP 系統上的日文介面。MATLAB for Mac OS 在日文 Mac OS 系統上只支援美國英文。如需詳細資訊,請洽詢 The MathWorks, Inc.。

在 MATLAB 中建立文件

  1. 在 MATLAB 中,輸入 psnewdoc
  2. 請執行下列任一項作業,指定新文件的屬性:
    • 若要使用預設值建立文件,請輸入 psnewdoc()。如需預設值的詳細資訊,請參閱下文。

    • 若要使用特定寬度與高度建立文件,請輸入 psnewdoc(W,H)。寬度 (W) 與高度 (H) 值會使用 Photoshop「偏好設定」對話框中「單位和尺標」目前設定的單位,其他文件屬性則會設為其預設值。

    註解:

    輸入字串「undefined」以略過輸入引數。新文件的預設尺寸是 504 x 360 像素。  

    • 若要建立文件並指定屬性,請輸入 psnewdoc(W,H,R,N,M,F,A,B,P)。如需新文件屬性的詳細資訊,請參閱以下的說明。

    下面是在 MATLAB 中建立文件並指定所有屬性的範例程式碼:

    psnewdoc(10, 10, 72, 'hi', 'cmyk', 'transparent', 2.5, 16, 'U.S. Web Coated (SWOP) v2')

新文件屬性與預設值

輸入 psnewdoc(W,H,R,N,M,F,A,B,P) 會使用下列屬性的值建立文件:

W

會使用 Photoshop「偏好設定中」對話框中,目前「單位和尺標」選項所使用的單位來指定文件的寬度。預設的寬度值為 504 像素。

H

會使用 Photoshop「偏好設定中」對話框中,目前「單位和尺標」面板所使用的單位來指定文件的高度。預設的高度值是 360 像素。

R

指定解析度。預設值是 72 ppi。

N

指定文件名稱。預設是 Untitled-X,其中 X 是新文件的索引。

M

指定色彩模式:RGB、CMYK、Lab、點陣圖或灰階。預設值是 RGB。

F

指定新文件的背景內容: 白色、背景色或透明。預設值是白色。

所謂

指定像素外觀比例。預設值是 1.0 (方形)。

B

指定位元深度:1、8、16 或 32。預設值是 8。

P

指定色彩描述檔。預設值是指定色彩模式的使用中色域。使用中色域是由 Photoshop 的「顏色設定」對話框中所指定

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策