Adobe Security Bulletin

Security update available for Adobe Acrobat and Reader  | APSB22-32

Bulletin ID

Date Published

Priority

APSB22-32

July 12, 2022

2

Summary

Adobe has released security updates for Adobe Acrobat and Reader for Windows and macOS. These updates address  multiple critical, and important vulnerabilities. Successful exploitation could lead to arbitrary code execution and memory leak.          

Affected Versions

Product

Track

Affected Versions

Platform

Acrobat DC 

Continuous 

22.001.20142 and earlier versions

Windows &  macOS

Acrobat Reader DC

Continuous 

22.001.20142 and earlier versions

 

Windows & macOS




     

Acrobat 2020

Classic 2020           

20.005.30334 and earlier versions

(Win)

 

20.005.30331 and earlier versions
(Mac)

Windows & macOS

Acrobat Reader 2020

Classic 2020           

20.005.30334 and earlier versions 

(Win)

 

20.005.30331 and earlier versions 
(Mac)

Windows & macOS

 

 

 

 

Acrobat 2017

Classic 2017

17.012.30229 and earlier versions  

(Win)


17.012.30227 and earlier versions  
(Mac)        

Windows & macOS

Acrobat Reader 2017

Classic 2017

 17.012.30229 and earlier versions  

(Win)


17.012.30227 and earlier versions  
(Mac)    
  

Windows & macOS

For questions regarding Acrobat DC, please visit the Acrobat DC FAQ page

For questions regarding Acrobat Reader DC, please visit the Acrobat Reader DC FAQ page.

Solution

Adobe recommends users update their software installations to the latest versions by following the instructions below.    

The latest product versions are available to end users via one of the following methods:    

  • Users can update their product installations manually by choosing Help > Check for Updates.     

  • The products will update automatically, without requiring user intervention, when updates are detected.      

  • The full Acrobat Reader installer can be downloaded from the Acrobat Reader Download Center.     

For IT administrators (managed environments):     

  • Refer to the specific release note version for links to installers.     

  • Install updates via your preferred methodology, such as AIP-GPO, bootstrapper, SCUP/SCCM (Windows), or on macOS, Apple Remote Desktop and SSH.     

   

Adobe categorizes these updates with the following priority ratings and recommends users update their installation to the newest version:    

Product

Track

Updated Versions

Platform

Priority Rating

Availability

Acrobat DC

Continuous

22.001.20169

Windows and macOS

2

Acrobat Reader DC

Continuous

22.001.20169

Windows and macOS

2

Release Notes     

 

 

 

 

 

 

Acrobat 2020

Classic 2020           

20.005.30362

 

Windows  and macOS  

2

Acrobat Reader 2020

Classic 2020 

20.005.30362

Windows  and macOS 

2

Acrobat 2017

Classic 2017

17.012.30249

Windows and macOS

2

Acrobat Reader 2017

Classic 2017

17.012.30249

Windows and macOS

2

Vulnerability Details

Vulnerability Category Vulnerability Impact Severity CVSS base score CVSS vector CVE Number
Use After Free (CWE-416) Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34230
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34229
Access of Uninitialized Pointer (CWE-824) Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34228
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34227
Out-of-bounds Read (CWE-125)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34226
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34225
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34224
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34223
Out-of-bounds Read (CWE-125)
Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34222
Use After Free (CWE-416)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34237
Out-of-bounds Read (CWE-125)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34238
Out-of-bounds Read (CWE-125)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34239
Out-of-bounds Read (CWE-125)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34236
Access of Resource Using Incompatible Type ('Type Confusion') (CWE-843) Arbitrary code execution Critical 7.8 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34221
Use After Free (CWE-416)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34234
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34220
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34219
Out-of-bounds Write (CWE-787) Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34217
Use After Free (CWE-416)
Arbitrary code execution Critical 7.8 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34216
Use After Free (CWE-416)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34233
Out-of-bounds Read (CWE-125) Arbitrary code execution Critical 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-34215
Use After Free (CWE-416)
Memory leak Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVE-2022-34232
Out-of-bounds Read (CWE-125)
Memory leak
Important 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVE-2022-35669

 

Acknowledgements

Adobe would like to thank the following for reporting these issues and for working with Adobe to help protect our customers:   

  • Mat Powell of Trend Micro Zero Day Initiative -  CVE-2022-34219, CVE-2022-34232
  • Mark Vincent Yason (@MarkYason) working with Trend Micro Zero Day Initiative - CVE-2022-34229, CVE-2022-34227, CVE-2022-34225, CVE-2022-34224, CVE-2022-34223
  • Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative - CVE-2022-34234
  • Anonymous working with Trend Micro Zero Day Initiative - CVE-2022-34228, CVE-2022-34222, CVE-2022-34216, CVE-2022-34215 
  • kdot working with Trend Micro Zero Day Initiative -  CVE-2022-34237, CVE-2022-34238, CVE-2022-34239, CVE-2022-34236, CVE-2022-34220, CVE-2022-34217, CVE-2022-35669
  • Mat Powell of Trend Micro Zero Day Initiative and Kai Lu of Zscaler's ThreatLabz -CVE-2022-34233
  • Dennis Herrmann and Sebastian Feldmann working with Trend Micro Zero Day Initiative - CVE-2022-34226 
  • Aleksandar Nikolic of Cisco Talos  - CVE-2022-34230, CVE-2022-34221

Revisions:


For more information, visit https://helpx.adobe.com/security.html, or email PSIRT@adobe.com.

 Adobe

קבל עזרה במהירות ובקלות

משתמש חדש?