System requirements

The following system requirements apply to Adobe Sign (formerly Adobe Document Cloud eSign services or Adobe EchoSign).

Browser

  • Microsoft Windows 10 using Microsoft Edge, Internet Explorer 11, or a current version of Firefox, or Chrome
  • Microsoft Windows 8 using Internet Explorer 11 or later, or a current version of Firefox, or Chrome
  • Mac OS X v10.9 or later using Safari 7 or later, or a current version of Firefox, or Chrome

הערה:

The Microsoft Edge browser does not natively support 256-bit AES encryption of PDF files.

If you are using the Edge browser, please ensure you are running the latest version of Adobe Reader

Mobile app

Language versions

US English

UK English

French

German

Spanish

Catalan

Basque

Brazilian Portuguese

Portuguese

Japanese

Chinese (Simplified)

Chinese (Traditional)

Korean

Indonesian

Malay

Thai

Vietnamese


Croatian

Czech

Polish 

Romanian

Russian

Slovenian

Slovakian 

Turkish

Ukrainian

Danish

Dutch

Finnish

Hungarian

Icelandic

Italian

Norwegian

Swedish



Supported document formats for signature

  • Adobe PDF (.pdf)
  • Microsoft Word (.doc and .docx)
  • Microsoft Excel (.xls and .xlsx)
  • Microsoft PowerPoint (.ppt and .pptx)
  • Text (.txt)
  • Rich Text (.rtf)
  • Graphics (.tif, .jpg, .jpeg, .gif, .bmp, and .png)
  • Web (.htm or .html)

Software required to view a signed document

  • Adobe Reader 9.0 or later for documents secured with AES 128-bit encryption or lower
  • Adobe Reader 10 or later for documents secured with AES 256-bit encryption

Adobe online services are available only to users 13 and older and require agreement to additional terms and the Adobe Privacy Policy. Online services are not available in all countries or languages, may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

IP Ranges to Whitelist

If you explicitly whitelist IP addresses on your network, please add the below IP ranges to your firewall:

North America:

  • 52.71.63.224/27 
  • 52.35.253.64/27 
  • 40.67.155.147/32
  • 40.67.154.249/32
  • 40.67.155.185/32
  • 40.67.155.112/32

Europe:

  • 52.48.127.160/27 
  • 52.58.63.192/27 

Japan:

  • 52.196.191.224/27 

Australia:

  • 52.65.255.192/27 

India:

  • 13.126.23.0/27


IP ranges for outbound mail relays

If your organization whitelists IP addresses to control connection to your inbound mail servers, add the following IP addresses to your whitelist:

  • 40.67.157.141/32
  • 40.67.154.24/32
  • 40.67.158.131/32
  • 52.205.63.172/30
  • 52.41.255.236/30
  • 52.208.255.252/30
  • 52.59.244.0/30
  • 52.197.127.252/30
  • 52.65.63.248/30
  • 13.126.23.32/30

SSL/TLS Requirements

Transport Layer Security (TLS) is the most widely deployed security protocol used today for Web browsers and other applications that require data to be securely exchanged over a network. Connections to Adobe Sign require use of TLS 1.2 and support for at least one of the cipher suites below.  These requirements apply both to inbound traffic to Sign servers (browsers, API) and outbound traffic from Sign servers to customer servers (API callbacks used for retrieving agreement source documents, returning status, and webhooks).

 

For browsers: as long as you adhere to the OS/Browser requirements, you should have no browser related issues. All these OS/browsers are fully compliant with our TLS requirements.

 

For applications using the Sign API,  these frameworks support TLS 1.2:

  • Java: use Java 8 or later
  • .NET: use .NET 4.6 or later
  • OpenSSL: use OpenSSL 1.0.1 or later

 

For servers used to received callbacks or webhook requests from Sign:

  • Support TLS 1.2 and at least one of the cipher suites listed below
  • Have a valid TLS certificate, and include all intermediate certificates.

Customers who wish to test that their server is compliant can use a variety of free or commercial tools, including the Qualys SSLLabs Server Test, to ensure that their server accepts TLSv1.2, supports at least one of the cipher suites below and has a valid certificate.

 

TLS Cipher Suites Required:

TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA

TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256

TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256

TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA

TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384

TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384

TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA

TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256

TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256

TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA

TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384

TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384

TLS_RSA_WITH_AES_128_CBC_SHA256

TLS_RSA_WITH_AES_128_GCM_SHA256

TLS_RSA_WITH_AES_256_CBC_SHA256

TLS_RSA_WITH_AES_256_GCM_SHA384

SSL Certificate Authority / Certificates (Active as of May 2, 2018)

Adobe Sign is moving to a new SSL Certificate on May 2, 2018. There is no change to the public key, underlying cryptographic protocols or scheme.

Only the Adobe Sign Certificate (listed below) is changing. The Public Key, Root CA, and Intermediate CA will remain the same.

Please contact Customer Support with questions.

הורד

הורד

עבודה זו בוצעה ברישיון של Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  הודעות המתפרסמות ב- Twitter™‎ ו- Facebook אינן מכוסות בתנאי Creative Commons.

הצהרות משפטיות   |   מדיניות פרטיות מקוונת