Learn how to vectorize pixel-based images automatically in Illustrator using Image Trace.
MG_Bio

Article contributed by: Monika Gause

Monika Gause is a freelance Communication Designer, Technical Writer, and teacher based in Hamburg, Germany. Vector graphics has been the constant in a career that led her from desktop publishing to multimedia, web design and - currently - writing. She has built 3D animations for museums, designed small companies' websites, and illustrated countless office supply items. As a teacher and an ACP in the Adobe forums, she loves to dive into her clients' and the forum participants' workflows and problems and develop solutions for them.


With the Image Trace function, you can vectorize pixel-based images automatically in Illustrator. People often refer to this kind of function as Autotracing. The results depend on the nature, quality, and size of the source image and the settings you choose in Illustrator. So to get good results you have to begin with the source image. 

Preparing files for image trace

Spend some time to optimize your images for tracing, so they can be processed faster and better and also it's difficult to edit the result after tracing.  

It's important to delete everything that you don't need from images, using an image-editing application. Remove dust and scratches. In case, there's a colored background – even a faint paper color – and you want that to be white, then it's better to get rid of it in image editing. It's important to isolate portraits in case you want to trace them in the 1-color stencil artwork (the iconic Che Guevara fashion). 

Isolate the subject from the background
Isolate the subject from the background

Although image trace does not work too well for 1-bit-images, it works really well for the grayscale image source. Also when optimizing sketches, brushstrokes, letterings, or the like, leave some anti-aliasing along the edges of the artwork. Image Trace can handle it better and produce smoother curves. 

Anti-aliasing in image
Preparing an image with the levels function in Photoshop – keeping slight anti-aliasing around the edges (top) vs. eliminating anti-aliasing (bottom)

The Image Trace function gives you warnings about file size when your image is larger than 1500 pixels wide or high, but work nonetheless, only slower. 

Large image warning
Large image warning

Save your optimized graphical artworks without using lossy compression in formats such as PNG, TIF or PSD. For photos, JPEG works.

Placing Files in Illustrator and applying the feature  

The steps to apply the function to a raster image are the same for all image types.

  1.  In Illustrator, create a new file in the desired document color mode and size. 

  2. Drag your source image into it from the Mac OS Finder resp. Windows Explorer or use File > Place to import it. For the Autotrace function, it doesn't matter if you embed or link the file. Don't check the Template option when placing the file, because it places the file on a locked layer.

  3. Select the source image and open the Image Trace panel via Window > Image Trace. Alternatively you can select a preset from the Control panel (by selecting from the small menu to the right of the Trace button) or the Properties panel (by clicking the Image trace button and then selecting from the menu). 

    The presets menu in the control panel
    The presets menu in the control panel  
    quick-actions
    The Image Trace button in the Properties panel’s Quick Actions section pops up the presets menu

    Doing so applies the preset to the image immediately and trace it. This might cause a delay while Illustrator is working.

    All the presets can be fine-tuned in the Image Trace panel and it pays off to do so. So if you haven’t already, you can open the Image Trace panel by clicking the button in either the Control panel or the Properties panel’s Image Trace section. 

    For deatiled information about the presets that you can use to generate a good-quality image trace, see Image tracing presets.

What to do if the Trace command is not active? 

In case the Image Trace command is not active, there might be a couple of reasons:

  • The image needs to be selected: Select the image you want to trace by clicking on it with the selection tool.
  • If that is not possible, check if the layer or the image itself is locked.
  • If everything is already unlocked, check if the selected image is a clipping group. If so, use Object > Clipping Mask > Release. Then delete the mask and select the image. This might happen when you copy/pasted the image from another application via the clipboard. 
clip-group
Clipping Mask (displayed as Clip Group) in the Control panel (left) and in the Properties panel (right)  

How is Image Trace different from the live trace?

The Image Trace feature shares most of the options, but they have been implemented differently. The source image optimization options in the left side of the Live Trace panel, such as the blur, have been integrated into the function and are applied automatically based on image analysis. 

Limitations

Image Trace is not the best method to choose when you want to vectorize the following images:

  • Geometric shapes: When you need to trace a logo, icon, symbol, or the like that has exact geometric shapes such as triangles, hexagons, or even straight lines in it, you'd better do it manually. Humans can recognize these shapes even in a badly compressed JPEG or on crumpled paper. Software just sees a bunch of pixels even in the best quality source file. 
  • Text: When you need to vectorize Text, it's always best to identify the font, for example, using Adobe Capture or Adobe Photoshop and then use that particular font to typeset the text. For longer text, you can use Adobe Acrobat optical character recognition (OCR) to create a text file. After typesetting and formatting in Illustrator, outline the text if necessary (such as, for cutting vinyl or generally before sending out logos).
  • Photos: Using autotracing to be able to scale up the photos most likely fails. The pixels in your image can only be made into shapes. In a small size, it doesn't show, but when you enlarge the image, those shapes become bigger. Just like pixels do. 
Traced photo (left), Zoomed in (center), Outline view (right)
Traced photo (left), Zoomed in (center), Outline view (right)
  • Gradients: The function can't generate gradients. They are converted to neighboring shapes with solid colors
Gradients are converted to single, solid colored shapes
Gradients are converted to single, solid colored shapes
  • Detailed artwork: Details in artworks almost always get lost, because you have to find an overall compromise between exact results and smooth paths. Smooth paths are more important than details most of the time and you can't have smooth paths in one part of the image and details in another part.
    Don't expect to get high-quality vector artwork from a small GIF that is barely recognizable by autotracing it.
A 70x70 pixels GIF (left:  source) cannot be improved by autotracing it (right: result)
A 70x70 pixels GIF (left: source) cannot be improved by autotracing it (right: result)