What's new and changed in Illustrator CC 2015.3

New features in June 2016

Fast export

Smartly collect Assets and export to multiple file types and scales.

Now export individual artwork or entire artboards to various file sizes and formats in one click of a button. Suited well for mobile and web workflows, the feature ensures that your time is spent on getting the design right, and not on manually repetitive export workflows.

  • The new Export for Screens dialog (File > Export > Export for Screens) allows you export artboards or artwork with various file options.
  • The new Asset Export panel (Window > Asset Export) provides you a holding area to collect assets that you frequently edit and export.
The Export for Screens dialog.


For more information on this enhanced feature, see the section on Collaboration in the article Collect Assets and Export in Batches.

Live Shapes enhancements

Do more with Live Shapes

Live Shapes have been enhanced to make your workflow easier, and also in response to feedback received about the way users interact with different shapes. Some notable changes are:

  • The bounding box has been simplified to present a more clutter-free experience while working with Live Shapes.
  • While working with the Shape tool, you can show or hide the bounding box (Toggle (Win) Shift + Ctrl + B, or (Mac) Shift + Cmd + B).

Polygons:

  • Polygons now retain their Live Shape properties even after the original Live Shape is modified (scaled, sheared, reshaped, etc.)
  • The Radius widget is not drawn by default at a 90 degree angle. 
  • If a polygon is modified, a new option is available to make the sides of the polygon equal in length.

For more information on the enhanced tool, see the article on the Live Shapes.

Enhanced Creative Cloud Libraries

Libraries have been enhanced to provide more control while collaborating with other users (read-only Libraries), and even deeper integration with Adobe Stock (now featuring 50+ million assets). 

Larger Libraries Panel. On computers that have screens wider than 1680px, the Libraries panel opens in a larger form, stretching vertically along the right corner of the screen. 

Better integration with Adobe Stock

  • In-app purchase for Adobe Stock images. When you search for an image on Adobe Stock via the CC Libraries panel and place it in your document, you now have a shopping cart icon that enables you to initiate the purchase process right from the asset. Also, the Links panel also displays a shopping cart icon next to un-licensed Adobe stock images placed in your layout. Clicking the cart icon also initiates the purchasing process.
  • Open-in from Adobe Stock. While searching for an asset on Adobe Stock, in addition to downloading the asset to your Desktop or CC Library, you can directly place the asset in your document.

For more information on this enhanced feature, see the section on Collaboration in the article Creative Cloud Libraries.

See how it works ›

Start and Recent Files workspaces

Now available in all language versions of Illustrator

Start workspace. When you launch Illustrator or when you close all Illustrator documents, a new Start workspace is displayed. You have convenient access to your recently used files, Libraries, and starter templates with the Start workspace. If you prefer the older dialogs, you can still type Ctrl/Cmd + O to launch the Open dialog, or Ctrl/Cmd + N to launch the New Document dialog.  

Recent Files workspace. If you have a document open, you can view the most recent files that you have worked on using the Recent Files workspace (Ctrl/Cmd + O, or Window > Workspace > Recent Files.). To enable the Recent Files workspace from the Preferences dialog, select the Show "Recent Files" Workspace When Opening A File checkbox (Illustrator > Ctrl/Cmd + K > General tab). 

For more information on the new workspaces, see the article on the new workspaces.

For Illustrator-specific information, see the Workspace Basics article.

What's new and changed in Illustrator CC 2015.2

New features in November 2015

Enhanced Creative Cloud Libraries

Now search for your assets across libraries and Adobe Stock. Work with your existing or older colors by importing color swatches and groups. There's better support for your paragraphy and character styles in libraries, for more creative control over your text, too.

See how it works ›

For more information on this enhanced feature, see the section on Collaboration in the article Creative Cloud Libraries.

Start and Recent Files workspaces

Available in English language versions of Illustrator

Start workspace. When you launch Illustrator or when you close all Illustrator documents, a new Start workspace is displayed. You have convenient access to your recently used files, Libraries, and starter templates with the Start workspace. If you prefer the older dialogs, you can still type Ctrl/Cmd + O to launch the Open dialog, or Ctrl/Cmd + N to launch the New Document dialog.  

Recent Files workspace. If you have a document open, you can view the most recent files that you have worked on using the Recent Files workspace (Ctrl/Cmd + O, or Window > Workspace > Recent Files.). To enable the Recent Files workspace from the Preferences dialog, select the Show "Recent Files" Workspace When Opening A File checkbox (Illustrator > Ctrl/Cmd + K > General tab). 

For more information on the new workspaces, see the article on the new workspaces.

For Illustrator-specific information, see the Workspace Basics article.

Shaper tool

Convert your natural, free-flowing gestures into perfect geometric shapes. And then use them like regular shapes - combine, delete, fill, and transform them - to create editable designs. You can use the Shaper tool in both - the traditional workspaces and in the touch-optimized Touch workspace.

See how it works ›

For more information on this new tool, see the article on the Shaper tool.

New Live Shapes

More of the Illustrator Shape tools are now fully live, interactive and dynamically adjustable, so you can quickly modify and enhance traditional vector shapes without having to apply special effects or use other tools.

See how it works ›

For more information on this enhanced feature, see the article Live Shapes.

Dynamic Symbols

Symbols can now share a master shape but be modified to have different appearances such as stroke, fill and opacity. Scale, rotate, mirror and skew them without having to break the link to the parent symbol.

See how it works ›

For more information on this new feature, see the article Dynamic Symbols.

Smart Guides

You now have the ability to align and space objects using the enhanced Smart Guides in Illustrator CC 2015. Check the new hints to draw perfect shapes like squares and circles without using control keys and modifiers.

New SVG Export options

A new SVG Export workflow (File > Export > SVG) is available to export web-optimized SVG files for your web and screen design workflows. You can also choose to export individual objects versus the entire artboard.

See how it works ›

For more information on the enhanced feature, see the section on the web-optimized SVG export options in the article SVG.

Touch workspace enhancements

The Touch workspace for Windows tablets adds the Shaper tool, new Live shapes, enhanced Smart Guides, an option to easily zoom when using a mouse and support for HP Sprout.

Mobile apps

Adobe Capture CC integration

Use an iPad, iPhone or Android phone to turn any image into a production-ready asset. Extract a color theme or create a brush, shape or vector graphic, and then save the asset to your Creative Cloud Libraries to use in Illustrator.

Adobe Illustrator Draw for Android

Create freeform vector designs on your Android phone with the Adobe Illustrator Draw app, and then send your work to Illustrator on your desktop to refine it further.

Enhanced Comp CC integration, plus iPhone support

Now you can use Comp CC to explore layout possibilities on your iPhone as well as your iPad. Assets in Comp can be linked so when you edit them in Illustrator or another Creative Cloud desktop app, they'll instantly update in Comp.

What's new and changed in Illustrator CC 2015

June, 2015

Linked Assets in Creative Cloud Libraries

Edit once, update everywhere.

Graphics in Creative Cloud Libraries are now linked, so that when they’re changed, you and your team members have the option of updating them across any Illustrator CC, Photoshop CC, or InDesign CC projects where they’re used. Adobe CreativeSync powers your libraries and keeps everything up to date and right at your fingertips for a seamless workflow. All your projects are always up-to-date with your latest edits!

For more information on this enhanced feature, see the section on Collaboration in the article Creative Cloud Libraries.

Adobe Stock

Millions of high-quality images. Right inside Illustrator.

Search from just under 40,000,000 images, vectors, and artwork! Check out Adobe Stock!
Search 40 million photos, illustrations, and vectors.

With Adobe Stock, you can purchase, access, and manage high-quality, high-resolution, royalty-free images directly from Illustrator CC, Photoshop CC, InDesign CC, and other Adobe desktop apps.
You can save images directly to Creative Cloud Libraries. You can license an image immediately, or save a watermarked preview to use in a comp. Thanks to Adobe CreativeSync, you can immediately access your images across your desktop and mobile devices, and even share them with your team. When you're ready to use the non-watermarked version, you can license the image for use directly in Illustrator.

For information on using Adobe Stock, see Using Adobe Stock.

For answers to questions about Adobe Stock service, see Adobe Stock Common Questions.

10x faster zoom, pan, scroll

Any which way — 10x faster.

Pan, zoom and scroll up to 10 times faster, thanks to Mercury Performance System enhancements that brings GPU acceleration to both Mac and Windows.

Zoom is now animated, so you can quickly zoom in and out of your document by scrubbing left and right. You can also click and hold the Zoom tool over a spot to dynamically zoom in.  

Watch this video on the performance enhancements in Illustrator CC 2015.

For more information, see the knowledgebase article on GPU Performance feature.

10x greater zoom magnification

64,000%, up from 6,400%

Work with greater precision and make accurate and exact edits with the new 64,000% zoom level. Previously, the maximum zoom achievable was 6,400%.

Safe Mode

Diagnose and fix startup problems.

Safe Mode is a new feature that enables Illustrator to launch even if there are fatal, crash-inducing files (for example, corrupt fonts, out-of-date plug-ins, or incorrect drivers) in the system. You can choose to diagnose the cause of the error. When the application starts after isolating and disabling crash-causing files, Illustrator is in Safe Mode.

The Safe Mode dialog lists crash-causing issues
The Safe Mode dialog lists crash-causing issues.

The Safe Mode dialog provides you with information to diagnose and troubleshoot the problem area, thus providing you with a way to fix any issues. When done, mark all issues resolved and enable Illustrator to relaunch in normal mode at the next restart.

For more information, see Safe Mode.

Recover data in your files

Never lose your work again.

Forgetting to periodically save your open projects can cause you to lose time and work if an improper shutdown happens before you could save your files. An improper shutdown could be Illustrator crashing, an operating system error, or a power outage.

When such an error occurs, simply relaunch Illustrator and your work can be restored. If the cause of error is a damaged font or incompatible driver or plug-in, Illustrator provides you with options to diagnose the issue and fix any errors.

For more information, see the article on recovering document data after a crash.

Integration with Creative Cloud mobile apps

Adobe Comp CC, Illustrator Draw, Photoshop Sketch, and more!

Illustrator no longer requires you to be at your studio or office to be creative and productive. Keep your ideas, discoveries, and thoughts constantly evolving and rapidly developing into awesome artwork and projects – all while on-the-go – using Adobe’s mobile apps. A few examples:

Adobe Comp CC. Pull creative assets into Comp from your or your team’s shared Creative Cloud Libraries, then instantly send your layouts to Illustrator. All your text, images, and graphics are live and fully editable.

Comp for iPad is available as a free download through the iTunes App Store.


Illustrator Draw. Create with your favorite vector drawing tools and features in a streamlined, modern interface. You can draw lines, shapes, and free-form illustrations and with ten drawing layers and a photo layer. Creative Cloud connectivity makes it easy to apply finishing touches in Illustrator CC or Photoshop CC.

Draw for iOS (iPhone, iPad, and iPad Mini) is available as a free download through the iTunes App Store


Adobe Shape CC. Photograph any object, design, or shape - and convert them into vector shapes in a few simple steps. Store the resulting vectors in your Creative Cloud Libraries, and access them or refine them in Illustrator or Photoshop.

Shape is available as a free download through the iTunes App Store.


Adobe Brush CC. Use your iPad or iPhone to design beautiful, high-quality brushes from photos of anything that inspires you. Save the brushes to your Creative Cloud Library and access them anywhere across Photoshop and Illustrator!

Adobe Brush for iOS is available as a free download through the iTunes App Store.


Adobe Color. Capture inspiring color combinations wherever you see them, in a fun and intuitive way. Simply point the camera at something colorful and Adobe Color CC will instantly extract a series of colors.

Color for iOS (iPad, iPad Mini, iPhone, and iPod Touch) and Android is available as a free download through the iTunes App Store.


Creative Cloud Charts (Preview)Feature no longer available

This feature is no longer available in Illustrator v19.2 (November, 2015) and later.

Create, edit, color, and generate amazing infographics
Create, edit, color, and generate amazing infographics!

Creative Cloud Charts (Preview) was introduced in the June 2015 release of Illustrator CC as a technology preview to gather real-world feedback from customers on the new service. Based on customer feedback, the Illustrator team has decided to pause Charts and revisit the design of the feature. The Charts preview won’t be included in Illustrator with the November 2015 release.

After November 30, 2015 when an Illustrator document containing a chart is opened, the Chart will be converted to standard Illustrator vector graphics. Customers who have Chart data they would like to save will have until January 15, 2016 to visit the Creative Cloud Charts service and copy the chart data to a spreadsheet that can be saved to their desktop. Please refer to the Creative Cloud Charts FAQ for more information.

GPU Performance

Leverage the power of your GPU! Now for Macs, too!

The 2015 release of Illustrator CC now better leverages the power of GPU to render content — which means faster artwork rendering during zooming, panning, and scrolling. Each art type has been rewritten, so that it is computed and rendered on the graphic processor. GPU enhancements are now available for Macs as well.

For more information, see the knowledgebase article on GPU Performance feature.

Touch workspace enhancements

Image Place
You can now place an image (raster format) in the Touch workspace.

Distribute Options in Align Panel
Previously, the Align panel did not have distribute options. Now, users can use the two most popular align options from the align panel in the Touch workspace.

Tools reset
Some tools in the Touch workspace have options like Draw from Center in Shape Tools, Merge and Subtract Mode in Shape Builder. When switching between tools, one often forgot that an option was enabled when the same tool was used previously. This affected productivity. Now, whenever there is a change of tools in the Touch workspace, the active tool becomes available with the default settings.

Flip buttons for Variable Width
Stroke options in the Touch workspace have a way to apply variable-width profiles to paths, to make them look organic. Variable-width profiles are based on an arbitrary direction (one end - thin, the other - thick). With the introduction of Flip buttons for these profiles, you now have better control on variable-width profiles they use on paths in the Touch workspace

Tool enhancements

Curvature tool

Separate Rubber-banding Preference
Rubber-banding preferences for the Pen and Curvature tools were tied to one single value. The Illustrator team found that users preferred this value for the Curvature tool than for the Pen tool. Now, both tools have separate values so that users have independent control over both tools.

Joining two paths
The Curvature tool only worked with one path at a time - the active path. Now it is possible to join a non-active path and continue working with it.

Start from either ends
The Curvature tool had a fixed direction of working - even when a path was deselected and reselected. Now for any open path, users can pick which end of the path to start working with. To be able to draw from the other end-point, press Esc to deselect the active curvature point, click and move the end-point slightly, and then continue drawing with the Curvature tool.  

Shape Builder Tool: free-form Mode

The Shape Builder tool previously had linear feedback for Merge and Subtract options. Now, this tool can be used in free-form mode. This mode is on by default. To get back to older, straight-line feedback, change the option in the tool's options dialog. This is available in the Touch workspace as well.

Pencil Tool: Turn off auto-close

Although most users loved auto-close in Pencil Tool, there were some users who required path closure to occur at their own discretion. The Pencil tool options dialog now has an option to control auto-closing.

Other important enhancements

Copy-paste hexadecimal values

When copying a hexadecimal value from other applications, users most likely pick the '#' symbol with the actual hexadecimal value. The Hex field in Color panel only accepts pure hexadecimal values, and repeated, precise copy-paste actions are required until only the right value is pasted. Now, this field automatically removes pasted characters that are not part of the hexadecimal value. This makes it much easier to bring in hexadecimal values using a copy-paste workflow.

Used Swatches on gradient stops

There are times when gradient stops are defined by a swatch color. Previously, it was not possible to identify this swatch when the Color Stop was double-clicked. Now, if a color swatch is used on the Color Stop, it retains the information and highlights the swatch used when the Color Stop is accessed.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy