Use Adobe Shape CC on your iPhone or iPad to photograph objects, designs, or shapes, and convert them into vector shapes in a few simple steps. Store the resulting vectors in your Creative Cloud Libraries, and access them or refine them in Illustrator or Photoshop.

Learn more about the Adobe Shape CC app.

Download the awesome Adobe Shape CC app from the iTunes app store (available for iPhone and iPad).


If you want to base a new drawing on an existing piece of artwork, you can trace it. For example, you can create a graphic based on a pencil sketch drawn on paper. Or, import a raster image saved in another graphics program, and trace over it.

The easiest way to trace artwork is to open or place a file into Illustrator, and automatically trace the artwork using the Image Trace command.

Several tracing presets provide prespecified tracing options for specific types of artwork. For example, if you’re tracing an image that you plan to use as a technical drawing, choose the Technical Drawing preset. All the tracing options change for optimal tracing of a technical drawing.

You can also control the level of detail and how the tracing is filled, and even save the settings as a custom preset for future use.

For a video on tracing, see Image Trace in Illustrator CS6.

Using Live Trace.

Before and after tracing a bitmap image
Before and after tracing a bitmap image using the Image Trace command

Trace an image

  1. Open or place a bitmap image to use as a source.

  2. With the placed image selected, do one of the following:

    • Choose Object > Image Trace > Make to trace with default parameters.
    • Choose Window > Image Trace, and choose one of the default presets by clicking the icons on top of the panel.
    • Choose Window > Image Trace and choose a preset or specify the tracing options. In the Image Trace panel, enable Preview to see the results of your modifications.

     

    Note:

    You can also click the Image Trace button in the Control panel, or select a preset from the Tracing Presets button .

  3. (Optional) Adjust the results of the tracing in the Image Trace panel (Windows > Image Trace).

  4. To manually edit the vector arwork, choose Object > Image Trace > Expand and convert the tracing object to paths.

Tracing options

Preset

Specifies a tracing preset. Click the menu icon to save the current settings as a new preset, or to delete or rename existing presets.

Note:

You can’t edit or delete the default presets (default presets appear in brackets [ ]). However, you can make an editable copy of a default preset by selecting the preset and clicking New.

View

Specifies the view of the traced object. A tracing object is made up of two components: the original source image and the tracing result (which is the vector artwork). You can choose to view the tracing result, source image, outlines, and other options. Click the eye icon to overlay the selected view over the source image.

Mode

Specifies a color mode for the tracing result.

Palette

Specifies a palette for generating a color or grayscale tracing from the original image. (This option is available only when Mode is set to Color or Grayscale.)

To let Illustrator determine the colors in the tracing, select Automatic. To use the document swatches as a palette for the tracing, select Document Library.

Color settings

Color settings appear based on the settings in the Mode and Palette options:

Colors

Specifies the number of colors to use in a color tracing result. If you have selected Document Library as the palette, you can choose a swatch. (This option is available only when Mode is set to Color.)

Grays

Specifies the number of grays to use in a grayscale tracing result. (This option is available only when Mode is set to Grayscale.)

Threshold

Specifies a value for generating a black and white tracing result from the original image. All pixels lighter than the Threshold value are converted to white; all pixels darker than the Threshold value are converted to black. (This option is available only when Mode is set to Black and White.)

Paths

Controls the distance between the traced shape and the original pixel shape. Lower values create a tighter path fitting; higher values create a looser path fitting.

Corners

Specifies the emphasis on corners. A higher value results in more corners.

Noise

Specifies an area in pixels that is ignored while tracing. A higher value results in less noise.

Method

Specifies a method for tracing. Choosing abutting creates cutout paths, while choosing overlapping creates stacked paths.

Fills

Creates filled regions in the tracing result.

Strokes

Creates stroked paths in the tracing result.

Stroke

Specifies the maximum width of features in the original image that can be stroked. Features larger than the maximum width become outlined areas in the tracing result.

Snap Curves To Lines

Specifies if slightly curved lines are replaced with straight lines.

Ignore White

Specifies if white fills areas are replaced with no fills.

Note:

Enable Preview in the Image Trace panel to preview the result of the current settings.

Release a tracing object

To discard a tracing but keep the original placed image, release the tracing object.

  1. Select the tracing object.

  2. Choose Object > Image Trace > Release.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy