그래픽 및 텍스트를 재사용하는 방법

InDesign은 그래픽 및 텍스트 재이용을 위해 여러 가지 방법을 제공합니다.

스니펫

스니펫은 개체가 들어 있으며 페이지 또는 스프레드의 다른 개체를 기준으로 개체의 위치를 설명하는 파일입니다. 자세한 내용은 스니펫 사용을 참조하십시오.

개체 라이브러리

개체 라이브러리는 로고, 보조 설명, 인용문, 기타 반복 항목 등의 항목을 저장할 수 있는 편리한 공간을 제공합니다. 자세한 내용은 개체 라이브러리 사용을 참조하십시오.

템플릿

템플릿은 자리표시자 텍스트 및 그래픽이 포함된 문서입니다. 자세한 내용은 문서 템플릿 사용을 참조하십시오.

스니펫 사용

스니펫은 개체가 들어 있으며 파일 또는 파일 스프레드의 다른 개체를 기준으로 개체의 위치를 설명하는 파일입니다. 스니펫을 사용하여 편리하게 페이지 개체를 재사용하거나 배치할 수 있습니다. 확장자가 .IDMS인 스니펫 파일에 개체를 저장하여 스니펫을 만듭니다. 이전 InDesign 버전에서는 .INDL 확장자가 사용됩니다. InDesign에서 스니펫을 가져올 때 개체를 원래 위치에 놓을지 또는 클릭하는 위치에 놓을지 결정할 수 있습니다. 하드 디스크는 물론 개체 라이브러리와 Adobe Bridge에 스니펫을 저장할 수 있습니다.

스니펫 내용을 가져올 때 해당 레이어 연결이 유지됩니다. 스니펫에 리소스 정의가 들어 있고 스니펫이 복사되는 문서에도 있는 이러한 정의가 경우 문서의 리소스 정의가 사용됩니다.

InDesign CS4에서는 InDesign CS5에서 만든 스니펫을 열 수 있지만 그보다 이전 버전의 InDesign에서는 열 수 없습니다.

스니펫 만들기

  1. 다음 중 하나를 수행합니다.
    • [선택 도구]를 사용하여 하나 이상의 개체를 선택하고 [파일] > [내보내기]를 선택합니다. [파일 형식](Windows) 또는 [포맷](Mac OS) 메뉴에서 [InDesign 스니펫]을 선택합니다. 파일 이름을 입력하고 [저장]을 클릭합니다.

    • [선택 도구]를 사용하여 하나 이상의 개체를 선택하고 선택 항목을 바탕 화면으로 드래그합니다. 스니펫 파일이 만들어집니다. 파일 이름을 바꿉니다.

    • 개체를 하나 이상 선택한 다음 선택 항목을 Mini Bridge 패널로 드래그합니다. 스니펫 파일이 만들어집니다. 파일 이름을 바꿉니다.

    • 구조 보기에서 데스크탑으로 항목을 드래그합니다.

문서에 스니펫 추가

  1. [파일] > [가져오기]를 선택합니다.
  2. 하나 이상의 스니펫 파일(*.IDMS 또는 *.INDS)을 선택합니다.
  3. 스니펫 파일의 왼쪽 위 모퉁이를 표시할 위치에 불러온 스니펫 커서를 놓고 클릭합니다.

    텍스트 프레임에 삽입점을 놓으면 스니펫이 고정된 개체로 텍스트에 삽입됩니다.

    스니펫을 가져온 후 모든 개체가 선택된 상태로 있습니다. 드래그하여 모든 개체의 위치를 조정할 수 있습니다.

  4. 두 개 이상의 스니펫을 불러온 경우 스크롤하고 불러온 스니펫 커서를 클릭하여 다른 스니펫을 배치할 수 있습니다.

참고:

바탕 화면에서 InDesign 문서로 스니펫 파일을 드래그하고 스니펫의 왼쪽 위 모퉁이를 표시할 위치를 클릭합니다.

스니펫 배치 방법 선택

페이지에서 클릭하는 위치에 따라 스니펫 개체를 배치하는 대신 원래 위치에 스니펫 개체를 배치할 수 있습니다. 예를 들어, 스니펫의 일부로 만들어질 때 페이지의 가운데에 표시된 텍스트 프레임은 스니펫으로 가져올 때와 같은 위치에 표시될 수 있습니다.

  1. 스니펫에서 개체의 원래 위치를 유지하려면 [파일 처리] 환경 설정의 [배치 위치] 메뉴에서 [원래 위치]를 선택합니다. 페이지의 클릭한 위치에 스니펫을 배치하려면 [배치 위치] 메뉴에서 [커서 위치]를 선택합니다.

참고:

Alt 키(Windows) 또는 Option 키(Mac)를 눌러서 스니펫 처리에 대해 선택한 [위치] 설정을 오버라이드할 수 있습니다. 예를 들어, [커서 위치에 배치]를 선택했지만 원래 위치에 스니펫 개체를 배치하려면 Alt 키 또는 Option 키를 누른 채 페이지에서 불러온 스니펫 커서를 클릭합니다.

개체 라이브러리 사용

개체 라이브러리를 사용하여 가장 자주 사용하는 그래픽, 텍스트 및 페이지를 정리할 수 있습니다. 눈금자 안내선, 격자, 그린 모양 및 그룹화된 이미지도 라이브러리에 추가할 수 있습니다. 라이브러리는 필요한 만큼 만들 수 있습니다. 예를 들어, 여러 프로젝트 또는 클라이언트에 대해 서로 다른 개체 라이브러리를 만들 수 있습니다.

작업 세션 동안 시스템 메모리에서 허용하는 만큼 라이브러리를 열 수 있습니다. 개체 라이브러리는 여러 서버 및 플랫폼에서 공유할 수 있지만 한 번에 한 사람만 라이브러리를 열 수 있습니다. 개체 라이브러리에 텍스트 파일이 포함되어 있으면 이 파일의 글꼴이 해당 라이브러리에 액세스할 모든 시스템에서 사용 가능하며 활성화되어 있는지 확인합니다.

개체 라이브러리에 그래픽 등의 페이지 요소를 추가하는 경우 가져왔거나 적용된 모든 특성이 유지됩니다. 예를 들어, InDesign 문서의 그래픽을 라이브러리에 추가하면 원본 라이브러리의 링크 정보까지 포함하는 라이브러리 사본이 복제되므로 디스크의 파일이 변경될 때 그래픽을 업데이트할 수 있습니다.

InDesign 문서에서 개체를 삭제해도 [라이브러리] 패널에는 해당 개체의 축소판이 여전히 표시되며 모든 링크 정보도 그대로 유지됩니다. 원본 개체를 이동하거나 삭제하면 다음에 [라이브러리] 패널에서 해당 개체를 문서로 가져올 때 [링크] 패널의 개체 이름 옆에 누락된 링크 아이콘이 표시됩니다.

각 개체 라이브러리 내에서 제목, 라이브러리에 추가된 날짜 또는 키워드로 항목을 식별하고 검색할 수 있습니다. 라이브러리 항목을 정렬하고 라이브러리 하위 세트를 표시하여 개체 라이브러리를 간단하게 표시할 수도 있습니다. 예를 들어, EPS 파일을 제외한 모든 항목을 숨길 수 있습니다.

라이브러리 패널의 개체 라이브러리
라이브러리 패널의 개체 라이브러리

A. 개체 축소판 및 이름 B. 라이브러리 항목 정보 단추 C. 라이브러리 하위 세트 표시 단추 D. 새 라이브러리 항목 단추 E. 라이브러리 항목 삭제 단추 

개체 라이브러리에 항목을 추가할 때 모든 페이지, 텍스트 및 이미지 특성이 저장되고 다음과 같은 방식으로 라이브러리 개체와 다른 페이지 요소 간의 상호 관계가 유지됩니다.

  • InDesign 문서에서 [라이브러리] 패널로 드래그할 때 그룹화되어 있던 요소는 [라이브러리] 패널 밖으로 드래그할 때도 그룹화된 상태로 유지됩니다.

  • 텍스트 서식이 유지됩니다.

  • 단락 스타일, 문자 스타일 및 개체 스타일은 대상 문서에 사용된 스타일과 이름이 동일할 경우 대상 문서의 스타일로 변환되고 이름이 다를 경우에는 그대로 문서에 추가됩니다.

  • [레이어] 패널 메뉴의 [붙여넣을 때 레이어 기억] 옵션이 선택되어 있으면 개체의 원래 레이어가 유지됩니다.

개체 라이브러리 만들기

개체 라이브러리는 디스크에 명명된 파일로 있습니다. 개체 라이브러리를 만들 때 해당 라이브러리를 저장할 위치를 지정합니다. 라이브러리를 열면 라이브러리는 다른 패널과 그룹화할 수 있는 패널로 표시되며 패널 탭에는 개체 라이브러리의 파일 이름이 표시됩니다. 개체 라이브러리를 닫으면 현재 세션에서만 라이브러리가 제거되고 해당 파일은 삭제되지 않습니다.

개체, 선택한 페이지 요소 또는 요소의 전체 페이지를 개체 라이브러리에 추가하거나 개체 라이브러리에서 제거할 수 있습니다. 한 라이브러리의 라이브러리 개체를 다른 라이브러리에 추가하거나 이동할 수도 있습니다.

  1. [파일] > [새로 만들기] > [라이브러리]를 선택합니다.
  2. [CC 라이브러리] 대화 상자에서 InDesign의 개체 라이브러리를 계속 사용하도록 선택하거나 CC 라이브러리를 사용하여 모든 크리에이티브 자산을 정리, 탐색 및 액세스할 수 있습니다. 자세한 내용은 Creative Cloud Libraries - 자산 공동 작업, 동기화 및 공유를 참조하십시오.

  3. 라이브러리의 위치와 이름을 지정하고 [저장]을 클릭합니다. 여기에서 지정한 이름은 라이브러리의 패널 탭 이름이 됩니다.

기존 라이브러리 열기

  1. 다음 중 하나를 수행합니다.
    • 현재 세션에서 라이브러리를 열어 둔 경우 [창] 메뉴에서 해당 라이브러리 파일을 선택합니다.

    • 라이브러리를 아직 열지 않은 경우 [파일] > [열기]를 선택하고 하나 이상의 라이브러리를 선택합니다. Windows에서는 라이브러리 파일에 INDL 확장자가 사용됩니다. 이전 버전의 프로그램에서 새로 연 라이브러리는 새 라이브러리 형식으로 변환됩니다. 또한 이러한 라이브러리를 새 이름으로 저장하라는 메시지가 표시됩니다.

라이브러리 닫기

  1. 닫을 라이브러리의 탭을 클릭합니다.
  2. 다음 중 하나를 수행합니다.
    • [개체 라이브러리] 패널 메뉴에서 [라이브러리 닫기]를 선택합니다.

    • [창] 메뉴에서 라이브러리 파일 이름을 선택합니다.

라이브러리 삭제

  1. 탐색기(Windows) 또는 Finder(Mac OS)에서 라이브러리 파일을 [휴지통]으로 드래그합니다. Windows에서는 라이브러리 파일에 INDL 확장자가 사용됩니다.

라이브러리에 개체 또는 페이지 추가

  1. 다음 중 원하는 작업을 수행합니다.
    • 문서 창에서 활성 [개체 라이브러리] 패널로 하나 이상의 개체를 드래그합니다.

    • 문서 창에서 하나 이상의 개체를 선택하고 [개체 라이브러리] 패널에서 [새 라이브러리 항목] 버튼을 클릭합니다.

    • 문서 창에서 하나 이상의 개체를 선택하고 [개체 라이브러리] 패널 메뉴에서 [항목 추가]를 선택합니다.

    • [개체 라이브러리] 패널 메뉴에서 [[“숫자”]페이지의 항목을 개별 개체로 추가]를 선택하여 모든 개체를 개별 라이브러리 개체로 추가합니다.

    • [개체 라이브러리] 패널 메뉴에서 [[“숫자”]페이지의 항목 추가]를 선택하여 모든 개체를 하나의 라이브러리 개체로 추가합니다.

    • [구조] 창에서 활성 [개체 라이브러리] 패널로 요소를 드래그합니다.

참고:

Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 채 위의 명령을 수행하면 항목이 라이브러리에 추가될 때 [항목 정보] 대화 상자가 표시됩니다.

문서에 라이브러리의 개체 추가

  1. 다음 중 하나를 수행합니다.
    • [개체 라이브러리] 패널에서 문서 창으로 개체를 드래그합니다.

    • [개체 라이브러리] 패널에서 개체를 선택하고 [개체 라이브러리] 패널 메뉴에서 [항목 가져오기]를 선택합니다. 이렇게 하면 개체가 원래 X,Y 좌표에 배치됩니다.

    • XML 요소를 [구조] 창의 상위 요소나 페이지로 드래그합니다.

라이브러리 개체 관리

[개체 라이브러리] 패널을 사용하여 개체를 관리할 수 있습니다.

새 항목으로 라이브러리 개체 업데이트

  1. 문서 창에서 [라이브러리] 패널에 추가할 항목을 선택합니다.
  2. [라이브러리] 패널에서 바꿀 개체를 선택하고 [개체 라이브러리] 패널 메뉴에서 [라이브러리 항목 업데이트]를 선택합니다.

한 라이브러리의 개체를 다른 라이브러리로 복사 또는 이동

  1. 두 라이브러리를 동시에 볼 수 있도록 한 라이브러리의 패널 탭을 [개체 라이브러리] 패널 그룹 밖으로 드래그하여 두 라이브러리를 분리합니다.
  2. 다음 중 하나를 수행합니다.
    • 한 라이브러리의 개체를 다른 라이브러리에 복사하려면 한 [라이브러리] 패널 탭에서 다른 [라이브러리] 패널 탭으로 항목을 드래그합니다.

    • 한 라이브러리의 개체를 다른 라이브러리로 이동하려면 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 채 한 [라이브러리] 패널 탭에서 다른 [라이브러리] 패널 탭으로 항목을 드래그합니다.

개체 라이브러리에서 개체 삭제

  1. [개체 라이브러리] 패널에서 개체를 선택하고 다음 중 하나를 수행합니다.
    • [라이브러리 항목 삭제] 단추를 클릭합니다.

    • 항목을 [라이브러리 항목 삭제] 버튼으로 드래그합니다.

    • [개체 라이브러리] 패널 메뉴에서 [항목 삭제]를 선택합니다.

개체 라이브러리의 표시 방식 변경

개체 라이브러리에서 개체는 축소판이나 텍스트 목록으로 표시됩니다. 축소판이나 목록을 개체 이름, 기간 또는 유형별로 정렬할 수도 있습니다. 목록 보기 및 정렬 옵션은 개체를 카탈로그화한 경우 가장 효과적입니다.

  1. 다음 중 원하는 작업을 수행합니다.
    • 개체를 축소판으로 보려면 [개체 라이브러리] 패널 메뉴에서 [축소판 보기]나 [큰 축소판 보기]를 선택합니다.

    • 개체를 텍스트 목록으로 보려면 [개체 라이브러리] 패널 메뉴에서 [목록 보기]를 선택합니다.

    • 개체를 정렬하려면 [개체 라이브러리] 패널 메뉴에서 [항목 정렬]을 선택하고 정렬 방법을 선택합니다.

모든 개체 보기

  1. [개체 라이브러리] 패널 메뉴에서 [모두 표시]를 선택합니다.

라이브러리 정보 보기, 추가 또는 편집

크거나 많은 수의 개체 라이브러리가 있는 경우 표시된 개체의 이름을 사용하여 개체 유형이나 설명에 포함된 단어 수별로 라이브러리 정보를 카탈로그화할 수 있습니다.

  1. [개체 라이브러리] 패널에서 다음 중 하나를 수행합니다.
    • 개체를 두 번 클릭합니다.

    • 개체를 선택하고 [라이브러리 항목 정보] 버튼을 클릭합니다.

    • 개체를 선택하고 [개체 라이브러리] 패널 메뉴에서 [항목 정보]를 선택합니다.

  2. 필요한 경우 [항목 이름], [개체 유형] 또는 [설명] 옵션을 보거나 변경하고 [확인]을 클릭합니다.

라이브러리에서 개체 찾기

개체를 검색할 때 검색 결과 이외의 모든 개체를 보기에서 숨길 수 있습니다. 검색 기능을 사용하여 특정 개체 범주를 표시하거나 숨길 수도 있습니다. 예를 들어, 이름에 “star”라는 단어가 포함된 개체만 표시할 수 있습니다.

  1. [개체 라이브러리] 패널 메뉴에서 [하위 세트 표시]를 선택하거나 [라이브러리 하위 세트 표시] 단추를 클릭합니다.
  2. 다음 중 하나를 수행합니다.
    • 라이브러리의 모든 개체를 검색하려면 [전체 라이브러리 검색]을 선택합니다.

    • 라이브러리에 현재 나열된 개체 내에서만 검색하려면(예: 이전 검색을 구체화하려는 경우) [현재 표시된 항목 검색]을 선택합니다.

  3. [매개 변수] 섹션의 첫 번째 메뉴에서 범주를 선택합니다.
  4. 두 번째 메뉴에서는 첫 번째 메뉴에서 선택한 범주를 검색에 포함할지 여부를 지정합니다.
  5. 두 번째 메뉴 오른쪽에 지정한 범주 내에서 검색할 단어나 구를 입력합니다.
  6. 검색 기준을 추가하려면 [선택 확장]을 클릭합니다. 다섯 번까지 클릭할 수 있으며 클릭할 때마다 검색 항목이 하나씩 추가됩니다. 검색 기준을 제거하려면 필요한 만큼 [선택 축소]를 클릭합니다. 클릭할 때마다 검색 항목이 하나씩 제거됩니다.
  7. 모든 검색 기준과 일치하는 개체만 표시하려면 [모두 일치]를 선택합니다. 검색 기준 중 하나라도 일치하는 개체를 표시하려면 [하나라도 일치]를 선택합니다.
  8. [확인]을 클릭하여 검색을 시작합니다.

참고:

모든 개체를 다시 표시하려면 [개체 라이브러리] 패널 메뉴에서 [모두 표시]를 선택합니다.

개체 라이브러리 자산을 CC 라이브러리로 마이그레이션

Creative Cloud 라이브러리는 창작 자산을 정리하고, 찾아보고, 액세스하는 데 도움이 됩니다. InDesign에서 CC 라이브러리를 개체 라이브러리에 대한 대체 라이브러리로 사용할 수 있습니다.

참고:

InDesign은 개체 라이브러리를 계속 지원합니다.

InDesign에서는 개체 라이브러리 자산을 CC 라이브러리로 마이그레이션할 수 있습니다.

  1. [개체 라이브러리] 패널에서 [마이그레이션] 단추를 클릭하여 현재 라이브러리의 모든 자산을 마이그레이션하십시오.

    또는, 라이브러리에서 자산을 여러 개 선택하고, 마우스 오른쪽 단추를 클릭하고 옵션을 선택하여 선택한 자산을 마이그레이션할 수 있습니다.

  2. [자산 마이그레이션] 대화 상자에서 옵션을 선택하여 자산을 새 Creative Cloud 라이브러리나 기존 Creative Cloud 라이브러리로 마이그레이션하십시오.

CC Libraries에 대한 자세한 내용은 Creative Cloud Libraries - 자산 공동 작업, 동기화 및 공유를 참조하십시오.

Creative Cloud Libraries - 자산 공동 작업, 동기화 및 공유
Creative Cloud Libraries - 자산 공동 작업, 동기화 및 공유
Creative Cloud Libraries - 자산 공동 작업, 동기화 및 공유

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책