Adobe Security Bulletin

Security Updates Available for Adobe Lightroom | APSB20-74

Bulletin ID

Date Published

Priority

ASPB20-74

December 08, 2020     

3

Summary

Adobe has released updates for Adobe Lightroom Classic for Windows and macOS. This update addresses a critical vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.  

Affected Versions

Product

Version

Platform

Lightroom Classic

10.0 and earlier versions      

Windows

Lightroom Classic

9.4.0 and earlier versions

Windows

Solution

Adobe categorizes these updates with the following priority ratings and recommends users update their installation to the newest version via the Creative Cloud desktop app’s update mechanism.  For more information, please reference this help page.

Product

Version

Platform

Priority Rating

Availability

Lightroom Classic        

10.1

Windows and macOS

3

Lightroom Classic

9.4.1

Windows and macOS

3

For managed environments, IT administrators can use the Admin Console to deploy Creative Cloud applications to end users. Refer to this help page for more information.

Vulnerability details

Vulnerability Category

Vulnerability Impact

Severity

CVE Numbers

Uncontrolled Search Path Element 

Arbitrary Code Execution        

Critical

CVE-2020-24447 

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:   

  • Hou JingYi (@hjy79425575) of Qihoo 360 CERT
  • Yongjun Liu of nsfocus security team. 

Revisions

December 10, 2020: Added acknowledgement for CVE-2020-24447.

May 04, 2021: Updated Solution table with Lightroom Classic version 9.4.1 and Affected version table with '9.4.0 and earlier version'.

Adobe logotips

Pierakstieties savā kontā