De opdrachten Ongedaan maken, Opnieuw en Herhalen

Wanneer u handelingen voor afzonderlijke objecten of alle objecten in het huidige document ongedaan wilt maken of opnieuw wilt uitvoeren, moet u de opdrachten voor Ongedaan maken en Opnieuw opgeven op object- of documentniveau (Bewerken > Ongedaan maken of Bewerken > Opnieuw). Standaard vindt ongedaan maken en opnieuw uitvoeren op documentniveau plaats.

Ga als volgt te werk als u de opties Ongedaan maken op objectniveau of documentniveau wilt kiezen:

  1. Selecteer in Animate CC de optie Bewerken > Voorkeuren.
  2. Selecteer op het tabblad Algemeen de optie Ongedaan maken op objectniveau in de vervolgkeuzelijst Ongedaan maken.

Merk op dat u een aantal handelingen op objectniveau niet ongedaan kunt maken. De meeste zijn Bewerkmodus starten en sluiten, bibliotheekitems selecteren, bewerken en wijzigen en scènes maken, verwijderen en verplaatsen.

Wanneer u een stap opnieuw wilt toepassen op hetzelfde object of op een ander object, gebruikt u de opdracht Herhalen. Wanneer u bijvoorbeeld een vorm genaamd vorm_A verplaatst, selecteert u Bewerken > Herhalen om de vorm nogmaals te verplaatsen of selecteert u een andere vorm, vorm_B, en selecteert u Bewerken > Herhalen om de tweede vorm op dezelfde manier te verplaatsen.

Het standaardaantal niveaus voor ongedaan maken in Animate is ingesteld op 100. In de voorkeuren van Animate kunt u het aantal niveaus aangeven voor ongedaan maken en opnieuw instellen. Het bereik ligt tussen 2 en 300.

Wanneer u een stap ongedaan maakt met Bewerken > Ongedaan maken of via het deelvenster Historie, blijft de bestandsgrootte van het document ongewijzigd, ook als u een item uit het document verwijdert. Wanneer u bijvoorbeeld een videobestand importeert in een document en deze bewerking ongedaan maakt, is de bestandsgrootte van het document nog steeds inclusief de grootte van het videobestand. Items die u uit een document verwijdert met de opdracht Ongedaan maken, worden bewaard om de items met de opdracht Opnieuw te kunnen herstellen.

Deelvenster Historie gebruiken

Het deelvenster Historie (Venster > Historie) bevat een lijst met de stappen die u in het actieve document hebt uitgevoerd sinds u het document hebt gemaakt of geopend, tot een opgegeven maximum aantal stappen. (Het deelvenster Historie geeft niet aan welke stappen u in andere documenten hebt uitgevoerd.) De schuifregelaar in het deelvenster Historie wijst aanvankelijk naar de laatste stap die u hebt uitgevoerd.

  • Gebruik het deelvenster Historie als u afzonderlijke stappen of meerdere stappen tegelijk ongedaan wilt maken of opnieuw wilt uitvoeren. U kunt stappen vanuit het deelvenster Historie opnieuw toepassen op hetzelfde object of op een ander object in het document. U kunt de volgorde van de stappen in het deelvenster Historie echter niet wijzigen. Het deelvenster Historie is in feite een opname van stappen in de volgorde waarin ze zijn uitgevoerd.

    Opmerking: wanneer u een of meerdere stappen ongedaan maakt en vervolgens iets nieuws doet in het document, kunt u de stappen in het deelvenster Historie niet meer opnieuw uitvoeren: ze verdwijnen uit het deelvenster.

  • Het standaardaantal niveaus voor het deelvenster Geschiedenis in Animate is ingesteld op 100. In de voorkeuren van Animate kunt u het aantal niveaus aangeven voor ongedaan maken en opnieuw instellen. Het bereik ligt tussen 2 en 300.

  • U kunt de historielijst voor het huidige document wissen in het deelvenster Historie. Eenmaal gewiste stappen in de historielijst kunt u niet meer ongedaan maken. Het wissen van de historielijst maakt de stappen niet ongedaan, alleen de opname van die stappen wordt uit het geheugen van het huidige document verwijderd.

Bij het sluiten van een document wordt de historie gewist. Wanneer u stappen uit een document wilt gebruiken nadat het is gesloten, kopieert u de stappen met de opdracht Stappen kopiëren of slaat u de stappen als een opdracht op.

Stappen ongedaan maken via het deelvenster Historie

Wanneer u een stap ongedaan maakt, wordt die stap gedimd weergegeven in het deelvenster Historie.

  • Sleep de schuifregelaar in het deelvenster Historie één stap terug in de lijst om de laatste uitgevoerde stap ongedaan te maken.

  • Wanneer u meerdere stappen ineens ongedaan wilt maken, sleept u de schuifregelaar naar de stap tot waar u ongedaan wilt maken of klikt u links van een stap langs het pad van de schuifregelaar. De schuifregelaar gaat dan automatisch naar die stap, waarbij alle stappen tot aan dat punt achtereenvolgens ongedaan worden gemaakt.

Opmerking: schuiven naar een stap (en het selecteren van de opeenvolgende stappen) is niet hetzelfde als het selecteren van een afzonderlijke stap. U schuift naar een stap door links van de stap te klikken.

Stappen opnieuw afspelen via het deelvenster Historie

Wanneer u stappen opnieuw afspeelt via het deelvenster Historie, betreft het de geselecteerde (gemarkeerde) stappen in het deelvenster Historie, niet per se de stap die op dat moment door de schuifregelaar wordt aangegeven.

U kunt stappen in het deelvenster Historie toepassen op elk geselecteerd object in het document.

Eén stap opnieuw afspelen

  1. Selecteer een stap in het deelvenster Historie en klik op de knop Opnieuw afspelen.

Reeks aangrenzende stappen opnieuw afspelen

  1. U kunt als volgt stappen in het deelvenster Historie selecteren:
    • Sleep van de ene stap naar de andere. (Sleep niet de schuifregelaar, maar sleep van het tekstlabel van de ene stap naar het tekstlabel van een andere stap.)

    • Selecteer de eerste stap, houd de Shift-toets ingedrukt en selecteer de laatste stap (of andersom).

  2. Klik op Opnieuw afspelen. De stappen worden in volgorde opnieuw afgespeeld en in het deelvenster Historie wordt een nieuwe stap weergegeven met het label Stappen opnieuw afspelen.

Niet-aangrenzende stappen opnieuw afspelen

  1. Selecteer een stap in het deelvenster Historie en houd de Ctrl-toets (Windows) of de Cmd-toets (Macintosh) ingedrukt en klik op andere stappen. U heft de selectie van een geselecteerde stap met dezelfde procedure op.
  2. Klik op Opnieuw afspelen.

Stappen kopiëren en plakken tussen documenten

Elk geopend document heeft een eigen historie van stappen. Met de opdracht Stappen kopiëren in het optiemenu van het deelvenster Historie kunt u stappen kopiëren van het ene document en deze plakken in een ander document. Wanneer u stappen kopieert in een teksteditor, worden die als JavaScript™-code geplakt.

  1. Selecteer de gewenste stappen in het deelvenster Historie in het document met de stappen die u opnieuw wilt gebruiken.
  2. Selecteer Stappen kopiëren in het optiemenu van het deelvenster Historie.
  3. Open het document waarin u de stappen wilt plakken.
  4. Selecteer een object waarop u de stappen wilt toepassen.
  5. Selecteer Bewerken > Plakken om de stappen te plakken. De stappen worden opnieuw uitgevoerd nadat ze in het deelvenster Historie zijn geplakt. In het deelvenster Historie worden deze als slechts één stap weergegeven, Stappen plakken genoemd.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid