Brukerveiledning Avbryt

Preferences

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
    3. Features in Beta
      1. Import and add 3D models to your composition (Beta)
      2. Image-Based Lighting (Beta)
      3. Extract and animate cameras and lights from 3D models (Beta)
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. After Effects for Apple silicon
    9. Planning and setup
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. Detect edit points using Scene Edit Detection
    8. XMP metadata
  7. Text and Graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
      5. Animate faster and easier using the Properties panel
  8. Drawing, Painting, and Paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. Taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Layers, Markers, and Camera
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, Keyframes, Motion Tracking, and Keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and Compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels and masks
    3. Track Mattes and Traveling Mattes
  12. Adjusting color
    1. Color basics
    2. Color management
    3. Color Correction effects
    4. OpenColorIO and ACES color management
  13. Effects and Animation Presets
    1. Effects and animation presets overview
    2. Effect list
    3. Effect Manager
    4. Simulation effects
    5. Stylize effects
    6. Audio effects
    7. Distort effects
    8. Perspective effects
    9. Channel effects
    10. Generate effects
    11. Transition effects
    12. The Rolling Shutter Repair effect
    13. Blur and Sharpen effects
    14. 3D Channel effects
    15. Utility effects
    16. Matte effects
    17. Noise and Grain effects
    18. Detail-preserving Upscale effect
    19. Obsolete effects
  14. Expressions and Automation
    1. Expressions
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. 3D Transform Gizmos
    7. Do more with 3D animation
    8. Preview changes to 3D designs real time with the Mercury 3D engine
    9. Add responsive design to your graphics 
  16. Views and Previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and Exporting
    1. Basics of rendering and exporting
    2. H.264 Encoding in After Effects
    3. Export an After Effects project as an Adobe Premiere Pro project
    4. Converting movies
    5. Multi-frame rendering
    6. Automated rendering and network rendering
    7. Rendering and exporting still images and still-image sequences
    8. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Creative Cloud Libraries in After Effects
    5. Plug-ins
    6. Cinema 4D and Cineware
  19. Collaboration: Frame.io, and Team Projects
    1. Collaboration in Premiere Pro and After Effects
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Team Projects
      1. Get Started with Team Projects
      2. Create a Team Project
      3. Collaborate with Team Projects
  20. Memory, storage, performance
    1. Memory and storage
    2. How After Effects handles low memory issues while previewing    
    3. Improve performance
    4. Preferences
    5. GPU and GPU driver requirements for After Effects
  21. Knowledge Base
    1. Known issues
    2. Fixed issues
    3. Frequently asked questions
    4. After Effects and macOS Ventura
    5. How After Effects handles low memory issues while previewing

The following sections describe the Preferences dialog box and the various tasks that can be performed using this menu.

Launch the Preferences dialog in After Effects

To open the Preferences dialog box, go to:

  • Windows: Edit > Preferences > [category name]
  • macOS: After Effects > Preferences > [category name]

Use the following keyboard shortcuts to open the Preferences > General menu:

  • Windows: Ctrl+Alt+; (semicolon) 
  • macOS: Command+Option+; (semicolon)

Reset preferences

Restore the default Preference settings

To restore the default preference settings, press and hold the following keys while the application is starting.

  • Windows: Ctrl+Alt+Shift
  • macOS: Command+Option+Shift

Restore default Keyboard Shortcuts

To restore default keyboard shortcuts,

  • Windows: Alt+Click
  • macOS: Option+Click

Reset background preferences

To reset background preferences, follow these steps:

  • macOS
  1. Go to your desktop and select GO on the menu bar.
  2. Select Go to Folder from the drop-down and type the following path: /Users/[user_name]/Library/Preferences/Adobe/After Effects/[version].
  3. Rename the After Effects folder as ’OldAfterEffects’.
  • Windows
  1. Access the path C:\Users\”username” \AppData\Roaming\Adobe, or
  2. In the Run command (Windows key+R) dialog, type %appdata%
  3. Open the folder named Adobe.
  4. In the folder, select the After Effects folder and rename it as ’OldAfterEffects’, or
  5. Access the path C:\Users\”username”\Documents\Adobe and rename the After Effects folder as ’OldAfterEffects’.

Reveal preferences

Preferences, including keyboard shortcuts and workspaces, are stored as files in the following locations:

  • Windows: \Users\[user_name]\AppData\Roaming\Adobe\After Effects\[version]
  • macOS: /Users/[user_name]/Library/Preferences/Adobe/After Effects/[version]

To reveal the preferences in After Effects, go to:

  • WindowsEdit > Preferences > General and select Reveal Preferences in Explorer button
  • macOS: After Effects > Preferences > General and select Reveal Preferences in the Finder button

It is recommended that you do not modify the files in this directory manually; use the Preferences dialog box to modify the preferences. For information on modifying keyboard shortcuts, see Modify keyboard shortcuts and Workspaces and Panels for managing workspaces.

Merk:

The Library folder in macOS X is hidden. See the following article to learn how to access hidden user files on Mac OS:

http://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

The following list briefly describes the different options listed under the Edit > Preferences menu, especially those options that are not self-explanatory.

General preferences

Path Point and Handle Size

Specifies the size of Bezier direction handles and vertices for masks and shapes, direction handles for motion paths, and other similar controls.

Create Layers At Composition Start Time

Switches Affect Nested Comps

Default Spatial Interpolation To Linear

Default Position Property to Separate Dimensions

Set After Effects to default to separated X, Y dimensions (for 2D layers) or separated X, Y, Z dimensions (for 3D layers) on position properties.

Preserve Constant Vertex and Feather Point Count When Editing Masks

Pen Tool Shortcut Toggles Between Pen and Mask Feather Tools

Create Anchor Point In New Shape Layers

Automatically sets the Anchor Point in the center of newly created shapes. 

Create Split Layers Above Original Layer

Use System Color Picker

Dynamic Link with After Effects Uses Project File Name with Highest Number

Play Sound When Render Finishes

Enable or disable the playing of a sound when the last item in the render queue has been processed. 

Use System Shortcut Keys

Enable Coach Marks

Enable notifications when you select certain parts of the UI, After Effects suggests new features, introduces you to changed functionality and offers tips to improve your workflow.

Opening layers with Double-click (use Option to reverse)

You can use this option to configure:

  • On Footage Layer Opens: Select whether double-clicking a footage layer opens the Layer panel (default) or the source footage item.
  • On Comp Layer Opens: Select whether double-clicking a pre-composition layer opens the source composition of the layer (default) or the Layer panel.
  • Open Layer Panel when Double-clicking with Paint, Roto Brush, and Refine Edge Tools: If selected, double-clicking a precomposition layer when a Paint tool, Roto Brush, or Refine Edge tool is active opens the layer in the Layer panel. 

For more information, see Creating layers and Precomposing, nesting, and pre-rendering.    

Startup and Repair

Use Startup & Repair to quickly diagnose and troubleshoot issues with After Effects preferences without having to make changes in your set preferences or starting over from scratch. 

Startup and Repair panel in Preferences with Safe Mode option selected.
Startup & Repair option in After Effects Preferences.

Startup Options

Enable Home Screen

Select to display the Start screen when you launch After Effects.

Show System Compatibility Issues

Enables a System Compatibility Report that lists any compatibility issues and suggested fixes when you start After Effects.

Repair Options

There are two repair options that you can use to identify and resolves startup issues.

Start in Safe Mode

It temporarily restarts After Effects with default preferences. If restarting After Effects in Safe Mode resolves the issue, it indicates that your current preferences are corrupt and need to be reset or replaced or an installed plugin is unstable.

Empty All Caches

It empties all caches to clear up additional storage space and can resolve certain startup issues.

Reveal and Reset Preferences 

Reveal Preferences in Finder

Forsiktig!

Editing any preferences files may result in crashes or other unexpected behavior.

Reset All Preferences To Defaults

Merk:

After Effects needs to restart for changes to take place, and it also resets your workspaces.

Migrate Previous Version Preferences

After Effects prompts you to migrate settings from a previous version if it finds a preference folder from a previous version and no preference folder for the current version. This occurs when you start After Effects for the first time and when you delete the entire preferences folder.

If you want to migrate settings from your previous version of After Effects, see the Migrating your settings from a previous minor version of After Effects section.

Previews

Adaptive Resolution Limit

Preview modes and Fast Previews preferences and also, see Fast Previews.

The GPU Information dialog box is available to check the texture memory for your GPU, and to set the ray-tracing preference to the GPU, if it is available. The Copy button is available to copy the general information at the top of the dialog box to the system clipboard.

Viewer Quality

This option allows you to configure Zoom Quality and Color Management Quality. See Viewer Quality preferences.

Automatically Enable Frame Blending and Motion Blur Rendering

When you enable this feature, whenever you apply a motion blur or frame blending on a layer, it automatically gets enabled for the composition preview rendering as well.

Mute Audio When Preview Is Not Real-time

Choose whether to play audio during previews when the frame rate is slower than realtime. When the frame rate is slower than realtime, audio will stutter to maintain sync.

Cache Frames When Idle

You can set After Effects to render compositions automatically while idle after a set amount of time. See Preview and render with Multi-Frame Rendering.

Merk:

Frames will not be rendered and cached while the Layer or Footage panel is in focus.

Display

Motion Path

Disable Thumbnails In Project Panel

Show Rendering Progress In Info Panel And Flowchart

Hardware Accelerate Composition, Layer, And Footage Panels

Show Both Timecode and Frames in Timeline Panel

Import

Automatic Footage Reloading

Footage that has changed is automatically reloaded when switching back from another application. By default, footage other than the image sequence is automatically reloaded. You can change this behavior by using the Auto Reload drop-down.

  • All Footage Types: Includes even the image sequence footage.
  • Non-sequence Footage: Includes footage other than the image sequence.
  • Off: Turn off auto-reloading of footage.

Indeterminiate Media NSTC

Choose drop-frame or non-drop-frame timecode for Indeterminate Media NTSC, which applies to imports like still image sequences in which timecode values are not present or are unknown.

Drag Import Multiple Items As

Output

Segment Sequences At

Set the maximum number of still-image files in a folder. See Segment settings.

Segment Video-only Movie Files At

Set the maximum size for segments in megabytes. See Segment settings.

Use Default File Name And Folder

Audio Block Duration

Audio is also rendered in segments, the length of which is set by the Audio Block Duration value.

Grids & Guides preferences

Labels

You can use labels (colored boxes in the Label column) in the Project and Timeline panel to organize and manage compositions, footage items, layers, and keyframes. By default, different label colors indicate different kinds of footage items, but you can assign label colors to indicate whatever categories you choose.

Merk:

Rename label groups to help you to organize and categorize layers and footage items. To see label names in the Label column, widen the column to greater than the default width.

Tips for using labels during your workflow

  • To change the color of a label for one layer, select the label in the Timeline panel and choose a color.
  • To select all layers with the same label color, select a layer with that label color and choose Edit > Label > Select Label Group.
  • To change the color of a label for all layers with that label color, select one of the layers belonging to the label group, choose Edit > Label > Select Label Group, and choose Edit > Label > [color name].
  • To change the default associations of label colors with source types, choose Edit > Preferences > Labels (Windows) or After Effects > Preferences > Labels (macOS).
  • To disable the use of a layer’s label color for layer handles and motion paths, choose Edit > Preferences > Appearance (Windows) or After Effects > Preferences > Appearance (macOS), and deselect Use Label Colors For Layer Handles And Paths.
  • To disable the use of a layer, footage item, or composition’s label color in the tabs of corresponding panels, choose Edit > Preferences > Appearance (Windows) or After Effects > Preferences > Appearance (macOS), and deselect Use Label Colors For Related Tabs.
  • To set or change the keyframe colors, select the keyframe > Edit > Label > Choose the colors from the list, or in the Timeline panel, right-click the keyframe > Label > Choose the colors from the list. (See Keyframe Color Labels.)
  • To select keyframes with the same label group, select the keyframe > Edit > Select Keyframe Label Group, or in the Timeline panel, right-click the keyframe > Select Keyframe Label Group.

Media & Disk Cache

Enable Disk Cache

Disk Cache is enabled by default. You can enable or disable disk caching and also select a folder to contain your cache. See Caches: RAM cache, disk cache, and media cache.

Conformed Media Cache

Choose folders or change the location of the media cache database or the media cache itself.

  • Clean Database & Cache: Remove conformed and indexed files from the cache and remove their entries from the database. This command only removes files associated with footage items for which the source file is no longer available.

Write XMP IDs to Files on Import

Writes an XMP ID to imported files that improve the sharing of media cache files and previews. See XMP metadata in After Effects.

Create Layer Markers from Footage XMP Metadata

When you create a layer based on a footage item that contains XMP metadata, After Effects automatically converts XMP metadata to layer markers. See XMP metadata in After Effects.

Video Preview preferences

Enable Mercury Transmit

Toggle video preview with Mercury Transmit. Use the on the numeric keypad to toggle this option. On macOS without a numeric keypad, use Control+Shift+/ on the main keyboard.

Disable video output when in the background

Select this option to prevent sending video frames to the external monitor when After Effects is not the foreground application.

Video preview during render queue output

Select this option to send video frames to the external monitor when After Effects is rendering frames in the render queue.

Appearance

Use Label Color For Layer Handles And Paths

Use Gradients

Use gradients in the user interface.

Brightness

Brightens or darkens user interface (UI) colors.

Highlight Color

Set the preference to darken or lighten the color of highlighted Interactive Controls or Focus Indicators in the app.

New Project

You can create a template with your preferred project settings, such as color management and folder structure, and use it as a foundation for every new project you create. 

New Project Loads Template

If enabled and a template project chosen, the New Project command allows you to open a project based on a template. The template project can be an After Effects template project file (.aet), an After Effects project file (.aep), or an After Effects XML project file (.aepx).  

For more information, see Save and backup projects in After Effects.

Auto-Save

Use the Auto-Save feature in After Effects to automatically save a copy of your project while you work. You can set the frequency of how often After Effects saves your work and also the number of copies of the project it saves.

Save every

Specify a time in minutes to set intervals after which the project gets automatically saved.

Save when starting render queue

Once enabled, After Effects automatically saves the project when you start the render queue.  

Maximum Project Versions

Specify how many versions of each project file you want to save. For example, if you type 5, After Effects saves five versions of each project you open.

Auto-Save Location

Once Auto-Save is enabled and configured, After Effects creates a folder named Adobe After Effects Auto-Save in the same directory as your project file or a folder as specified in Custom Location.

To view and return to a previously saved version of your project, select File > Open in After Effect > Saved Version.

For more information, see Save and back up projects in After Effects.

Memory & Performance

Set memory preferences and specify how After Effects allocates and uses memory and CPUs.

RAM reserved for other applications

Increase or decrease the value to specify how much available RAM After Effects can use and how much for applications you're running in the background.

RAM available for

Displays how much RAM is available for After Effects and other Creative Cloud apps.

Show Memory Usage Details

Launches the Memory Details dialog and displays all memory-related details.

  • Installed RAM
  • Current RAM Usage
  • Allowed RAM Usage
  • Process ID
  • Application Name
  • Min Needed Memory
  • Max Usable Memory
  • Max Allowed Memory
  • Current Memory
  • Current Priority

Enable Multi-Frame Rendering

Multi-Frame Rendering allows After Effects to render multiple frames at the same time during Preview and Render Queue Export. This setting also applies when After Effects compositions are rendered from Media Encoder and Premiere Pro.

% CPU reserved for other applications

Choose to limit how much CPU power to reserve so that other applications other than After Effects can still be used.

Audio Hardware and Audio Output Mapping

Device Class

Choose the driver for the sound card you want to use.

Default Output

Choose a default audio output.

I/O Buffer Size

Specify the lowest setting possible without audio dropouts. The ideal setting depends on the speed of your system, so some experimentation is necessary.

Sample Rate

Choose a Sample Rate for the audio hardware. For common rates for different output mediums, see Understanding sample rate in Adobe Audition Help.

For more information, see Audio Hardware Preferences.

Sync Settings

The Sync Settings feature enables you to synchronize preferences and settings through the Creative Cloud. 

Automatically clear user profile on application quit

Enable this option to clear the user profile when you quit After Effects. On the next launch, preferences are fetched from the default Adobe ID used to license the product.

Select the preferences to synchronize.

  • Synchronizable Preferences
  • Keyboard Shortcuts
  • Composition Settings Presets
  • Interpretation Rules
  • Render Settings Templates
  • Output Module Settings Templates

For more information, see Sync Settings.

Type

Font Menu

Set preferences for the font size or the number of recent fonts for After Effects to display.

  • Preview Size: Change the size of the font preview.
  • Number of Recent Fonts to Display: Change the number of recent fonts to display at the top of the menu.

Scripting & Expressions

Allow Scripts to Write Files and Access Network

By default, scripts are not allowed to write files or send or receive communication over a network. Enable this option to allow scripts to write files and communicate over a network.

Enable JavaScript Debugger

Enable this option to enable the JavaScript debugger to open automatically when After Effects encounters a script error.

Expression Pick Whip Writes Compact English

This once enabled determines the format of expressions created by the pick whip.

Show Warning Banner When Project Contains Expression Errors

When an expression fails to evaluate, expression errors appear in a warning banner at the bottom of the Composition and Layer panels. When this option is disabled, the warning banner remains hidden even when new expression errors occur.

For detailed information, see Expression errors.

Expression Editor

Set preferences for the Expression Editor field in the Timeline panel by enabling or disabling the following:

  • Font Size
  • Syntax Highlighting
  • Show Line Numbers
  • Show Indent Guides
  • Highlight Matching Braces
  • Auto Insert Braces
  • Auto Indent Braces
  • Folding 
  • Word Wrap
  • Use Tabs and Width
  • Backspace Unindents
  • Inline Errors
  • Auto Complete

Theme

Set different colors for the background and different elements within the expression editor field.

  • Default
  • Background
  • Keywords
  • Identifiers
  • Comments
  • Numbers
  • Strings
  • Operators
  • Selection Alpha
  • Line Numbers
  • Indent Guides
  • Good Brace
  • Bad Brace
  • Selection

3D

Camera Navigation

Set preferences to use the keyboard and mouse for easy navigation while working on 3D elements.

  • Use 1/2/3 for navigation and 4/5/6 for transform gizmos: Marker commands will be deactivated when this option is enabled.
  • Activate Option - Left / Middle / Right mouse click for camera navigation: The temporary wireframe mode will be deactivated when this option is enabled.

Camera manipulation point

Select between None, Indicator, and Directional indicator.

Camera Navigation - Dolly

Set preferences on how the dolly should behave during mouse scroll and also the drag direction.

  • Mouse Scroll Wheel Behavior: Select between Magnify composition, Dolly camera, and Reverse dolly camera.
  • Drag Direction: Select between Normal and Reverse.

3D Cache

Deletes all files from this folder except for any cached files in use by the current project.

Notifications

Render Notifications

Enable automatic notifications when you add a composition to the Render Queue. These notifications will be sent to Creative Cloud desktop and mobile apps.

Related resources

Talk to us

If you have questions about After Effects, reach out to us in our After Effects community. We would love to help.

Adobe-logoen

Logg på kontoen din